Prosíme přihlašte se nebo zaregistrujte.

Přihlašte se svým uživatelským jménem a heslem.
Blog Ubuntu -- Správa "projektů" české komunity Ubuntu

Novinky: Školení nejen k OS Ubuntu pro širokou veřejnost, více informací zde.

Autor Téma: apt-get? Zapomeňte!... aneb How to Gentooize Debian-like Systems for n00bs  (Přečteno 47272 krát)

Roman Vacho

  • Člen placené komunitní podpory
  • Moderátor
  • Guru
  • *****
  • Příspěvků: 5588
  • Karma: +218/-47
  • Jeden vykope studnu, tisíce z ní pijí tisíc let.
    • Zobrazit profil
Re: apt-get? Zapomeňte!... aneb How to Gentooize Debian-like Systems for n00bs
« Odpověď #25 kdy: 10 Listopad 2009, 23:37:00 »
Pak jsem ještě našel

Kód: [Vybrat]
Format: 1.8
Date: Tue, 10 Nov 2009 22:03:56 +0100
Source: totem
Binary: totem totem-mozilla totem-common totem-dbg totem-plugins totem-plugins-extra totem-xine totem-gstreamer
Architecture: all amd64
Version: 2.28.1-0ubuntu4
Distribution: karmic
Urgency: low
Maintainer: Ubuntu Desktop Team <ubuntu-desktop@lists.ubuntu.com>
Changed-By: root <root@panter>
Description:
 totem      - A simple media player for the GNOME desktop based on GStreamer
 totem-common - Data files for the Totem media player
 totem-dbg  - Debugging symbols for the Totem media player
 totem-gstreamer - A simple media player for the GNOME desktop (transitional package
 totem-mozilla - Totem Mozilla plugin
 totem-plugins - Plugins for the Totem media player
 totem-plugins-extra - Extra plugins for the Totem media player
 totem-xine - A simple media player for the GNOME desktop (transitional package
Changes:
 totem (2.28.1-0ubuntu4) karmic; urgency=low
 .
   [ Robert Ancell ]
   * debian/patches/03_screensaver_preferences.patch:
     - Fix logic on "Also disable the screensaver when playing audio" preference
       (LP: #448456)
 .
   [ root ]
   * Built by apt-build
   * Build options: -O3 -mtune=athlon64-sse3
Checksums-Sha1:
 fb907aa152f09eee7f270128a058090c19db6bd4 2844538 totem-common_2.28.1-0ubuntu4_all.deb
 594ef28e28885aa660e78a57bc32bc25ac20c011 51906 totem-xine_2.28.1-0ubuntu4_all.deb
 f10bc98269f23373bf038bdfc634c2a2e55fde9f 51910 totem-gstreamer_2.28.1-0ubuntu4_all.deb
 c58587fefa140a32e045b1d427208cc895e093e2 558928 totem_2.28.1-0ubuntu4_amd64.deb
 707b06a4dcf50133f980f6bd76e8e47a4f231aa8 187760 totem-mozilla_2.28.1-0ubuntu4_amd64.deb
 c85f2151894edc4be6ab6374f24a49eff52b45e5 1848314 totem-dbg_2.28.1-0ubuntu4_amd64.deb
 bc998562cdd9e636533434b932d1bb6d4ece8fe3 212978 totem-plugins_2.28.1-0ubuntu4_amd64.deb
 e93724efc375b4c7d574f0ffc5baf535205a8327 115806 totem-plugins-extra_2.28.1-0ubuntu4_amd64.deb
Checksums-Sha256:
 a821048c33a2d96dfa6367a1014d5230fe845c80a8bc3f6399aade2e08884404 2844538 totem-common_2.28.1-0ubuntu4_all.deb
 c3552db2a1f5ce2cb96ad4c698511a110b2e4e99330b9086bb98783fd53d4a50 51906 totem-xine_2.28.1-0ubuntu4_all.deb
 921c6c787ae81af44cd360a6c127d02b5017914219d024bf857ae6e64752c8bd 51910 totem-gstreamer_2.28.1-0ubuntu4_all.deb
 20ce7c6afa6fc585530ba0fdae2946da74dec6cf11d7cb21eabb4aef1a19eb30 558928 totem_2.28.1-0ubuntu4_amd64.deb
 018c60cd8f41ee621199f8b90026a00f309741a7860b080ab4595c0b5053739e 187760 totem-mozilla_2.28.1-0ubuntu4_amd64.deb
 6ae87b556faafe884700bc02b3f3d6baaf838699aaade5b463499c9dab3359e1 1848314 totem-dbg_2.28.1-0ubuntu4_amd64.deb
 ca79b061a23ba4cb31494967f27234e94451eb143ef7b2764fc37424a9bbdc48 212978 totem-plugins_2.28.1-0ubuntu4_amd64.deb
 5e3eed5f6418eb651bc2789d99f54a9b293da187fd9e37807f934560741797c0 115806 totem-plugins-extra_2.28.1-0ubuntu4_amd64.deb
Files:
 af71b5bdae4d79270067a9717b89a614 2844538 gnome optional totem-common_2.28.1-0ubuntu4_all.deb
 1fc8558d1acb758e8a337454f68e0738 51906 gnome optional totem-xine_2.28.1-0ubuntu4_all.deb
 a55d2a0a4cd6fe12b67189691a4b6111 51910 gnome optional totem-gstreamer_2.28.1-0ubuntu4_all.deb
 e26c20e2f830231268a40a93436685b3 558928 gnome optional totem_2.28.1-0ubuntu4_amd64.deb
 218f7aca1841dad8a14f58d090ce1dec 187760 web optional totem-mozilla_2.28.1-0ubuntu4_amd64.deb
 4ae08e3c2393e3db39df09cd991a8bab 1848314 libdevel extra totem-dbg_2.28.1-0ubuntu4_amd64.deb
 fda3624c8b006dd784868e4a8df49dac 212978 gnome optional totem-plugins_2.28.1-0ubuntu4_amd64.deb
 2b95437ed3aa621021a15b74c24d8db2 115806 gnome optional totem-plugins-extra_2.28.1-0ubuntu4_amd64.deb
Launchpad-Bugs-Fixed: 448456
Original-Maintainer: Sebastien Bacher <seb128@debian.org>

ve /var/cache/apt-build/build
soubor totem blabla .changes

Je to divné. Teď jsem zrušil ostatní internetový sources a aktualizoval... a už je tam. Asi to chtělo přímo od něj update :) Nj špatně jsem pochopil návod.
« Poslední změna: 10 Listopad 2009, 23:40:05 od Rovano »
Vyřešená vlákna je vhodné uzavřít dodáním znaků "[vyřešeno]" do názvu téma v editaci prvního příspěvku.

apollo

  • Návštěvník
  • *
  • Příspěvků: 61
  • Karma: +3/-0
    • Zobrazit profil
Re: apt-get? Zapomeňte!... aneb How to Gentooize Debian-like Systems for n00bs
« Odpověď #26 kdy: 11 Listopad 2009, 09:24:15 »
6) architektura vašeho procesoru- zdá se, že tam jsou pouze architektury Intelu (alespoň u mně; mám navoleno core2).

Potrebujem poradit -  rad by som si zvolil architekturu co najblizsie k mojmu CPU. Hladal som na nete a k nicomu konkretnemu som sa nedostal (mozno som zle hladal - nevylucujem). Mam dvojjadro Intel Pentium Dual CPU T3400 2.16GHz (notes), ktora z moznosti ponukanych pre gcc je pre mna najvhodnejsia? (moj tip i686, ale ak by bola vhodnejsia niektora ina, prosim opravte ma). Thx.

Este som zabudol prihodit listing:
Kód: [Vybrat]
zeus@olymp:~$ cat /proc/cpuinfo
processor : 0
vendor_id : GenuineIntel
cpu family : 6
model : 15
model name : Intel(R) Pentium(R) Dual  CPU  T3400  @ 2.16GHz
stepping : 13
cpu MHz : 1000.000
cache size : 1024 KB
physical id : 0
siblings : 2
core id : 0
cpu cores : 2
apicid : 0
initial apicid : 0
fdiv_bug : no
hlt_bug : no
f00f_bug : no
coma_bug : no
fpu : yes
fpu_exception : yes
cpuid level : 10
wp : yes
flags : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe nx lm constant_tsc arch_perfmon pebs bts pni dtes64 monitor ds_cpl est tm2 ssse3 cx16 xtpr pdcm lahf_lm
bogomips : 4321.97
clflush size : 64
power management:

processor : 1
vendor_id : GenuineIntel
cpu family : 6
model : 15
model name : Intel(R) Pentium(R) Dual  CPU  T3400  @ 2.16GHz
stepping : 13
cpu MHz : 1000.000
cache size : 1024 KB
physical id : 0
siblings : 2
core id : 1
cpu cores : 2
apicid : 1
initial apicid : 1
fdiv_bug : no
hlt_bug : no
f00f_bug : no
coma_bug : no
fpu : yes
fpu_exception : yes
cpuid level : 10
wp : yes
flags : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe nx lm constant_tsc arch_perfmon pebs bts pni dtes64 monitor ds_cpl est tm2 ssse3 cx16 xtpr pdcm lahf_lm
bogomips : 4322.50
clflush size : 64
power management:
« Poslední změna: 11 Listopad 2009, 10:59:28 od apollo »

Evžen Šubrt

  • Závislák
  • ****
  • Příspěvků: 2218
  • Karma: +177/-35
    • Zobrazit profil
    • EuGenio's Lair
Re: apt-get? Zapomeňte!... aneb How to Gentooize Debian-like Systems for n00bs
« Odpověď #27 kdy: 11 Listopad 2009, 10:31:09 »
Supr návod, o takové možnosti jsem nevěděl a nejspíš ji u "kousků" využiju! (K+)

Jinak chlape, vážně je nutný používat všechno to exkrementální výrazivo?? (K-)
Athlon X2 6000+, MB ASUS M2R32-MVP, 6GB RAM, ATI Radeon HD7850 1GB, 1GB SSHD + 250GB HDD, Ubuntu 13.10 Saucy Salamander 64bit

GdH

  • Moderátor
  • Závislák
  • *****
  • Příspěvků: 3008
  • Karma: +480/-17
    • Zobrazit profil
    • GdH-Notes
Re: apt-get? Zapomeňte!... aneb How to Gentooize Debian-like Systems for n00bs
« Odpověď #28 kdy: 11 Listopad 2009, 11:22:29 »
Milý Horníčku, toto je opravdu pěkná hračka, máš ŽETÓN!  ;D

Nebylo by dobré zmínit v návodu, že pokud chci nahradit stávající instalaci balíku, balíkem rekompilovaným stejné verze, musím napsat sudo apt-build install --reinstall balík? Jinak si budou někteří uživatelé jen plnit repo.
« Poslední změna: 11 Listopad 2009, 11:50:53 od GdH »

airlive

  • Závislák
  • ****
  • Příspěvků: 2279
  • Karma: +244/-31
  • Linux User: 479151.
    • Zobrazit profil
Re: apt-get? Zapomeňte!
« Odpověď #29 kdy: 11 Listopad 2009, 11:46:43 »
4@Roman Horník  
dobrá práce K+ ;)

Hm,tak později,mám vybranej limit na aplaus,ale neboj já nezapomenu.  :D

Slib splněn ;)
openSUSE 12.2/btrfs
Opera: King of Browsers.
"Tón, kterým se hovoří v linuxových skupinách, je tvrdý, ale srdečný..."

NoWin

  • Host
Re: apt-get? Zapomeňte!... aneb How to Gentooize Debian-like Systems for n00bs
« Odpověď #30 kdy: 11 Listopad 2009, 12:21:18 »
6) architektura vašeho procesoru- zdá se, že tam jsou pouze architektury Intelu (alespoň u mně; mám navoleno core2).

Potrebujem poradit -  rad by som si zvolil architekturu co najblizsie k mojmu CPU. Hladal som na nete a k nicomu konkretnemu som sa nedostal (mozno som zle hladal - nevylucujem). Mam dvojjadro Intel Pentium Dual CPU T3400 2.16GHz (notes), ktora z moznosti ponukanych pre gcc je pre mna najvhodnejsia? (moj tip i686, ale ak by bola vhodnejsia niektora ina, prosim opravte ma). Thx.

Este som zabudol prihodit listing:
Kód: [Vybrat]
zeus@olymp:~$ cat /proc/cpuinfo
processor : 0
vendor_id : GenuineIntel
cpu family : 6
model : 15
model name : Intel(R) Pentium(R) Dual  CPU  T3400  @ 2.16GHz
stepping : 13
cpu MHz : 1000.000
cache size : 1024 KB
physical id : 0
siblings : 2
core id : 0
cpu cores : 2
apicid : 0
initial apicid : 0
fdiv_bug : no
hlt_bug : no
f00f_bug : no
coma_bug : no
fpu : yes
fpu_exception : yes
cpuid level : 10
wp : yes
flags : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe nx lm constant_tsc arch_perfmon pebs bts pni dtes64 monitor ds_cpl est tm2 ssse3 cx16 xtpr pdcm lahf_lm
bogomips : 4321.97
clflush size : 64
power management:

processor : 1
vendor_id : GenuineIntel
cpu family : 6
model : 15
model name : Intel(R) Pentium(R) Dual  CPU  T3400  @ 2.16GHz
stepping : 13
cpu MHz : 1000.000
cache size : 1024 KB
physical id : 0
siblings : 2
core id : 1
cpu cores : 2
apicid : 1
initial apicid : 1
fdiv_bug : no
hlt_bug : no
f00f_bug : no
coma_bug : no
fpu : yes
fpu_exception : yes
cpuid level : 10
wp : yes
flags : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe nx lm constant_tsc arch_perfmon pebs bts pni dtes64 monitor ds_cpl est tm2 ssse3 cx16 xtpr pdcm lahf_lm
bogomips : 4322.50
clflush size : 64
power management:
Máš-li dvoujádro, zvol core2 ;)

NoWin

  • Host
Re: apt-get? Zapomeňte!... aneb How to Gentooize Debian-like Systems for n00bs
« Odpověď #31 kdy: 11 Listopad 2009, 12:23:08 »
Supr návod, o takové možnosti jsem nevěděl a nejspíš ji u "kousků" využiju! (K+)

Jinak chlape, vážně je nutný používat všechno to exkrementální výrazivo?? (K-)
Sorry za můj hrubší slovník, píšu tak, jak mi zobák narost'. Požaduješ-li ode mne spisovnou češtinu, budiž.

apollo

  • Návštěvník
  • *
  • Příspěvků: 61
  • Karma: +3/-0
    • Zobrazit profil
Re: apt-get? Zapomeňte!... aneb How to Gentooize Debian-like Systems for n00bs
« Odpověď #32 kdy: 11 Listopad 2009, 12:24:23 »
to Roman Hornik: vdaka (a potlesk za prispevok), sam som si nebol isty...

NoWin

  • Host
Re: apt-get? Zapomeňte!... aneb How to Gentooize Debian-like Systems for n00bs
« Odpověď #33 kdy: 11 Listopad 2009, 12:27:10 »
Milý Horníčku, toto je opravdu pěkná hračka, máš ŽETÓN!  ;D

Nebylo by dobré zmínit v návodu, že pokud chci nahradit stávající instalaci balíku, balíkem rekompilovaným stejné verze, musím napsat sudo apt-build install --reinstall balík? Jinak si budou někteří uživatelé jen plnit repo.
Milý GdHíčku ;D,
díky za info i za , mně to ale funguje i bez --reinstall, ale na Ubuntu to jít nemusí. Návod opravím ;)
« Poslední změna: 11 Listopad 2009, 13:03:40 od Roman Horník »

NoWin

  • Host
Re: apt-get? Zapomeňte!
« Odpověď #34 kdy: 11 Listopad 2009, 12:27:44 »
4@Roman Horník  
dobrá práce K+ ;)

Hm,tak později,mám vybranej limit na aplaus,ale neboj já nezapomenu.  :D

Slib splněn ;)
Díky!

Evžen Šubrt

  • Závislák
  • ****
  • Příspěvků: 2218
  • Karma: +177/-35
    • Zobrazit profil
    • EuGenio's Lair
Re: apt-get? Zapomeňte!... aneb How to Gentooize Debian-like Systems for n00bs
« Odpověď #35 kdy: 11 Listopad 2009, 12:33:25 »
Sorry za můj hrubší slovník, píšu tak, jak mi zobák narost'. Požaduješ-li ode mne spisovnou češtinu, budiž.
Bylo to spíš takový rýpnutí ;) V normálním příspěvku by mi to ani tak nevadilo, ale tento se tváří jako návod, který by se bez hrubších výrazů dal použít na wiki či v nějaké Ubuntu příručce.
Athlon X2 6000+, MB ASUS M2R32-MVP, 6GB RAM, ATI Radeon HD7850 1GB, 1GB SSHD + 250GB HDD, Ubuntu 13.10 Saucy Salamander 64bit

NoWin

  • Host
Re: apt-get? Zapomeňte!... aneb How to Gentooize Debian-like Systems for n00bs
« Odpověď #36 kdy: 11 Listopad 2009, 12:43:29 »
Sorry za můj hrubší slovník, píšu tak, jak mi zobák narost'. Požaduješ-li ode mne spisovnou češtinu, budiž.
Bylo to spíš takový rýpnutí ;) V normálním příspěvku by mi to ani tak nevadilo, ale tento se tváří jako návod, který by se bez hrubších výrazů dal použít na wiki či v nějaké Ubuntu příručce.
Evžene, už jsem to přepsal, podívej se ;)

Roman Vacho

  • Člen placené komunitní podpory
  • Moderátor
  • Guru
  • *****
  • Příspěvků: 5588
  • Karma: +218/-47
  • Jeden vykope studnu, tisíce z ní pijí tisíc let.
    • Zobrazit profil
Re: apt-get? Zapomeňte!... aneb How to Gentooize Debian-like Systems for n00bs
« Odpověď #37 kdy: 11 Listopad 2009, 13:17:56 »
Kód: [Vybrat]
flags : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush mmx fxsr sse sse2 ht syscall nx mmxext fxsr_opt
 rdtscp lm 3dnowext 3dnow rep_good extd_apicid pni cx16 lahf_lm cmp_legacy svm extapic cr8_legacy 3dnowprefetch

Teda teď nechápu, proč mi to neuvádí SSE3? Že by chyběla podpora v jádře?
Zkusím reinstalovat na zkompilovaný balík pro jistotu a uvidím co to udělá.
« Poslední změna: 11 Listopad 2009, 14:58:12 od Rovano »
Vyřešená vlákna je vhodné uzavřít dodáním znaků "[vyřešeno]" do názvu téma v editaci prvního příspěvku.

Evžen Šubrt

  • Závislák
  • ****
  • Příspěvků: 2218
  • Karma: +177/-35
    • Zobrazit profil
    • EuGenio's Lair
Re: apt-get? Zapomeňte!... aneb How to Gentooize Debian-like Systems for n00bs
« Odpověď #38 kdy: 11 Listopad 2009, 14:17:30 »
Sorry za můj hrubší slovník, píšu tak, jak mi zobák narost'. Požaduješ-li ode mne spisovnou češtinu, budiž.
Bylo to spíš takový rýpnutí ;) V normálním příspěvku by mi to ani tak nevadilo, ale tento se tváří jako návod, který by se bez hrubších výrazů dal použít na wiki či v nějaké Ubuntu příručce.
Evžene, už jsem to přepsal, podívej se ;)
Veliké díky ;) ;)
Citace
Von jako: "A vám se jako ten původní příspěvek líbil, pane Horník?" To by jeden blil.
Athlon X2 6000+, MB ASUS M2R32-MVP, 6GB RAM, ATI Radeon HD7850 1GB, 1GB SSHD + 250GB HDD, Ubuntu 13.10 Saucy Salamander 64bit

NoWin

  • Host
Re: apt-get? Zapomeňte!... aneb How to Gentooize Debian-like Systems for n00bs
« Odpověď #39 kdy: 11 Listopad 2009, 14:49:37 »
Pak jsem ještě našel

Kód: [Vybrat]
Format: 1.8
Date: Tue, 10 Nov 2009 22:03:56 +0100
Source: totem
Binary: totem totem-mozilla totem-common totem-dbg totem-plugins totem-plugins-extra totem-xine totem-gstreamer
Architecture: all amd64
Version: 2.28.1-0ubuntu4
Distribution: karmic
Urgency: low
Maintainer: Ubuntu Desktop Team <ubuntu-desktop@lists.ubuntu.com>
Changed-By: root <root@panter>
Description:
 totem      - A simple media player for the GNOME desktop based on GStreamer
 totem-common - Data files for the Totem media player
 totem-dbg  - Debugging symbols for the Totem media player
 totem-gstreamer - A simple media player for the GNOME desktop (transitional package
 totem-mozilla - Totem Mozilla plugin
 totem-plugins - Plugins for the Totem media player
 totem-plugins-extra - Extra plugins for the Totem media player
 totem-xine - A simple media player for the GNOME desktop (transitional package
Changes:
 totem (2.28.1-0ubuntu4) karmic; urgency=low
 .
   [ Robert Ancell ]
   * debian/patches/03_screensaver_preferences.patch:
     - Fix logic on "Also disable the screensaver when playing audio" preference
       (LP: #448456)
 .
   [ root ]
   * Built by apt-build
   * Build options: -O3 -mtune=athlon64-sse3
Checksums-Sha1:
 fb907aa152f09eee7f270128a058090c19db6bd4 2844538 totem-common_2.28.1-0ubuntu4_all.deb
 594ef28e28885aa660e78a57bc32bc25ac20c011 51906 totem-xine_2.28.1-0ubuntu4_all.deb
 f10bc98269f23373bf038bdfc634c2a2e55fde9f 51910 totem-gstreamer_2.28.1-0ubuntu4_all.deb
 c58587fefa140a32e045b1d427208cc895e093e2 558928 totem_2.28.1-0ubuntu4_amd64.deb
 707b06a4dcf50133f980f6bd76e8e47a4f231aa8 187760 totem-mozilla_2.28.1-0ubuntu4_amd64.deb
 c85f2151894edc4be6ab6374f24a49eff52b45e5 1848314 totem-dbg_2.28.1-0ubuntu4_amd64.deb
 bc998562cdd9e636533434b932d1bb6d4ece8fe3 212978 totem-plugins_2.28.1-0ubuntu4_amd64.deb
 e93724efc375b4c7d574f0ffc5baf535205a8327 115806 totem-plugins-extra_2.28.1-0ubuntu4_amd64.deb
Checksums-Sha256:
 a821048c33a2d96dfa6367a1014d5230fe845c80a8bc3f6399aade2e08884404 2844538 totem-common_2.28.1-0ubuntu4_all.deb
 c3552db2a1f5ce2cb96ad4c698511a110b2e4e99330b9086bb98783fd53d4a50 51906 totem-xine_2.28.1-0ubuntu4_all.deb
 921c6c787ae81af44cd360a6c127d02b5017914219d024bf857ae6e64752c8bd 51910 totem-gstreamer_2.28.1-0ubuntu4_all.deb
 20ce7c6afa6fc585530ba0fdae2946da74dec6cf11d7cb21eabb4aef1a19eb30 558928 totem_2.28.1-0ubuntu4_amd64.deb
 018c60cd8f41ee621199f8b90026a00f309741a7860b080ab4595c0b5053739e 187760 totem-mozilla_2.28.1-0ubuntu4_amd64.deb
 6ae87b556faafe884700bc02b3f3d6baaf838699aaade5b463499c9dab3359e1 1848314 totem-dbg_2.28.1-0ubuntu4_amd64.deb
 ca79b061a23ba4cb31494967f27234e94451eb143ef7b2764fc37424a9bbdc48 212978 totem-plugins_2.28.1-0ubuntu4_amd64.deb
 5e3eed5f6418eb651bc2789d99f54a9b293da187fd9e37807f934560741797c0 115806 totem-plugins-extra_2.28.1-0ubuntu4_amd64.deb
Files:
 af71b5bdae4d79270067a9717b89a614 2844538 gnome optional totem-common_2.28.1-0ubuntu4_all.deb
 1fc8558d1acb758e8a337454f68e0738 51906 gnome optional totem-xine_2.28.1-0ubuntu4_all.deb
 a55d2a0a4cd6fe12b67189691a4b6111 51910 gnome optional totem-gstreamer_2.28.1-0ubuntu4_all.deb
 e26c20e2f830231268a40a93436685b3 558928 gnome optional totem_2.28.1-0ubuntu4_amd64.deb
 218f7aca1841dad8a14f58d090ce1dec 187760 web optional totem-mozilla_2.28.1-0ubuntu4_amd64.deb
 4ae08e3c2393e3db39df09cd991a8bab 1848314 libdevel extra totem-dbg_2.28.1-0ubuntu4_amd64.deb
 fda3624c8b006dd784868e4a8df49dac 212978 gnome optional totem-plugins_2.28.1-0ubuntu4_amd64.deb
 2b95437ed3aa621021a15b74c24d8db2 115806 gnome optional totem-plugins-extra_2.28.1-0ubuntu4_amd64.deb
Launchpad-Bugs-Fixed: 448456
Original-Maintainer: Sebastien Bacher <seb128@debian.org>

ve /var/cache/apt-build/build
soubor totem blabla .changes
To je prosím seznam změn oproti předchozí verzi.

NoWin

  • Host
Re: apt-get? Zapomeňte!... aneb How to Gentooize Debian-like Systems for n00bs
« Odpověď #40 kdy: 11 Listopad 2009, 14:50:01 »
Sorry za můj hrubší slovník, píšu tak, jak mi zobák narost'. Požaduješ-li ode mne spisovnou češtinu, budiž.
Bylo to spíš takový rýpnutí ;) V normálním příspěvku by mi to ani tak nevadilo, ale tento se tváří jako návod, který by se bez hrubších výrazů dal použít na wiki či v nějaké Ubuntu příručce.
Evžene, už jsem to přepsal, podívej se ;)
Veliké díky ;) ;)
Citace
Von jako: "A vám se jako ten původní příspěvek líbil, pane Horník?" To by jeden blil.
;D

Milhouse

  • Moderátor
  • Guru
  • *****
  • Příspěvků: 5633
  • Karma: +232/-36
    • Zobrazit profil
Re: apt-get? Zapomeňte!... aneb How to Gentooize Debian-like Systems for n00bs
« Odpověď #41 kdy: 11 Listopad 2009, 14:56:54 »
Jen si značím. ;)

N. Á. V. O. D. Y.
 "...naše práce není vidět, ale je důležitá!"

Iljusin

  • Člen
  • **
  • Příspěvků: 350
  • Karma: +31/-2
    • Zobrazit profil
Re: apt-get? Zapomeňte!... aneb How to Gentooize Debian-like Systems for n00bs
« Odpověď #42 kdy: 11 Listopad 2009, 19:28:04 »
Když si přeinstaluju již instalované aplikace, tak mi to na za začátku píše, že přeinstaluje ten můj volaný balíček + nainstaluje x dalších. Ty "další" jsou potřeba jen pro tu kompilaci a pak už jsou zbytečný? Nebo jsou nutné pro další chod aplikace? Třeba po kompilaci Rhythmboxu mám skoro o 300MB na disku míň a na notebooku s místem na disku dost zápasím.

Iljusin

  • Člen
  • **
  • Příspěvků: 350
  • Karma: +31/-2
    • Zobrazit profil
Re: apt-get? Zapomeňte!... aneb How to Gentooize Debian-like Systems for n00bs
« Odpověď #43 kdy: 11 Listopad 2009, 19:31:52 »
Konkrétně v tom Rhythmboxu jde o tyto nové balíky:
Kód: [Vybrat]
Následující NOVÉ balíky budou nainstalovány:
  docbook-utils dvipdfmx jadetex lacheck latex-beamer latex-xcolor
  libaudiofile-dev libavahi-client-dev libavahi-common-dev libavahi-glib-dev
  libbonobo2-dev libbrasero-media-dev libesd0-dev libglade2-dev
  libgmime-2.4-dev libgnome-keyring-dev libgnome-media-dev libgnome2-dev
  libgnomevfs2-dev libgpod-dev libgstreamer-plugins-base0.10-dev
  libgstreamer0.10-dev libgudev-1.0-dev liblircclient-dev libmtp-dev
  libmusicbrainz4-dev libpopt-dev libsgmls-perl libsoup-gnome2.4-dev
  libsoup2.4-dev libtotem-plparser-dev libudev-dev libusb-dev lmodern pgf
  prosper ps2eps python-gst0.10-dev sgmlspl tex-common texlive-base
  texlive-base-bin texlive-base-bin-doc texlive-common texlive-doc-base
  texlive-extra-utils texlive-fonts-recommended texlive-fonts-recommended-doc
  texlive-generic-recommended texlive-latex-base texlive-latex-base-doc
  texlive-latex-recommended texlive-latex-recommended-doc texlive-pstricks
  texlive-pstricks-doc tipa

aloisam

  • Host
Re: apt-get? Zapomeňte!... aneb How to Gentooize Debian-like Systems for n00bs
« Odpověď #44 kdy: 11 Listopad 2009, 20:02:40 »
Úspěšně jsem to vyzkoušel na:
Totem
Nautilus
GNOME Panel
GIMP
APT, Aptitude, Synaptic
částečně GNOME
BIND9
DebConf
GPartEd
Apache2
Me TV
ALSA
několik knihoven atd.


Na něčem to jít nemusí, třeba to vyžaduje zvláštní volby pro GCC a/nebo Make.

a co firefox prosím? to by mě dost zajímalo ;)

Roman Vacho

  • Člen placené komunitní podpory
  • Moderátor
  • Guru
  • *****
  • Příspěvků: 5588
  • Karma: +218/-47
  • Jeden vykope studnu, tisíce z ní pijí tisíc let.
    • Zobrazit profil
Re: apt-get? Zapomeňte!... aneb How to Gentooize Debian-like Systems for n00bs
« Odpověď #45 kdy: 11 Listopad 2009, 20:17:20 »
Zkompiloval sjem Tremulous, změny nepozoruji, protože mě brzdí jen grafika, ale když ukončím Tremulous, už mám správně 85Hz. Předtím mi to dávalo 75Hz. Možná za to však může editace souboru header_00.

Chtěl jsem si zkompilovat FF, ale Missing source package name for source_by_source(). mi v tom brání. Měl sem duplicitní zdroje, to jsem spravil, ale stále ta stejná chyba.
« Poslední změna: 11 Listopad 2009, 21:06:38 od Rovano »
Vyřešená vlákna je vhodné uzavřít dodáním znaků "[vyřešeno]" do názvu téma v editaci prvního příspěvku.

Robert1106

  • Návštěvník
  • *
  • Příspěvků: 69
  • Karma: +3/-1
    • Zobrazit profil
Re: apt-get? Zapomeňte!... aneb How to Gentooize Debian-like Systems for n00bs
« Odpověď #46 kdy: 11 Listopad 2009, 21:37:03 »
to je zlastne firefox mi isel normalne skompilovat a aj na instalovat a co je najdivnejsie aj funguje  ;D Inak chcel som sa spitat ci nebudu na ubuntu problemi s kompilaciou, lebo tu je gnome znacne upravene. Ako je to sa aktualizaciami? Po kazdej aktualizacii kompilovat je trocu nahlavu nie? :D

Kedrigern

  • Stálý člen
  • ***
  • Příspěvků: 919
  • Karma: +127/-18
    • Zobrazit profil
    • Má osobní stránka
Re: apt-get? Zapomeňte!... aneb How to Gentooize Debian-like Systems for n00bs
« Odpověď #47 kdy: 11 Listopad 2009, 22:42:37 »
Tak jsem zkompiloval Totem a jede parádně (předtím se skoro nonstop sekal, nemluvím o titulcích).

Jen bych se zeptal (padlo to tu, ale jasnou odpověď jsem neviděl), lze nějak rozumně a inteligentně zjistit, že je používán mnou zkompilovaný balík?

Roman Vacho

  • Člen placené komunitní podpory
  • Moderátor
  • Guru
  • *****
  • Příspěvků: 5588
  • Karma: +218/-47
  • Jeden vykope studnu, tisíce z ní pijí tisíc let.
    • Zobrazit profil
Re: apt-get? Zapomeňte!... aneb How to Gentooize Debian-like Systems for n00bs
« Odpověď #48 kdy: 11 Listopad 2009, 23:01:17 »
Tak jsem zkompiloval Totem a jede parádně (předtím se skoro nonstop sekal, nemluvím o titulcích).

Jen bych se zeptal (padlo to tu, ale jasnou odpověď jsem neviděl), lze nějak rozumně a inteligentně zjistit, že je používán mnou zkompilovaný balík?

Tvůj popis ti nestačí?  ;D Jako já žádné zrychlení nepozoruji. Takže si nejsem vůbec jist, zda užívám zkompilované balíky a zda je vůbec v tom generic kernelu podpora pro SSE3.
Vyřešená vlákna je vhodné uzavřít dodáním znaků "[vyřešeno]" do názvu téma v editaci prvního příspěvku.

GdH

  • Moderátor
  • Závislák
  • *****
  • Příspěvků: 3008
  • Karma: +480/-17
    • Zobrazit profil
    • GdH-Notes
Re: apt-get? Zapomeňte!... aneb How to Gentooize Debian-like Systems for n00bs
« Odpověď #49 kdy: 11 Listopad 2009, 23:20:56 »
to je zlastne firefox mi isel normalne skompilovat a aj na instalovat a co je najdivnejsie aj funguje  ;D Inak chcel som sa spitat ci nebudu na ubuntu problemi s kompilaciou, lebo tu je gnome znacne upravene. Ako je to sa aktualizaciami? Po kazdej aktualizacii kompilovat je trocu nahlavu nie? :D

Za normálních okolností máš ve zdrojích software (sources.list) u každého repozitáře jeden odkaz na předkompilované deb balíky a druhý na zdrojové kódy, ze kterých byly vyrobeny. Apt-build bere ty zdrojáky a kompiluje je sám, vyrobí nový optimalizovaný deb a uloží ho do vlastního repozitáře na disku. Odtud je pak nainstaluje stejně jako kdybys instaloval bez kompilace. Tudíž, pokud nemáš ve zdrojích kraviny, není teoreticky důvod k jakékoli nekompatibilitě.