Prosíme přihlašte se nebo zaregistrujte.

Přihlašte se svým uživatelským jménem a heslem.
Vaše pomoc je stále potřeba!

Novinky: Školení nejen k OS Ubuntu pro širokou veřejnost, více informací zde.

Autor Téma: nelze zapisovat na partišnu  (Přečteno 724 krát)

Matěj Valášek

  • Návštěvník
  • *
  • Příspěvků: 9
  • Karma: +0/-1
    • Zobrazit profil
nelze zapisovat na partišnu
« kdy: 03 Listopad 2017, 09:13:32 »
Dobrý den mám problém mám na svém notebooku tři partišny.
Na první je Ubuntu 17.10,na druhé jsou upgradované windows 10 z windows 7,na třetí partišně jsou namapované
windows účty + společná data s Ubuntu(nenamapováno!)-kopírována!.Jmenuje se DATA(třetí partišna).
Problém je v tom, že nelze vkládat ani mazat soubory na třetí partišně z Ubuntu,je po otevření vlastností oprávnění jako
root,místo mého účtu a nelze to změnit!
Zde je výpis příkazu ls -l  v Data:
celkem 36
drwxrwxrwx 1 root root  8192 zář 28 14:25 hudba
drwxrwxrwx 1 root root  4096 říj 20 12:01 MapData
drwxrwxrwx 1 root root     0 lis  3 07:36 $RECYCLE.BIN
drwxrwxrwx 1 root root  4096 lis  3 07:11 System Volume Information
drwxrwxrwx 1 root root 20480 říj 24 16:51 Ubuntu
drwxrwxrwx 1 root root     0 říj 18 20:43 WIN
drwxrwxrwx 1 root root     0 říj 20 12:01 WindowsApps
drwxrwxrwx 1 root root     0 říj 18 20:42 Windows.old

Zkoušel jsem také příkazy chmod:(neúspěšně!)
matej@mates-ntb:/DATA$ chmod 777 /DATA
chmod: práva '/DATA' nelze změnit: Systém souborů je pouze pro čtení
matej@mates-ntb:/DATA$

a chown:
matej@mates-ntb:/DATA$ chown 777 /DATA
chown: změnění vlastnictví souboru '/DATA': Systém souborů je pouze pro čtení
matej@mates-ntb:/DATA$

A nepomohla ani reinstalace systému!

Děkuji Matěj Valášek
« Poslední změna: 03 Listopad 2017, 10:44:40 od Matěj Valášek »

jmp

  • Závislák
  • ****
  • Příspěvků: 2536
  • Karma: +240/-32
    • Zobrazit profil
Re:nelze zapisovat na partišnu
« Odpověď #1 kdy: 03 Listopad 2017, 10:25:53 »
hmm, reinstalace systému opravdu na lidskou blbost/neznalost nepomáhá...

na NTFS nelze používat oprávnění jako na unixu (nastavíte si emulaci jednorázově a globálně pro celou partišnu při mountování a chmod, chown prostě použít nelze)

dále jste se pravděpodobně vůbec nepodíval na výstup mount ani do logu proč se tak děje - asi to bude zapnutým fastbootem ve windows, ale musíte se podívat sám (to způsobí připojení partišny RO a ne RW)

pokud budete dále používat spousty vykřičníků, tak si uvědomte, že je to neslušné a podle toho může vypadat odezva...

juwa2

  • Závislák
  • ****
  • Příspěvků: 1117
  • Karma: +81/-24
    • Zobrazit profil
Re:nelze zapisovat na partišnu
« Odpověď #2 kdy: 03 Listopad 2017, 10:28:21 »
V prvé řadě si ve Win. vypni zhůvěřilost zvanou fastboot (rychlý start). Pak restartuj do ubuntu a podívej se, zda už je ta partyšna připojena v režimu čten/zápis. Pokud ne, uprav parametry připojení (soubor /etc/fstab - odstraníš parametr ro). Lze to i "naklikat" v aplikaci "Disky".

Nebo to můžeš (jednorázově) vyřešit příkazem:
Kód: [Vybrat]
sudo ntfsfix /dev/sdXY
(kam za "sdXY" dosadíš správné označení toho oddílu, např. sda4)
Označení jednotlivých oddílů zjistíš z výpisu příkazu:
Kód: [Vybrat]
sudo fdisk -l
« Poslední změna: 03 Listopad 2017, 10:38:26 od juwa2 »

Matěj Valášek

  • Návštěvník
  • *
  • Příspěvků: 9
  • Karma: +0/-1
    • Zobrazit profil
Re:nelze zapisovat na partišnu
« Odpověď #3 kdy: 03 Listopad 2017, 10:49:50 »
zde je výpis mého souboru fstab:
Kód: [Vybrat]
# /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
# / was on /dev/sda7 during installation
UUID=fe144609-e450-4da1-a2a5-9720975dafee /               ext4    errors=remount-ro 0       1
# /boot was on /dev/sda5 during installation
UUID=f0161c01-c4de-47bb-bbcb-44dd9b7d9e5b /boot           ext4    defaults        0       2
# swap was on /dev/sda6 during installation
UUID=a5170204-e282-4535-8fcc-d98946c5eec1 none            swap    sw              0       0
#
UUID=72883F88883F4A3D  /DATA/  ntfs-3g  defaults,windows_names,locale=cs_CZ.utf8  0 0

poslední řádek slouží k automatickému přimountování partišny DATA-fungovalo to i před tímto problémem.

juwa2

  • Závislák
  • ****
  • Příspěvků: 1117
  • Karma: +81/-24
    • Zobrazit profil
Re:nelze zapisovat na partišnu
« Odpověď #4 kdy: 03 Listopad 2017, 13:26:58 »
Fstab je v pořádku. Je jasné, že to blokuje Win. - udělej co píšu výše.

Matěj Valášek

  • Návštěvník
  • *
  • Příspěvků: 9
  • Karma: +0/-1
    • Zobrazit profil
Re:nelze zapisovat na partišnu
« Odpověď #5 kdy: 03 Listopad 2017, 13:34:52 »
zde je výpis příkazů:
matej@mates-ntb:~$ sudo ntfsfix /dev/sda3
[sudo] heslo pro matej:
Mounting volume... OK
Processing of $MFT and $MFTMirr completed successfully.
Checking the alternate boot sector... OK
NTFS volume version is 3.1.
NTFS partition /dev/sda3 was processed successfully.
matej@mates-ntb:~$ sudo fdisk -l
Disk /dev/sda: 465,8 GiB, 500107862016 bytes, 976773168 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 4096 bytes
I/O size (minimum/optimal): 4096 bytes / 4096 bytes
Disklabel type: dos
Disk identifier: 0xa5c6eb71

Zařízení   Zaveditelný     Start     Konec   Sektory   Size Id Druh
/dev/sda1  *                2048    206847    204800   100M  7 HPFS/NTFS/exFAT
/dev/sda2                 206848 209717247 209510400  99,9G  7 HPFS/NTFS/exFAT
/dev/sda3              419432448 976771071 557338624 265,8G  7 HPFS/NTFS/exFAT
/dev/sda4              209719294 419432447 209713154   100G  5 Rozšířený
/dev/sda5              409667584 419432447   9764864   4,7G 83 Linux
/dev/sda6              209719296 211718143   1998848   976M 82 Linux swap/Solari
/dev/sda7              211720192 409657343 197937152  94,4G 83 Linux

Partition 4 does not start on physical sector boundary.
Partition table entries are not in disk order.
matej@mates-ntb:~$

jmp

  • Závislák
  • ****
  • Příspěvků: 2536
  • Karma: +240/-32
    • Zobrazit profil
Re:nelze zapisovat na partišnu
« Odpověď #6 kdy: 03 Listopad 2017, 13:49:23 »
pokud je ve windows zapnutý fastboot, tak windows nejsou vypnuté

použít ntfsfix v takovém případě _není_ dobrý nápad ... (až tak, že windows následně třeba nenastartujete vůbec)


juwa2

  • Závislák
  • ****
  • Příspěvků: 1117
  • Karma: +81/-24
    • Zobrazit profil
Re:nelze zapisovat na partišnu
« Odpověď #7 kdy: 03 Listopad 2017, 13:55:11 »
zde je výpis příkazů:
matej@mates-ntb:~$ sudo ntfsfix /dev/sda3
[sudo] heslo pro matej:
Mounting volume... OK
Processing of $MFT and $MFTMirr completed successfully.
Checking the alternate boot sector... OK
NTFS volume version is 3.1.
NTFS partition /dev/sda3 was processed successfully.
matej@mates-ntb:~$ sudo fdisk -l
Disk /dev/sda: 465,8 GiB, 500107862016 bytes, 976773168 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 4096 bytes
I/O size (minimum/optimal): 4096 bytes / 4096 bytes
Disklabel type: dos
Disk identifier: 0xa5c6eb71

Zařízení   Zaveditelný     Start     Konec   Sektory   Size Id Druh
/dev/sda1  *                2048    206847    204800   100M  7 HPFS/NTFS/exFAT
/dev/sda2                 206848 209717247 209510400  99,9G  7 HPFS/NTFS/exFAT
/dev/sda3              419432448 976771071 557338624 265,8G  7 HPFS/NTFS/exFAT
/dev/sda4              209719294 419432447 209713154   100G  5 Rozšířený
/dev/sda5              409667584 419432447   9764864   4,7G 83 Linux
/dev/sda6              209719296 211718143   1998848   976M 82 Linux swap/Solari
/dev/sda7              211720192 409657343 197937152  94,4G 83 Linux

Partition 4 does not start on physical sector boundary.
Partition table entries are not in disk order.
matej@mates-ntb:~$

No, dobře - a už se na tu partišnu tedy dá zapisovat, zkoušels to??

Matěj Valášek

  • Návštěvník
  • *
  • Příspěvků: 9
  • Karma: +0/-1
    • Zobrazit profil
Re:nelze zapisovat na partišnu
« Odpověď #8 kdy: 03 Listopad 2017, 14:41:17 »
ano dá už to všechno funguje nevím proč ale spustil jsem chkdisk we windows na tu partišnu poprvé to našlo nějaké chyby nevím jaké nevypsalo je to a podruhé to nenašlo nic tak nevím ,po následném restartu do linuxu to najednou funguje ale je pořád vlastníkem root tak nevím.

juwa2

  • Závislák
  • ****
  • Příspěvků: 1117
  • Karma: +81/-24
    • Zobrazit profil
Re:nelze zapisovat na partišnu
« Odpověď #9 kdy: 03 Listopad 2017, 15:13:07 »
ano dá už to všechno funguje nevím proč ale spustil jsem chkdisk we windows na tu partišnu poprvé to našlo nějaké chyby nevím jaké nevypsalo je to a podruhé to nenašlo nic tak nevím ,po následném restartu do linuxu to najednou funguje ale je pořád vlastníkem root tak nevím.
1. Ty chyby na disku byly působené tím, že se win. úplně nevypínal (částečná hibernace spojená s fastbootem).
Takže občas to projet chkdiskem není na škodu...
2. Pokud se tedy už dá na disk zapisovat, nic nebrání abys převzal jeho vlastnictví:
Kód: [Vybrat]
sudo chown -R matej:matej /DATAmísto "/DATA"  napiš v případě potřeby přesnou cestu k přípojnému bodu (pokud se liší)
« Poslední změna: 03 Listopad 2017, 15:22:36 od juwa2 »

jmp

  • Závislák
  • ****
  • Příspěvků: 2536
  • Karma: +240/-32
    • Zobrazit profil
Re:nelze zapisovat na partišnu
« Odpověď #10 kdy: 03 Listopad 2017, 16:21:19 »
oba mrkněte na
Kód: [Vybrat]
man mount.ntfs-3g...
Citace
   Windows hibernation and fast restarting
       On  computers  which  can be dual-booted into Windows or Linux, Windows
       has to be fully shut down before booting into Linux, otherwise the NTFS
       file systems on internal disks may be left in an inconsistent state and
       changes made by Linux may be ignored by Windows.

       So, Windows may not be left in  hibernation  when  starting  Linux,  in
       order  to  avoid  inconsistencies.  Moreover,  the fast restart feature
       available on recent Windows systems has to be  disabled.  This  can  be
       achieved  by issuing as an Administrator the Windows command which dis‐
       ables both hibernation and fast restarting :

              powercfg /h off

...
Citace
OPTIONS
       Below is a summary of the options that ntfs-3g accepts.

       uid=value and gid=value
              Set the owner and the group of files and directories. The values
              are  numerical.  The defaults are the uid and gid of the current
              process.

       umask=value
              Set the  bitmask of the file and directory permissions that  are
              not present. The value is given in octal. The default value is 0
              which means full access to everybody.

       fmask=value
              Set the  bitmask of the file permissions that are  not  present.
              The  value is given in octal. The default value is 0 which means
              full access to everybody.

       dmask=value
              Set the  bitmask of  the  directory  permissions  that  are  not
              present.  The  value  is  given in octal. The default value is 0
              which means full access to everybody.


Matěj Valášek

  • Návštěvník
  • *
  • Příspěvků: 9
  • Karma: +0/-1
    • Zobrazit profil
Re:nelze zapisovat na partišnu
« Odpověď #11 kdy: 03 Listopad 2017, 16:55:27 »
ten příkaz nefunguje ,pořád i po tom příkazu jsem root.Tak fakt nevím
« Poslední změna: 03 Listopad 2017, 17:01:25 od Matěj Valášek »

jmp

  • Závislák
  • ****
  • Příspěvků: 2536
  • Karma: +240/-32
    • Zobrazit profil
Re:nelze zapisovat na partišnu
« Odpověď #12 kdy: 03 Listopad 2017, 17:17:17 »

Marp

  • Moderátor
  • Závislák
  • *****
  • Příspěvků: 2396
  • Karma: +195/-69
  • Nejčastější příčinou úmrtí je smrt!
    • Zobrazit profil
    • Svět podle Marpa
Re:nelze zapisovat na partišnu
« Odpověď #13 kdy: 03 Listopad 2017, 17:26:16 »
ten příkaz nefunguje ,pořád i po tom příkazu jsem root.Tak fakt nevím
No ale ty musíš být root přeci  ;) Co na tom nechápeš?
Marek *Marp* Pszczolka
Lenovo IdeaPad B590 + openSUSE Tumbleweed

Matěj Valášek

  • Návštěvník
  • *
  • Příspěvků: 9
  • Karma: +0/-1
    • Zobrazit profil
Re:nelze zapisovat na partišnu
« Odpověď #14 kdy: 03 Listopad 2017, 17:35:45 »
vždyť jsem,prostě to nefunguje má být nějaký výstup nebo ne když po tomto příkazu zadám ls -l tak je pořád oprávnění root
Kód: [Vybrat]
matej@mates-ntb:~$ sudo su
[sudo] heslo pro matej:
root@mates-ntb:/home/matej# sudo chown -R matej:matej /DATA
root@mates-ntb:/home/matej# ls -l /DATA
celkem 32
drwxrwxrwx 1 root root  8192 zář 28 14:25 hudba
drwxrwxrwx 1 root root  4096 říj 20 12:01 MapData
drwxrwxrwx 1 root root 20480 lis  3 14:00 Ubuntu
drwxrwxrwx 1 root root     0 říj 18 20:43 WIN
root@mates-ntb:/home/matej#
« Poslední změna: 03 Listopad 2017, 17:43:30 od Matěj Valášek »

juwa2

  • Závislák
  • ****
  • Příspěvků: 1117
  • Karma: +81/-24
    • Zobrazit profil
Re:nelze zapisovat na partišnu
« Odpověď #15 kdy: 03 Listopad 2017, 18:17:35 »
Změň přípojný bod na   /media/matej/DATA
Vytvoř složku
Kód: [Vybrat]
sudo mkdir /media/matej/DATA
A změň příp. bod v fstab. Pak restartuj.
Pak budeš vlastníkem ty (matej).

Matěj Valášek

  • Návštěvník
  • *
  • Příspěvků: 9
  • Karma: +0/-1
    • Zobrazit profil
Re:nelze zapisovat na partišnu
« Odpověď #16 kdy: 03 Listopad 2017, 18:33:05 »
pořád nejsem vlastník

jmp

  • Závislák
  • ****
  • Příspěvků: 2536
  • Karma: +240/-32
    • Zobrazit profil
Re:nelze zapisovat na partišnu
« Odpověď #17 kdy: 03 Listopad 2017, 18:37:23 »
tak znova...
oba mrkněte na
Kód: [Vybrat]
man mount.ntfs-3g...
Citace
   Windows hibernation and fast restarting
       On  computers  which  can be dual-booted into Windows or Linux, Windows
       has to be fully shut down before booting into Linux, otherwise the NTFS
       file systems on internal disks may be left in an inconsistent state and
       changes made by Linux may be ignored by Windows.

       So, Windows may not be left in  hibernation  when  starting  Linux,  in
       order  to  avoid  inconsistencies.  Moreover,  the fast restart feature
       available on recent Windows systems has to be  disabled.  This  can  be
       achieved  by issuing as an Administrator the Windows command which dis‐
       ables both hibernation and fast restarting :

              powercfg /h off

...
Citace
OPTIONS
       Below is a summary of the options that ntfs-3g accepts.

       uid=value and gid=value
              Set the owner and the group of files and directories. The values
              are  numerical.  The defaults are the uid and gid of the current
              process.

       umask=value
              Set the  bitmask of the file and directory permissions that  are
              not present. The value is given in octal. The default value is 0
              which means full access to everybody.

       fmask=value
              Set the  bitmask of the file permissions that are  not  present.
              The  value is given in octal. The default value is 0 which means
              full access to everybody.

       dmask=value
              Set the  bitmask of  the  directory  permissions  that  are  not
              present.  The  value  is  given in octal. The default value is 0
              which means full access to everybody.


potřebné hodnoty získáte třeba pomocí
Kód: [Vybrat]
id

juwa2

  • Závislák
  • ****
  • Příspěvků: 1117
  • Karma: +81/-24
    • Zobrazit profil
Re:nelze zapisovat na partišnu
« Odpověď #18 kdy: 03 Listopad 2017, 20:26:21 »
pořád nejsem vlastník
Spusť Nautilus s právy roota
Kód: [Vybrat]
gksudo nautilusOznač v něm tu složku (DATA) > pravoklik > vlastnosti > oprávnění
A tam si nastav vlastníka na sebe a zrovna i oprávnění jaké chceš...

jmp

  • Závislák
  • ****
  • Příspěvků: 2536
  • Karma: +240/-32
    • Zobrazit profil
Re:nelze zapisovat na partišnu
« Odpověď #19 kdy: 03 Listopad 2017, 20:35:51 »
jde o NTFS => musí to dát jako gid a uid optiony v momentě kdy to mountuje (tedy např. ve fstab) a bude to pro celou partišnu

chmod, chown a podobné změny vlastníka/oprávnění tu nezaberou, protože je to pouze emulováno


Matěj Valášek

  • Návštěvník
  • *
  • Příspěvků: 9
  • Karma: +0/-1
    • Zobrazit profil
Re:nelze zapisovat na partišnu
« Odpověď #20 kdy: 04 Listopad 2017, 08:25:27 »
super už jde zapisovat na partišnu a už jsem i vlastník akorát mi nelze změnit skupina hodím sem printscreen co mi nejde změnit -zůstane to po potvrzení na té původní hodnotě.