Prosíme přihlašte se nebo zaregistrujte.

Přihlašte se svým uživatelským jménem a heslem.
Vaše pomoc je stále potřeba!

Novinky: Děkujeme všem návštěvníkům fóra, kteří ochotně radí ostatním. Vaše práce je velmi potřebná a vážíme si jí.

Autor Téma: chybějící libwxgtk2.8-0  (Přečteno 380 krát)

DanielK

  • Návštěvník
  • *
  • Příspěvků: 89
  • Karma: +0/-0
    • Zobrazit profil
chybějící libwxgtk2.8-0
« kdy: 28 Květen 2018, 22:26:58 »
Ahoj, nevím si rady jak doinstalovat knihovnu libwx_gtk2u_richtext-2.8.so.0: do Ubuntu 18.04

Našel jsem nějaký návody pro předešlé LTS verze, ale pokusy o stejný postupy instalace se nějak nezdařily...

Po přidání repozitářů
Kód: [Vybrat]
sudo add-apt-repository ppa:nilarimogard/webupd8

a následném update jsem se zasekl u:

Kód: [Vybrat]
sudo apt-get install libwxgtk2.8-0
Načítají se seznamy balíků… Hotovo
Vytváří se strom závislostí       
Načítají se stavové informace… Hotovo
E: Nelze najít balík libwxgtk2.8-0
E: Nelze najít balík vyhovující masce „libwxgtk2.8-0“
E: Nelze najít balík vyhovující regulárnímu výrazu „libwxgtk2.8-0“

Jak dostanu tuhle knihovnu do systému Ubuntu 18.04?
Děkuji za rady.

DanielK

  • Návštěvník
  • *
  • Příspěvků: 89
  • Karma: +0/-0
    • Zobrazit profil
Re:chybějící libwxgtk2.8-0
« Odpověď #1 kdy: 29 Květen 2018, 19:54:35 »
Ahoj, tak jsem nainstaloval starší verzi ubuntu 16.04 a nainstaloval :

Kód: [Vybrat]
sudo apt-get install libwxgtk2.8.0:i386
Kód: [Vybrat]
sudo apt-get install libusb-0.1:i386
ale při spuštění programu mi vypíše:

Kód: [Vybrat]
./avrprog
Fatal Error: Mismatch between the program and library build versions detected.
The library used 2.8 (no debug,Unicode,compiler with C++ ABI 1009,wx containers,compatible with 2.6),
and your program used 2.8 (no debug,Unicode,compiler with C++ ABI 1002,wx containers,compatible with 2.6).
Neúspěšně ukončen (SIGABRT) (core dumped [obraz paměti uložen])

Avšak nerozumím co po mě chtějí...
Nějaký tip jak to opravit?

juwa2

  • Závislák
  • ****
  • Příspěvků: 1745
  • Karma: +121/-34
    • Zobrazit profil
Re:chybějící libwxgtk2.8-0
« Odpověď #2 kdy: 29 Květen 2018, 20:38:35 »
No máš to tam napsané - máš nainstalovanou jinou verzi knihovny než ten program vyžaduje. Musíš to uvést do souladu.
A pokud budeš shánět balíčky, stačí se přece do PPA podívat a odtud si je stáhnout...
Příklad:
Repozitář je  ppa:nilarimogard/webupd8
Jeho adresa je (vygooglíš)  https://launchpad.net/~nilarimogard/+archive/ubuntu/webupd8
Balíčky ke stažení jsou zde (rozklikni si šipky vlevo) https://launchpad.net/~nilarimogard/+archive/ubuntu/webupd8/+packages
(pak bys zjistil, že uvedený PPA balík libwxgtk2.8-0 neobsahuje)
No a pokud požadovaný balík najdeš, stáhni ho a nainstaluj pomocí gdebi - upozorní tě na příp. další závislosti)
---------------------------------------------------------
Balík je totiž zde http://ppa.launchpad.net/nilarimogard/webupd8/ubuntu/pool/main/w/wxwidgets2.8/
Nejvyšší verze je pro xenial. Takže si k ní schrasti ještě ten program.
Hledat můžeš taky zde https://pkgs.org/download/libwxgtk2.8-0
a zde https://reposcope.com


DanielK

  • Návštěvník
  • *
  • Příspěvků: 89
  • Karma: +0/-0
    • Zobrazit profil
Re:chybějící libwxgtk2.8-0
« Odpověď #3 kdy: 31 Květen 2018, 19:45:34 »
Ahoj, díky za obsáhlou odpověď, zkoušel jsem instalovat ty balíky, u některých mi to psalo, že už je vyšší verze u některých, že je potřeba nainstalovat závislosti ( sudo apt-get -f install), instaloval jsem je i pomocí toho gdebi u některých to psalo, že už je nainstalovaný u jiných že to poškodí stávající balík...

Bohužel mi to stále nefunguje :(
jak poznám kde se nachází ten "compiler with C++ ABI 1002"? Když jsem to zkoušel gůglovat, tak lidi měli opačný problém, že potřebovali tu novější"?" verzi a to na starším  ubuntu 14.04


Potřebuju program pro programování MCU: http://www.extremeelectronics.co.in/software/BurnerAVR/xAVR_Ubuntu.tar.gz

Děkuju za ochotu.

juwa2

  • Závislák
  • ****
  • Příspěvků: 1745
  • Karma: +121/-34
    • Zobrazit profil
Re:chybějící libwxgtk2.8-0
« Odpověď #4 kdy: 31 Květen 2018, 20:43:59 »
S těmi závislostmi (že to některé stávající balíky poškodí) se to má tak, že je potřeba napřed tyto závislé balíky (co jsou jiné verze (nižší nebo vyšší, to je jedno)) odinstalovat. Teprve potom lze ninstalovat postupně "celou novou závislou sadu" požadovaných balíků. Není to až tak těžké, chce to trochu cviku a zkušeností.
A kde se co a ve kterém balíku nachází?  Podrobné popisy obsahu balíků jsou na stránkách  PPA.
Balík .deb je archiv jako každý jiný, otevřeš/rozbalíš ho ve správci archivů a můžeš se probírat jeho obsahem. Kromě toho si můžeš takový balík, pokud není dostupný v nějakém PPA sám zkompilovat ze zdrojáku.
--------------------------------------------------------------------------------------------------------
Poznámka: Před těmito "pokusy" a podobným laborováním (jinak nic proti nim, ba naopak) je vhodné si systém zálohovat buď pomocí image, stačí systémový oddíl /   (pomocí Clonezilla), nebo poněkud pohodlněji do snapshotů pomocí aplikace
http://www.teejeetech.in/p/timeshift.html
Protože někdy mohou tyto "akce" vyústit až k rozbití systému a náprava není vůbec jednoduchá, ne - li nemožná.
Takto máš "krytá záda" a můžeš bez obav experimentovat protože obnova původního stavu ze zálohy  je otázkou pár kliknutí.... ;)

DanielK

  • Návštěvník
  • *
  • Příspěvků: 89
  • Karma: +0/-0
    • Zobrazit profil
Re:chybějící libwxgtk2.8-0
« Odpověď #5 kdy: 01 Červen 2018, 12:22:19 »
Ahoj, tak to vzdávám, to je nad rámec mého chápání...  :-[

Podařilo se mi rozjet avrdude (negrafické prostředí které umí to co extremeburner), který na 16.04 funguje moc pěkně, zatím co na 14.04, nefungoval vůbec...