Prosíme přihlašte se nebo zaregistrujte.

Přihlašte se svým uživatelským jménem a heslem.
Vaše pomoc je stále potřeba!

Novinky: Děkujeme všem návštěvníkům fóra, kteří ochotně radí ostatním. Vaše práce je velmi potřebná a vážíme si jí.

Autor Téma: Storage Made Easy - balíčky nainstalovány, ale stále nesplněné závislosti  (Přečteno 570 krát)

joeedit

  • Návštěvník
  • *
  • Příspěvků: 61
  • Karma: +1/-0
    • Zobrazit profil
Zdarte,

pokouším se nainstalovat Storage Made Easy, ale dostal jsem se do fáze, kdy už nevím, jak nainstalovat potřebný balíček.

Klasické apt-update && apt-get upgrade - následné čištění clean, autoclean, autoremove a pak zase update...... jsem už vyzkoušel.
apt-get -f install nepomáhá, pouze mi nabídne odebrání balíčku storagemadeeasy_4.8.3.deb, který se snažím nainstalovat.

Aktuálně jsem se tedy zasekl zde:
Kód: [Vybrat]
joe@G580:~$ sudo apt-get install libgdk-pixbuf2.0-dev
Načítají se seznamy balíků… Hotovo
Vytváří se strom závislostí       
Načítají se stavové informace… Hotovo
Některé balíky nemohly být instalovány. To může znamenat, že požadujete
nemožnou situaci, nebo, pokud používáte nestabilní distribuci, že
vyžadované balíky ještě nebyly vytvořeny nebo přesunuty z Příchozí fronty.
Následující informace vám mohou pomoci vyřešit tuto situaci:

Následující balíky mají nesplněné závislosti:
 libgdk-pixbuf2.0-dev : Závisí na: libgdk-pixbuf2.0-0 (= 2.32.2-1ubuntu1.4) ale 2.32.2-1ubuntu1.4ppa1 se bude instalovat
                        Závisí na: gir1.2-gdkpixbuf-2.0 (= 2.32.2-1ubuntu1.4) ale 2.32.2-1ubuntu1.4ppa1 se bude instalovat
E: Nelze opravit problémy, některé balíky držíte v porouchaném stavu.
joe@G580:~$ sudo apt-get install libgdk-pixbuf2.0-dev
Načítají se seznamy balíků… Hotovo
Vytváří se strom závislostí       
Načítají se stavové informace… Hotovo
Některé balíky nemohly být instalovány. To může znamenat, že požadujete
nemožnou situaci, nebo, pokud používáte nestabilní distribuci, že
vyžadované balíky ještě nebyly vytvořeny nebo přesunuty z Příchozí fronty.
Následující informace vám mohou pomoci vyřešit tuto situaci:

Následující balíky mají nesplněné závislosti:
 libgdk-pixbuf2.0-dev : Závisí na: libgdk-pixbuf2.0-0 (= 2.32.2-1ubuntu1.4) ale 2.32.2-1ubuntu1.4ppa1 se bude instalovat
                        Závisí na: gir1.2-gdkpixbuf-2.0 (= 2.32.2-1ubuntu1.4) ale 2.32.2-1ubuntu1.4ppa1 se bude instalovat
E: Nelze opravit problémy, některé balíky držíte v porouchaném stavu.
joe@G580:~$ sudo apt-get install gir1.2-gdkpixbuf-2.0
Načítají se seznamy balíků… Hotovo
Vytváří se strom závislostí       
Načítají se stavové informace… Hotovo
gir1.2-gdkpixbuf-2.0 je již nejnovější verze (2.32.2-1ubuntu1.4ppa1).
0 aktualizováno, 0 nově instalováno, 0 k odstranění a 0 neaktualizováno.
joe@G580:~$ sudo apt-get install libgdk-pixbuf2.0-0
Načítají se seznamy balíků… Hotovo
Vytváří se strom závislostí       
Načítají se stavové informace… Hotovo
libgdk-pixbuf2.0-0 je již nejnovější verze (2.32.2-1ubuntu1.4ppa1).
0 aktualizováno, 0 nově instalováno, 0 k odstranění a 0 neaktualizováno.

Výše uvedené balíčky jsou již nainstalované v nejnovější verzi, ale potřebný balíček nelze nainstalovat.

Kód: [Vybrat]
joe@G580:~$ sudo apt-get install libgdk-pixbuf2.0-dev
Načítají se seznamy balíků… Hotovo
Vytváří se strom závislostí       
Načítají se stavové informace… Hotovo
Některé balíky nemohly být instalovány. To může znamenat, že požadujete
nemožnou situaci, nebo, pokud používáte nestabilní distribuci, že
vyžadované balíky ještě nebyly vytvořeny nebo přesunuty z Příchozí fronty.
Následující informace vám mohou pomoci vyřešit tuto situaci:

Následující balíky mají nesplněné závislosti:
 libgdk-pixbuf2.0-dev : Závisí na: libgdk-pixbuf2.0-0 (= 2.32.2-1ubuntu1.4) ale 2.32.2-1ubuntu1.4ppa1 se bude instalovat
                        Závisí na: gir1.2-gdkpixbuf-2.0 (= 2.32.2-1ubuntu1.4) ale 2.32.2-1ubuntu1.4ppa1 se bude instalovat
E: Nelze opravit problémy, některé balíky držíte v porouchaném stavu.

Synaptic žádný problém nevidí, nevím už jak dál.
Bude tedy moc vděčný za každou radu!
Předem díky!

juwa2

  • Závislák
  • ****
  • Příspěvků: 1966
  • Karma: +139/-34
    • Zobrazit profil
Vše tam máš vypsané. Prostě balík co chceš instalovat vyžaduje (jako závislost) mít nainstalované určité konkrétní verze dalších balíků.  Ty však nejsou v repozitářích které máš aktuálně přidané (do zdrojů SW) k dispozici. Z tohoto důvodu nemůže apt (ani Synaptic) situaci vyřešit - nemá zkrátka odkud ty potřebné balíky vzít (stáhnout) a doinstalovat.
--------------------------------------------------------------------------
Vyřešíš to přidáním PPA které potřebné balíky obsahuje, nebo si ty balíky  *.deb schrasti a nainstaluj ručně - důrazně doporučuji postupně instalovat pomocí Gdebi (pořeší případné další závislosti).
http://security.ubuntu.com/ubuntu/pool/main/g/gdk-pixbuf/libgdk-pixbuf2.0-0_2.32.2-1ubuntu1.4_amd64.deb
http://security.ubuntu.com/ubuntu/pool/main/g/gdk-pixbuf/gir1.2-gdkpixbuf-2.0_2.32.2-1ubuntu1.4_amd64.deb
http://security.ubuntu.com/ubuntu/pool/main/g/gdk-pixbuf/libgdk-pixbuf2.0-dev_2.32.2-1ubuntu1.4_amd64.deb
-------------------------------------------------------------------------
Nebo to vezmi z druhého konce - instaluj jinou verzi  storagemadeeasy.
Další možnost je instalovat (pokud tam tato aplikace existuje) přes snap nebo flatpack. Tam žádné závislosti nepotřebuješ, aplikace si vše potřebné "vezou s sebou".
----------------------------------------------------------------------------------------------------------------------------------------------------------------------------
A ano, s těmi závislostmi je to někdy na mrtvici, ale při troše zkušeností a cviku to většinou řešitelné je. A pokud ne, pak je v rezervě ještě hackování, ale to je už jiná kapitola.
« Poslední změna: 17 Červen 2018, 17:00:51 od juwa2 »

joeedit

  • Návštěvník
  • *
  • Příspěvků: 61
  • Karma: +1/-0
    • Zobrazit profil
Super - díky za pomoc! Já si podle výpisu nebyl úplně jistý, co to chce a na odlišnou verzi jsem měl podezření. Závislosti jsem už dříve řešil, ale tady jsem raději vyčkal na radu někoho zkušenějšího.

Jak to rozběhám, dám vědět.

Moc díky!