Prosíme přihlašte se nebo zaregistrujte.

Přihlašte se svým uživatelským jménem a heslem.
World of Warcraft

Novinky: Děkujeme všem návštěvníkům fóra, kteří ochotně radí ostatním. Vaše práce je velmi potřebná a vážíme si jí.

Autor Téma: LAMP  (Přečteno 17614 krát)

Tomáš Břinčil

  • Občanské sdružení Ubuntu ČR
  • Zasloužilý Ubunťák
  • Závislák
  • ******
  • Příspěvků: 1613
  • Karma: +135/-56
  • moje obrázky ↓
    • Zobrazit profil
    • TomasBrincil.cz
Re: LAMP
« Odpověď #25 kdy: 11 Srpen 2011, 11:28:14 »
Tak přidávám návod na zprovoznění https.
Poprosil bych o zpětnou vazbu ;)

Armus69

  • Člen
  • **
  • Příspěvků: 297
  • Karma: +25/-2
    • Zobrazit profil
    • http://www.netlancers.cz
Re: LAMP
« Odpověď #26 kdy: 13 Srpen 2011, 08:32:43 »
 Pro provozování SSL domén (certifikát pro každou doménu) na jedné adrese musí apache mít podporu pro SNI.  Ta je od verze  2.2.14 (přesně si nejsem tak jistej). Dále je problém se stále rozšířenýma Windows XP, kde je problém s podporou browserů:
Kód: [Vybrat]
SNI has only recently gained support in browsers. The browsers that have been confirmed to support SNI are
    Opera 8.0+
    Firefox 2+
    Internet Explorer 7+
    Safari 3.2.1+
    Chrome (NOT Chromium) ((Chromium 11.0.696.28 seems to do sni fine -mt))
Note: Safari and Chrome only support SNI on Vista or higher.
=====================
ad
  
Kód: [Vybrat]
Nejdříve bude vyžadováno ověření pro naši doménu (záložka Validations Wizard). Nechápu, proč si nemůžeme zadat vlastní mail ale budiž. V Google Apps to je otázka dvou kliknutí.
   To proto aby alespoň částečně zachovali vazbu na doménu a vlastníka domény, protože ten jediný má přístup na hostmaster@domena.tld. Nejde jen o šifrování, ale také o ověření identity serveru, což je stejně důležité jako to šifrování a neměl by si kdokoliv generovat certifikáty k doménám co mu nepatří..
    V Google Apps je to jednoduché protože tu doménu tam máš za hostovanou a oni vědí že je tvoje když jsi zakládal účet, ale StartSSL u certifikátů class1 může validovat jen    
 podle servisního účtu.  
    
      
« Poslední změna: 13 Srpen 2011, 08:43:28 od Armus69 »

Tomáš Břinčil

  • Občanské sdružení Ubuntu ČR
  • Zasloužilý Ubunťák
  • Závislák
  • ******
  • Příspěvků: 1613
  • Karma: +135/-56
  • moje obrázky ↓
    • Zobrazit profil
    • TomasBrincil.cz
Re: LAMP
« Odpověď #27 kdy: 14 Srpen 2011, 00:10:50 »
Pro provozování SSL domén (certifikát pro každou doménu) na jedné adrese musí apache mít podporu pro SNI.  Ta je od verze  2.2.14 (přesně si nejsem tak jistej). Dále je problém se stále rozšířenýma Windows XP, kde je problém s podporou browserů:
Kód: [Vybrat]
...
S tímto jsem problém neměl.
 
Kód: [Vybrat]
Nejdříve bude vyžadováno ověření pro naši doménu (záložka Validations Wizard). Nechápu, proč si nemůžeme zadat vlastní mail ale budiž. V Google Apps to je otázka dvou kliknutí.
   To proto aby alespoň částečně zachovali vazbu na doménu a vlastníka domény, protože ten jediný má přístup na hostmaster@domena.tld. Nejde jen o šifrování, ale také o ověření identity serveru, což je stejně důležité jako to šifrování a neměl by si kdokoliv generovat certifikáty k doménám co mu nepatří..
    V Google Apps je to jednoduché protože tu doménu tam máš za hostovanou a oni vědí že je tvoje když jsi zakládal účet, ale StartSSL u certifikátů class1 může validovat jen    
 podle servisního účtu.
Vlastní mail na vlastní doméně, nemusíš mi vysvětlovat smysl tohoto kroku, stačilo by cokoliv@domain.tld. postmaster@domain.tld jsem zrovna neměl, tak jsem to musel nastavit a dost mě to otrávilo - byl to časově nejnáročnější úkon.

Armus69

  • Člen
  • **
  • Příspěvků: 297
  • Karma: +25/-2
    • Zobrazit profil
    • http://www.netlancers.cz
Re: LAMP
« Odpověď #28 kdy: 14 Srpen 2011, 13:07:25 »
Cokoliv by asi nestačilo, to by jsem  si pak třeba mohl udělat certifikát na host  email.seznam.cz jen proto že mam u nich jednu z mailovejch adres. Prostě hostmaster@, postmaster@, webmaster@, abuse@ jsem servisní účty a přístup k nim má  držitel domény, pak ta doména může mít dalších milion maiboxů.
« Poslední změna: 14 Srpen 2011, 13:11:59 od Armus69 »

Galaxi

  • Návštěvník
  • *
  • Příspěvků: 9
  • Karma: +0/-0
    • Zobrazit profil
Re:LAMP
« Odpověď #29 kdy: 11 Prosinec 2011, 00:09:03 »
Zdravím,
nainstaloval jsem si Ubuntu 7.10 chci ho využívat jako server a tak jsem si chtěl nainstalovat balíček LAMP pokračoval jsem podle návodu zde http://wiki.ubuntu.cz/Apache%20s%20MySQL%20a%20PHP je zde i napsané, že návod je od 7.10, když jsem si nainstaloval tasksel a spustil ho měl jsem na výběr jen ze dvou balíčků (print server  a jakjsik další).....ale LAMP tam není ani v Synapticu....Díky za pomoc kde ho mám hledat případně jak ho nainstalovat

ETNyx

  • Člen
  • **
  • Příspěvků: 425
  • Karma: +37/-2
    • Zobrazit profil
Re:LAMP
« Odpověď #30 kdy: 11 Prosinec 2011, 12:35:14 »
Zdravím,
nainstaloval jsem si Ubuntu 7.10 chci ho využívat jako server a tak jsem si chtěl nainstalovat balíček LAMP pokračoval jsem podle návodu zde http://wiki.ubuntu.cz/Apache%20s%20MySQL%20a%20PHP je zde i napsané, že návod je od 7.10, když jsem si nainstaloval tasksel a spustil ho měl jsem na výběr jen ze dvou balíčků (print server  a jakjsik další).....ale LAMP tam není ani v Synapticu....Díky za pomoc kde ho mám hledat případně jak ho nainstalovat

Ubuntu 7.10 již není podporovanou verzí, instalujte verzi která má oficiální podporu, nevíte které to jsou? https://wiki.ubuntu.com/LTS podívejte se zde na graf