Prosíme přihlašte se nebo zaregistrujte.

Přihlašte se svým uživatelským jménem a heslem.
World of Warcraft

Novinky: Školení nejen k OS Ubuntu pro širokou veřejnost, více informací zde.

Autor Téma: LAN e1000e problém  (Přečteno 508 krát)

Standa99

  • Stálý člen
  • ***
  • Příspěvků: 535
  • Karma: +49/-2
    • Zobrazit profil
LAN e1000e problém
« kdy: 26 Únor 2017, 07:20:04 »
Už se tu v minulosti něco probíralo, ale na tom driveru e1000e běží starší i novější Intel LANky, od kterých bych čekal bezproblémový chod. Mám 4 Intel LANky viz. výpis, kde problém dělá ta první I219-V (eth1), která je WAN port:
Kód: [Vybrat]
Ethernet controller: Intel Corporation Ethernet Connection (2) I219-V (rev 31)
Kernel driver in use: e1000e
Kernel modules: e1000e

Ethernet controller: Intel Corporation 82571EB Gigabit Ethernet Controller (rev 06)
Kernel driver in use: e1000e
Kernel modules: e1000e

Ethernet controller: Intel Corporation 82571EB Gigabit Ethernet Controller (rev 06)
Kernel driver in use: e1000e
Kernel modules: e1000e

Ethernet controller: Intel Corporation I211 Gigabit Network Connection (rev 03)
Kernel driver in use: igb
Kernel modules: igb

V logu se mi objeví tohle a ten spodní odstavec se stále opakuje:
Kód: [Vybrat]
kernel: [261012.941212] e1000e 0000:00:1f.6 eth1: Reset adapter unexpectedly
NetworkManager[1062]: <info>  [1488056439.8294] device (eth1): link disconnected
NetworkManager[1062]: <info>  [1488056443.1061] device (eth1): link connected
kernel: [261016.219032] e1000e: eth1 NIC Link is Up 1000 Mbps Full Duplex, Flow Control: None

kernel: [261018.830346] e1000e 0000:00:1f.6 eth1: Detected Hardware Unit Hang:
                          TDH                  <d2>
                          TDT                  <f4>
kernel: [261007.821139]   next_to_use          <f4>
kernel: [261007.821139]   next_to_clean        <d0>
kernel: [261007.821139]   buffer_info[next_to_clean]:
kernel: [261007.821139]   time_stamp           <103e28226>
kernel: [261007.821139]   next_to_watch        <d2>
kernel: [261007.821139]   jiffies              <103e28480>
kernel: [261007.821139]   next_to_watch.status <0>
kernel: [261007.821139]   MAC Status             <40080083>
kernel: [261007.821139]   PHY Status             <796d>
kernel: [261007.821139]   PHY 1000BASE-T Status  <3800>
kernel: [261007.821139]   PHY Extended Status    <3000>
kernel: [261007.821139]   PCI Status             <10>

Někde radí vypnutí TSO, GSO a GRO, ale to jsem zatím nezkoušel. 
Dělá to na kernelu 4.4 i 4.8 a už jsem vyzkoušel zkompilovat nové drivery pro e1000e a při jednom i drivery pro igb. To zatím nepomohlo a chystám se na přehrání firmwaru u všech LANek (pokud mi to nabídne aktualizaci).
Taky ještě vyzkouším přehodit ten WAN port na tu igb LANku. Tím že mám optiku až domů, tak je naproti GPON Huawei HG8245, do kterého přístup nemám, ale je v bridge, protože veřejku mám na té Intel LANce (a WiFi používám svou), možná si mezi sebou nerozumí.
Nemáte někdo nějaký tip?

Server#1 - GA-H170N-WIFI, Pentium G4400, 8GB RAM, 4xLAN Intel i211+i219+Dual 82571EB, WiFi Intel AC-8260, SSD+HDD, 16.04
Server#2 - Intel DN2800MT, 4GB RAM, 2xLAN Intel 82574L, WiFi Atheros AR5BHB92, SSD+HDD, 12.04

TIBOR

  • Guru
  • *****
  • Příspěvků: 5721
  • Karma: +424/-20
  • Som uzivatel linuxovej distribucie, som linuxak?
    • Zobrazit profil
Re:LAN e1000e problém
« Odpověď #1 kdy: 26 Únor 2017, 10:19:06 »
Ja sa v tom sice nevyznam ale prekvapilo ma ze mas eth1. Podla jadra mas ubuntu 16.04 alebo vyssi a tam sa uz toto oznacenie nepouziva. Ak sa nemylim.
Asus X751LB-TY014H Ubuntu 16.04 XX 64bit - Mate.
Linus, Lajnas, Línus, Luínus, Lajnus a je mi naozaj jedno, ako ľudia vyslovujú moje meno. Ale "Linux" je vždy "Linux". LINUS TORVALDS, tvorca Linuxového jadra.(V dokumente Revolution OS)

Standa99

  • Stálý člen
  • ***
  • Příspěvků: 535
  • Karma: +49/-2
    • Zobrazit profil
Re:LAN e1000e problém
« Odpověď #2 kdy: 26 Únor 2017, 12:04:49 »
Ano je to Ubuntu 16.04 (první server z mého podpisu) a musel jsem si to přejmenovat (stará škola). U těch LAN karet ty názvy ještě šly, ale u WiFi byly zoufalé, zlaté wlan0. Pokud si pamatuju, tak stačilo do /etc/default/grub přidat GRUB_CMDLINE_LINUX="net.ifnames=0 biosdevname=0" (upgate-grub + reboot).

Server#1 - GA-H170N-WIFI, Pentium G4400, 8GB RAM, 4xLAN Intel i211+i219+Dual 82571EB, WiFi Intel AC-8260, SSD+HDD, 16.04
Server#2 - Intel DN2800MT, 4GB RAM, 2xLAN Intel 82574L, WiFi Atheros AR5BHB92, SSD+HDD, 12.04

Standa99

  • Stálý člen
  • ***
  • Příspěvků: 535
  • Karma: +49/-2
    • Zobrazit profil
Re:LAN e1000e problém
« Odpověď #3 kdy: 27 Únor 2017, 12:33:49 »
Tak jsem přehodil WAN port na tu LANku I211 a vypadá to lépe (ťuk, ťuk), protože předtím jsem měl někdy problém s navázáním konektivity i po restartu. Možná to opravdu bude nekompatibilita s tím Huaweiem, kde by měl být Broadcom chipset.
Každopádně jsem chtěl zkusit přehrát firmwary, ale nabídlo mi to pouze tu I211:
Kód: [Vybrat]
sudo ./bootutil64e
Connection to QV driver failed - please reinstall it!

Intel(R) Ethernet Flash Firmware Utility
BootUtil version 1.6.36.0
Copyright (C) 2003-2016 Intel Corporation

Type BootUtil -? for help

Port Network Address Location Series  WOL Flash Firmware                Version
==== =============== ======== ======= === ============================= =======
  1   408D5C56XXXX     5:00.0 Gigabit YES FLASH Not Present
  2   (Cannot initialize adapter)
  3   (Cannot initialize adapter)
  4   (Cannot initialize adapter)
Zatím jsem nechtěl kompilovat a instalovat vyžadovaný "QV driver", protože zbytek LANek stejně nevidí a tu co ano, tak ta funguje.
Nezkoušel někdo také přehrát firmware a po instalaci toho "QV driveru" se objevily i ty další LANky?

Server#1 - GA-H170N-WIFI, Pentium G4400, 8GB RAM, 4xLAN Intel i211+i219+Dual 82571EB, WiFi Intel AC-8260, SSD+HDD, 16.04
Server#2 - Intel DN2800MT, 4GB RAM, 2xLAN Intel 82574L, WiFi Atheros AR5BHB92, SSD+HDD, 12.04