Prosíme přihlašte se nebo zaregistrujte.

Přihlašte se svým uživatelským jménem a heslem.
World of Warcraft

Novinky: Děkujeme všem návštěvníkům fóra, kteří ochotně radí ostatním. Vaše práce je velmi potřebná a vážíme si jí.

Autor Téma: Editor videa [Vyřešeno]  (Přečteno 1530 krát)

Jana

  • Člen
  • **
  • Příspěvků: 431
  • Karma: +45/-4
    • Zobrazit profil
Editor videa [Vyřešeno]
« kdy: 17 Únor 2017, 20:37:59 »
Mám dotaz.
Po létech jsem se rozhodla zdigitalizovat nahrávky rodiny a dát je na externí HDD. Použila jsem DVD rekordér a z něho potom zkopírovala soubor VR_MOVIE.VRO (video/mpeg) o velikosti 4,6 GB který jde bez problému přehrát. Jenže potřebovala bych ho rozdělit na 6 různě velkých částí a  uložit třeba do .avi (.mp4) zkrátka co vezme TV.
Před několika léty jsem to úspěšně prováděla v Openshotu, jenomže nyní nelze nainstalovat a když jsem použila terminál (doufám že dobře), tak mi to vypíše:
Citace
abcd@abcd-HP-Pro-3400-Series-MT:~$ sudo apt-get install openshot
[sudo] heslo pro abcd:
Načítají se seznamy balíků… Hotovo
Vytváří se strom závislostí       
Načítají se stavové informace… Hotovo
Některé balíky nemohly být instalovány. To může znamenat, že požadujete
nemožnou situaci, nebo, pokud používáte nestabilní distribuci, že
vyžadované balíky ještě nebyly vytvořeny nebo přesunuty z Příchozí fronty.
Následující informace vám mohou pomoci vyřešit tuto situaci:

Následující balíky mají nesplněné závislosti:
 openshot : Závisí na: gtk2-engines-pixbuf ale nebude se instalovat
E: Nelze opravit problémy, některé balíky držíte v porouchaném stavu.
abcd@abcd-HP-Pro-3400-Series-MT:~$
nutno dodat že jsem zkusila čistou instalaci a prvně instalovala Openshot, ovšem se stejným výsledkem.

v zoufalství jsem zkusila nainstalovat avidemux, který jsem kvůli složitosti neměla ráda, ale ten to vůbec nenašlo a terminál mi napsal:
Citace
abcd@abcd-HP-Pro-3400-Series-MT:~$ sudo apt-get install avidemux
[sudo] heslo pro abcd:
Načítají se seznamy balíků… Hotovo
Vytváří se strom závislostí       
Načítají se stavové informace… Hotovo
Balík avidemux není dostupný, ale jiný balík se na něj odkazuje.
To může znamenat že balík chybí, byl zastarán, nebo je dostupný
pouze z jiného zdroje

E: Balík „avidemux“ nemá kandidáta pro instalaci
abcd@abcd-HP-Pro-3400-Series-MT:~$

Zkoušela jsem i pitivi, ale ten nám neustále ztmavoval a zesvětloval monitor jak kdybychom měli RAM 0,1 GB (máme 6 GB)

Zkoušela jsem kino, ale ten mi hned na počátku ze 4,6 GB vždy udělal 26 GB  .DV a volba pro TV nepoužitelných  formátů omezená.

Existuje nyní nějaký jednoduchý a spolehlivý, - existuje vůbec nějaký editor videa v linuxu? Jaké máte zkušenosti?

« Poslední změna: 22 Únor 2017, 10:09:59 od Jana »
Ubuntu 16.04 LTS 64bit

theadoua

  • Člen
  • **
  • Příspěvků: 127
  • Karma: +20/-1
  • The quieter you become the more you are able to ..
    • Zobrazit profil
Re:Editor videa
« Odpověď #1 kdy: 17 Únor 2017, 22:13:50 »
Pekny den prajem,

tato alternativa je celkom ok a UI dost podobna OpenShot:

https://github.com/mltframework/shotcut/releases/download/v17.02/shotcut-linux-x86_64-170205.tar.bz2

neinstaluje sa, len sa rozbali a spusti. Kliknutim na "Timeline" tlacitko vznikne zname UI ako ma openshot. staci drag and drop subory. Keby nieco, v sekcii "Help" su tutorialy na kadeco :) snad som pomohol

jarek163

  • Návštěvník
  • *
  • Příspěvků: 22
  • Karma: +12/-0
    • Zobrazit profil
Re:Editor videa
« Odpověď #2 kdy: 18 Únor 2017, 05:51:13 »
zdravím
Avidemux si můžeš stáhnout a používat i jako portable verzi - neinstaluje se. Zde https://www.fosshub.com/Avidemux.html nebo zde https://sourceforge.net/projects/avidemux/  stáhni si do domovské složky soubor s koncovkou .appimage.
V terminálu zadej příkaz, u mne
Kód: [Vybrat]
~$ chmod a+x avidemux_2.6.17.appImage

Pak stačí soubor poklepáním spustit...

juwa2

  • Stálý člen
  • ***
  • Příspěvků: 946
  • Karma: +70/-19
    • Zobrazit profil
Re:Editor videa
« Odpověď #3 kdy: 18 Únor 2017, 12:08:41 »
Nepíšeš co máš za verzi OS a jaké repozitáře máš ve zdrojích SW!
Od toho se odvíjí "potíže" s instalací..........

Jana

  • Člen
  • **
  • Příspěvků: 431
  • Karma: +45/-4
    • Zobrazit profil
Re:Editor videa
« Odpověď #4 kdy: 18 Únor 2017, 14:52:19 »
theadoua
Stažení a uvedení do chodu se zdá být jednoduché. Spouštím to klikem na ikonku audio video – viz obr1. Zdá se že vše funguje dle mých představ, až na to že to přehraje vždy pouze 5,50 minut. Nemohu dojít na to jak tuto dobu libovolně měnit. Potřebuji tak 10 – 20 minut šoty. Co vím jistě, že si zasloužíš minimálně  +

jarek163
Jak bude chvíle, odzkouším i tvé zkušenosti, ale + ti dávám už jen za ochotu.

juwa2
Verzi OS mám uvedeno v každém příspěvku dole ↓↓↓ Jinak nevím přesně co myslíš,  je to obr 2 ?

obr 1 a obr 2



obr
« Poslední změna: 18 Únor 2017, 16:48:51 od Jana »
Ubuntu 16.04 LTS 64bit

theadoua

  • Člen
  • **
  • Příspěvků: 127
  • Karma: +20/-1
  • The quieter you become the more you are able to ..
    • Zobrazit profil
Re:Editor videa
« Odpověď #5 kdy: 18 Únor 2017, 15:35:54 »
 
Kód: [Vybrat]
cat /etc/apt/sources.list nam ukaze ake mas zdroje

ten openshot ma problemy s kdenlive (dalsi program co mozes skusit, ale ma konflikt s openshot a videl som vlakna, kde ludia nemohli instalovat openshot pokym neodinstalovali kdenlive) kdenlive je pre KDE ale vraj funguje aj na Gnome alebo unity.<br>
skus mozno nainstalovat ten OpenShot pomocou oficialnej PPA, nie cez klasicke ubuntu repos.
Kód: [Vybrat]
sudo add-apt-repository ppa:openshot.developers/ppa
sudo apt-get update
sudo apt-get install openshot-qt
aj ked si nie som isty ci to vyriesi tie konflikty... skor nie ako ano.. :(
<br>
musim este povedat, ze ten shotcut mi prehrava aj hodinove videa, nikdy nie len 5,50 min, skus upresnit ako sa to deje

Jana

  • Člen
  • **
  • Příspěvků: 431
  • Karma: +45/-4
    • Zobrazit profil
Re:Editor videa
« Odpověď #6 kdy: 18 Únor 2017, 16:41:03 »
Citace
abcd@abcd-HP-Pro-3400-Series-MT:~$ cat /etc/apt/sources.list
#deb cdrom:[Ubuntu 16.04.1 LTS _Xenial Xerus_ - Beta amd64 (20161226)]/ xenial main restricted

# See http://help.ubuntu.com/community/UpgradeNotes for how to upgrade to
# newer versions of the distribution.
deb http://cz.archive.ubuntu.com/ubuntu/ xenial main restricted
# deb-src http://cz.archive.ubuntu.com/ubuntu/ xenial main restricted

## Major bug fix updates produced after the final release of the
## distribution.
deb http://cz.archive.ubuntu.com/ubuntu/ xenial-updates main restricted
# deb-src http://cz.archive.ubuntu.com/ubuntu/ xenial-updates main restricted

## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu
## team. Also, please note that software in universe WILL NOT receive any
## review or updates from the Ubuntu security team.
deb http://cz.archive.ubuntu.com/ubuntu/ xenial universe
# deb-src http://cz.archive.ubuntu.com/ubuntu/ xenial universe
deb http://cz.archive.ubuntu.com/ubuntu/ xenial-updates universe
# deb-src http://cz.archive.ubuntu.com/ubuntu/ xenial-updates universe

## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu
## team, and may not be under a free licence. Please satisfy yourself as to
## your rights to use the software. Also, please note that software in
## multiverse WILL NOT receive any review or updates from the Ubuntu
## security team.
deb http://cz.archive.ubuntu.com/ubuntu/ xenial multiverse
# deb-src http://cz.archive.ubuntu.com/ubuntu/ xenial multiverse
deb http://cz.archive.ubuntu.com/ubuntu/ xenial-updates multiverse
# deb-src http://cz.archive.ubuntu.com/ubuntu/ xenial-updates multiverse

## N.B. software from this repository may not have been tested as
## extensively as that contained in the main release, although it includes
## newer versions of some applications which may provide useful features.
## Also, please note that software in backports WILL NOT receive any review
## or updates from the Ubuntu security team.
deb http://cz.archive.ubuntu.com/ubuntu/ xenial-backports main restricted universe multiverse
# deb-src http://cz.archive.ubuntu.com/ubuntu/ xenial-backports main restricted universe multiverse

## Uncomment the following two lines to add software from Canonical's
## 'partner' repository.
## This software is not part of Ubuntu, but is offered by Canonical and the
## respective vendors as a service to Ubuntu users.
# deb http://archive.canonical.com/ubuntu xenial partner
# deb-src http://archive.canonical.com/ubuntu xenial partner

deb http://security.ubuntu.com/ubuntu xenial-security main restricted
# deb-src http://security.ubuntu.com/ubuntu xenial-security main restricted
deb http://security.ubuntu.com/ubuntu xenial-security universe
# deb-src http://security.ubuntu.com/ubuntu xenial-security universe
deb http://security.ubuntu.com/ubuntu xenial-security multiverse
# deb-src http://security.ubuntu.com/ubuntu xenial-security multiverse
abcd@abcd-HP-Pro-3400-Series-MT:~$
Abych se přiznala, moc z toho chytrá nejsem.

Ale ten Shotcut vypadá vcelku dobře kdybych uměla nastavit délku shotu který se má „vyvést“. Dole na obr je vidět čas 00:00:00:00 až do 00:05:00:00 a ono to skutečně udělá šot 5 minut a něco vteřin. Víc ne. Když to posunu, sice to udělá v jiném místě, ale zase pouze 5 minutový shot. Kratší jak 5 minut už umím, ale delší ne.

Již včera jsem zkoušela openshot pro linux z tohoto odkazu:
http://www.openshotvideo.com/2016/12/openshot-22-released-4k-video-editing.html
Je to velký program a stejně mi nefungoval.




« Poslední změna: 18 Únor 2017, 17:15:39 od Jana »
Ubuntu 16.04 LTS 64bit

jarek163

  • Návštěvník
  • *
  • Příspěvků: 22
  • Karma: +12/-0
    • Zobrazit profil
Re:Editor videa
« Odpověď #7 kdy: 18 Únor 2017, 16:49:03 »
Openshot verze 2.2 je ke stažení také jako appImage  http://www.openshot.org/download/

Jana

  • Člen
  • **
  • Příspěvků: 431
  • Karma: +45/-4
    • Zobrazit profil
Re:Editor videa
« Odpověď #8 kdy: 18 Únor 2017, 16:54:07 »
Openshot verze 2.2 je ke stažení také jako appImage  http://www.openshot.org/download/
No a není to stejný odkaz jak můj?
Ubuntu 16.04 LTS 64bit

jarek163

  • Návštěvník
  • *
  • Příspěvků: 22
  • Karma: +12/-0
    • Zobrazit profil
Re:Editor videa
« Odpověď #9 kdy: 18 Únor 2017, 17:00:34 »
Máš pravdu je, jestli ti program padá můžeš ještě zkusit Kdenlive jako appImage http://files.kde.org/kdenlive/release/Kdenlive-16.12.2-x86_64.AppImage.mirrorlist
« Poslední změna: 18 Únor 2017, 17:07:21 od jarek163 »

Jana

  • Člen
  • **
  • Příspěvků: 431
  • Karma: +45/-4
    • Zobrazit profil
Re:Editor videa
« Odpověď #10 kdy: 18 Únor 2017, 17:10:54 »
Na vyzkoušení to bude chtít trochu času. Jak dopadnu dám vědět, ale aby si nevyšel zatím zkrátka, dám další plus. 
A theadoua také  !


Openshot podle theadoua se podařilo nainstalovat a funguje  :)  ,  ale přehrává také pouze 5 min. 50 sec. Tedy stejný problém jak u Shotcut. Dumali jsme v čem je tedy problém a vypadá to že DVD z kterého jsem nahrávku zkopírovala má časový údaj 5 min. a 50 sec. DVD jede normálně dál, ale čas se už nemění. Takže co se času týče bude problém v DVD, nebo v recorderu.
« Poslední změna: 18 Únor 2017, 17:59:22 od Jana »
Ubuntu 16.04 LTS 64bit

theadoua

  • Člen
  • **
  • Příspěvků: 127
  • Karma: +20/-1
  • The quieter you become the more you are able to ..
    • Zobrazit profil
Re:Editor videa
« Odpověď #11 kdy: 18 Únor 2017, 19:40:33 »
Tyjo, jak sa divam na ten screen z toho shotcut, fakt tam je 5:50 jako celkova dlzka klipu o.O
Kazdopadne som rad ze OpenShot nainstalovany, a ze si prisla na pricinu tych zahadnych 5:50 min.

na to pokazene video by malo pomoct toto
Kód: [Vybrat]
ffmpeg -i TvojeOriginalVideo.mp4 -qscale:v 1 OpraveneVideo.avi
kde -qscale:v je kvalita videa a cislo 1 je najlepsia kvalita a 31 je najhorsia. Treba si vybrat co najviac vyhovuje.

tak isto daj pozor aby si zadala spravne cesty k suborom a tak isto aj pripony. mp4 som len typol. vysledny subor ale mozes konvertovat aj do inych formatov ako je avi, ak chces. Vysledne avi video by malo mat opravenu dlzku a malo by sa dat pouzit s OpenShotom.

ak tvoje video ma 4,6 GB, otestuje to tvoju trpezlivost ;)
Good luck a pekny vecer
« Poslední změna: 18 Únor 2017, 20:17:41 od theadoua »

Jana

  • Člen
  • **
  • Příspěvků: 431
  • Karma: +45/-4
    • Zobrazit profil
Re:Editor videa
« Odpověď #12 kdy: 18 Únor 2017, 20:26:16 »
Citace
abcd@abcd-HP-Pro-3400-Series-MT:~$ ffmpeg -i /home/abcd/Plocha/VR_MOVIE.VRO -sameq /home/abcd/Plocha/VR_MOVIE.avi
ffmpeg version 2.8.11-0ubuntu0.16.04.1 Copyright (c) 2000-2017 the FFmpeg developers
  built with gcc 5.4.0 (Ubuntu 5.4.0-6ubuntu1~16.04.4) 20160609
  configuration: --prefix=/usr --extra-version=0ubuntu0.16.04.1 --build-suffix=-ffmpeg --toolchain=hardened --libdir=/usr/lib/x86_64-linux-gnu --incdir=/usr/include/x86_64-linux-gnu --cc=cc --cxx=g++ --enable-gpl --enable-shared --disable-stripping --disable-decoder=libopenjpeg --disable-decoder=libschroedinger --enable-avresample --enable-avisynth --enable-gnutls --enable-ladspa --enable-libass --enable-libbluray --enable-libbs2b --enable-libcaca --enable-libcdio --enable-libflite --enable-libfontconfig --enable-libfreetype --enable-libfribidi --enable-libgme --enable-libgsm --enable-libmodplug --enable-libmp3lame --enable-libopenjpeg --enable-libopus --enable-libpulse --enable-librtmp --enable-libschroedinger --enable-libshine --enable-libsnappy --enable-libsoxr --enable-libspeex --enable-libssh --enable-libtheora --enable-libtwolame --enable-libvorbis --enable-libvpx --enable-libwavpack --enable-libwebp --enable-libx265 --enable-libxvid --enable-libzvbi --enable-openal --enable-opengl --enable-x11grab --enable-libdc1394 --enable-libiec61883 --enable-libzmq --enable-frei0r --enable-libx264 --enable-libopencv
  libavutil      54. 31.100 / 54. 31.100
  libavcodec     56. 60.100 / 56. 60.100
  libavformat    56. 40.101 / 56. 40.101
  libavdevice    56.  4.100 / 56.  4.100
  libavfilter     5. 40.101 /  5. 40.101
  libavresample   2.  1.  0 /  2.  1.  0
  libswscale      3.  1.101 /  3.  1.101
  libswresample   1.  2.101 /  1.  2.101
  libpostproc    53.  3.100 / 53.  3.100
Option 'sameq' was removed. If you are looking for an option to preserve the quality (which is not what -sameq was for), use -qscale 0 or an equivalent quality factor option.
Failed to set value '1' for option 'sameq': Invalid argument
Error parsing global options: Invalid argument
abcd@abcd-HP-Pro-3400-Series-MT:~$
Opravit video by bylo dobré, ale asi jsem to blbě napsala.
Video má 4,6 GB název VR_MOVIE.VRO a je umístěno na ploše.
Ubuntu 16.04 LTS 64bit

theadoua

  • Člen
  • **
  • Příspěvků: 127
  • Karma: +20/-1
  • The quieter you become the more you are able to ..
    • Zobrazit profil
Re:Editor videa
« Odpověď #13 kdy: 18 Únor 2017, 20:29:40 »
Par don, ja som editoval moj komentar pretoze -sameq sa uz nepouziva.. :/ sry pozri komentar este raz

ak by konverzia nepomohla skus mu natvrdo nadiktovat dlzku a iba prekopirovat video bez konverzie:

Kód: [Vybrat]
ffmpeg -i video.mp4 -t 2:09:39 -c:v copy -c:a copy -c:s copy vysledneVideo.mp4
tato moznost by mala byt rychlejsia, snad aspon jedna z nich pomoze

(btw, mas velmi staru verziu ffmpeg ale snad nevadi)
« Poslední změna: 18 Únor 2017, 20:31:41 od theadoua »

Jana

  • Člen
  • **
  • Příspěvků: 431
  • Karma: +45/-4
    • Zobrazit profil
Re:Editor videa
« Odpověď #14 kdy: 18 Únor 2017, 20:50:04 »
 :)  díky!
Bylo to za 5 minut hotový a čas v Openshotu 2 hodiny. Tak zítra se s tím budu mořit. Jak to dopadne dám vědět J.


« Poslední změna: 19 Únor 2017, 19:07:19 od Jana »
Ubuntu 16.04 LTS 64bit

Jana

  • Člen
  • **
  • Příspěvků: 431
  • Karma: +45/-4
    • Zobrazit profil
Re:Editor videa
« Odpověď #15 kdy: 19 Únor 2017, 19:07:40 »
Tak se mi dnes podařilo zdárně zpracovat jedno (první) DVD na flešku a pouštět v TV, což bylo záměrem.  Děkuji panu theadoua, ale i jarkovi kterým musím dát ještě jednu +   Jana
Ubuntu 16.04 LTS 64bit