Prosíme přihlašte se nebo zaregistrujte.

Přihlašte se svým uživatelským jménem a heslem.
World of Warcraft

Novinky: Děkujeme všem návštěvníkům fóra, kteří ochotně radí ostatním. Vaše práce je velmi potřebná a vážíme si jí.

Autor Téma: USB porty nefungují - Gentoo Linux  (Přečteno 481 krát)

BlueManCZ

  • Návštěvník
  • *
  • Příspěvků: 87
  • Karma: +5/-1
    • Zobrazit profil
USB porty nefungují - Gentoo Linux
« kdy: 12 Březen 2017, 11:32:12 »
Zdravím Vás Linuxáci!
Potřeboval bych někoho, kdo má trošku zkušenosti s kompilací a laděním kernelu a zaváděním modulů a ovladačů.

Mám základní desku Gigabyte Z170-D3H a snažím se vyladit kernel 4.9.6-gentoo-r1, jenomže se mi nedaří zprovoznit USB porty.
Když spustím Gentoo live, tak porty fungují normálně.

Zde vám přiložím několik výpisů:

lspci | grep USB
Kód: [Vybrat]
00:14.0 USB controller: Intel Corporation Sunrise Point-H USB 3.0 xHCI Controller (rev 31)
lsusb
Kód: [Vybrat]
libusb: debug [libusb_init] created default context
libusb: debug [libusb_init] libusb v1.0.19.10903
libusb: error [op_init] could not find usbfs
unable to initialize libusb: -99

dmesg | grep 'USB\|usb'
Kód: [Vybrat]
[    0.293570] ACPI: bus type USB registered
[    0.293665] usbcore: registered new interface driver usbfs
[    0.293756] usbcore: registered new interface driver hub
[    0.293850] usbcore: registered new device driver usb
[    0.987392] ehci_hcd: USB 2.0 'Enhanced' Host Controller (EHCI) Driver
[    0.987449] ohci_hcd: USB 1.1 'Open' Host Controller (OHCI) Driver
[    0.987487] uhci_hcd: USB Universal Host Controller Interface driver
[    0.987548] usbcore: registered new interface driver usblp
[    0.987592] usbcore: registered new interface driver usb-storage
[    0.992362] usbcore: registered new interface driver usbhid
[    0.992376] usbhid: USB HID core driver

Tady je celý dmesg výpis: dmesg_log.txt

usb-devices nevrací nic.

lsmod vrací jen "Module Size Used by" ale nic víc.

grep XHCI /usr/src/linux-$(uname -r)/.config
Kód: [Vybrat]
CONFIG_USB_XHCI_HCD=y
CONFIG_USB_XHCI_PCI=y
CONFIG_USB_XHCI_PLATFORM=y

Nechci po vás hned řešení (jistě, pokud nějaké máte, tak sem s ním), ale alespoň radu nebo názor, díky kterým bych mohl hlouběji analyzovat problém a s vaší pomocí dojít k nějakému řešení. Předem děkuji za ochotu a Váš čas. :)
Pokud vyřešíte problém určitého vlákna, připište do předmětu prvního dotazu [VYŘEŠENO].

Počítač: GA-Z170-D3H / IC i5-6400 SkyLake / Intel HD Graphic 530 / HyperX Fury 8GB RAM / WD10EZEX (WD Blue 1TB) / ATX-400PNF / ML X801
Distribuce: Debian 9.0 (x86-64)

kapitanseyfert

  • Návštěvník
  • *
  • Příspěvků: 1
  • Karma: +0/-0
    • Zobrazit profil
Re:USB porty nefungují - Gentoo Linux
« Odpověď #1 kdy: 12 Březen 2017, 12:09:38 »
nazdar, měl jsem hodně problémů z nastavením wifi a brzdami na Deepin 14.03 a Ubuntu 14. poprvé musíš zkontrolovat jeli nainstalovány ovladače pro usb porty. v mém případě jsem hledal ovladač pro  Lenovo G50 (zároveň použil slevu na laptop zde reklama odstraněna pro distributive Ubuntu a tak vyřešil svůj problém. zkus to ;)


EDIT: Odstraněna nepovolená reklama nesouvisející s tématem.
« Poslední změna: 12 Březen 2017, 15:23:39 od GdH »
Windows je nejlepší, zatím nepřešel na Ubuntu :)