Prosíme přihlašte se nebo zaregistrujte.

Přihlašte se svým uživatelským jménem a heslem.
Vaše pomoc je stále potřeba!

Novinky: Školení nejen k OS Ubuntu pro širokou veřejnost, více informací zde.

Zobrazit příspěvky

Tato sekce Vám umožňuje zobrazit všechny příspěvky tohoto uživatele. Prosím uvědomte si, že můžete vidět příspěvky pouze z oblastí Vám přístupných.


Příspěvky - juwa2

Stran: [1] 2 3 ... 66
1
Co ostatní prohlížeče?
Odkdy se to vyskytuje?
Co to dělá na stejném stroji v live režimu? A v čisté instalaci?
Je v pořádku veškerý HW (RAM, HDD) ?  Kontroloval jsi to?
--------------------------
Pokud máš nabořený OS, obnov ho ze zdravé zálohy (vytvořené v době kdy vše fungovalo). Jinak reinstalace..

2
Opera novější než 50 na starších OS neběží, dokonce ani na U14.04 které je ještě víc jak rok podporované....
Takže zkus starší verzi.

3
Nejnovější Ubuntu 18.04 má výchozí prostředí Gnome - launcher je vlevo a jde přemisťovat...
Lišta s hodinama je nahoře. Tady si to prohlídni...
https://www.root.cz/clanky/vychazi-ubuntu-18-04-lts-bezpecnejsi-a-aktualizovane-ale-stale-bez-waylandu/

4
No jo, už z toho blbnu....
Kód: [Vybrat]
#!/bin/sh
if [ "${1}" = "post" ]; then
sh /path/to/script.sh
fi

Takže viníkem bylo dvojité rovnítko. Díky.... :)

5
Tak jsem tedy za then dal ten stejný skript
Kód: [Vybrat]
#!/bin/sh/
if [ "${1}" == "pre" ]; then
sh /path/to/script.sh
elif [ "${1}" == "post" ]; then
sh /path/to/script.sh
fi

Změna veškerá žádná...  :-[
Dále se mi nechce věřit, že by to bylo v toliko návodech na všech těch webech špatně. Proto jsem pojal podezření na nějaké změny v 18.04, protože v diskusích pod návody  si všichni svorně pochvalují jak jim to funguje, ale nikdo výslovně neuvádí že na 18.04.
A k té nesmyslné komplikovanosti.  To si netroufám posoudit, ale jak jsem viděl i spousta ostatních skriptů přímo v instalaci OS je psána takto - ostatně, řešení jsem odtud odkoukal..
Ale třeba bys tedy prosím mohl mě (a tvůrcům Ubuntu) alespoň nastínit lepší (a hlavně funkční) řešení....

6
Zřejmě je v rámci instalace stažen a použit driver grafiky který nedělá tomu ntb "dobře", přitom driver který je na inst. flešce je OK.
Další možnost je (neuvádíš přesně jakou vezi 16.04 instaluješ, nyní je už myslím 16.04.5), že to souvisí s kernelem, ty letos vydané mají záplaty na meltdown&spectre což u tebe může být zdrojem potíží...
----------------------------------------------------------------------------------------------
1. Zkus instalovat znovu, ale bez připojení k internetu (nebo odškrtni stahování updatů během instalace).
(Pokud by to běželo, musel bys pak zakázat update kernelu + driveru grafiky.)
2. Do bootovacího parametru přidej "nopti" (do /etc/default/grub)
3. Zkus nabootovat z původním kernelem (tím co je v instalačce).
4. Vyzkoušej jiné distro (14.04 nebo Ubuntu-Mate nebo Lubuntu.
Až skončíš, určitě budeš chytřejší....

7
Zdravím.
Zkouším teď nové U 18.04 a potřebuji spouštět určitý skript po probuzení PC ze spánku (resume). Vím, že ve verzích 16.04+ je to jinak než dříve protože systemd.
Ve všech možných návodech které jsem našel, např. tu https://www.addictivetips.com/ubuntu-linux-tips/run-scripts-and-commands-on-suspend-and-resume-on-linux/  je tento postup.  Vytvořit spustitelný soubor
Kód: [Vybrat]
/lib/systemd/system-sleep/post-suspend
s tímto obsahem
Kód: [Vybrat]
#!/bin/sh/
if [ "${1}" == "pre" ]; then
# nothing goes here
elif [ "${1}" == "post" ]; then
sh /path/to/script.sh
fi

Bohužel to nefunguje, ani změna z #!/bin/sh/  na  #!/bin/bash/ nepomohla...
Po prozkoumání ostatních skriptů které ve složce /lib/systemd/system-sleep jsou jsem dospěl k tomuto již funkčnímu skriptu:
Kód: [Vybrat]
#!/bin/sh
set -e
if [ "$2" = "suspend" ]; then
    case "$1" in
    post) /path/to/script.sh ;;
    esac   
fi

Otázka tedy zní:  Proč skript který se uvádí ve všech návodech nefunguje?  Je to proto, že se v 18.04 zase něco změnilo"?
Nebo je chyba jinde, dosti by mě to totiž zajímalo.....


8
Pomoc s instalací a aktualizací / Re:Přechod ze 14.04 na 16.04
« kdy: 18 Květen 2018, 19:03:10 »
Po aktualizaci Ubuntu 14.04 na 16.04 mi nejde se přihlásit. Zadám heslo a přes černou obrazovku to se zvukem bubínku vrací na úvodní stránku se zadáním hesla. Zkoušel jsem měnit heslo, ale výsledek je stejný a přes dalšího uživatele je situace stejná.

Takto aktualizovat (upgradovat neboli povyšovat) OS silně nedoporučuji - většinou to končívá právě takto.
Naprostou nuností je napřed systém zálohovat, aby se bylo možno v případě nezdaru vrátit do výchozího stavu.
----------------------------------------------------
Udělej čistou instalaci se zachováním oddílu /home.  Nainstalované programy zálohuj a pak obnov do nového systému pomocí Aptik. Ušetříš spoustu práce a času.

9
Pomoc s hardwarem / Re:Jak zjistit stav SSD
« kdy: 18 Květen 2018, 18:57:48 »
Tak zrovna tohle bych v Ubuntu neřešil....
Použij diagnostickou utilitu od výrobce disku - ta jediná je relevantní. Naprostá většina je ovšem napsaná pro Windows, ale některé jsou bootovací.

10
Pomoc s hardwarem / Re:CD/DVD write nefunkční
« kdy: 18 Květen 2018, 18:51:30 »
Já bohužel nemám ty systémy na flešce, ale na DVD, takže to neumím  - mám jen 1 DVD drive.
Ale jsem si jist, že pod Lubuntu 14.03/4 to fungovalo.

To je sice hezké, ale připadá mi, že to vlastně ani moc vyřešit nechceš. Především ty sám pro to musíš něco udělat...
Nebo co od nás očekáváš?  Že za tebe půjdeme tu flešku koupit??  :-\

11
Pomoc s hardwarem / Re:CD/DVD write nefunkční
« kdy: 17 Květen 2018, 15:38:19 »
Dík, ale já jsem to zkoušel na dvou počítačích (desktop, notebook), u obou mám Lubuntu 16.04 LTS a u obou je ta chyba stejná - že by obě vypalovačky byly vadné, tomu se mi nechce věřit. Přitom pod 14.04 to nedělalo.

Tak to ještě ověř - nabootuj z flešky 16.04 14.04 a 18.04  a vyzkoušej to tam...

12
Internet a sítě / Re:bezdratovy usb adapter
« kdy: 17 Květen 2018, 15:29:01 »
po zadani prikazu:
Kód: [Vybrat]
sudo apt update && sudo apt install build-essential linux-headers-$(uname -r) git dkmsmi naskocilo:
Kód: [Vybrat]
Načítají se seznamy balíků… Hotovo
E: Nelze získat zámek /var/lib/apt/lists/lock - open (11: Resource temporarily unavailable)
E: Nelze uzamknout adresář /var/lib/apt/lists/

no a pokud bych zkusil dalsi prikaz, tak dalsi hlaska
Kód: [Vybrat]
The program 'git' is currently not installed. You can install it by typing:
sudo apt install git
no a pokud zkusim zadat
Kód: [Vybrat]
sudo apt install gittak:
Kód: [Vybrat]
E: Nelze získat zámek /var/lib/dpkg/lock - open (11: Resource temporarily unavailable)
E: Nelze uzamknout administrační adresář (/var/lib/dpkg/). Používá jej jiný proces?


To se stává v případě, že se pokoušíš instalovat přes Terminál a zároveň máš ještě otevřený třeba Synaptic nebo Centrum SW.   Proto musíš napřed tyto aplikace ukončit....

13
Pomoc s hardwarem / Re:CD/DVD write nefunkční
« kdy: 17 Květen 2018, 15:19:10 »
Použij jinou vypalovačku - čtení není tak náročné, proto i vypalovačky které to mají "za sebou" dokážou ještě číst....
Nová stojí cca 3 stovky, proto nemá cenu se tím více zabývat. Je to zkrátka spotřební věc.
--------------------
A doufám, že po vypálení vždy provádíš kontrolu (porovnáním vypáleného obsahu se zdrojovými soubory), což většina vypalovacího SW umožňuje. To že se disk "nějak" vypálí ještě neznamená že tam vše skutečně je. U fotek nebo videa výpadek pár bitů nic neznamená a ani si ho nevšimneš, ale pokud vypaluješ třeba OS, tak tam už to není žádná legrace...

14
Obecná podpora / Re:Nejde spustit kalkulačka ubuntu 18.04.
« kdy: 17 Květen 2018, 15:13:39 »
Pokud nejde nějaká aplikace spustit, spusť ji v Terminálu. Vypíše se chybové hlášení.
Příkaz pro spuštění by měl být
Kód: [Vybrat]
gnome-calculator

15
Spouteni U-mate na raspberry jeste nekolikrat nejak chodilo, s tim, ze se po kratke dobe kouslo
(vetsinou to indikovalo zmizeni ikon v horni liste obrazu). Nasledny reboot se vetsinou musel opakovat.
Po tech nekolika takovych spusteni to po uvodnim logu U-mate skoncilo cernou obrazovkou.

To mne donutilo, pokusit se znovu SSD otestovat. Vzhledem k pritomnosti klasickeho U16 na tomto SSD
jsem je na nem znovu spustil na klasicem PC (v SATA interface). Znovu jsem testoval stav 'sda' U-mate.
Aplikace 'Disky' stale neindikovaly nejaky problem. Protoze v instalaci U16 na tomto ssd nemam
zavadeci menu, umoznujici vstup do boot v rezimu obnoveni, a zrejme neco neznam,
spustil jsem kontrolu stavu partition sda s U-mate v 'Gparted'. 'Disky' stale neindikovaly nejaky problem.

K memu prekvapeni, jsem po naslednem spusteni U-mate raspberry, byl schopen opravit
spatne baliky i bez problemu aktualizovat system. Po te jsem od vcerejska nezaznamel zadny problem.
A to nejen pri pristupech na web ale i pri kompilacich v C::B a spousteni mnou zde vytvarenych aplikacich
pro obsluhu komunikaci domaci 485 site.

Nevim, zda v ssd doslo k oprave problematickych casti ssd v 'Gparted' nebo se jen nejak opravil souborovy system EXT4.
Mam s EXT4 rovnez spatnou zkusenost na klasickem HDD s U16-04 pri vzniku vadneho sektoru. Zde se objevovaly
rovnez zahadne chyby a pady systemu.  Nakonec jsem musel cele partition U16 preformatovat a preinstalovat.
Po instalaci po beznem formatovani byl U16 znovu nefunkcni ! Pomohlo az prepsani celeho partition nulami !

Jeste bych mel dotaz k zmizelemu Aptiku. V systemu existuje a v terminalu spustit jde.
Jsem ale zvykly na jeho graficke interface a mam z nej z SSD U-mate zalohy.
Zkusil jsem jej preinstalovat ale byla mi vracena hlaska ze je aktualni.
Poradi mi nekdo jak jej donutit k spousteni v grafickem interface ?

Aptik má novou verzi 18 (osobně se mi vůbec nelíbí....). Oproti minulosti je rozdělená na aptik a aptik-gtk. Pokud požaduješ grafické rozhraní, musíš nainstalovat oba balíky...
Jo, a zálohy vytvořené v předchozích verzích aptiku nejsou s novou verzí kompatibilní, takže nejdou obnovit.
Naštěstí lze do U 18.04 nainstalovat Aptik 16.5.2 (pomocí gdebi!) a obnova proběhne normálně. Ale zase balíčky starších verzí se těžko shání...

16
Citace
Zkoušel jsem tento problém vyhledat na fórech jak v češtině tak angličtině a koukal jsem na postupy jak přes terminál instalovat .sh soubory, ale nikde jsem neviděl, že by někdo měl stejný problém natož, že bych někde viděl jak ho řešit.
Soubory .sh se neinstalují, nýbrž spouští - to se ti sice povedlo,
ale záleží co za příkazy ten soubor obsahuje - a to je věc jiná....

17
Ukaž příkaz, jinak správně bude:
Citace
sudo ./nazev_souboru

Ovšem za předpokladu, že má Terminál otevřený ve složce s tím souborem .sh což zřejmě nemá......
V tom případě bude příkaz
Kód: [Vybrat]
sudo "/cesta/k/soubor.sh"

18
Podpora pro pracovní prostředí / Re:Zamykací obrazovka
« kdy: 15 Květen 2018, 15:46:58 »
Zdravím,

právě jsem přešel na nové Ubuntu 18.04, snažím si ho uživatelsky přizpůsobit a narazil jsem na jeden "problém". Jedná se o to, že když uzamču počítač, tedy přejdu na lock screen, obrazovka ihned zčerná. Když pohnu s myší opět se probudí, ale pouze na 15 vteřin a znovu zčerná. Je zde nějaký způsob jak udržet obrazovku při lock screenu stále vzhůru?

Díky

Zkus v nastavení systému ztmavování displaye zakázat/příp. nastavit delší čas.

19
Zdravím,
snažím se nainstalovat jeden program, vytvořený jako diplomka jednoho člověka a nedaří se mi spustit soubor .sh - dostane se mi hlášky:

sudo: nm-tool: příkaz nenalezen a Internet connection needed!

přičemž připojen jsem, zkouším to teď i na druhém počítači vybaveným Suse a na svém počítači, kde mám ubuntu 16.04
Nevěděl by jste si někdo rady?

dokumentace k programu je zde: file:///home/jakub/.cache/.fr-zshevJ/dAGPort/DOCUMENTATION

Co to je za odkaz??   Ty si myslíš, že když dáš odkaz na lokální soubor z tvého PC  že to bude dostupné na netu?
Buď dej odkaz odkud jsi to stáhl, nahraj to na nějaký filehosting a dej sem na to odkaz,  nebo to zazipuj a vlož to sem jako přílohu (Rozšířené možnosti).

20
Obecná podpora / Re:boční tlačítka myši
« kdy: 13 Květen 2018, 11:57:03 »
zdravím jsem co se tyče linuxu celkem začátečník jsem zvyklý mít na boční tlačítka myši nastaveny esc a space bohužel se mi nikde nepodařilo najít jak o nastavit v linuxu ubuntu 18.04  existuje nějaký jednoduchý zpusob jak to přenastavit? tlačítka funguji ale pouze jako zpět/vpřed.
děkuji

Použij xdotool a xbindkeys (pokud nemáš, doinstaluj).
Není to složité, v případě zájmu podrobně vysvětlím.
Jako základ je potřeba si uvědomit jak jsou číslovaná tlačítka myši, boční tlačítka jsou b8 a b9 (nikoli b4 a b5).
Těmto tlačítkům pak pomocí xbindkeys přiřadíš klávesu prostřednictvím xdotool
----------------------
Např. přiřazení které požaduješ ty bude vypadat (v konfiguračním souboru xbindkeys) takto:
Kód: [Vybrat]
# Namapování 4 tl. myši na kl. ESC
"xdotool key esc"
  m:0x0 + b:9

# Namapování 5 tl. myši na kl. SPACE
"xdotool key space"
  m:0x0 + b:8

Výše uvedené vlož do souboru (vytvoří se po prvním spuštění xbindkeys)
Kód: [Vybrat]
~/.xbindkeysrc
Samozřejmě, utilita xbindkeys musí běžet (přidej ji do Aplikací spouštěných po přihlášení).




21
Pomoc s hardwarem / Re:Špatné barvy ihned po instalaci
« kdy: 13 Květen 2018, 03:12:29 »
A proč sis to nevyzkoušel ještě před instalací v live režimu?  Pokud to neběží v něm, nemá smysl distro instalovat - je třeba zkusit jiné.

22
Zkrátka skutečnost je taková, že některé závislosti nelze (pro určitou verzi ubuntu) vyřešit.
To znamená, že některé balíky tam zkrátka nenainstaluješ z důvodu nesplnitelných závislostí.
Jediná možnost je přejít na vyšší verzi. Pak budou závislosti splnitelné.
-----------------------------------------------------------------------------------------------
Pokud rád experimentuješ, přidej si tento PPA
https://launchpad.net/~ubuntu-toolchain-r/+archive/ubuntu/test/+packages
A spusť instalační skript znova (ten s gdebi). Je pravděpodobné, že se závislosti vyřeší (repozitář obsahuje libstdc++ a gcc až ve verzi 8 pro U14.04).

23
Pro juwa2:

No jo, ale to už je pro uživatele příliš nekomfortní a složité.
Představ si, že si z Netu stáhneš nějaký program pro Ubuntu a v instalačních instrukcích to po tobě bude chtít, aby sis nainstaloval nějaký program (gdebi) a pak spustil v Terminálu nějaký script a pak teprve si rozbalil ten program do libovolného adresáře a dvojklikem na spustitelný soubor ho spustil.
Takhle distribuovat svůj program opravdu nechci.

A co Ubuntu Software Center?
Dokázal by USC při instalaci těch balíčků vošéfovat ty závislosti?
Jde mi o to, že USC má ve svém Ubuntu každý defaultně, nemusel by si tedy instalovat zbytečně další program na správu balíčků (gdebi).
Do toho scriptu by se místo sudo gdebi $HOME/installdeb/*.deb napsalo USC místo gdebi.
Fungovalo by to?

Instalaci gdebi lze dopsat přímo do toho skriptu - je to jeden řádek.  A pak už vše proběhne automaticky.
Uživatel pouze spustí skript....
Princip je ten, že ty závislosti by se měly instalovat napřed. A právě tohle gdebi "umí"
----------------------------------------------------------------------------
SW center používá k instalaci apt (zohlednil jsem ve skriptu č.2) - vyzkoušej, měly by se nainstalovat i závislosti.

24
Použij gdebi  - ve skriptu změň řádek
Kód: [Vybrat]
sudo dpkg -i $HOME/installdeb/*.deb
na
Kód: [Vybrat]
sudo gdebi $HOME/installdeb/*.deb
Předpokladem je mít gdebi nainstalovaný. Pokud nemáš, tak
Kód: [Vybrat]
sudo apt-get install gdebi
(můžeš to dopsat na začátek skriptu)

----------------------------------------------------------------------------------------------------------------------------------------------------------------------
Zde je druhá verze skriptu
Kód: [Vybrat]
#!/bin/bash
mkdir $HOME/installdeb
cd $HOME/installdeb
wget http://cz.archive.ubuntu.com/ubuntu/pool/universe/w/wxwidgets3.0/libwxbase3.0-0v5_3.0.2+dfsg-1.3_amd64.deb http://cz.archive.ubuntu.com/ubuntu/pool/universe/w/wxwidgets3.0/libwxgtk3.0-0v5_3.0.2+dfsg-1.3_amd64.deb http://cz.archive.ubuntu.com/ubuntu/pool/universe/w/wxwidgets3.0/libwxgtk-media3.0-0v5_3.0.2+dfsg-1.3_amd64.deb http://cz.archive.ubuntu.com/ubuntu/pool/universe/w/wxwidgets3.0/libwxgtk-webview3.0-0v5_3.0.2+dfsg-1.3_amd64.deb
sudo apt-get install libwxbase3.0-0v5_3.0.2+dfsg-1.3_amd64.deb
sudo apt-get install libwxgtk3.0-0v5_3.0.2+dfsg-1.3_amd64.deb
sudo apt-get install libwxgtk-media3.0-0v5_3.0.2+dfsg-1.3_amd64.deb
sudo apt-get install libwxgtk-webview3.0-0v5_3.0.2+dfsg-1.3_amd64.deb
rm -R $HOME/installdeb

25
Pomoc s hardwarem / Re:WiFi adapter TP-LINK Archer T2UH - ovladač
« kdy: 12 Květen 2018, 03:00:35 »
Musíš taky číst co ti Terminál píše a hlavně se tím řídit....
Už po prvním příkazu make (správně má být ./make) ti píše, že ti v PC chybí a máš doinstalovat
libelf-dev, libelf-devel nebo elfutils-libelf-devel
Ty jsi ale na to nedbal, kompilace neproběhla v pořádku, tys přesto pokračoval v instalaci dalším příkazem na kterém jsi pochopitelně skončil...  Takže nejprve doinstaluj co je potřeba
Kód: [Vybrat]
sudo apt-get install libelf-dev libelf-devel
A pak to zkompiluj znova (složku mt7610u-master odstraň, stažený archiv rozbal znova a začni od začátku)
Teprve pak má smysl pokračovat v instalaci dalším příkazem.
(Pokud ty balíky nebudou v repozitáři tak si je budeš muset schrastit jinde...)

Stran: [1] 2 3 ... 66