Prosíme přihlašte se nebo zaregistrujte.

Přihlašte se svým uživatelským jménem a heslem.
Vaše pomoc je stále potřeba!

Novinky: Školení nejen k OS Ubuntu pro širokou veřejnost, více informací zde.

Zobrazit příspěvky

Tato sekce Vám umožňuje zobrazit všechny příspěvky tohoto uživatele. Prosím uvědomte si, že můžete vidět příspěvky pouze z oblastí Vám přístupných.


Témata - Standa99

Stran: [1] 2
1
Podpora pro Ubuntu Server / IPv6 skrz router s NATem
« kdy: 02 Červenec 2017, 15:12:51 »
Na WANu mám veřejnou IPv4 a globální IPv6 přímo od poskytovatele. Zajímavé že v /etc/network/interfaces nemám žádnou konfiguraci ohledně IPv6. Na routeru mi ping6 + traceroute6 funguje a http://test-ipv6.com/ vyhodí 10/10. Za NATem mám vnitřní síť, ze které bych chtěl také přistupovat na IPv6, ale z různých návodů nemám jasno, co použít. Nejblíž se mi jeví radvd, ale nechci to jen tak zkoušet na funkčním routeru. Předem dík za rady.

2
Podpora pro Ubuntu Server / Roundcube problém
« kdy: 08 Červen 2017, 09:37:41 »
Na mail serveru (postfix 3.1.0 + dovecot 2.2.22) mi vše přes Thunderbird funguje (příjem i odeslání pošty) viz. přihlášení:
Kód: [Vybrat]
Jun  8 9:16:20 mail-server dovecot: imap-login: Login: user=<mail@domena.eu>, method=PLAIN, rip=XX.XX.XX.XX, lip=XX.XX.XX.XX, mpid=20403, TLS, session=<jH6GDmFRPKpZHUIW>(XX.XX.XX.XX=veřejná IP)

Problém mám s Roundcube (1.2.5), při jeho nastavování mi přes port 587 testovací email odešle (v Thunderbirdu ověřeno), ale nedokážu se přihlásit na port 993 viz. TLS handshaking: Disconnected
Kód: [Vybrat]
Jun  8 9:17:47 mail-server dovecot: imap-login: Disconnected (no auth attempts in 60 secs): user=<>, rip=127.0.0.1, lip=127.0.0.1, TLS handshaking: Disconnected, session=<HPvTAWFRuol/AAAB>
Certifikát mám vygenerovaný přes Let's Encrypt a už jsem zkoušel do "config.inc.php" naimplantovat tohle, kde jako CA jsem použil "/etc/letsencrypt/live/domena.eu/fullchain.pem", ale taky to nepomohlo. V konfiguraci používám pouze localhost viz.
Kód: [Vybrat]
<?php

/* Local configuration for Roundcube Webmail */

$config['db_dsnw'] = 'mysql://user:password@localhost/roundcubemail';

$config['default_host'] = 'localhost';

$config['default_port'] = 993;

$config['smtp_port'] = 587;

$config['smtp_user'] = 'mail@domena.eu';

$config['smtp_pass'] = 'password';

$config['support_url'] = '';

$config['auto_create_user'] = false;

$config['des_key'] = 'keykeykey';

$config['plugins'] = array();

Nevím jaký je přesně rozdíl v přihlašování mezi Thunderbirdem a Roundcube, ale snad v tom není nějaký bug.

Edit:
Nepomůže ani, když dám místo localhostu domena.eu nebo tls://domena.eu.

3
Internet a sítě / Proxy + VPN tunel
« kdy: 02 Květen 2017, 16:01:26 »
Přes proxy běžící asi na Ciscu, do které nemám přístup (a domluva není možná), potřebuji projít VPNkou. Aby ta proxyna mohla filtrovat i HTTPS, tak jsou do systému doinstalovány zprostředkující + kořenové certifikáty.
Dá se přes ní připojit pouze na port 80, takže např. OpenVPN musí běžet na tomto portu. Připojení proběhne a funguje, jenže v okamžiku, kdy probíhá větší přenos dat, tak ta proxyna tu komunikaci zařízne. Mimo VPNku, třeba přes prohlížeč, fungují i velmi datově náročná videa, ale tu VPN zařízne (asi kvůli HTTP-hlavičkám). Už jsem zkoušel i nějaké další nastavení pro OpenVPN např. http-proxy-option AGENT 'Chrome/58.0.3029.81' i jiné identifikátory prohlížečů, ale proxy odolává.
Tuším, že to asi oblbnout nepůjde, ale klidně se nechám nakopnout.

4
Pomoc s hardwarem / LAN e1000e problém
« kdy: 26 Únor 2017, 07:20:04 »
Už se tu v minulosti něco probíralo, ale na tom driveru e1000e běží starší i novější Intel LANky, od kterých bych čekal bezproblémový chod. Mám 4 Intel LANky viz. výpis, kde problém dělá ta první I219-V (eth1), která je WAN port:
Kód: [Vybrat]
Ethernet controller: Intel Corporation Ethernet Connection (2) I219-V (rev 31)
Kernel driver in use: e1000e
Kernel modules: e1000e

Ethernet controller: Intel Corporation 82571EB Gigabit Ethernet Controller (rev 06)
Kernel driver in use: e1000e
Kernel modules: e1000e

Ethernet controller: Intel Corporation 82571EB Gigabit Ethernet Controller (rev 06)
Kernel driver in use: e1000e
Kernel modules: e1000e

Ethernet controller: Intel Corporation I211 Gigabit Network Connection (rev 03)
Kernel driver in use: igb
Kernel modules: igb

V logu se mi objeví tohle a ten spodní odstavec se stále opakuje:
Kód: [Vybrat]
kernel: [261012.941212] e1000e 0000:00:1f.6 eth1: Reset adapter unexpectedly
NetworkManager[1062]: <info>  [1488056439.8294] device (eth1): link disconnected
NetworkManager[1062]: <info>  [1488056443.1061] device (eth1): link connected
kernel: [261016.219032] e1000e: eth1 NIC Link is Up 1000 Mbps Full Duplex, Flow Control: None

kernel: [261018.830346] e1000e 0000:00:1f.6 eth1: Detected Hardware Unit Hang:
                          TDH                  <d2>
                          TDT                  <f4>
kernel: [261007.821139]   next_to_use          <f4>
kernel: [261007.821139]   next_to_clean        <d0>
kernel: [261007.821139]   buffer_info[next_to_clean]:
kernel: [261007.821139]   time_stamp           <103e28226>
kernel: [261007.821139]   next_to_watch        <d2>
kernel: [261007.821139]   jiffies              <103e28480>
kernel: [261007.821139]   next_to_watch.status <0>
kernel: [261007.821139]   MAC Status             <40080083>
kernel: [261007.821139]   PHY Status             <796d>
kernel: [261007.821139]   PHY 1000BASE-T Status  <3800>
kernel: [261007.821139]   PHY Extended Status    <3000>
kernel: [261007.821139]   PCI Status             <10>

Někde radí vypnutí TSO, GSO a GRO, ale to jsem zatím nezkoušel. 
Dělá to na kernelu 4.4 i 4.8 a už jsem vyzkoušel zkompilovat nové drivery pro e1000e a při jednom i drivery pro igb. To zatím nepomohlo a chystám se na přehrání firmwaru u všech LANek (pokud mi to nabídne aktualizaci).
Taky ještě vyzkouším přehodit ten WAN port na tu igb LANku. Tím že mám optiku až domů, tak je naproti GPON Huawei HG8245, do kterého přístup nemám, ale je v bridge, protože veřejku mám na té Intel LANce (a WiFi používám svou), možná si mezi sebou nerozumí.
Nemáte někdo nějaký tip?

5
Obecná podpora / Úprava řádku v konf. souboru (vyřešeno)
« kdy: 25 Únor 2017, 08:54:01 »
Na tohle jsem levý, potřebuju nahradit 22 řádek v konfiguračním souboru, což mi příkazem níže funguje, ale nebere mi to lomítko mezi Connection a PortRangeMin. Zkoušel jsem přidat jednoduché i dvojité uvozovky, ale bez výsledku. Dík za jakoukoliv snahu.

Kód: [Vybrat]
sed -i "22s/.*/Connection\PortRangeMin=${json:8:5}/" /root/.config/qBittorrent/qBittorrent.conf
P.S. Je to vloženo do scriptu, který mi u vytvořeného VPN spojení (PIA) přesměruje port z veřejné IP a ten potřebuju doplnit do konfiguráku torrent klienta.

6
Všiml jsem si, že už mám 16.04.2 a někdy v prosinci (2016) jsem narazil na tento článek, kde by tato verze měla dostat kernel 4.8. Vím, že jde dodat ručně, ale potom se automaticky neaktualizuje (možná s dodatečnou konfigurací). Oficiální ISO ještě ke stažení není.
Přechod na novější kernel 4.8 potvrzuje i stránka Rolling HWE Stacks for 16.04 na wiki.
Akorát netuším, jestli to bude dostupné jen z obrazu 16.04.2, nebo to půjde dodat i do stávající instalace?

7
Pomoc s hardwarem / Uspání HDD 4TB (vyřešeno)
« kdy: 11 Únor 2017, 17:38:02 »
Doteď jsem používal konfiguraci v /etc/hdparm.conf
Kód: [Vybrat]
/dev/sdb {
spindown_time = 12
}
kde se můj letitý 2TB WD20EARS bezproblému uspával (ve starším Ubuntu 12.04).

Nyní na 16.04 mám nový 4TB WD40PURX a ten se mi uspávat nechce.
Zkusil jsem i jiný zápis do /etc/hdparm.conf
Kód: [Vybrat]
command_line {
    hdparm -S 12 /dev/sdb
}

a ani z terminálu se nedaří
Kód: [Vybrat]
root@server:~# uname -a
Linux server 4.4.0-62-generic #83-Ubuntu SMP Wed Jan 18 14:10:15 UTC 2017 x86_64 x86_64 x86_64 GNU/Linux
root@server:~# hdparm -C /dev/sdb

/dev/sdb:
 drive state is:  active/idle
root@server:~# hdparm -S 12 /dev/sdb

/dev/sdb:
 setting standby to 12 (1 minutes)
root@server:~# date
So úno 11 17:14:35 CET 2017
root@server:~# date
So úno 11 17:25:54 CET 2017
root@server:~# hdparm -C /dev/sdb

/dev/sdb:
 drive state is:  active/idle

Neřešil jste někdo podobný problém?

8
Internet a sítě / OpenVPN a torrenty
« kdy: 24 Listopad 2016, 20:07:20 »
původní vlákno jsem smazal

9
Internet a sítě / vino-server & windows klient
« kdy: 26 Květen 2016, 11:06:46 »
Netušíte, jestli se nějaký klient ve Windows umí připojit na linuxový vino-server, který používá šifrování?
Nechce se mi ho vypínat
Kód: [Vybrat]
DISPLAY=:0  gsettings set org.gnome.Vino require-encryption 'false'
a mnou používaný UltraVNC to neumí. Díval jsem se i po nějakých pluginech např. SecureVNCPlugin.dsm, ale ani s ním to nejde.

10
Obecná podpora / systemd - problém se spuštěním služeb
« kdy: 25 Květen 2016, 08:19:12 »
Na 16.04 se mi dost často stává, že se mi nespustí některé služby při startu. Onu velkou výhodu systemd "paralelizace při startu" bych rád ocenil, ale spíše to dělá neplechu, než dobro.
Nejde WiFi a zjistím, že se nespustil hostapd, někdy to je squid nebo třeba samba. Nevím proč si nezjišťuje, které služby měly být spuštěny a jestli teda vůbec jsou? Nebo to jde nějak donutit ručně?
Ve výpisu
Kód: [Vybrat]
systemctl list-units -t service --alljdou ty stavy hezky vidět, ale to mi prd pomůže.
Vše se děje na mém nově připravovaném strojku z podpisu.

11
Zkouším Ubuntu 15.10 a pod systemd jsou názvy síťových zařízení (pro mě) divné. Dvě LANky jsem si přejmenoval pomocí /etc/udev/rules.d/10-network.rules, ale nedokážu přejmenovat WiFi zařízení, stále ho mám wlp4s0. Zkoušel jsem to jako u těch LANek, tak i přes DEVPATH=="/sys/device/pci0000:00/.........", ale bezvýsledně.
Netušíte někdo, jak to spáchat?

Edit:
Doplním, že v syslogu je tohle:
Kód: [Vybrat]
iwlwifi 0000:04:00.0 wlp4s0: renamed from wlan0
a také
NetworkManager[609]: <info>  device added (path: /sys/devices/pci0000:00/0000:00:1c.5/0000:04:00.0/net/wlp4s0, iface: wlp4s0): no ifupdown configuration found.

12
Netušíte, jestli jde příkazem (po kabelu) zapnout USB tethering na Androidu?
Mám RPi2 (Debian netinst) s USB WiFi (Atheros chipset s anténou) a na něm rozchozené sdílení NETu "Android -> RPi2 -> USB WiFi -> cokoliv", ale bodlo by mi, abych nemusel v telefonu do menu a ručně tuto funkci zapínat.

Edit: Nejspíš se budu muset zaměřit na nějakou appku, která bude v telefonu automaticky zapínat USB tethering při připojení kabelu. Nějaké jsem zkusil, ale nepodporovaly Lollipop.

13
Zkouším smazat soubory kromě 144 posledních a nedaří se mi to.
Kód: [Vybrat]
ls -rt | head -n -144 | rm -f
Dík za nakopnutí.

Doplním, že příkaz proběhne v pořádku (bez žádné varovné hlášky), ale soubory se nesmažou, přitom příkaz
Kód: [Vybrat]
ls -rt | head -n -144
vypíše všechny soubory správně (kromě těch 144 posledních).

14
Podpora pro Ubuntu Server / phpMyAdmin - problém s přístupem
« kdy: 06 Září 2014, 07:57:21 »
Dost často se mi stává, že mi nastavení phpMyAdminu vypustí povolené IP adresy (subnety) z configu. Mám to sice navíc zajištěné přes Fail2ban, ale štve mě to. Když se někdy podívám do fail2ban.log, tak tam mám např.
Citace
2014-09-03 04:47:41,361 fail2ban.actions: WARNING [apache-phpmyadmin] Ban 218.152.216.82 (ku...  šikmooké)
Po restartu apache2 je vše v pořádku (You don't have permission to access /phpmyadmin/ on this server.). Když jsem zkusil službu několikrát za sebou restartovat, tak to pokaždé bylo v pořádku. Nejspíš se to děje jinak, než špatným načtením konfigurace při restartu služby a nebo ty povolené adresy jdou nějak vypnout + ti šmejdi to umí.

15
Volná diskuze kolem Linuxu a OSS / RRDtool - rada [vyřešeno]
« kdy: 27 Srpen 2014, 07:16:40 »
Neděláte někdo v rrdtool? Potřeboval bych, aby mi na ose Y (vlevo) místo měřítka 1.2 k zobrazovalo 1200. Zkoušel jsem přidat řádek s "--left-axis-format", ale ten u mě nepodporuje a graf se nevytvoří. Systém je raspbian.


16
Internet a sítě / ProFTPD + virtualhost [vyřešeno]
« kdy: 30 Duben 2014, 08:26:02 »
Používám úspěšně ProFPTD s FTPS konfigurací. Chci nahodit další virtuální FTP na jiném portu. Přihlašování podle portu probíhá správně, ale na ten virtuální se nelze přihlásit. Skončí to akorát hláškou 530 Login incorrect, i když přidám funkčního usera z toho standalone do virtuálního.
Používám jednu složku pro certifikáty a jeden soubor pro usery, takže netuším jestli v tom je zakopaný pes, nebo že používám jedno rozhraní (standalone mám pro All interface a virtuální pro eth0)? Ta složka s certifikáty by měla jít změnit, ale ten soubor pro usery asi ne ( http://www.proftpd.org/docs/configs/virtual.conf ). Netušíte někdo?

17
Internet a sítě / OpenVPN + komprese dat
« kdy: 16 Březen 2014, 17:13:42 »
(Vím, že existuje Opera, která slušně kompresuje data, ale dal bych přednost vlastnímu řešení.)

Jde o to, že v zahraničí bych měl k dispozici pouze určitý balíček dat a proto bych chtěl u sebe (v ČR) rozjet OpenVPN + kompresi dat. Telefon je s Androidem (prohlížeč mám oblíbený Maxthon) a netuším, jestli "comp-lzo" (co jsem se dočetl) budou spolu kompatibilní? A má důležitá otázka zní, jestli to má cenu a kolik by se s tímto řešením ušetřilo dat (prohlížení s obrázky)? S tímhle nemám vůbec zkušenost.

P.S. Na svém strojku mám rozjetou i proxynu pomocí Squid3 a netuším, jestli by s tímto šla nějaká komprimace vůbec zapnout? Vím, že jsem shnilý si to najít (momentálně se léčím a vypaluju červa), ale snad by to do budoucna pomohlo i jiným. Budu vděčný za každý podnětný příspěvek (nejlépe z praxe).

18
Obecná podpora / Ubuntu 13.10 Final
« kdy: 17 Říjen 2013, 15:58:00 »
Tak jsem nyní testnul finální vydání 13.10 64-bit a na NB s Haswell CPU+GPU a nVidia 750M mi nenaběhlo. Ale není to jediné distro, protože kernely v poslední době stojí za dvě věci. Zkrachovalo to díky nouveau ovladačům pro nVidii.

Edit: Kdyby měl někdo podobný problém a chtěl se dostat do desktopu, tak při startu editujte "Try Ubuntu without installing" a přidejte nouveau.modeset=0.

19
Volná diskuze kolem Linuxu a OSS / Live USB s UEFI/GPT
« kdy: 21 Září 2013, 21:03:58 »
Jde vytvořit Live USB disk, aby byl schopen nabootovat přes UEFI? Když jsem zkusil Rufus http://rufus.akeo.ie/ , tak mi nenabootovalo Ubuntu. Nenajela mi ani Fedora s jejich liveusb creatorem. Všude je sice adresář /EFI/boot, ale start mi skončí na hlášce ve smyslu "blocked security policy". Jediné co mi najelo, bylo systemrescuecd-x86-3.8.0 s jejich sysresccd-installer-2.0.0.

20
Ubuntu 12.04 + squid3
Rozjel jsem přihlašování na proxy (to mi funguje), ale nedokážu filtrovat určité slova nebo domény.
Mám pouze minimální config:
Kód: [Vybrat]
auth_param digest program /usr/lib/squid3/digest_pw_auth -c /etc/squid3/pass.txt
auth_param digest realm proxy
acl authenticated proxy_auth REQUIRED
http_access allow authenticated

http_port 3128

acl zakaz url_regex ^http://*.youtube.*/*
acl zakaz url_regex sex porn xxx adult
http_access deny zakaz
Nevím, co dělám blbě, ale nejde mi to. V access.logu je vidět, že mi youtube proleze a zakázaná slova taky neblokuje:
Kód: [Vybrat]
1374260328.731     47 192.168.1.100 TCP_MISS/204 478 GET http://s.youtube.com/stream_204? proxy-server DIRECT/46.47.136.99 text/html
Zkuste mě nakopnout. Dík

21
Volná diskuze kolem Linuxu a OSS / Nahrazení Google reader
« kdy: 14 Březen 2013, 12:08:32 »
Dnes je toho celý web. Vím, že určitě ho nějaká jiná služba nahradí.
Běží mi strojek celý den a chtěl bych toho využít. Neexistuje nějaká aplikace, která by sbírala rss kanály a exportovala do html přes apache?

22
Pomoc s hardwarem / TV tuner + uspaný stav (zařízení nenalezeno)
« kdy: 06 Březen 2013, 16:56:26 »
Mám TV tuner Pinnacle 340e. Funguje mi s nakopírovaným FW + posledními zkompilovanými ovladači V4L. Problém mám, že mi ho někdy systém (Ubuntu 12.10) při startu nepřipojí a pokaždé se to také stane z uspaného stavu (STR).
Jde to řešit, že ho na chvíli vytáhnu z USB, ale nebaví mě pokaždé padnout na kolena a toto provádět z druhé strany skříně. Zkoušel jsem najít nějaký reset USB portu např. http://www.roman10.net/how-to-reset-usb-device-in-linux/ , ale tohle mi nepomáhá, i když resetuju tuner na správném portu (lsusb).
Nemáte někdo vyzkoušené funkční řešení?

24
Obecná podpora / kernel.ubuntu.com
« kdy: 26 Listopad 2012, 13:55:52 »
http://kernel.ubuntu.com/~kernel-ppa/mainline/

Netušíte proč se tam už nejde dostat? Že by nějaké restrikce? Chtěl jsem testnout jiné jádro na 12.04 a už ho netestnu.

25
Pomoc s hardwarem / SSD - Zjištěny problémy s pevným diskem
« kdy: 16 Listopad 2012, 09:23:38 »
Je to na Ubuntu 12.04.1 a děje se to po naklonování partitionu. S.M.A.R.T. je v pohodě, nastartoval jsem z USB a projel disk fsck (žádný problém). Nevím jak se toho mám zbavit, aby se to po každém startu neobjevilo.



S.M.A.R.T.
http://89.29.66.22/standa/router/ssd-kingston.txt

Stran: [1] 2