Prosíme přihlašte se nebo zaregistrujte.

Přihlašte se svým uživatelským jménem a heslem.
Blog Ubuntu -- Správa "projektů" české komunity Ubuntu

Novinky: Děkujeme všem návštěvníkům fóra, kteří ochotně radí ostatním. Vaše práce je velmi potřebná a vážíme si jí.

Autor Téma: ALSA - problem se zvukem  (Přečteno 5995 krát)

bak0nuk3m

  • Návštěvník
  • *
  • Příspěvků: 28
  • Karma: +0/-0
    • Zobrazit profil
ALSA - problem se zvukem
« kdy: 04 Prosinec 2007, 19:11:38 »
Ahoj vsem, resim nasledujici problem se zvukem, ktery nastal zniceho nic.

nefunguje mi v XFCE ovladani hlasitosti v pripade ze dam alsamixer rika me to:

alsamixer: function snd_ctl_open failed for default: No such device, zvuk v programech nefunguje

V pripade, ze zalozim noveho uzivatele prihlasim se pod nim tak me mixer bez problemu jede
v pripade ze pod svym uctem dam sudo ALSAMIXER, take bez problemu jede

vypada to jako by byl problem s pravy uzivatele pod kterym jsem prihlaseny...
proste pokud jsem prihlasen na svuj ucet dokud nedam sudo alsamixer me nenajede...

Na jednom foru jsem nasel informaci o tom, ze se ma udelat nasledujici

1. Create a new user account
2. Login using new user account
3. Check to see if sound works properly
4. If it does, then the issue is likely some sort of config file. Look for the .asoundrc file in your original home directory and move it to a backup folder (just in case)
5. Log back in as your original user and test.
6. If it fails to cure the problem, try the Comprehensive Guide above.

Problem ovsem je ze ja ten soubor ve svem ani novem home diru nemam, nejde mi ho najit ani v ETC
proste tam neni, skryte soubory mam samo zobrazeny...

Nevite nekdo co s tim ?
« Poslední změna: 13 Prosinec 2007, 18:16:15 od Anna Taliánová »

anicka

  • Host
Re: ALSA - problem se zvukem
« Odpověď #1 kdy: 13 Prosinec 2007, 18:33:01 »
Podívejte se také na oprávnění, která máte pro Váš účet pod kterým jste příhlášen (v Xfce nevím kde to je, mám Gnome).

Možná by Vám pomohlo tohle: Zkuste napsat do terminálu příkaz newgrp

Důležitý rozdíl terminálového příkazu newgrp a příkazu groupadd je tento (sdělil Chocholoušek z chatu Ubuntu):

groupadd = přidáš se do skupiny, ale nic víc, systém to neví!
     ALE
newgrp = přidání se do skupiny právě ohlásí systému!! :-)


Edit:
Ještě jsem na fóru našla další tip k řešení problému. Podobné téma je na fóru zde, a řešení Jakuba Šťastného je následující: "Hmm, tak pokud bude někdo taky takovej blbec jako já, tak gpasswd -a user audio :-)
Jinými slovy nově vytvořený uživatel není ve skupině audio, takže mu zvuk nepůjde...taktéž není v sudo userech...J"
« Poslední změna: 14 Prosinec 2007, 02:33:33 od Anna Taliánová »

Matenko

  • Návštěvník
  • *
  • Příspěvků: 6
  • Karma: +4/-1
    • Zobrazit profil
Re: ALSA - problem se zvukem
« Odpověď #2 kdy: 14 Prosinec 2007, 18:40:54 »
Mne zasa nefunguje ovladanie basov a vysok v alsa mixeri. Mam SB live! a drivre na emuk10k1. Vsetko slae a hra, len tato vec neide.

Funguje to niekomu z vas? Dik
Athlon XP 2600+, 768MB RAM, HD SG 160GB SATA 7200rpm, Nvidia GF 5200 FX, SB Live!

hase

  • Závislák
  • ****
  • Příspěvků: 2934
  • Karma: +265/-96
    • Zobrazit profil
    • www.palenka.org
Re: ALSA - problem se zvukem
« Odpověď #3 kdy: 14 Prosinec 2007, 18:45:47 »
mne to na SB live fachcilo vcetne tych basov a vysok - ale mam Ubuntu Studio. Teraz uz mi to nefunguje, lebo sa mi slavna SB live odvarila pri vypalovani vadneho CD v k3b! Neviem ako je to mozne, ale fakt sa to tak stalo... :(
AMD 64.bit  6-core mb: M4A89PRO/USB3 , Nvidia GT 520