Prosíme přihlašte se nebo zaregistrujte.

Přihlašte se svým uživatelským jménem a heslem.
Vaše pomoc je stále potřeba!

Novinky: Školení nejen k OS Ubuntu pro širokou veřejnost, více informací zde.

Autor Téma: Nelze najít balík Python3 pro Ubuntu 16.04 - VYŘEŠENO -  (Přečteno 1189 krát)

Kvido

  • Člen
  • **
  • Příspěvků: 221
  • Karma: +4/-0
    • Zobrazit profil
    • phpfusioncz
Nelze najít balík Python3 pro Ubuntu 16.04 - VYŘEŠENO -
« kdy: 17 Prosinec 2017, 16:05:55 »
Hoj všichni.
Nedaří se přes Terminál přidat balík Python3.
Kód: [Vybrat]
sudo apt-get install Python3Resp. nepusti mě to - ani přes Nautilus - do /var/lib/dpkg/
Co s tím?
« Poslední změna: 18 Prosinec 2017, 15:32:35 od Kvido »
Základní deska: ASUS, Procesor: Dual Core AMD Athlon 64 X2 2100 MHz, Brisbone, 1. HDD na SATA 6M-WDC WD 500.1 GB. 2. HDD 4M-Samsung 190 GB. RAM DDR2 2x, DDR3 1x - 4,2G. Grafika: Gallium 0.4 on ATI RS690. OS: Ubuntu 16.03.04 LTS, 64bit.

juwa2

  • Závislák
  • ****
  • Příspěvků: 1976
  • Karma: +140/-34
    • Zobrazit profil

Kvido

  • Člen
  • **
  • Příspěvků: 221
  • Karma: +4/-0
    • Zobrazit profil
    • phpfusioncz
Re:Nelze najít balík Python3 pro Ubuntu 16.04
« Odpověď #2 kdy: 18 Prosinec 2017, 05:42:11 »
@juwa2 díky...
ale tohle se nedokončilo:
Kód: [Vybrat]
root@vv-System:/home/vv# sudo apt-get install idle-python3.4
Načítají se seznamy balíků… Hotovo
Vytváří se strom závislostí       
Načítají se stavové informace… Hotovo
E: Nelze najít balík idle-python3.4
E: Nelze najít balík vyhovující masce „idle-python3.4“
E: Nelze najít balík vyhovující regulárnímu výrazu „idle-python3.4“
root@vv-System:/home/vv#
root@vv-System:/home/vv#
root@vv-System:/home/vv#

Které balíky doinstalovat, to je hrůza jsou tam desítrky...
Takže jdu na to zde:
Kód: [Vybrat]
vv@vv-System:~$ sudo dpkg -i python3_3.5.1-3_amd64.de
[sudo] heslo pro vv:
dpkg: chyba: stavová databáze dpkg je uzamčen jiným procesem
vv@vv-System:~$
...ale zase problém ZAMČENO, přes Nautilus jsem neotevřel...
Jak dál? Co řekneš, prosím?
« Poslední změna: 18 Prosinec 2017, 06:13:23 od Kvido »
Základní deska: ASUS, Procesor: Dual Core AMD Athlon 64 X2 2100 MHz, Brisbone, 1. HDD na SATA 6M-WDC WD 500.1 GB. 2. HDD 4M-Samsung 190 GB. RAM DDR2 2x, DDR3 1x - 4,2G. Grafika: Gallium 0.4 on ATI RS690. OS: Ubuntu 16.03.04 LTS, 64bit.

jarek163

  • Návštěvník
  • *
  • Příspěvků: 29
  • Karma: +12/-0
    • Zobrazit profil
Re:Nelze najít balík Python3 pro Ubuntu 16.04
« Odpověď #3 kdy: 18 Prosinec 2017, 06:24:36 »

Kvido

  • Člen
  • **
  • Příspěvků: 221
  • Karma: +4/-0
    • Zobrazit profil
    • phpfusioncz
Re:Nelze najít balík Python3 pro Ubuntu 16.04
« Odpověď #4 kdy: 18 Prosinec 2017, 06:52:33 »
Skoro se již podařilo podle Vašeho návodu:
Kód: [Vybrat]
Stahuje se:20 http://security.ubuntu.com/ubuntu xenial-security/universe DEP-11 64x64 Icons [79,7 kB]
Staženo 1 583 kB za 2s (717 kB/s)                                     
Načítají se seznamy balíků… Hotovo
vv@vv-System:~$ sudo apt-get install python3.6
E: Nelze získat zámek /var/lib/dpkg/lock - open (11: Prostředek je dočasně nepřístupný)
E: Nelze uzamknout administrační adresář (/var/lib/dpkg/). Používá jej jiný proces?
vv@vv-System:~$

....ale jedště problém s tím uzamčením, to mě zaskočilo.

Ještě zkouším:
Kód: [Vybrat]
vv@vv-System:~$ sudo apt-get install python3.6
Načítají se seznamy balíků… Hotovo
Vytváří se strom závislostí       
Načítají se stavové informace… Hotovo
Následující balíky byly nainstalovány automaticky a již nejsou potřeba:
  linux-headers-4.4.0-101 linux-headers-4.4.0-101-generic
  linux-image-4.4.0-101-generic linux-image-extra-4.4.0-101-generic
Pro jejich odstranění použijte „sudo apt autoremove“.
Následující dodatečné balíky budou instalovány:
  libpython3.6-minimal libpython3.6-stdlib python3.6-minimal
Navrhované balíky:
  python3.6-venv python3.6-doc
Následující NOVÉ balíky budou nainstalovány:
  libpython3.6-minimal libpython3.6-stdlib python3.6 python3.6-minimal
0 aktualizováno, 4 nově instalováno, 0 k odstranění a 1 neaktualizováno.
E: Nelze získat zámek /var/cache/apt/archives/lock - open (11: Prostředek je dočasně nepřístupný)
E: Nelze uzamknout adresář /var/cache/apt/archives/
vv@vv-System:~$

Hm, co s těmi zámky, neznám vychytávku, jak odemknout a umožnit uzamčení pak.
« Poslední změna: 18 Prosinec 2017, 07:08:21 od Kvido »
Základní deska: ASUS, Procesor: Dual Core AMD Athlon 64 X2 2100 MHz, Brisbone, 1. HDD na SATA 6M-WDC WD 500.1 GB. 2. HDD 4M-Samsung 190 GB. RAM DDR2 2x, DDR3 1x - 4,2G. Grafika: Gallium 0.4 on ATI RS690. OS: Ubuntu 16.03.04 LTS, 64bit.

Kvido

  • Člen
  • **
  • Příspěvků: 221
  • Karma: +4/-0
    • Zobrazit profil
    • phpfusioncz
Re:Nelze najít balík Python3 pro Ubuntu 16.04
« Odpověď #5 kdy: 18 Prosinec 2017, 07:13:02 »
Tak to zřejmě blokuje:
var/cache/apt/archives/lock
podle výpisu v Terminálu je to označeno "červeně"

Kód: [Vybrat]
0 aktualizováno, 4 nově instalováno, 0 k odstranění a 1 neaktualizováno.
E: Nelze získat zámek /var/cache/apt/archives/lock - open (11: Prostředek je dočasně nepřístupný)
E: Nelze uzamknout adresář /var/cache/apt/archives/
vv@vv-System:~$ sudo lsof | grep apt/archives/lock
lsof: WARNING: can't stat() fuse.gvfsd-fuse file system /run/user/1000/gvfs
      Output information may be incomplete.
synaptic  3760            root   57uW     REG        8,1         0    1181995 /var/cache/apt/archives/lock
gmain     3760 3778       root   57uW     REG        8,1         0    1181995 /var/cache/apt/archives/lock
vv@vv-System:~$

Zkoušel jsem tedy změnit chmod, ale nepomohlo, co s tím?
Kód: [Vybrat]
vv@vv-System:~$ chmod -R 777 /var/cache/apt/archives/
chmod: práva '/var/cache/apt/archives/' nelze změnit: Operace není povolena

V "archives" je ale složka "partial", má to nějakou roli, je zamčená!!!???
« Poslední změna: 18 Prosinec 2017, 07:48:38 od Kvido »
Základní deska: ASUS, Procesor: Dual Core AMD Athlon 64 X2 2100 MHz, Brisbone, 1. HDD na SATA 6M-WDC WD 500.1 GB. 2. HDD 4M-Samsung 190 GB. RAM DDR2 2x, DDR3 1x - 4,2G. Grafika: Gallium 0.4 on ATI RS690. OS: Ubuntu 16.03.04 LTS, 64bit.

Kvido

  • Člen
  • **
  • Příspěvků: 221
  • Karma: +4/-0
    • Zobrazit profil
    • phpfusioncz
Re:Nelze najít balík Python3 pro Ubuntu 16.04
« Odpověď #6 kdy: 18 Prosinec 2017, 09:47:25 »
Instalace se zřejmě podařilo, viz. T.:
Kód: [Vybrat]
vv@vv-System:~$ sudo apt-get install python3.6
[sudo] heslo pro vv:
Načítají se seznamy balíků… Hotovo
Vytváří se strom závislostí       
Načítají se stavové informace… Hotovo
Následující balíky byly nainstalovány automaticky a již nejsou potřeba:
  linux-headers-4.4.0-101 linux-headers-4.4.0-101-generic
  linux-image-4.4.0-101-generic linux-image-extra-4.4.0-101-generic
Pro jejich odstranění použijte „sudo apt autoremove“.
Následující dodatečné balíky budou instalovány:
  libpython3.6-minimal libpython3.6-stdlib python3.6-minimal
Navrhované balíky:
  python3.6-venv python3.6-doc
Následující NOVÉ balíky budou nainstalovány:
  libpython3.6-minimal libpython3.6-stdlib python3.6 python3.6-minimal
0 aktualizováno, 4 nově instalováno, 0 k odstranění a 1 neaktualizováno.
Nutno stáhnout 4 383 kB archivů.
Po této operaci bude na disku použito dalších 23,9 MB.
Chcete pokračovat? [Y/n] y
Stahuje se:1 http://ppa.launchpad.net/jonathonf/python-3.6/ubuntu xenial/main i386 libpython3.6-minimal i386 3.6.3-1ubuntu1~16.04.york1 [574 kB]
Stahuje se:2 http://ppa.launchpad.net/jonathonf/python-3.6/ubuntu xenial/main i386 python3.6-minimal i386 3.6.3-1ubuntu1~16.04.york1 [1 463 kB]
Stahuje se:3 http://ppa.launchpad.net/jonathonf/python-3.6/ubuntu xenial/main i386 libpython3.6-stdlib i386 3.6.3-1ubuntu1~16.04.york1 [2 130 kB]
Stahuje se:4 http://ppa.launchpad.net/jonathonf/python-3.6/ubuntu xenial/main i386 python3.6 i386 3.6.3-1ubuntu1~16.04.york1 [217 kB]
Staženo 4 383 kB za 1s (2 824 kB/s)
Vybírá se dosud nevybraný balík libpython3.6-minimal:i386.
(Načítá se databáze … nyní je nainstalováno 399095 souborů a adresářů.)
Připravuje se nahrazení …/libpython3.6-minimal_3.6.3-1ubuntu1~16.04.york1_i386.deb …
Rozbaluje se libpython3.6-minimal:i386 (3.6.3-1ubuntu1~16.04.york1) …
Vybírá se dosud nevybraný balík python3.6-minimal.
Připravuje se nahrazení …/python3.6-minimal_3.6.3-1ubuntu1~16.04.york1_i386.deb …
Rozbaluje se python3.6-minimal (3.6.3-1ubuntu1~16.04.york1) …
Vybírá se dosud nevybraný balík libpython3.6-stdlib:i386.
Připravuje se nahrazení …/libpython3.6-stdlib_3.6.3-1ubuntu1~16.04.york1_i386.deb …
Rozbaluje se libpython3.6-stdlib:i386 (3.6.3-1ubuntu1~16.04.york1) …
Vybírá se dosud nevybraný balík python3.6.
Připravuje se nahrazení …/python3.6_3.6.3-1ubuntu1~16.04.york1_i386.deb …
Rozbaluje se python3.6 (3.6.3-1ubuntu1~16.04.york1) …
Zpracovávají se spouštěče pro balík man-db (2.7.5-1) …
Zpracovávají se spouštěče pro balík gnome-menus (3.13.3-6ubuntu3.1) …
Zpracovávají se spouštěče pro balík desktop-file-utils (0.22-1ubuntu5.1) …
Zpracovávají se spouštěče pro balík mime-support (3.59ubuntu1) …
Zpracovávají se spouštěče pro balík bamfdaemon (0.5.3~bzr0+16.04.20160824-0ubuntu1) …
Rebuilding /usr/share/applications/bamf-2.index...
Nastavuje se balík libpython3.6-minimal:i386 (3.6.3-1ubuntu1~16.04.york1) …
Nastavuje se balík python3.6-minimal (3.6.3-1ubuntu1~16.04.york1) …
Nastavuje se balík libpython3.6-stdlib:i386 (3.6.3-1ubuntu1~16.04.york1) …
Nastavuje se balík python3.6 (3.6.3-1ubuntu1~16.04.york1) …
vv@vv-System:~$
Základní deska: ASUS, Procesor: Dual Core AMD Athlon 64 X2 2100 MHz, Brisbone, 1. HDD na SATA 6M-WDC WD 500.1 GB. 2. HDD 4M-Samsung 190 GB. RAM DDR2 2x, DDR3 1x - 4,2G. Grafika: Gallium 0.4 on ATI RS690. OS: Ubuntu 16.03.04 LTS, 64bit.

juwa2

  • Závislák
  • ****
  • Příspěvků: 1976
  • Karma: +140/-34
    • Zobrazit profil
Re:Nelze najít balík Python3 pro Ubuntu 16.04
« Odpověď #7 kdy: 18 Prosinec 2017, 11:34:32 »
Ten problém s "uzamčením" je dán např. tím, že se pokoušíš instalovat přes Terminál a zároveň máš otevřený třeba Synaptic nebo Centrum SW které rovněž používají apt. Proto je vždy třeba nejprve všechny tyto aplikace ukončit...

Kvido

  • Člen
  • **
  • Příspěvků: 221
  • Karma: +4/-0
    • Zobrazit profil
    • phpfusioncz
Re:Nelze najít balík Python3 pro Ubuntu 16.04 - VYŘEŠENO!
« Odpověď #8 kdy: 18 Prosinec 2017, 15:31:38 »
VYŘEŠENO
@juwa2
Ano, ano. Dík, moje nepozornost.
Jinak Python 3.6 mně již funguje!
Základní deska: ASUS, Procesor: Dual Core AMD Athlon 64 X2 2100 MHz, Brisbone, 1. HDD na SATA 6M-WDC WD 500.1 GB. 2. HDD 4M-Samsung 190 GB. RAM DDR2 2x, DDR3 1x - 4,2G. Grafika: Gallium 0.4 on ATI RS690. OS: Ubuntu 16.03.04 LTS, 64bit.