Prosíme přihlašte se nebo zaregistrujte.

Přihlašte se svým uživatelským jménem a heslem.
World of Warcraft

Novinky: Děkujeme všem návštěvníkům fóra, kteří ochotně radí ostatním. Vaše práce je velmi potřebná a vážíme si jí.

Autor Téma: ubuntu a chyba zavislosti  (Přečteno 720 krát)

Kony.cz

  • Člen
  • **
  • Příspěvků: 237
  • Karma: +4/-9
    • Zobrazit profil
ubuntu a chyba zavislosti
« kdy: 25 Leden 2018, 09:28:44 »
zkousim delat apt-get upgrade a haze mi to porad tuto chybu

Kód: [Vybrat]
root@kony:~# apt-get upgrade
Čtu seznamy balíků… Hotovo
Vytvářím strom závislostí
Čtu stavové informace… Hotovo
Pro opravení můžete spustit „apt-get -f install“.
Následující balíky mají nesplněné závislosti:
 libc-dev-bin : Závisí na: libc6 (< 2.16) ale 2.16-0ubuntu6 je nainstalován
 libc6-dev : Závisí na: libc6 (= 2.15-0ubuntu10.18) ale 2.16-0ubuntu6 je nainstalován
 libnih1 : Předzávisí na: libc6 (< 2.16) ale 2.16-0ubuntu6 je nainstalován
E: Nesplněné závislosti. Zkuste použít -f.

i kdyz dam apt-get -f install tak to hodi chybu

Kód: [Vybrat]
root@kony:~# apt-get -f install
Čtu seznamy balíků… Hotovo
Vytvářím strom závislostí
Čtu stavové informace… Hotovo
Opravuji závislosti… selhalo.
Následující balíky mají nesplněné závislosti:
 libc-dev-bin : Závisí na: libc6 (< 2.16) ale 2.16-0ubuntu6 je nainstalován
 libc6-dev : Závisí na: libc6 (= 2.15-0ubuntu10.18) ale 2.16-0ubuntu6 je nainstalován
 libnih1 : Předzávisí na: libc6 (< 2.16) ale 2.16-0ubuntu6 je nainstalován
E: Chyba, pkgProblemResolver::Resolve vytváří poruchy, to může být způsobeno podrženými balíky.
E: Nelze opravit závislosti


juwa2

  • Závislák
  • ****
  • Příspěvků: 1646
  • Karma: +116/-34
    • Zobrazit profil
Re:ubuntu a chyba zavislosti
« Odpověď #1 kdy: 25 Leden 2018, 10:09:11 »
Obnov ze zdravé zálohy nebo reinstaluj.

Kony.cz

  • Člen
  • **
  • Příspěvků: 237
  • Karma: +4/-9
    • Zobrazit profil
Re:ubuntu a chyba zavislosti
« Odpověď #2 kdy: 25 Leden 2018, 11:27:32 »
no to neni moc dobra zprava, nemuzu to jen tak preinstalovat

jmp

  • Závislák
  • ****
  • Příspěvků: 2569
  • Karma: +242/-32
    • Zobrazit profil
Re:ubuntu a chyba zavislosti
« Odpověď #3 kdy: 25 Leden 2018, 11:43:04 »
ještě je možná můžete zkusit odinstalovat (pokud to v tomto stavu půjde), pak aktualizovat metainformace repositářů a potom případně znovu instalovat (snad už kompatibilní verze)...

Kony.cz

  • Člen
  • **
  • Příspěvků: 237
  • Karma: +4/-9
    • Zobrazit profil
Re:ubuntu a chyba zavislosti
« Odpověď #4 kdy: 25 Leden 2018, 11:47:30 »
no odinstalovat libc6 ??
Kód: [Vybrat]
root@kony:~# apt-get remove libc6a vybehlo mraky radku znejici jako tohle
Kód: [Vybrat]
Čtu seznamy balíků… Hotovo
Vytvářím strom závislostí
Čtu stavové informace… Hotovo
Pro opravení následujících můžete spustit „apt-get -f install“:
Následující balíky mají nesplněné závislosti:
 accountsservice : Závisí na: libc6 (>= 2.4) ale nebude se instalovat
 acpid : Závisí na: libc6 (>= 2.7) ale nebude se instalovat
 apache2-utils : Závisí na: libc6 (>= 2.4) ale nebude se instalovat
 apache2.2-bin : Závisí na: libc6 (>= 2.4) ale nebude se instalovat
 apparmor : Závisí na: libc6 (>= 2.8) ale nebude se instalovat
 apt : Závisí na: libc6 (>= 2.15) ale nebude se instalovat
 apt-transport-https : Závisí na: libc6 (>= 2.4) ale nebude se instalovat
 apt-utils : Závisí na: libc6 (>= 2.4) ale nebude se instalovat
 aptitude : Závisí na: libc6 (>= 2.4) ale nebude se instalovat
 at : Závisí na: libc6 (>= 2.7) ale nebude se instalovat
 base-passwd : Závisí na: libc6 (>= 2.8) ale nebude se instalovat
 bash : Předzávisí na: libc6 (>= 2.15) ale nebude se instalovat

a na konci

Kód: [Vybrat]
E: Nesplněné závislosti. Zkuste spustit „apt-get -f install“ bez balíků (nebo navrhněte řešení
pokud potom pouziju

apt-get -f install tak znovu

Kód: [Vybrat]
root@kony:~# apt-get -f install
Čtu seznamy balíků… Hotovo
Vytvářím strom závislostí
Čtu stavové informace… Hotovo
Opravuji závislosti… selhalo.
Následující balíky mají nesplněné závislosti:
 libc-dev-bin : Závisí na: libc6 (< 2.16) ale 2.16-0ubuntu6 je nainstalován
 libc6-dev : Závisí na: libc6 (= 2.15-0ubuntu10.18) ale 2.16-0ubuntu6 je nainstalován
 libnih1 : Předzávisí na: libc6 (< 2.16) ale 2.16-0ubuntu6 je nainstalován
E: Chyba, pkgProblemResolver::Resolve vytváří poruchy, to může být způsobeno podrženými balíky.
E: Nelze opravit závislosti

jmp

  • Závislák
  • ****
  • Příspěvků: 2569
  • Karma: +242/-32
    • Zobrazit profil
Re:ubuntu a chyba zavislosti
« Odpověď #5 kdy: 25 Leden 2018, 11:53:30 »
nene
odinstalovat následující (ty si stěžujou, že závisej na starších balíčcích než které jsou aktuálně instalované):
libc-dev-bin
libc6-dev
libnih1

a pak je v novějších verzích (po aktualizaci metadat to snad bude OK) znovu nainstalovat

Kony.cz

  • Člen
  • **
  • Příspěvků: 237
  • Karma: +4/-9
    • Zobrazit profil
Re:ubuntu a chyba zavislosti
« Odpověď #6 kdy: 25 Leden 2018, 11:55:31 »
mohl bych tedy poprosit o postup ???

Kód: [Vybrat]
root@kony:~# apt-get remove libc-dev-bin
Kód: [Vybrat]
Čtu seznamy balíků… Hotovo
Vytvářím strom závislostí
Čtu stavové informace… Hotovo
Pro opravení následujících můžete spustit „apt-get -f install“:
Následující balíky mají nesplněné závislosti:
 libc6-dev : Závisí na: libc6 (= 2.15-0ubuntu10.18) ale 2.16-0ubuntu6 se bude instalovat
             Závisí na: libc-dev-bin (= 2.15-0ubuntu10.18) ale nebude se instalovat
 libnih1 : Předzávisí na: libc6 (< 2.16) ale 2.16-0ubuntu6 se bude instalovat
E: Nesplněné závislosti. Zkuste spustit „apt-get -f install“ bez balíků (nebo navrhněte řešení).

Kód: [Vybrat]
root@kony:~# apt-get remove libc6-dev
Kód: [Vybrat]
Čtu seznamy balíků… Hotovo
Vytvářím strom závislostí... 50%
Vytvářím strom závislostí
Čtu stavové informace… Hotovo
Pro opravení následujících můžete spustit „apt-get -f install“:
Následující balíky mají nesplněné závislosti:
 build-essential : Závisí na: libc6-dev ale nebude se instalovat nebo
                                libc-dev
 libc-dev-bin : Závisí na: libc6 (< 2.16) ale 2.16-0ubuntu6 se bude instalovat
 libnih1 : Předzávisí na: libc6 (< 2.16) ale 2.16-0ubuntu6 se bude instalovat
 libstdc++6-4.6-dev : Závisí na: libc6-dev (>= 2.13-0ubuntu6) ale nebude se instalovat
 zlib1g-dev : Závisí na: libc6-dev ale nebude se instalovat nebo
                           libc-dev
E: Nesplněné závislosti. Zkuste spustit „apt-get -f install“ bez balíků (nebo navrhněte řešení).

Kód: [Vybrat]
root@kony:~# apt-get remove libnih1
Kód: [Vybrat]
Čtu seznamy balíků… Hotovo
Vytvářím strom závislostí
Čtu stavové informace… Hotovo
Pro opravení následujících můžete spustit „apt-get -f install“:
Následující balíky mají nesplněné závislosti:
 libc-dev-bin : Závisí na: libc6 (< 2.16) ale 2.16-0ubuntu6 se bude instalovat
 libc6-dev : Závisí na: libc6 (= 2.15-0ubuntu10.18) ale 2.16-0ubuntu6 se bude instalovat
 libnih-dbus1 : Závisí na: libnih1 (= 1.0.3-4ubuntu9.1) ale nebude se instalovat
 mountall : Závisí na: libnih1 (>= 1.0.0) ale nebude se instalovat
 upstart : Závisí na: libnih1 (>= 1.0.0) ale nebude se instalovat
 ureadahead : Závisí na: libnih1 (>= 1.0.0) ale nebude se instalovat
E: Nesplněné závislosti. Zkuste spustit „apt-get -f install“ bez balíků (nebo navrhněte řešení).
« Poslední změna: 25 Leden 2018, 11:57:07 od Kony.cz »

juwa2

  • Závislák
  • ****
  • Příspěvků: 1646
  • Karma: +116/-34
    • Zobrazit profil
Re:ubuntu a chyba zavislosti
« Odpověď #7 kdy: 25 Leden 2018, 11:57:43 »
no to neni moc dobra zprava, nemuzu to jen tak preinstalovat
Za normálních okolností nemůže nastat aby se ti to dostalo do tohoto nekonsistentního stavu.
Co jsi s tím prováděl za harakiri?

Kony.cz

  • Člen
  • **
  • Příspěvků: 237
  • Karma: +4/-9
    • Zobrazit profil
Re:ubuntu a chyba zavislosti
« Odpověď #8 kdy: 25 Leden 2018, 11:59:11 »
nedelal jsem tam nic, zniceho nic se tohle stalo.. je teda pravda ze je to ubuntu uz hodne stary 12.04

jmp

  • Závislák
  • ****
  • Příspěvků: 2569
  • Karma: +242/-32
    • Zobrazit profil
Re:ubuntu a chyba zavislosti
« Odpověď #9 kdy: 25 Leden 2018, 12:01:11 »
mno nevím, já ten problém nemám, tak to nemusím poskládat správně případně to nebude funkční postup (nemám to jak ověřit...)
při odinstalaci sledujte, jestli to nechce mazat něco dalšího (případně to zastavit a zkontrolovat o co jde a jestli je to bezpečné)

# apt-get purge libc-dev-bin libc6-dev libnih1
# apt-get update
# apt-get install libc-dev-bin libc6-dev libnih1

jmp

  • Závislák
  • ****
  • Příspěvků: 2569
  • Karma: +242/-32
    • Zobrazit profil
Re:ubuntu a chyba zavislosti
« Odpověď #10 kdy: 25 Leden 2018, 12:02:50 »
není to ten samý stroj, kde vám došlo místo v /boot ? - to samo o sobě může narušit instalace/aktualizace ...

Kony.cz

  • Člen
  • **
  • Příspěvků: 237
  • Karma: +4/-9
    • Zobrazit profil
Re:ubuntu a chyba zavislosti
« Odpověď #11 kdy: 25 Leden 2018, 12:03:37 »
nnn neni to ten samy. je to neco uplne jinyho

Kony.cz

  • Člen
  • **
  • Příspěvků: 237
  • Karma: +4/-9
    • Zobrazit profil
Re:ubuntu a chyba zavislosti
« Odpověď #12 kdy: 25 Leden 2018, 12:04:12 »
Kód: [Vybrat]
root@kony:~# apt-get purge libc-dev-bin libc6-dev libnih1
Kód: [Vybrat]
Čtu seznamy balíků… Hotovo
Vytvářím strom závislostí
Čtu stavové informace… Hotovo
Pro opravení následujících můžete spustit „apt-get -f install“:
Následující balíky mají nesplněné závislosti:
 build-essential : Závisí na: libc6-dev ale nebude se instalovat nebo
                                libc-dev
 libnih-dbus1 : Závisí na: libnih1 (= 1.0.3-4ubuntu9.1) ale nebude se instalovat
 libstdc++6-4.6-dev : Závisí na: libc6-dev (>= 2.13-0ubuntu6) ale nebude se instalovat
 mountall : Závisí na: libnih1 (>= 1.0.0) ale nebude se instalovat
 upstart : Závisí na: libnih1 (>= 1.0.0) ale nebude se instalovat
 ureadahead : Závisí na: libnih1 (>= 1.0.0) ale nebude se instalovat
 zlib1g-dev : Závisí na: libc6-dev ale nebude se instalovat nebo
                           libc-dev
E: Nesplněné závislosti. Zkuste spustit „apt-get -f install“ bez balíků (nebo navrhněte řešení).

jmp

  • Závislák
  • ****
  • Příspěvků: 2569
  • Karma: +242/-32
    • Zobrazit profil
Re:ubuntu a chyba zavislosti
« Odpověď #13 kdy: 25 Leden 2018, 12:16:50 »
hmm, zkuste ještě případně

# dpkg --remove libc-dev-bin libc6-dev libnih1

juwa2

  • Závislák
  • ****
  • Příspěvků: 1646
  • Karma: +116/-34
    • Zobrazit profil
Re:ubuntu a chyba zavislosti
« Odpověď #14 kdy: 25 Leden 2018, 12:29:50 »
nedelal jsem tam nic, zniceho nic se tohle stalo.. je teda pravda ze je to ubuntu uz hodne stary 12.04
Pak se to většinou stává po přidání nějakého "nespolehlivého" PPA. Nebo instalaci něčeho nekompatibilního pomocí .deb