Prosíme přihlašte se nebo zaregistrujte.

Přihlašte se svým uživatelským jménem a heslem.
World of Warcraft

Novinky: Děkujeme všem návštěvníkům fóra, kteří ochotně radí ostatním. Vaše práce je velmi potřebná a vážíme si jí.

Autor Téma: Uzivani SSD, problem EXT4-fs error ... reading directory iblock 0...  (Přečteno 771 krát)

miro_

  • Návštěvník
  • *
  • Příspěvků: 91
  • Karma: +2/-0
    • Zobrazit profil
Od lonska uzivame SATA WD SSD 120G pro Ubuntu-mate 16.04 na raspberry k TV jako monitoru zejmena pro pristup na web.
I pres 1GB RAM raspberry a pripojeni pres USB BOX jsou moznosti a zejmena rychlost proti TV webovemu prohlizeci vyborne.

Prislo mi zbytecne uzit cely SSD pro Ubuntu-mate 16.04 a tak jsem na SSD jeste instaloval klasicke Ubuntu 16.04
pro uziti v boxu na jinem PC (pro nahravani ze streamu). Zde na U16 dochazelo obcas k padum systemu.
Jiz tehdy jsem mel podezreni na problem s SSD viz. http://forum.ubuntu.cz/index.php?topic=83092.msg559465#msg559465.
Provozovani tohoto SSD na raspberry bylo bezproblemove a primo zapojeny SSD do PC neindikoval v aplikaci 'Disky'
zadne chyby (pri pristupu nebo spusteni z USB boxu nelze 'smart data' SSD cist !).
Diku bezproblemovemu provozu na raspberry jsem predokladal, ze by mohl byt zde nejaky problem s USB interface PC,
proto jsem prestal box pro nahravani uzivat.

Posledni mesic se pri provozu SSD s raspberry zacaly objevovat pady (U16-mate). Vzhledem k tomu, ze jsem mel vypnute
automaticke aktualizace tak jsem U16 rucne aktualizoval. Nekolik dnu to vypadalo OK ale dnes, po novych
padech systemu jsem se pokusil o dalsi aktualizaci. Po nekolika restartech systemu a pokusu o opravu chybneho baliku
z aktualizace jsem skoncil v cerne obrazovce na asi sesti chybach pristupu k SSD asi sektoru ve stylu cca:
  "[xxx.xxxx] EXT4-fs error(device sda4): ext4_find_entry:1450 com systemd ....".
Z instalace systemu zmizely zrejme nektere aplikace. Zjistil jsem chybejici Aptik, ktery mel byt dle
zprav z aktualizace take aktualizovan.

Sice na tomto SSD nemam zadna dulezita data ale chtel jsem zalohovat (pres USB box) na klasickem PC
 'U-mate home'  pres Xarchiver. Bohuzel to skoncilo zakousnutim pripojeneho U16 v PC (zrejme IO operace USB systemu).
V 'smart datech' 'Disky' spusteny instalovany system SSD U16 na PC (zapojeny do SATA PC) nevidi stale zadne chyby !
Nejak tomu nerozumim. SSD by mel problematicke casti disku automaticky vymenovat-odstavovat.

SSD ma za sebou rok bezneho provozu a tak uvazuji o reklamaci. Vzhledem k vyhradnimu uzivani linuxu netusim jak
s prodejcem komunikovat.

Pokud mate v tomto smeru nejake zkusenosti pridejte je sem.

miro_

  • Návštěvník
  • *
  • Příspěvků: 91
  • Karma: +2/-0
    • Zobrazit profil
Re:Uzivani SSD, problem EXT4-fs error ... reading directory iblock 0...
« Odpověď #1 kdy: 16 Květen 2018, 12:39:41 »
Spouteni U-mate na raspberry jeste nekolikrat nejak chodilo, s tim, ze se po kratke dobe kouslo
(vetsinou to indikovalo zmizeni ikon v horni liste obrazu). Nasledny reboot se vetsinou musel opakovat.
Po tech nekolika takovych spusteni to po uvodnim logu U-mate skoncilo cernou obrazovkou.

To mne donutilo, pokusit se znovu SSD otestovat. Vzhledem k pritomnosti klasickeho U16 na tomto SSD
jsem je na nem znovu spustil na klasicem PC (v SATA interface). Znovu jsem testoval stav 'sda' U-mate.
Aplikace 'Disky' stale neindikovaly nejaky problem. Protoze v instalaci U16 na tomto ssd nemam
zavadeci menu, umoznujici vstup do boot v rezimu obnoveni, a zrejme neco neznam,
spustil jsem kontrolu stavu partition sda s U-mate v 'Gparted'. 'Disky' stale neindikovaly nejaky problem.

K memu prekvapeni, jsem po naslednem spusteni U-mate raspberry, byl schopen opravit
spatne baliky i bez problemu aktualizovat system. Po te jsem od vcerejska nezaznamel zadny problem.
A to nejen pri pristupech na web ale i pri kompilacich v C::B a spousteni mnou zde vytvarenych aplikacich
pro obsluhu komunikaci domaci 485 site.

Nevim, zda v ssd doslo k oprave problematickych casti ssd v 'Gparted' nebo se jen nejak opravil souborovy system EXT4.
Mam s EXT4 rovnez spatnou zkusenost na klasickem HDD s U16-04 pri vzniku vadneho sektoru. Zde se objevovaly
rovnez zahadne chyby a pady systemu.  Nakonec jsem musel cele partition U16 preformatovat a preinstalovat.
Po instalaci po beznem formatovani byl U16 znovu nefunkcni ! Pomohlo az prepsani celeho partition nulami !

Jeste bych mel dotaz k zmizelemu Aptiku. V systemu existuje a v terminalu spustit jde.
Jsem ale zvykly na jeho graficke interface a mam z nej z SSD U-mate zalohy.
Zkusil jsem jej preinstalovat ale byla mi vracena hlaska ze je aktualni.
Poradi mi nekdo jak jej donutit k spousteni v grafickem interface ?

Milhouse

  • Moderátor
  • Guru
  • *****
  • Příspěvků: 5683
  • Karma: +235/-37
    • Zobrazit profil
Re:Uzivani SSD, problem EXT4-fs error ... reading directory iblock 0...
« Odpověď #2 kdy: 16 Květen 2018, 19:04:13 »
Jen krátce.

1) reklamace SSD nemí závyslá na OS. Takže pokud má špatné bloky, reklamovat. Ty ale zřejmě nemá...
2) spusť Aptik z terminálu a čti výpis. Lze odinstalovat aptik i s konf.souborama a pak znovu nainstalovat:
Kód: [Vybrat]
apt purge aptik

N. Á. V. O. D. Y.
 "...naše práce není vidět, ale je důležitá!"

juwa2

  • Závislák
  • ****
  • Příspěvků: 1980
  • Karma: +141/-34
    • Zobrazit profil
Re:Uzivani SSD, problem EXT4-fs error ... reading directory iblock 0...
« Odpověď #3 kdy: 16 Květen 2018, 19:38:51 »
Spouteni U-mate na raspberry jeste nekolikrat nejak chodilo, s tim, ze se po kratke dobe kouslo
(vetsinou to indikovalo zmizeni ikon v horni liste obrazu). Nasledny reboot se vetsinou musel opakovat.
Po tech nekolika takovych spusteni to po uvodnim logu U-mate skoncilo cernou obrazovkou.

To mne donutilo, pokusit se znovu SSD otestovat. Vzhledem k pritomnosti klasickeho U16 na tomto SSD
jsem je na nem znovu spustil na klasicem PC (v SATA interface). Znovu jsem testoval stav 'sda' U-mate.
Aplikace 'Disky' stale neindikovaly nejaky problem. Protoze v instalaci U16 na tomto ssd nemam
zavadeci menu, umoznujici vstup do boot v rezimu obnoveni, a zrejme neco neznam,
spustil jsem kontrolu stavu partition sda s U-mate v 'Gparted'. 'Disky' stale neindikovaly nejaky problem.

K memu prekvapeni, jsem po naslednem spusteni U-mate raspberry, byl schopen opravit
spatne baliky i bez problemu aktualizovat system. Po te jsem od vcerejska nezaznamel zadny problem.
A to nejen pri pristupech na web ale i pri kompilacich v C::B a spousteni mnou zde vytvarenych aplikacich
pro obsluhu komunikaci domaci 485 site.

Nevim, zda v ssd doslo k oprave problematickych casti ssd v 'Gparted' nebo se jen nejak opravil souborovy system EXT4.
Mam s EXT4 rovnez spatnou zkusenost na klasickem HDD s U16-04 pri vzniku vadneho sektoru. Zde se objevovaly
rovnez zahadne chyby a pady systemu.  Nakonec jsem musel cele partition U16 preformatovat a preinstalovat.
Po instalaci po beznem formatovani byl U16 znovu nefunkcni ! Pomohlo az prepsani celeho partition nulami !

Jeste bych mel dotaz k zmizelemu Aptiku. V systemu existuje a v terminalu spustit jde.
Jsem ale zvykly na jeho graficke interface a mam z nej z SSD U-mate zalohy.
Zkusil jsem jej preinstalovat ale byla mi vracena hlaska ze je aktualni.
Poradi mi nekdo jak jej donutit k spousteni v grafickem interface ?

Aptik má novou verzi 18 (osobně se mi vůbec nelíbí....). Oproti minulosti je rozdělená na aptik a aptik-gtk. Pokud požaduješ grafické rozhraní, musíš nainstalovat oba balíky...
Jo, a zálohy vytvořené v předchozích verzích aptiku nejsou s novou verzí kompatibilní, takže nejdou obnovit.
Naštěstí lze do U 18.04 nainstalovat Aptik 16.5.2 (pomocí gdebi!) a obnova proběhne normálně. Ale zase balíčky starších verzí se těžko shání...
« Poslední změna: 16 Květen 2018, 19:54:53 od juwa2 »

miro_

  • Návštěvník
  • *
  • Příspěvků: 91
  • Karma: +2/-0
    • Zobrazit profil
Re:Uzivani SSD, problem EXT4-fs error ... reading directory iblock 0...
« Odpověď #4 kdy: 17 Květen 2018, 12:12:58 »
Juwa2, dik za dulezitou informaci okolo kompatibility zaloh Aptik !!

Nepisi zde casto a tak si dovolim moje zkusenosti  zde popsat:

Na raspberry jsem si delal zalohy pres Aptik pred spustenim pripadnych aktualizaci.
Zazil jsem zde neprijemnou situaci, kdyz jsem s raspberry zacinal.
Po instalaci U16-mate neslo spustit Chromium. Firefox byl OK.
Ale asi po pul roce se situace obratila a dodnes je zde Firefox nespustitelny !
Zrejme diky narokum na RAM. Jine dostupne prohlizece pro ARM,
co jsem zkousel zde nebyly zcela funkcni.

Po techto problemech jsem udelal zalohu tohoto partition pres Acronis.
Hlavne pro to, ze instalace pres SD kartu a prechod na SSD byl velmi pomaly atd...
Acronis uzivan z doby, kdy jsem prevazne zil na Win. Nekolikrat jsem s nim
pres image v pohode obnovoval/instaloval U16-10.04(CNC) na stara PC.
Mam Acronis-2009 ktery bohuzel neumi praci GPT atd.. Zatim
jsem ale nemel duvod hledat jine prostredky pro zalohy image.   

Na raspberry mne zajimaji hlavne instalovane specificke aplikace a jejich nastaveni.
Nemam zde zadna dulezita data. Z toho duvodu mi Aptik prisel zajimavy.
Mam zkusenost s Aptikem jen s uspesnym obnovenim stavu U16 na klasickem HDD
(pri vyse zminenem problemu s vadnym sektorem) kde mam velke partition
a zaloha image pres Acronis je prilis velka.
« Poslední změna: 17 Květen 2018, 12:15:43 od miro_ »