Prosíme přihlašte se nebo zaregistrujte.

Přihlašte se svým uživatelským jménem a heslem.
World of Warcraft

Novinky: Školení nejen k OS Ubuntu pro širokou veřejnost, více informací zde.

Autor Téma: Instalace PHP [vyřešeno]  (Přečteno 487 krát)

Rellik

  • Návštěvník
  • *
  • Příspěvků: 89
  • Karma: +0/-0
    • Zobrazit profil
    • dv-foto
Instalace PHP [vyřešeno]
« kdy: 17 Květen 2018, 20:55:53 »
Zdravím vespolek. Měnil jsem systémový disk a tudíž instaloval i nový systém (Kubuntu 18.04.0 LTS). Ke své práci potřebuji zprovoznit na PC virtuální server se starší verzí PHP (max7.0 nebo 7.1). V nabídce synaptic je ale bohužel poslední verze 7.2 na kterou nemám uzpůsobené dřívější projekty. Zpětně kompatibilní je mám do verze PHP 5.6, ale na novější se mi je momentálně nechce a navíc nemám potřebu. Na ostrých verzích jednou na PHP 5.6. No nicméně to je jedno... Poradí někdo jak nainstalovat do apache2 starší verzi PHP?
Díky za případnou odpověď...
« Poslední změna: 18 Květen 2018, 21:20:23 od Rellik »
Není nic co by nebylo možné, stačí jen najít tu správnou cestu.
http://dv-foto.cz
PC: i3-6100, 12Gb DDR4, Mainboard Asus H110IPLUS, GK Asus GT1030-SL-2G-BRK, HDD SSD Crucial 128Gb (systém) + HDD Seagate Barracuda 1Tb (data).

JoK

  • Návštěvník
  • *
  • Příspěvků: 97
  • Karma: +4/-0
    • Zobrazit profil

Kvido

  • Člen
  • **
  • Příspěvků: 217
  • Karma: +4/-0
    • Zobrazit profil
    • phpfusioncz
Re:Instalace PHP
« Odpověď #2 kdy: 18 Květen 2018, 09:20:09 »
Mám podobný problém.
Upgradoval jsem na domácím PC Ubuntu 14.04. LTS PHP 7. Máme tedy v etc dvě složky:
php/7.0 a 7.2
ale také složku: php5

Na localhostu webu mám ale nastaveno: PHP 5.5.9-1ubuntu4.25.
Jak přinutit systém v Ubuntu, aby byl aktivní PHP 7?

Kód: [Vybrat]
va@va-System-Product-Name:~$ php -v shows
PHP 7.0.30-1+ubuntu14.04.1+deb.sury.org+1 (cli) (built: May  2 2018 13:06:22) ( NTS )
Copyright (c) 1997-2017 The PHP Group
Zend Engine v3.0.0, Copyright (c) 1998-2017 Zend Technologies
    with Zend OPcache v7.0.30-1+ubuntu14.04.1+deb.sury.org+1, Copyright (c) 1999-2017, by Zend Technologies
va@va-System-Product-Name:~$

Děkuji moc(!) za každou radu.

« Poslední změna: 18 Květen 2018, 09:32:19 od Kvido »
Základní deska: ASUS, Procesor: Dual Core AMD Athlon 64 X2 2100 MHz, Brisbone, 1. HDD na SATA 6M-WDC WD 500.1 GB. 2. HDD 4M-Samsung 190 GB. RAM DDR2 2x, DDR3 1x - 4,2G. Grafika: Gallium 0.4 on ATI RS690. OS: Ubuntu 16.03.04 LTS, 64bit.

Kvido

  • Člen
  • **
  • Příspěvků: 217
  • Karma: +4/-0
    • Zobrazit profil
    • phpfusioncz
Re:Instalace PHP
« Odpověď #3 kdy: 18 Květen 2018, 13:55:37 »
Tak si odpovím sám:
Kód: [Vybrat]
va@va-System-Product-Name:~$ sudo a2dismod php5
[sudo] password for va:
Module php5 already disabled
va@va-System-Product-Name:~$ sudo a2enmod php7.1
Considering dependency mpm_prefork for php7.1:
Considering conflict mpm_event for mpm_prefork:
Considering conflict mpm_worker for mpm_prefork:
Module mpm_prefork already enabled
Considering conflict php5 for php7.1:
Module php7.1 already enabled
va@va-System-Product-Name:~$
Základní deska: ASUS, Procesor: Dual Core AMD Athlon 64 X2 2100 MHz, Brisbone, 1. HDD na SATA 6M-WDC WD 500.1 GB. 2. HDD 4M-Samsung 190 GB. RAM DDR2 2x, DDR3 1x - 4,2G. Grafika: Gallium 0.4 on ATI RS690. OS: Ubuntu 16.03.04 LTS, 64bit.

Kvido

  • Člen
  • **
  • Příspěvků: 217
  • Karma: +4/-0
    • Zobrazit profil
    • phpfusioncz
Re:Instalace PHP
« Odpověď #4 kdy: 18 Květen 2018, 14:08:58 »
Zatím vše OK
PHP 7.1 máme v:
etc/php/7.1/cli/php.ini

Musím ale Apcha2 restartovat, a to se nedaří:
Kód: [Vybrat]
va@va-System-Product-Name:~$ /etc/init.d/apache2 restart
 * Restarting web server apache2                                         [fail]
va@va-System-Product-Name:~$
Základní deska: ASUS, Procesor: Dual Core AMD Athlon 64 X2 2100 MHz, Brisbone, 1. HDD na SATA 6M-WDC WD 500.1 GB. 2. HDD 4M-Samsung 190 GB. RAM DDR2 2x, DDR3 1x - 4,2G. Grafika: Gallium 0.4 on ATI RS690. OS: Ubuntu 16.03.04 LTS, 64bit.

Rellik

  • Návštěvník
  • *
  • Příspěvků: 89
  • Karma: +0/-0
    • Zobrazit profil
    • dv-foto
Re:Instalace PHP
« Odpověď #5 kdy: 18 Květen 2018, 17:28:01 »
Zkus
https://askubuntu.com/questions/756879/cant-install-php5-on-ubuntu-16-04
D9ky vyzkoušel jsem. To s tím PPA jsemnašel i předtím, ale chtěl jsem spíš něco oficiálního. No nicméně mám tedy nainstalovánu verzi PHP 7.0. Což mi stačí... :)
Díky

Takže po instalaci PHP 7.0 jsem si upravil projekty aby fungovaly i na poslední verzi PHP 7.2 a pak nainstaloval aktualizace. Všechno jede jak má, takže spokojenost... :)
« Poslední změna: 18 Květen 2018, 21:22:17 od Rellik »
Není nic co by nebylo možné, stačí jen najít tu správnou cestu.
http://dv-foto.cz
PC: i3-6100, 12Gb DDR4, Mainboard Asus H110IPLUS, GK Asus GT1030-SL-2G-BRK, HDD SSD Crucial 128Gb (systém) + HDD Seagate Barracuda 1Tb (data).

Kvido

  • Člen
  • **
  • Příspěvků: 217
  • Karma: +4/-0
    • Zobrazit profil
    • phpfusioncz
Re:Instalace PHP [vyřešeno]
« Odpověď #6 kdy: 19 Květen 2018, 08:21:52 »
Ještě k mému problému upgrade PHP 7:

Je nainstalován, ale nejede, protože nelze po instalaci restartovat apache2.
Důvod:
Ubuntu 14.04 LTS nemá "systemctl" je to zde rozebrané a jak dál:
Kód: [Vybrat]
https://docs.docker.com/install/linux/linux-postinstall/#configure-docker-to-start-on-boot
Základní deska: ASUS, Procesor: Dual Core AMD Athlon 64 X2 2100 MHz, Brisbone, 1. HDD na SATA 6M-WDC WD 500.1 GB. 2. HDD 4M-Samsung 190 GB. RAM DDR2 2x, DDR3 1x - 4,2G. Grafika: Gallium 0.4 on ATI RS690. OS: Ubuntu 16.03.04 LTS, 64bit.