Prosíme přihlašte se nebo zaregistrujte.

Přihlašte se svým uživatelským jménem a heslem.
Vaše pomoc je stále potřeba!

Novinky: Děkujeme všem návštěvníkům fóra, kteří ochotně radí ostatním. Vaše práce je velmi potřebná a vážíme si jí.

Autor Téma: Instalace firebird 2.5 na Ubuntu 18.04 LTS  (Přečteno 1003 krát)

maca2me

  • Návštěvník
  • *
  • Příspěvků: 5
  • Karma: +0/-0
    • Zobrazit profil
Instalace firebird 2.5 na Ubuntu 18.04 LTS
« kdy: 20 Červen 2018, 14:38:06 »
Zdravím,

pokouším se nainstalovat firebird 2.5 na ubuntu 18.04 z repo ppa:mapopa (bez problému funguje na 16.04).

Při update vyskočí hláška:

Ign:1 http://ppa.launchpad.net/mapopa/ppa/ubuntu bionic InRelease
Hit:2 http://archive.ubuntu.com/ubuntu bionic InRelease
Hit:3 http://security.ubuntu.com/ubuntu bionic-security InRelease
Hit:4 http://archive.ubuntu.com/ubuntu bionic-updates InRelease
Hit:5 http://archive.ubuntu.com/ubuntu bionic-backports InRelease
Err:6 http://ppa.launchpad.net/mapopa/ppa/ubuntu bionic Release
  404  Not Found [IP: 91.189.95.83 80]
Reading package lists... Done
E: The repository 'http://ppa.launchpad.net/mapopa/ppa/ubuntu bionic Release' does not have a Release file.
N: Updating from such a repository can't be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.

(přepínač --allow-unauthenticated jsem zkoušel)

Googlil jsem ale našel jsem jen jednu zmínku o tom, že to někdo řeší a tam odpověď nebyla. Je možné, že již nelze firebird2.5-superclassic nainstalovat na nové ubuntu?

Budu rád, pokud mě někdo nakopne, na co bych se měl podívat.

Díky
« Poslední změna: 20 Červen 2018, 14:45:56 od maca2me »

juwa2

  • Závislák
  • ****
  • Příspěvků: 2104
  • Karma: +154/-34
    • Zobrazit profil
Re:Instalace firebird 2.5 na Ubuntu 18.04 LTS
« Odpověď #1 kdy: 20 Červen 2018, 16:16:20 »
Zmíněný PPA verzi pro 18.04 neobsahuje. Nicméně můžeš zkusit si příslušné balíky (pro 16.04) odtud
https://launchpad.net/~mapopa/+archive/ubuntu/ppa/+packages
stáhnout a nainstalovat (přes gdebi!) ručně.
-------------------------------------------------------------------------------------------------------------------------
Nebo nainstaluj firebird 3.0 takto:
Kód: [Vybrat]
sudo add-apt-repository ppa:mapopa/firebird3.0
sudo apt-get update
sudo apt-get install firebird3.0

Databáze vytvořná ve verzi 2.5 není s verzí 3.0 kompatibilní. Ošetříš to takto:
https://stackoverflow.com/questions/50462043/how-to-install-firebird-2-5-on-ubuntu-18-04
« Poslední změna: 20 Červen 2018, 16:19:55 od juwa2 »

macu

  • Závislák
  • ****
  • Příspěvků: 1115
  • Karma: +98/-3
    • Zobrazit profil
Re:Instalace firebird 2.5 na Ubuntu 18.04 LTS
« Odpověď #2 kdy: 20 Červen 2018, 16:18:49 »
no v tom repozitáři máš poslední verzi právě pro Ubuntu 16.04 (xenial)

Pokud opravdu potřebuješ verzi 2.5 a ne vyšší, můžeš to zkusit znásilnit, ale za výsledek neručím (zvláště závislosti). V Gnome-shellu si vyhledej Software&Aktualizace - karta Ostatní Software - klikni na daný zdroj, který chceš editovat - tlačítko Upravit a pak na položce Distribuce přepiš z bionic na xenial

Viz. přiložený obrázek jako ukázka (akorát je z jiného zdroje)
PC: Intel i5-6600K, 16 GB DDR4 RAM, Intel 530HD, ASUS Z170 Pro Gaming, , 2TB Toshiba HDD Sata III DT01ACA200, Ubuntu 18.10 64bit, Gnome Shell 3.30
Ntb: Toshiba L850-U12 - Intel i3 , 8 GB DDR3 RAM, Ubuntu 18.10 64bit, Gnome Shell 3.30

maca2me

  • Návštěvník
  • *
  • Příspěvků: 5
  • Karma: +0/-0
    • Zobrazit profil
Re:Instalace firebird 2.5 na Ubuntu 18.04 LTS
« Odpověď #3 kdy: 21 Červen 2018, 11:38:40 »
Díky za tipy. Zdá se, že se mi to podařilo nainstalovat pomocí gdebi z těchto souborů:

https://launchpad.net/~mapopa/+archive/ubuntu/ppa/+packages

Musel jsem jen stáhnout libicu55 (v ubuntu 18.04 je verze 60):

https://packages.ubuntu.com/search?keywords=libicu55

Ve firebirdu používáme i události a další funkce a vše funguje OK. Aplikace, php - vše se připojí bez problému.

Díky všem za pomoc.