Prosíme přihlašte se nebo zaregistrujte.

Přihlašte se svým uživatelským jménem a heslem.
Vaše pomoc je stále potřeba!

Novinky: Školení nejen k OS Ubuntu pro širokou veřejnost, více informací zde.

Autor Téma: Bluethoot zapne a hned vypne [Vyřešeno!]  (Přečteno 466 krát)

Kvido

  • Člen
  • **
  • Příspěvků: 222
  • Karma: +4/-0
    • Zobrazit profil
    • phpfusioncz
Bluethoot zapne a hned vypne [Vyřešeno!]
« kdy: 25 Červenec 2018, 12:21:12 »
Ahoj!
Ví někdo o připojení Bluethoot k Ubuntu 16.04?
V nižší 14.04 šel Bluethoot bezvadně (přenos obrázků z mobilu na PC), ale v novější verzi tohle nefunguje, v mobilu hlási "Připojení se nepodařilo". Přitom obrázky z disku PC lze přenést do mobilu.

Chyba se projevuje tak, že, jak je vidět na obrázku, že spopjení je navazáno, avšak vypadne. Na ikonce vpravo nahoře naskočí zámek. Zkoušel jusem ledacos v /etc/bluethoot/main.conf je dole odkomentováno FALSE. Ve /var/lib/bluetooth je slopžka s jinou adresou, než jsou soubory se správnou adresou. Je to příčina? Někde jsem tu četl, že prostě vymazat a ono se to správně obnoví. Mám zkusit? Má nekdo nějaký nápad? Diky mockrát.

P.S. Obrázek, bohužel, nelze přidat, systém píše, že je místo v Přílohách malé.

Kód: [Vybrat]
vivi@vivi:~$ lspci -nnk | grep -iA2 net; lsusb; hciconfig -a; dmesg | egrep -i 'modrá | firma'
02:00.0 Ethernet controller [0200]: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller [10ec:8168] (rev 01)
Subsystem: ASUSTeK Computer Inc. P5B [1043:81aa]
Kernel driver in use: r8169
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 006 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 002: ID 1131:1001 Integrated System Solution Corp. KY-BT100 Bluetooth Adapter
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 002 Device 003: ID 275d:0ba6 
Bus 002 Device 002: ID 1a2c:2124 China Resource Semico Co., Ltd
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
hci0: Type: BR/EDR  Bus: USB
BD Address: 00:11:67:9D:8B:E3  ACL MTU: 1021:8  SCO MTU: 48:10
UP RUNNING PSCAN ISCAN
RX bytes:8275 acl:24 sco:0 events:166 errors:0
TX bytes:2361 acl:24 sco:0 commands:112 errors:0
Features: 0xff 0xfe 0x8d 0x3e 0x88 0x19 0x00 0x00
Packet type: DM1 DM3 DM5 DH1 DH3 DH5 HV1 HV2 HV3
Link policy: RSWITCH HOLD SNIFF
Link mode: SLAVE ACCEPT
Name: 'vivi'
Class: 0x0c0104
Service Classes: Rendering, Capturing
Device Class: Computer, Desktop workstation
HCI Version: 2.0 (0x3)  Revision: 0x2c6
LMP Version: 2.0 (0x3)  Subversion: 0x2c6
Manufacturer: Integrated System Solution Corp. (57)

vivi@vivi:~$ bluetoothctl
[NEW] Controller 00:11:67:9D:8B:E3 vivi [default]
[NEW] Device 00:21:08:B4:2A:ED Nokia 2600classic
[NEW] Device 00:61:88:B4:2A:ED 00-61-88-B4-2A-ED
[bluetooth]#

Po další kontroly to vypadá, že mám nastavgení Bluetooth dobré:

Kód: [Vybrat]
vivi@vivi:~$ bluetoothctl
[NEW] Controller 00:11:67:9D:8B:E3 vivi [default]
[NEW] Device 00:21:08:B4:2A:ED Nokia 2600classic
[NEW] Device 00:61:88:B4:2A:ED 00-61-88-B4-2A-ED
[bluetooth]# scan on
Discovery started
[CHG] Controller 00:11:67:9D:8B:E3 Discovering: yes
[CHG] Device 00:21:08:B4:2A:ED LegacyPairing: yes
[bluetooth]# discoverable on
Changing discoverable on succeeded
[bluetooth]# pair
Missing device address argument
[bluetooth]# trust
Missing device address argument
[bluetooth]# trust 00:61:88:B4:2A:ED
[CHG] Device 00:61:88:B4:2A:ED Trusted: yes
Changing 00:61:88:B4:2A:ED trust succeeded
[bluetooth]# quit
[DEL] Controller 00:11:67:9D:8B:E3 vivi [default]
vivi@vivi:~$
« Poslední změna: 25 Červenec 2018, 17:57:43 od Kvido »
Základní deska: ASUS, Procesor: Dual Core AMD Athlon 64 X2 2100 MHz, Brisbone, 1. HDD na SATA 6M-WDC WD 500.1 GB. 2. HDD 4M-Samsung 190 GB. RAM DDR2 2x, DDR3 1x - 4,2G. Grafika: Gallium 0.4 on ATI RS690. OS: Ubuntu 16.03.04 LTS, 64bit.

Kvido

  • Člen
  • **
  • Příspěvků: 222
  • Karma: +4/-0
    • Zobrazit profil
    • phpfusioncz
Re:Bluethoot zapne a hned vypne
« Odpověď #1 kdy: 25 Červenec 2018, 16:08:16 »
Prostě, Blutooth nefunguje a divné je, že nereaguuje nijak (tedy konečně připojením) ani po tomto:
Kód: [Vybrat]
vivi@vivi:~$ sudo service bluetooth restart
« Poslední změna: 25 Červenec 2018, 16:11:33 od Kvido »
Základní deska: ASUS, Procesor: Dual Core AMD Athlon 64 X2 2100 MHz, Brisbone, 1. HDD na SATA 6M-WDC WD 500.1 GB. 2. HDD 4M-Samsung 190 GB. RAM DDR2 2x, DDR3 1x - 4,2G. Grafika: Gallium 0.4 on ATI RS690. OS: Ubuntu 16.03.04 LTS, 64bit.

Kvido

  • Člen
  • **
  • Příspěvků: 222
  • Karma: +4/-0
    • Zobrazit profil
    • phpfusioncz
Re:Bluethoot zapne a hned vypne
« Odpověď #2 kdy: 25 Červenec 2018, 17:56:38 »
Tak konečně, VYŘEŠENO!!!!!!!!!!!!!!!!
1/ Provedl jsem čištění:
Kód: [Vybrat]
sudo apt-get purge blueman bluez-utils bluez bluetooth
2/ Změnil instalaci do:
Kód: [Vybrat]
apt-get install blueman bluez:i386 bluetooth
3/ Nainstaloval jsem známe balíčky pro Bluetooth:
Kód: [Vybrat]
sudo apt-get install pulseaudio-module-bluetooth* ubuntu-desktop* unity-control-center*
4/ Restartujeme přes T:
Kód: [Vybrat]
sudo service bluetooth restart
A překvápko, na horní liště prohlížeče přibyla druhá modrá větší ikonka Bluetooth! A vše již nyní konečně funguje.!!!!
« Poslední změna: 26 Červenec 2018, 09:32:17 od Kvido »
Základní deska: ASUS, Procesor: Dual Core AMD Athlon 64 X2 2100 MHz, Brisbone, 1. HDD na SATA 6M-WDC WD 500.1 GB. 2. HDD 4M-Samsung 190 GB. RAM DDR2 2x, DDR3 1x - 4,2G. Grafika: Gallium 0.4 on ATI RS690. OS: Ubuntu 16.03.04 LTS, 64bit.