Prosíme přihlašte se nebo zaregistrujte.

Přihlašte se svým uživatelským jménem a heslem.

Autor Téma: Beryl na Ati X1600?  (Přečteno 5786 krát)

MaJJ

  • Návštěvník
  • *
  • Příspěvků: 33
  • Karma: +1/-0
    • Zobrazit profil
Beryl na Ati X1600?
« kdy: 18 Květen 2007, 17:40:24 »
Dobrý den,
pokouším se rozjet Beryl na mém Ubuntu 7.04, už to mám vše nainstalované, jen se nic neděje (ani po restartu, nic).
Podíval jsem se, který Window Manager mám - a nebyl to Beryl, ale Metacity. Když jsem klikl na Beryl, nic se nedělo (Metacity tam zůstalo).
Navíc jsem teď v nějakém návodu pro instalaci Berylu zjistil, že moje grafická karta je nepodporovaná:
http://www.howtoforge.com/ubuntu_feisty_beryl_ati_radeon - trochu zascrollujte

Používám ovladače fglrx ... je tady teda nějaká možnost, jak nějaké akcelerované prostředí s těmi efekty zprovonit?

locki

  • Návštěvník
  • *
  • Příspěvků: 67
  • Karma: +2/-0
    • Zobrazit profil
Beryl na Ati X1600?
« Odpověď #1 kdy: 18 Květen 2007, 19:37:48 »
podle me to mozne neni uz se nejakou dobu pokousim o to same na X1800 GTO
CZFree admin, Ubuntu 7.04, 20x WRT54G,GS,GL http://openwrt.org

MaJJ

  • Návštěvník
  • *
  • Příspěvků: 33
  • Karma: +1/-0
    • Zobrazit profil
Beryl na Ati X1600?
« Odpověď #2 kdy: 18 Květen 2007, 19:47:29 »
aah, ted jsem to rozjel (podle nejakeho navodu jsem neco udelal, mel jsem restartovat, no zkusil jsem neco spustit, JELO TO, ale chybi mi ten horni ten ... vypadlo mi jak se to jmenuje ... s trema tlacitkama vpravo ... urcite vite co mam na mysli :D

a pry je to hodne rozsireny problem takze jdu zjistit jak to spravit ...

pro vas - locki - tady ten tutorial: http://ubuntuguide.org/wiki/Ubuntu:Feisty_cz#How_to_install_Beryl_.28ATI.29

nejdrive jsem jel ten prvni - az po Congratulations! ...
neslo to, a hned odstavec pod tim zacina dalsi navod, myslim s open source ovladacema, a JEDE!

takze hodne stesti :)

MaJJ

  • Návštěvník
  • *
  • Příspěvků: 33
  • Karma: +1/-0
    • Zobrazit profil
Beryl na Ati X1600?
« Odpověď #3 kdy: 18 Květen 2007, 20:24:03 »
eh, tak omyl ...

tim ze jsem podle toho navodu neco udelal, se mi rozjel compiz (ktery uz je ve feisty, jen hazel chybovou hlasku) ... sakra, tak asi mazu beryl a ten compiz si nejak donastavim ... nebo co s tim?

locki

  • Návštěvník
  • *
  • Příspěvků: 67
  • Karma: +2/-0
    • Zobrazit profil
Beryl na Ati X1600?
« Odpověď #4 kdy: 19 Květen 2007, 11:06:28 »
proste to nejde ovladace od ati to neumi a ty opensource ovladace neumi nove karty ...  :(
CZFree admin, Ubuntu 7.04, 20x WRT54G,GS,GL http://openwrt.org

Roman "Schmaker" Šmakal

  • Závislák
  • ****
  • Příspěvků: 1205
  • Karma: +59/-10
    • Zobrazit profil
Beryl na Ati X1600?
« Odpověď #5 kdy: 19 Květen 2007, 11:08:01 »
fglrx neumí AIGLX... XGL by umět měly... Jen to chce vědět,jak ho tam dát....
Linux Gaming Clan leader
Konference na linuxclan@chat.linjab.net

jurda64bit

  • Návštěvník
  • *
  • Příspěvků: 21
  • Karma: +0/-0
    • Zobrazit profil
Beryl na Ati X1600?
« Odpověď #6 kdy: 20 Květen 2007, 16:39:43 »
Citace: locki
podle me to mozne neni uz se nejakou dobu pokousim o to same na X1800 GTO
:) taky

Jakub Lucký

  • Závislák
  • ****
  • Příspěvků: 3433
  • Karma: +58/-10
    • Zobrazit profil
    • Jakub Lucký
Beryl na Ati X1600?
« Odpověď #7 kdy: 20 Květen 2007, 16:47:38 »
Rozjet by to jít mělo...
fgrlx + XGL...
fglrx (proprietární ovladač od Ati) už X1800 imho podporuje
FAQ-Často kladené otázky   Návody(wiki)     
Jakub@Life:~$ Ubuntu změnilo váš život, přejete si změny uložit?(Y/N)?
Děkujeme, že nekrmíte trolly Blogísek  :wq

locki

  • Návštěvník
  • *
  • Příspěvků: 67
  • Karma: +2/-0
    • Zobrazit profil
Beryl na Ati X1600?
« Odpověď #8 kdy: 20 Květen 2007, 17:00:01 »
Citace: jurda64bit
Citace: locki
podle me to mozne neni uz se nejakou dobu pokousim o to same na X1800 GTO
:) taky
ATI bratre :) pokud s tim neco neudela ati tak jsme v kadi ni ?

uz se tesim na ten krasny pocit az to na prvni pokus nainstaluji at zo budou drivery umet ...
CZFree admin, Ubuntu 7.04, 20x WRT54G,GS,GL http://openwrt.org

MaJJ

  • Návštěvník
  • *
  • Příspěvků: 33
  • Karma: +1/-0
    • Zobrazit profil
Beryl na Ati X1600?
« Odpověď #9 kdy: 28 Květen 2007, 12:48:47 »
TO JOOOO TO JOOO TO JOOOOO
lidi ja to dal - beryl mi na moji "nepodporovane" atine funguje naprosto sqele!

hodim jen odkaz na dva navody ... prvni je instalace fglrx - to jsem delal kvuli 3d akceleraci
a ten druhy je beryl na fglrx ...

https://help.ubuntu.com/community/BinaryDriverHowto/ATI
http://wiki.beryl-project.org/wiki/Install_Beryl_on_Ubuntu_Feisty_with_XGL

hodne stesti ;)

macu

  • Závislák
  • ****
  • Příspěvků: 1148
  • Karma: +105/-3
    • Zobrazit profil
Beryl na Ati X1600?
« Odpověď #10 kdy: 31 Květen 2007, 18:41:53 »
tak jsem zkoušel instalaci fglrx, instalace proběhne dobře ale po restartu mi to hodí bohužel hlášku: direct rendering: No
rekonfigurace xorg.conf bohužel dne návodu https://help.ubuntu.com/ubuntu/desktopguide/C/hardware.html
jaksi nepomohla (mám ATI X1600) Nevíte někdo, jak na to?
PC: Intel i5-6600K, 16 GB DDR4 RAM, Intel 530HD, ASUS Z170 Pro Gaming, , 2TB Toshiba HDD Sata III DT01ACA200, Ubuntu 19.10 64bit, Gnome Shell 3.34
Ntb: Toshiba L850-U12 - Intel i3 , 8 GB DDR3 RAM, Ubuntu 19.10 64bit, Gnome Shell 3.34

MaJJ

  • Návštěvník
  • *
  • Příspěvků: 33
  • Karma: +1/-0
    • Zobrazit profil
Beryl na Ati X1600?
« Odpověď #11 kdy: 31 Květen 2007, 19:48:51 »
mám tu samou co ty, ale ten můj první odkaz jak jsem podle toho návodu jel, tak mi pomohl ... nevím no ... a předtím vůbec nic nepomohlo - prostě až tohle

plysovej_kaktus

  • Návštěvník
  • *
  • Příspěvků: 4
  • Karma: +0/-0
    • Zobrazit profil
Beryl na Ati X1600?
« Odpověď #12 kdy: 01 Červen 2007, 14:51:46 »
mam sice Debian, ale instalace fglrx by mela byt pro vsechno stejna. Fglrx jsem instaloval asi milionkrat a slo jenom o to stahnout official driver od ati ( fungovalo mi to na verzi 8.34, ted bezim na vesa, nejak se mi to rozhasilo pod 8.36 ) na jadre 2.6.20+ bylo treba doinstalovat patch ( patch -p6 < [cesta_k_patchi]/patch v adresari s fglrx, defaultne /lib/modules/fglrx/build_mod ), jelikoz nemam k dispozici ftepko, patch najdete pod timhle textem. No a potom v tom adresari ./make.sh && cd .. && ./make_install. Konfigurace xorg.conf spociva v tom, ze v section device u grafiky nastavite Driver "fglrx" .. tot vse.

Tady je ten patch, v novejsi verzi ovladace uz neni treba, ale nejak mi nebeha:

--- ATi/common/lib/modules/fglrx/build_mod/firegl_public.c   2006-12-18 10:58:15.000000000 -0500
+++ common/lib/modules/fglrx/build_mod/firegl_public.c   2006-12-18 11:14:04.000000000 -0500
@@ -181,6 +181,70 @@
 int errno;
 #endif // __ia64__
 
+#if defined(__i386__)
+#define __syscall_return(type, res) \
+do { \
+        if ((unsigned long)(res) >= (unsigned long)(-(128 + 1))) { \
+                errno = -(res); \
+                res = -1; \
+        } \
+        return (type) (res); \
+} while (0)
+#define _syscall2(type,name,type1,arg1,type2,arg2) \
+type name(type1 arg1,type2 arg2) \
+{ \
+long __res; \
+__asm__ volatile ("push %%ebx ; movl %2,%%ebx ; int $0x80 ; pop %%ebx" \
+        : "=a" (__res) \
+        : "0" (__NR_##name),"ri" ((long)(arg1)),"c" ((long)(arg2)) \
+        : "memory"); \
+__syscall_return(type,__res); \
+}
+
+#define _syscall3(type,name,type1,arg1,type2,arg2,type3,arg3) \
+type name(type1 arg1,type2 arg2,type3 arg3) \
+{ \
+long __res; \
+__asm__ volatile ("push %%ebx ; movl %2,%%ebx ; int $0x80 ; pop %%ebx" \
+        : "=a" (__res) \
+        : "0" (__NR_##name),"ri" ((long)(arg1)),"c" ((long)(arg2)), \
+                  "d" ((long)(arg3)) : "memory"); \
+__syscall_return(type,__res); \
+}
+#elif defined(__x86_64__)
+#define __syscall_clobber "r11","rcx","memory"
+#define __syscall "syscall"
+
+#define __syscall_return(type, res) \
+do { \
+        if ((unsigned long)(res) >= (unsigned long)(-127)) { \
+                errno = -(res); \
+                res = -1; \
+        } \
+        return (type) (res); \
+} while (0)
+#define _syscall2(type,name,type1,arg1,type2,arg2) \
+type name(type1 arg1,type2 arg2) \
+{ \
+long __res; \
+__asm__ volatile (__syscall \
+        : "=a" (__res) \
+        : "0" (__NR_##name),"D" ((long)(arg1)),"S" ((long)(arg2)) : __syscall_clobber ); \
+__syscall_return(type,__res); \
+}
+
+#define _syscall3(type,name,type1,arg1,type2,arg2,type3,arg3) \
+type name(type1 arg1,type2 arg2,type3 arg3) \
+{ \
+long __res; \
+__asm__ volatile (__syscall \
+        : "=a" (__res) \
+        : "0" (__NR_##name),"D" ((long)(arg1)),"S" ((long)(arg2)), \
+                  "d" ((long)(arg3)) : __syscall_clobber); \
+__syscall_return(type,__res); \
+}
+#endif
+
 // int mlock(const void *addr, size_t len);
 _syscall2(int, mlock, const void *, addr, size_t, len )
 // int munlock(const void *addr, size_t len);
--- ATi/common/lib/modules/fglrx/build_mod/firegl_public.c   2007-02-20 19:23:07.000000000 +0100
+++ ATi/common/lib/modules/fglrx/build_mod/firegl_public.c.new   2007-02-21 23:36:19.000000000 +0100
@@ -5265,7 +5265,7 @@
     kasThread_t* thread_obj = (kasThread_t*)hThread;
     init_MUTEX(&(thread_obj->sleep_finished));
     init_waitqueue_head(&(thread_obj->wq_head));
-    INIT_WORK(&(thread_obj->work), routine, pcontext);
+    INIT_WORK(&(thread_obj->work), routine);
     schedule_work(&(thread_obj->work));
     return 1;
Systemu nikdy neskodi, kdyz se jeho majitel opije do nemoty a prihlasi se jako root. Den nato po par hodinach usilovneho obnovovani vzdy vypada jeste novejsi nez predtim :)

plysovej_kaktus

  • Návštěvník
  • *
  • Příspěvků: 4
  • Karma: +0/-0
    • Zobrazit profil
Beryl na Ati X1600?
« Odpověď #13 kdy: 01 Červen 2007, 14:54:33 »
btw.. moje konfigurace je Asus S96J s ATI radeon mobility X1600. Kernel 2.6.20.6, ktery blbne, ale na 2.6.20.1 to slapalo bezvadne, Asi budu downgradovat.
Systemu nikdy neskodi, kdyz se jeho majitel opije do nemoty a prihlasi se jako root. Den nato po par hodinach usilovneho obnovovani vzdy vypada jeste novejsi nez predtim :)

plysovej_kaktus

  • Návštěvník
  • *
  • Příspěvků: 4
  • Karma: +0/-0
    • Zobrazit profil
Beryl na Ati X1600?
« Odpověď #14 kdy: 01 Červen 2007, 15:02:51 »
Dalsi krok byl v nainstalovani XGL a beryla. Jde to celkem v poklidu az na fakt, ze windows decorator ( takove ty blbince nahore a _ [] X v pravo, o kterych jste mluvili ) proste spadnul pokazde, kdyz jsem ho spustil. Composite proste musi byt disabled a i kdyz akcelerace normalne funguje, po spusteni XGL to proste bezi na software. I tak je to dost rychle, ale pokud bezi beryl ci compiz na software rendering, pada. Nebo spis PADA. Dalsi problem by mohl byt ten, ze mate akcelerovane prostredi se vsim vsudy ( kostka se otaci a tak ), akorat vsechno na co mohou byt namapovane textury je ciste bile. Proste nevidite nic. No reseni je v tom, ze spustite pouze XGL a v nem proste spustite v konzoli

beryl-xgl --use-copy

 Funguje to skvele a PADA. Uz se tesim az ATI zakomponuje composite do jadra, do te doby se s tim budete rok stvat a potom to 2x spustite, 2x vam to do 10 minut spadne a potom si reknete, ze pohyblivou kostku a wobbly wokynka ukazete mozna tak kamaradovi vychloubajicim se 3D nahledem reknete wow ve vistach.
Systemu nikdy neskodi, kdyz se jeho majitel opije do nemoty a prihlasi se jako root. Den nato po par hodinach usilovneho obnovovani vzdy vypada jeste novejsi nez predtim :)

Jakub Lucký

  • Závislák
  • ****
  • Příspěvků: 3433
  • Karma: +58/-10
    • Zobrazit profil
    • Jakub Lucký
Beryl na Ati X1600?
« Odpověď #15 kdy: 01 Červen 2007, 16:40:44 »
Beryl je verze 0.2, což je poměrně mladý software... A vzhledem ke stavu binárních ovladačů v Linuxu se snaží jak jen to jde...
FAQ-Často kladené otázky   Návody(wiki)     
Jakub@Life:~$ Ubuntu změnilo váš život, přejete si změny uložit?(Y/N)?
Děkujeme, že nekrmíte trolly Blogísek  :wq

MaJJ

  • Návštěvník
  • *
  • Příspěvků: 33
  • Karma: +1/-0
    • Zobrazit profil
Beryl na Ati X1600?
« Odpověď #16 kdy: 01 Červen 2007, 21:46:45 »
to je fakt :) a lidi z nej chteji vytriskat co to jde ...

no ja mam s berylem jednu (vlastne odnedavna dve) chybicku/y ...

prvni je ze jak se mi nacita okno tak zacne (krome zadaneho efektu) chvili blikat ...

a druha je ze jak neco spustim a ma vyskocit okno nebo dialog, tak se jakoby minimalizuje - treba ve firefoxu dejmetomu kdyz chci zazalozkovat stranku ... tak kliknu na tu polozku v menu, a pak musim kliknout nekam do prostoru firefoxu aby se to vzpamatovalo a hodilo se do popredi (nevim jestli to budete chapat ^^ )

gusty32

  • Návštěvník
  • *
  • Příspěvků: 66
  • Karma: +0/-0
    • Zobrazit profil
    • Break Monopoly
Beryl na Ati X1600?
« Odpověď #17 kdy: 02 Červen 2007, 12:51:32 »
Mam X1550 je jsem na tom stejne - nejde to.

locki

  • Návštěvník
  • *
  • Příspěvků: 67
  • Karma: +2/-0
    • Zobrazit profil
Beryl na Ati X1600?
« Odpověď #18 kdy: 05 Červen 2007, 17:01:36 »
by me zajimalo jestli neco ty nove drivery od ati resi 8.37.6

https://a248.e.akamai.net/f/674/9206/0/www2.ati.com/drivers/linux/linux_8.37.6.html
CZFree admin, Ubuntu 7.04, 20x WRT54G,GS,GL http://openwrt.org

MaJJ

  • Návštěvník
  • *
  • Příspěvků: 33
  • Karma: +1/-0
    • Zobrazit profil
Beryl na Ati X1600?
« Odpověď #19 kdy: 06 Červen 2007, 13:30:07 »
no ... ja jsem to zprovnoznil, opakuju tyhle dva linky:
https://help.ubuntu.com/community/BinaryDriverHowto/ATI
http://wiki.beryl-project.org/wiki/Inst … y_with_XGL

v tom prvnim - postupujte jak pro 7.04 (jen apt-get) tak pro 6.10 - jako kdyby se vam to nerozjelo ... me to jede bez problemu, nevim proc :) a ten beryl - jen mi pri otevreni okna blikalo okno, jinak je to vsechno plynule atd. - vpohode.
toz nevim :) AIGLX je prozatim na nic ...
a ty propietary nove od ati - muzes to vyzkouset :)

snup

  • Návštěvník
  • *
  • Příspěvků: 41
  • Karma: +0/-0
    • Zobrazit profil
Beryl na Ati X1600?
« Odpověď #20 kdy: 16 Červen 2007, 13:02:20 »
Tak ja už beryl na X1800GTO rozjel a jede to krásně , xgl+beryl .Ale na Archlinuxu takže nevím jak ubuntu ;)
PC: P5WD2-E Premium , Pentium D805, ATI X1800GTO , 1.5GB RAM , Seagate 250GB , LG-4081B , LC6560T , Archlinux Duke ,Ubuntu mě sklamalo ale Arch ! to je síla
Jabber : snup@jabber.cz  Moje stránka :)