Prosíme přihlašte se nebo zaregistrujte.

Přihlašte se svým uživatelským jménem a heslem.

Autor Téma: Problem s MPlayer  (Přečteno 2761 krát)

jvysocan

  • Návštěvník
  • *
  • Příspěvků: 58
    • Zobrazit profil
Problem s MPlayer
« kdy: 29 Červen 2007, 13:05:42 »
Uz som to skusal instalovat viackrat a nedari sa mi. Proste skusam to cez Adept nainstalovat a vsetko prebehne OK aj adresar MPlayer v etc a v usr/share je zo vsetkym, len mi neide. Mam Kubuntu 7.04 a v menu- multimedia ho ani vobec po instalacii nenajdem. Pritom mi nevyhodi ziadnu chybu pri instalacii. V Edgym mi isiel v pohode.

Skeletonix

  • Závislák
  • ****
  • Příspěvků: 1258
    • Zobrazit profil
Problem s MPlayer
« Odpověď #1 kdy: 29 Červen 2007, 15:14:10 »
co znamená nejde ... co se objeví pokud zadáte v terminálu mplayer ?

jvysocan

  • Návštěvník
  • *
  • Příspěvků: 58
    • Zobrazit profil
Problem s MPlayer
« Odpověď #2 kdy: 29 Červen 2007, 15:26:22 »
Citace: Skeletonix
co znamená nejde ... co se objeví pokud zadáte v terminálu mplayer ?
:~$ mplayer
MPlayer 2:1.0~rc1-0ubuntu9.1 (C) 2000-2006 MPlayer Team
CPU: AMD Athlon(tm) XP 2400+ (Family: 6, Model: 8, Stepping: 1)
CPUflags:  MMX: 1 MMX2: 1 3DNow: 1 3DNow2: 1 SSE: 1 SSE2: 0
Compiled with runtime CPU detection.
Usage:   mplayer [options] [url|path/]filename

Basic options: (complete list in the man page)
 -vo        select video output driver ('-vo help' for a list)
 -ao        select audio output driver ('-ao help' for a list)
 vcd://  play (S)VCD (Super Video CD) track (raw device, no mount)
 dvd://  play DVD title from device instead of plain file
 -alang/-slang    select DVD audio/subtitle language (by 2-char country code)
 -ss   seek to given (seconds or hh:mm:ss) position
 -nosound         do not play sound
 -fs              fullscreen playback (or -vm, -zoom, details in the man page)
 -x -y    set display resolution (for use with -vm or -zoom)
 -sub      specify subtitle file to use (also see -subfps, -subdelay)
 -playlist specify playlist file
 -vid x -aid y    select video (x) and audio (y) stream to play
 -fps x -srate y  change video (x fps) and audio (y Hz) rate
 -pp    enable postprocessing filter (details in the man page)
 -framedrop       enable frame dropping (for slow machines)

Basic keys: (complete list in the man page, also check input.conf)
 <-  or  ->       seek backward/forward 10 seconds
 down or up       seek backward/forward  1 minute
 pgdown or pgup   seek backward/forward 10 minutes
 < or >           step backward/forward in playlist
 p or SPACE       pause movie (press any key to continue)
 q or ESC         stop playing and quit program
 + or -           adjust audio delay by +/- 0.1 second
 o                cycle OSD mode:  none / seekbar / seekbar + timer
 * or /           increase or decrease PCM volume
 x or z           adjust subtitle delay by +/- 0.1 second
 r or t           adjust subtitle position up/down, also see -vf expand

 * * * SEE THE MAN PAGE FOR DETAILS, FURTHER (ADVANCED) OPTIONS AND KEYS * * *

DuckD

  • Stálý člen
  • ***
  • Příspěvků: 878
  • Open Srdcař
    • Zobrazit profil
    • www.duckd.cz
Problem s MPlayer
« Odpověď #3 kdy: 29 Červen 2007, 15:43:28 »
zkus do terminálu zadat mplayer a nějakej film co máš na disku:
mplayer soubor.wmv
8) Lidé žijí v souborech. ===>> LINUXTERO <<=== Pravidelná dávka tvého linuxtera!

jvysocan

  • Návštěvník
  • *
  • Příspěvků: 58
    • Zobrazit profil
Problem s MPlayer
« Odpověď #4 kdy: 29 Červen 2007, 16:14:36 »
Citace: duckd
zkus do terminálu zadat mplayer a nějakej film co máš na disku:
mplayer soubor.wmv
Ide to, ale zo strasnym zvukom. Proste len to strasne chrapci a zvuk neide.

Skeletonix

  • Závislák
  • ****
  • Příspěvků: 1258
    • Zobrazit profil
Problem s MPlayer
« Odpověď #5 kdy: 29 Červen 2007, 16:25:04 »
1. zkus si pročíst toto: http://wiki.ubuntu.cz/MPlayer?highlight=%28mplayer%29
2. zkus příkaz gmplayer .. třeba ti bude do začátku sympatičtější
3. asi máš špatně nastavený audio výstup zkus přidat -ao=alsa

jvysocan

  • Návštěvník
  • *
  • Příspěvků: 58
    • Zobrazit profil
Problem s MPlayer
« Odpověď #6 kdy: 29 Červen 2007, 17:05:25 »
Citace: Skeletonix
1. zkus si pročíst toto: http://wiki.ubuntu.cz/MPlayer?highlight=%28mplayer%29
2. zkus příkaz gmplayer .. třeba ti bude do začátku sympatičtější
3. asi máš špatně nastavený audio výstup zkus přidat -ao=alsa
Ten navod som uz cital, ale nepomohol. Co myslis, pridat ao=alsa. Vsak ja to mam. Aj ked spustim GMPlayer, tak je nastaveny alsa ako audio vystup.

Skeletonix

  • Závislák
  • ****
  • Příspěvků: 1258
    • Zobrazit profil
Problem s MPlayer
« Odpověď #7 kdy: 29 Červen 2007, 18:32:16 »
tak pokud nepomůže ao=alsa skus ao=esd (v gmplayer jen změn alsa na esd a restartuj pro sichr gmplayer)(pokud máš gnome) ... mplayer ./film.avi -ao=esd

... skus zjistit jestli to blne jen u toho wma či to dělá u všech formátů.

jvysocan

  • Návštěvník
  • *
  • Příspěvků: 58
    • Zobrazit profil
Problem s MPlayer
« Odpověď #8 kdy: 29 Červen 2007, 18:49:04 »
Citace: Skeletonix
tak pokud nepomůže ao=alsa skus ao=esd (v gmplayer jen změn alsa na esd a restartuj pro sichr gmplayer)(pokud máš gnome) ... mplayer ./film.avi -ao=esd

... skus zjistit jestli to blne jen u toho wma či to dělá u všech formátů.
Robi to u vsetkych filmoch a mam Kubuntu, co som uz pisal. Takze esd vobec nepojde.

Skeletonix

  • Závislák
  • ****
  • Příspěvků: 1258
    • Zobrazit profil
Problem s MPlayer
« Odpověď #9 kdy: 29 Červen 2007, 19:24:09 »
mno tak prozkoušej vše co je v nabídce ..oss, "to co ma kubuntu (budeto začínat na k ;),  ..., ...,

  a zkus také nastavit v gmplayeru audio kodek na FFmpeg. Snad něco zabere.

jvysocan

  • Návštěvník
  • *
  • Příspěvků: 58
    • Zobrazit profil
Problem s MPlayer
« Odpověď #10 kdy: 29 Červen 2007, 22:04:30 »
Citace: Skeletonix
mno tak prozkoušej vše co je v nabídce ..oss, "to co ma kubuntu (budeto začínat na k ;),  ..., ...,

  a zkus také nastavit v gmplayeru audio kodek na FFmpeg. Snad něco zabere.
Ten codec zabral.