Prosíme přihlašte se nebo zaregistrujte.

Přihlašte se svým uživatelským jménem a heslem.

Autor Téma: /home - právo měnit obsah  (Přečteno 5492 krát)

Bufik

  • Návštěvník
  • *
  • Příspěvků: 58
  • Karma: +0/-0
    • Zobrazit profil
/home - právo měnit obsah
« kdy: 28 Srpen 2007, 00:39:15 »
Tak ve Winech jsem si do /home/bufik udělal pár složek a naházel do nich nějaký obsah. Teď bych s ním v Linuxech potřeboval hejbat tzn. přesouvat a mazat, ale píše mi to, že na to nemám Permission > povolení (některý věci jsou tam v angličtině, proč? To nevím.) Kde ho mám získat?
Úspěch není finální, selhání je fatální.

Sakal77

  • Návštěvník
  • *
  • Příspěvků: 51
  • Karma: +2/-2
    • Zobrazit profil
/home - právo měnit obsah
« Odpověď #1 kdy: 28 Srpen 2007, 00:55:13 »
Jak jsi to tam přes ty Windowsy vytvořil? Přes sambu, resp. sdílení na síti? Nebo pomocí nějakého programu přistupoval přímo na linuxový oddíl? Ať už tak nebo tak, pravděpodobně tam ten program přistupoval pod nějakým jménem, jiným než "bufik", který je majitelem cílového adresáře /home/bufik. Tím pádem potom jako uživatel bufik v linuxu nemáš právo něco dělat se soubory, které vytvořil a tudíž je vlastní uživatel jiný, asi nobody nebo tak někdo.
Zkus použít v tvém domovském adresáři příkaz "sudo chown -R bufik *"
Tím by se měl veškerý obsah tvého adresáře i podadresářů stát tvým majetkem :D

Bufik

  • Návštěvník
  • *
  • Příspěvků: 58
  • Karma: +0/-0
    • Zobrazit profil
/home - právo měnit obsah
« Odpověď #2 kdy: 28 Srpen 2007, 01:00:17 »
EXT2IFS a uživatel Petr to asi bude tím no....
A kam mám napsat ten příkaz???
A to napořád nebo budu muset vždycky, když něco ve Windowsech udělám v tom adresáři dát zase ten příkaz?
Úspěch není finální, selhání je fatální.

Sakal77

  • Návštěvník
  • *
  • Příspěvků: 51
  • Karma: +2/-2
    • Zobrazit profil
/home - právo měnit obsah
« Odpověď #3 kdy: 28 Srpen 2007, 01:31:28 »
No pokud to bude pořád dělat ten Petr, tak ano. Pokud jde nastavit v EXT2IFS nejen uživatele, ale i masku pro vytváření souborů na linuxovém oddíle, pak nastav 777 a budeš je moci číst pod Linuxem jako Bufik bez příkazu chown.  Ale pokud jde nastavit uživatel, pak si nastav Bufik a máš to vyřešené. EXT2IFS neznám, tak nevím, jaké má možnosti.
Pokud toto nejde, budeš muset vždy po kopírování, zadat příkaz chown v Linuxu. Ten příkaz musíš napsat v terminálu, ve svém domovském adresáři. Tzn. pro jistotu ještě před ním zadat příkaz "cd".
Mimochodem, raději bych ti doporučil používat chown i v případě toho, že EXT2IFS má možnost nastavení masky. Budou to pak totiž opravdu tvoje soubory a ne "nějakého Petra" :)

Bufik

  • Návštěvník
  • *
  • Příspěvků: 58
  • Karma: +0/-0
    • Zobrazit profil
/home - právo měnit obsah
« Odpověď #4 kdy: 28 Srpen 2007, 02:19:08 »
Ta možnost tu bohužel není :o
Asi jsem měl měl při migrování souborů vzít z Winů uživatele Petr. Nebo by šel na wine udělat uživatel Bufik, kterej kdyby nějaký ty soubory vytvářel v Linuxech už bych nemusel zadávat ten příkaz? Anebo vy znáte nějakej program kde se tohle nastavit dá?
Úspěch není finální, selhání je fatální.

Sakal77

  • Návštěvník
  • *
  • Příspěvků: 51
  • Karma: +2/-2
    • Zobrazit profil
/home - právo měnit obsah
« Odpověď #5 kdy: 28 Srpen 2007, 09:05:40 »
Nebere náhodou EXT2IFS jméno uživatele z Windows? Pod jakým uživatelem jsi ve Windows? Jestli pod "Petr", tak je to jasné. Zkus si založit ve Win uživatele "bufik" a nakopíruj si něco na linuxový oddíl. V linuxu si potom zkontroluj, pod jakým uživatelem tam vidíš jako vlastníka těchto nakopírovaných souborů. Třeba se to dá vyřešit i takto, relativně jednoduše.

PS: Pokud jsi tím "wine" myslel windows, tak jsem teď vlastně zkopíroval tvou myšlenku, ale pokud jsi opravdu myslel "wine" (programové prostředí pro emulaci windows pod linuxem), tak se bavíme jeden o koze a druhý o voze.

qUAKER

  • Host
/home - právo měnit obsah
« Odpověď #6 kdy: 28 Srpen 2007, 09:47:18 »
nebere. soubory zkopírované přes ext2ifs vlastní root.

Bufik

  • Návštěvník
  • *
  • Příspěvků: 58
  • Karma: +0/-0
    • Zobrazit profil
/home - právo měnit obsah
« Odpověď #7 kdy: 28 Srpen 2007, 14:42:46 »
Citace: qUAKER
nebere. soubory zkopírované přes ext2ifs vlastní root.
A jak by to šlo udělat teda abych nemusel pokaždý zadávat ten PŘÍKAZ? NĚKDE JSEM SLYŠEL JE POWECOMMANDER S NĚJAKÝM PLUGINEM NEBO CO...
Úspěch není finální, selhání je fatální.

Pavel Půlpán

  • Závislák
  • ****
  • Příspěvků: 4757
  • Karma: +324/-47
    • Zobrazit profil
    • EIX.cz
/home - právo měnit obsah
« Odpověď #8 kdy: 28 Srpen 2007, 17:24:49 »
Kód: [Vybrat]
chown bufik -R /home/bufik

Bufik

  • Návštěvník
  • *
  • Příspěvků: 58
  • Karma: +0/-0
    • Zobrazit profil
/home - právo měnit obsah
« Odpověď #9 kdy: 28 Srpen 2007, 21:20:27 »
A šlo by nastavit to jako trvalej příkaz jako třeba při každým spuštění???
Úspěch není finální, selhání je fatální.

nettezzaumana

  • Host
/home - právo měnit obsah
« Odpověď #10 kdy: 28 Srpen 2007, 21:34:19 »
cron ! napriklad /etc/cron.hourly..
nebo uplne jednoduchy skriprtik:

Kód: [Vybrat]
#!/bin/bash
while :; do
    find /home/bufik | grep -v '^/home/bufik/\..*' | sed 's/^/"/;s/$/"/' | xargs chown bufik
    sleep 1m
done
coz je sice hloupe, nesikovne a opravdu presprilis velkorazni, ale bude to fungovat.. pokud na tebe bude chtit byt nekdo hodnej, jiste ti vymysli nejakou lepsi funkci, zalozenou treba na hashovani obsahu adresare apod..

ps. strc to do nejakeho souboru jako root, umisti do /etc/init.d/, napis v konzoli 'apt-get install rcconf', spust rcconf a jednoduse zaskrtni tenhle skript (bude se jmenovat pod jakym jmenem ho ulozis).. ps a jeste predtim mu udel prikazem 'chmod +x ' prava na spousteni..

enjoy!

Bufik

  • Návštěvník
  • *
  • Příspěvků: 58
  • Karma: +0/-0
    • Zobrazit profil
/home - právo měnit obsah
« Odpověď #11 kdy: 28 Srpen 2007, 21:39:59 »
Tak to jsem nepochopil... Musíš mi to vysvětlit nějak podrobnějc co kam mám dát a tak, protože linux mám teprve pár dní a tohle je na mně moc...
Úspěch není finální, selhání je fatální.

nettezzaumana

  • Host
/home - právo měnit obsah
« Odpověď #12 kdy: 28 Srpen 2007, 21:52:07 »
text v ramecku "Code" (bez "Code:") zkopiruj do prazdneho souboru, ktery nejak pojmenuj (treba hlidej_mi_home.sh) a nekde uloz.
otevri si terminal a prikazem cd se do adresare, kde mas ulozeny tento soubor. Potom se prihlas jako root a soubor zkopiruj do adresare /etc/init.d a prirad mu prava na spusteni. Nainstaluj rcconf a spoustej skriptik pri startu..

Predpokladejme, ze si soubor vytvoris na plose, potom udelej nasledujici (coz jsou vsechny vyse popsane kroky, kdyz to udelas, nemuzes nic zkazit..):

> cd ~/Desktop
> sudo -i
> chmod +x jmeno_tveho_souboru
> mv jmeno_tveho_souboru /etc/init.d
> apt-get install rcconf
> rcconf     #az ti nastartuje, zaskrtnes jmeno_tveho_souboru, tabulatorem se prepnes na ok a zmacknes enter..
> /etc/init.d/jmeno_tveho_souboru & # nemusis, tim si ho spustis hned, jinak se spusti az po rebootu
> exit
> exit

su v ubuntu nefunguje!

Bufik

  • Návštěvník
  • *
  • Příspěvků: 58
  • Karma: +0/-0
    • Zobrazit profil
/home - právo měnit obsah
« Odpověď #13 kdy: 28 Srpen 2007, 22:29:17 »
A když to udělám takhle bude to fungovat?


> cd ~/home/bufik/jmeno_meho_souboru.sh


A to exit je tam 2x proč???
Úspěch není finální, selhání je fatální.

nettezzaumana

  • Host
/home - právo měnit obsah
« Odpověď #14 kdy: 28 Srpen 2007, 22:43:27 »
ne, nebude.. Bufiku nezlob me! kdyz to udelas presne jak jsem napsal, tak to bude fungovat!
ps. prvni exit je tam abys jsi se odhlasil z roota (su te prihlasilo jako root) a druhym si zavres konzoli, protoze se odhlasis jako uzivatel bufik

Bufik

  • Návštěvník
  • *
  • Příspěvků: 58
  • Karma: +0/-0
    • Zobrazit profil
/home - právo měnit obsah
« Odpověď #15 kdy: 28 Srpen 2007, 22:49:10 »
Ale mně to bude hyzdit plochu a to já nechciiii :)
Můžu to teda potom smazat az tyhlety úkony udělám?
Úspěch není finální, selhání je fatální.

nettezzaumana

  • Host
/home - právo měnit obsah
« Odpověď #16 kdy: 28 Srpen 2007, 22:53:35 »
bufiku! ksakru. mv znamena move! v mem bodu 4 si vec natrvalo odstranis z plochy, pac si ji presunes do /etc/init.d !!!! nezlob me uz

nettezzaumana

  • Host
/home - právo měnit obsah
« Odpověď #17 kdy: 28 Srpen 2007, 22:55:13 »
ps. na prvnim radku toho souboru musi byt: "#!/bin/bash" a posledni radek musi byt prazdny, tzn. na predposlednim bude: "done"

Bufik

  • Návštěvník
  • *
  • Příspěvků: 58
  • Karma: +0/-0
    • Zobrazit profil
/home - právo měnit obsah
« Odpověď #18 kdy: 28 Srpen 2007, 23:03:08 »
Takže tak?

Kód: [Vybrat]
_____________________________________________
#!/bin/bash
while :; do
    chown -R buffik /home/buffik/*
    sleep 1m
done

_____________________________________________
Úspěch není finální, selhání je fatální.

nettezzaumana

  • Host
/home - právo měnit obsah
« Odpověď #19 kdy: 28 Srpen 2007, 23:05:18 »
k tomuto tematu za me posledni prispevek: ANO! YES! JA! DA! SI!

ps. precti si to poradne: jestli nejsi "buffik" ale "bufik" nebo "Bufik", potazmo "BUFIK"  tak to nebude fungovat!

Bufik

  • Návštěvník
  • *
  • Příspěvků: 58
  • Karma: +0/-0
    • Zobrazit profil
/home - právo měnit obsah
« Odpověď #20 kdy: 29 Srpen 2007, 00:41:58 »
příkaz sudo -i hlásí chybu:

Usage: command-not-found [options] command-not-found: error: no such option: -ibash: -i: command not found
Úspěch není finální, selhání je fatální.

nettezzaumana

  • Host
/home - právo měnit obsah
« Odpověď #21 kdy: 29 Srpen 2007, 14:15:28 »
sorry -- zdejsi retardovani a drzi admini mi zmenili v mem navodu pro tebe prikaz "su", na "sudo -i"  .. to je konec!
potrebujes si jeste v klikatkach otevrit zalozku system>sprava>Uzivatele a Skupiny>root>Vlastnosti a nastav mu nejake heslo a pak to bude fungovat!

Citace
ps. pro admina ktery edituje primo prispevky:
Citace: drzy_admin
su v ubuntu nefunguje!
co to blabolis? mas se jeste opravdu co ucit!
ps a zkontroluj si jak se opravdu jmenujes, v mem skriptu je buffik se dvema "f" a malym "b" !
pps. a bude fungovat to "su", ne "sudo -i"

nettezzaumana

  • Host
/home - právo měnit obsah
« Odpověď #22 kdy: 29 Srpen 2007, 15:10:52 »
ps. a pry pote co zmenis heslo pro roota, nebude fungovat sudo.. v ubuntu je naprosto prvni vec co delam po instalaci prave ona zmena hesla pro roota.. to je klasicky unixovy model. prikaz sudo nepouzivam, nevim jak je to s nim v ubuntu

Jakub Lucký

  • Závislák
  • ****
  • Příspěvků: 3433
  • Karma: +58/-10
    • Zobrazit profil
    • Jakub Lucký
/home - právo měnit obsah
« Odpověď #23 kdy: 29 Srpen 2007, 15:13:15 »
Citace: nettezzaumana
sorry -- zdejsi retardovani a drzi admini mi zmenili v mem navodu pro tebe prikaz "su", na "sudo -i"  .. to je konec!
potrebujes si jeste v klikatkach otevrit zalozku system>sprava>Uzivatele a Skupiny>root>Vlastnosti a nastav mu nejake heslo a pak to bude fungovat!

Citace
ps. pro admina ktery edituje primo prispevky:
Citace: drzy_admin
su v ubuntu nefunguje!
co to blabolis? mas se jeste opravdu co ucit!
ps a zkontroluj si jek se opravdu jmenujes, v mem skriptu je buffik se dvema "f" a malym "b" !
pps. a bude fungovat to "su", ne "sudo -i"
Můj názor na vaše chování a omyl se nachází ve vlákně
http://forum.ubuntu.cz/viewtopic.php?pid=96538


Citace: nettezzaumana
ps. a pry pote co zmenis heslo pro roota, nebude fungovat sudo.. v ubuntu je naprosto prvni vec co delam po instalaci prave ona zmena hesla pro roota.. to je klasicky unixovy model. prikaz sudo nepouzivam, nevim jak je to s nim v ubuntu
Ano, ale jste jeden z mála a proto je vhodné uvádět rady tak, aby fungovaly v defaultní instalaci.
FAQ-Často kladené otázky   Návody(wiki)     
Jakub@Life:~$ Ubuntu změnilo váš život, přejete si změny uložit?(Y/N)?
Děkujeme, že nekrmíte trolly Blogísek  :wq

nettezzaumana

  • Host
/home - právo měnit obsah
« Odpověď #24 kdy: 29 Srpen 2007, 16:11:31 »
bufiku, koukni jeste na ten skriptik kterej jsem ti psal vyse, lehce jsem ho upravil, takze je nyni lepsi a logictejsi, pouzij tuhle vylepsenou verzi..