Prosíme přihlašte se nebo zaregistrujte.

Přihlašte se svým uživatelským jménem a heslem.

Novinky: Školení nejen k OS Ubuntu pro širokou veřejnost, více informací zde.

Autor Téma: Proxy  (Přečteno 6227 krát)

pedrs

  • Návštěvník
  • *
  • Příspěvků: 35
  • Karma: +1/-0
    • Zobrazit profil
Proxy
« kdy: 07 Červen 2006, 10:58:00 »
zdravim.Tak mam zase maly problemek.V praci mame proxy k pristupu do netu.To vse mi funguje,ale problem je v SYNAPTICU.Tam si sice taky nastavim proxy,ale ne uzivatele a heslo,takze pri aktualizaci zdroju mi to hodi:ze proxy vyzaduje autorizaci.Ale jak to mam udelat,kdyz tam nic takoveho nejde zadat.Prosim moc o radu,jinak jsem v praci s Ubuntou zkoncil a zas mi zbydou jen widle
linux    → IN
wokna ← OUT

MarrLiss

  • Stálý člen
  • ***
  • Příspěvků: 901
  • Karma: +3/-0
    • Zobrazit profil
Proxy
« Odpověď #1 kdy: 07 Červen 2006, 11:04:58 »
Synaptic by se mel ridit nastavenim proxy pro root. Melo by stacit spustit sudo gnome-network-preferences a nastavit pristup.
Prestigio Nobile 1590: P-M 740, 1 GB RAM, NV 6600
Ubuntu FF

pedrs

  • Návštěvník
  • *
  • Příspěvků: 35
  • Karma: +1/-0
    • Zobrazit profil
Proxy
« Odpověď #2 kdy: 07 Červen 2006, 11:13:41 »
Diky,ale nejde to.V menu System-Volby-Proxy to mam taky nastaveny.Udelal jsem tu konfiguraci jak pises.Tam to bylo prazdne.Tak jsem to doplnil a nic.
linux    → IN
wokna ← OUT

pedrs

  • Návštěvník
  • *
  • Příspěvků: 35
  • Karma: +1/-0
    • Zobrazit profil
Proxy
« Odpověď #3 kdy: 07 Červen 2006, 13:57:11 »
To nikdo nevi kde nastavit SYNAPTICU,kdyz uz tam jde zadat proxy,proc nejde  zadat uzivatele a heslo?
linux    → IN
wokna ← OUT

MarrLiss

  • Stálý člen
  • ***
  • Příspěvků: 901
  • Karma: +3/-0
    • Zobrazit profil
Proxy
« Odpověď #4 kdy: 07 Červen 2006, 14:12:12 »
Prestigio Nobile 1590: P-M 740, 1 GB RAM, NV 6600
Ubuntu FF

pedrs

  • Návštěvník
  • *
  • Příspěvků: 35
  • Karma: +1/-0
    • Zobrazit profil
Proxy
« Odpověď #5 kdy: 07 Červen 2006, 14:39:33 »
Taky nic.
linux    → IN
wokna ← OUT

Ac3ri

  • Návštěvník
  • *
  • Příspěvků: 46
  • Karma: +0/-0
    • Zobrazit profil
Proxy
« Odpověď #6 kdy: 07 Červen 2006, 20:09:40 »
co treba apt-get ?
ja moc adept ani synaptic nepouzivam, ale pro apt-get nastavim proxy
pomoci prikazu :

export http_proxy='http://proxy.server.cz:3128'

a pak uz vse funguje update, upgrade, install, remove,... :)
reseni to problemu to neni, jen mala alternatvia

vlako

  • Návštěvník
  • *
  • Příspěvků: 97
  • Karma: +1/-0
    • Zobrazit profil
    • http://www.vlakx.com
Proxy
« Odpověď #7 kdy: 07 Červen 2006, 21:48:46 »
export http_proxy='http://meno:heslo@ipcka:port'

a potom apt-get install, upgrade ....

po reboote treba nastavit znova
ShaRe Or DIE!
open youR SOURcE!
uSe SSL ! ---------------------------- NTB: Debian Lenny/Sid Desktop: Ubuntu 7.10 Gutsy Gibbon Servers: Debian Etch 4.01

pedrs

  • Návštěvník
  • *
  • Příspěvků: 35
  • Karma: +1/-0
    • Zobrazit profil
Proxy
« Odpověď #8 kdy: 07 Červen 2006, 21:55:37 »
diky,zitra to prubnu.takze prikaz bude vypadat takto:
sudo export http_proxy.....

ono mi to proxy normalne najde,jen proste chce jeste overit,protoze mi v praci pouzivame http overeni pro pristup na net,tak snad to bude fungovat.
Jenze je jeste problem,ze kdyz pozivam synaptic v grafice pro instalovani softu tak tam to taky akt.zdroje a to zase neprojde.
Potreboval bych trvale reseni.
Prece nekde musi mit synaptic nebo apt nastaveni i pro heslo,nebo to je chyba programu.
Nasel jsem vypis nastaveni synapticu v konzoli
sudo synaptic-config dump
a na konci je radka,ktera by to mohla ovlivnit,ale to taky zkusim az zitra.

Kdyztak prosim stale,jestli nekdo nezna trvale reseni
linux    → IN
wokna ← OUT

pedrs

  • Návštěvník
  • *
  • Příspěvků: 35
  • Karma: +1/-0
    • Zobrazit profil
Proxy
« Odpověď #9 kdy: 08 Červen 2006, 08:57:06 »
tak uz mi to funguje.
Chyba se nasla,ze jsem v nastaveni proxy ve sprave zrusil a dal prime propojeni kabelem,v synapricu jsem taky zrusil proxy.Mam ji nastavenou pouze v gnome-network-preferences a v apt.conf.
Ted to funguje bez problemu.
linux    → IN
wokna ← OUT