Prosíme přihlašte se nebo zaregistrujte.

Přihlašte se svým uživatelským jménem a heslem.

Novinky: Školení nejen k OS Ubuntu pro širokou veřejnost, více informací zde.

Autor Téma: cs1.6 přestal bežet (compiz)  (Přečteno 4208 krát)

zmije

  • Návštěvník
  • *
  • Příspěvků: 21
  • Karma: +3/-5
    • Zobrazit profil
cs1.6 přestal bežet (compiz)
« kdy: 14 Leden 2008, 21:46:03 »
Zdravim. Když jsem nainstaloval Ubuntu7.10 běžel cs bez problému, ale začal sem dělat pokusy s compiz. Tady na fóru sem zjistil že to s compiz asi nepude, tak sem vypnul ve vzhledu všlijaké vizuální efekty a zkusil sem do terminálu zadat:
sudo killall compiz.real
po té jsem se pokusil spustit znovu cs, ale neúspěšně:
zmije@zmije:~$ env WINEPREFIX="/home/zmije/.wine" wine "C:\Program_Files\Counter-Strike\hl.exe" -game cstrike
fixme:spoolsv:serv_main (0 (nil))
fixme:ntdll:RtlNtStatusToDosErrorNoTeb no mapping for 8000000a
err:wgl:get_render_type_from_fbconfig Unknown render_type: 0
err:d3d:WineD3D_CreateFakeGLContext Can't find a suitable iPixelFormat
err:d3d:InitAdapters Failed to get a gl context for default adapter
Grafiku mám GF FX5700

Roman "Schmaker" Šmakal

  • Závislák
  • ****
  • Příspěvků: 1205
  • Karma: +59/-10
    • Zobrazit profil
Re: cs1.6 přestal bežet (compiz)
« Odpověď #1 kdy: 15 Leden 2008, 15:43:03 »
možná bych compiz neukončoval takhle... spíš ho ukončete pomocí
metacity --replace &
Vypadá to totiž, že vám compiz "uzamknul" přístup k akceleraci...
Linux Gaming Clan leader
Konference na linuxclan@chat.linjab.net

zmije

  • Návštěvník
  • *
  • Příspěvků: 21
  • Karma: +3/-5
    • Zobrazit profil
Re: cs1.6 přestal bežet (compiz)
« Odpověď #2 kdy: 15 Leden 2008, 17:45:22 »
teď sem to zkusil, ale bota bude nejspíš ještě jinde.
zmije@zmije:~$ metacity --replace &
[1] 8787
zmije@zmije:~$ env WINEPREFIX="/home/zmije/.wine" wine "C:\Program_Files\Counter-Strike\hl.exe" -game cstrike
fixme:spoolsv:serv_main (0 (nil))
err:advapi:service_get_status service protocol error - failed to read pipe r = 0  count = 0!
err:wgl:get_render_type_from_fbconfig Unknown render_type: 0
err:d3d:WineD3D_CreateFakeGLContext Can't find a suitable iPixelFormat
err:d3d:InitAdapters Failed to get a gl context for default adapter

Roman "Schmaker" Šmakal

  • Závislák
  • ****
  • Příspěvků: 1205
  • Karma: +59/-10
    • Zobrazit profil
Re: cs1.6 přestal bežet (compiz)
« Odpověď #3 kdy: 15 Leden 2008, 21:40:58 »
a já už asi vím kde... spouštíte counter strike s directX vykreslováním.. musíte nastavit opengl
Linux Gaming Clan leader
Konference na linuxclan@chat.linjab.net

zmije

  • Návštěvník
  • *
  • Příspěvků: 21
  • Karma: +3/-5
    • Zobrazit profil
Re: cs1.6 přestal bežet (compiz)
« Odpověď #4 kdy: 17 Leden 2008, 11:35:32 »
kde se to dá nastavit? je na to nějaký soubor?

Roman "Schmaker" Šmakal

  • Závislák
  • ****
  • Příspěvků: 1205
  • Karma: +59/-10
    • Zobrazit profil
Re: cs1.6 přestal bežet (compiz)
« Odpověď #5 kdy: 17 Leden 2008, 13:27:02 »
zkuste CS spustit třeba jako wine hl.exe -game cstrike -opengl
Linux Gaming Clan leader
Konference na linuxclan@chat.linjab.net

zmije

  • Návštěvník
  • *
  • Příspěvků: 21
  • Karma: +3/-5
    • Zobrazit profil
Re: cs1.6 přestal bežet (compiz)
« Odpověď #6 kdy: 17 Leden 2008, 14:13:43 »
stále nic:
zmije@zmije:~$ fixme:spoolsv:serv_main (0 (nil))
wine hl.exe -game cstrike -opengl
wine: could not load L"c:\\windows\\system32\\hl.exe": Module not found
upravil jsem tedy link z wine:
zmije@zmije:~$ env WINEPREFIX="/home/zmije/.wine" wine "C:\Program_Files\Counter-Strike\hl.exe" -game cstrike -opengl
fixme:spoolsv:serv_main (0 (nil))
err:advapi:service_get_status service protocol error - failed to read pipe r = 0  count = 0!
err:wgl:get_render_type_from_fbconfig Unknown render_type: 0
err:d3d:WineD3D_CreateFakeGLContext Can't find a suitable iPixelFormat
err:d3d:InitAdapters Failed to get a gl context for default adapter
ale hlásí stále to samé.

Roman "Schmaker" Šmakal

  • Závislák
  • ****
  • Příspěvků: 1205
  • Karma: +59/-10
    • Zobrazit profil
Re: cs1.6 přestal bežet (compiz)
« Odpověď #7 kdy: 17 Leden 2008, 14:49:55 »
Podle výpisů stále běží direct3d, takže přepínač nefungoval... Bohužel nemůžu najít nějakej konfigurák pro nastavení DX/OGL, takže víc poradit nemůžu, je mi líto...
Linux Gaming Clan leader
Konference na linuxclan@chat.linjab.net

zmije

  • Návštěvník
  • *
  • Příspěvků: 21
  • Karma: +3/-5
    • Zobrazit profil
Re: cs1.6 přestal bežet (compiz)
« Odpověď #8 kdy: 20 Leden 2008, 16:08:53 »
Zjistil jsem že problém nemá jen cs, ale i UT2004, který mi po instalaci taky šel. Myslím si že mám špatně nakonfigurovaný xserver nebo gnome. Kompiz sem uplně odinstaloval a vyzkoušel ovladače grafiky, a ejhle nefungují.
Kód: [Vybrat]
zmije@zmije:~$ glxinfo | grep direct
direct rendering: No (If you want to find out why, try setting LIBGL_DEBUG=verbose)

Roman "Schmaker" Šmakal

  • Závislák
  • ****
  • Příspěvků: 1205
  • Karma: +59/-10
    • Zobrazit profil
Re: cs1.6 přestal bežet (compiz)
« Odpověď #9 kdy: 20 Leden 2008, 18:53:44 »
Zjistil jsem že problém nemá jen cs, ale i UT2004, který mi po instalaci taky šel. Myslím si že mám špatně nakonfigurovaný xserver nebo gnome. Kompiz sem uplně odinstaloval a vyzkoušel ovladače grafiky, a ejhle nefungují.
Kód: [Vybrat]
zmije@zmije:~$ glxinfo | grep direct
direct rendering: No (If you want to find out why, try setting LIBGL_DEBUG=verbose)
Takže už víme, kde je zakopanej pes... Vyřešit by to mohlo sudo dpkg-reconfigure xserver-xorg
Linux Gaming Clan leader
Konference na linuxclan@chat.linjab.net

zmije

  • Návštěvník
  • *
  • Příspěvků: 21
  • Karma: +3/-5
    • Zobrazit profil
Re: cs1.6 přestal bežet (compiz)
« Odpověď #10 kdy: 21 Leden 2008, 12:53:34 »
taky to není ono, moji katru to sice poznalo, parkrát sem nabootoval do low grafiky (v screen and Graphics Preferencech na kartě Graphics Card sem měl driver jakésy vesa karty), podíval sem se na xorg.con a v sekci Device v položce Driver bylo nv to sem změnil na nvidia rebootoval a už to jede v normálním rozlišení akorad sem si změnil nastavení myši takže mi nejde kolečko. Myš mám Genius NetScroll Optical PS2. Tady je můj xorg.conf, třeba tam najdete nějakou chybu:
Kód: [Vybrat]
# xorg.conf (xorg X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the xorg.conf manual page.
# (Type "man xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
#   sudo dpkg-reconfigure -phigh xserver-xorg

Section "Files"
EndSection

Section "InputDevice"
Identifier "Generic Keyboard"
Driver "kbd"
Option "CoreKeyboard"
Option "XkbRules" "xorg"
Option "XkbModel" "pc101"
Option "XkbLayout" "cz"
EndSection

Section "InputDevice"
Identifier "Configured Mouse"
Driver "mouse"
Option "CorePointer"
Option "Device" "/dev/psaux"
Option "Protocol" "PS/2"
Option "ZAxisMapping" "4 5"
Option "Emulate3Buttons" "true"
EndSection

Section "InputDevice"
Driver "wacom"
Identifier "stylus"
Option "Device" "/dev/input/wacom"
Option "Type" "stylus"
Option "ForceDevice" "ISDV4" # Tablet PC ONLY
EndSection

Section "InputDevice"
Driver "wacom"
Identifier "eraser"
Option "Device" "/dev/input/wacom"
Option "Type" "eraser"
Option "ForceDevice" "ISDV4" # Tablet PC ONLY
EndSection

Section "InputDevice"
Driver "wacom"
Identifier "cursor"
Option "Device" "/dev/input/wacom"
Option "Type" "cursor"
Option "ForceDevice" "ISDV4" # Tablet PC ONLY
EndSection

Section "Device"
Identifier "nVidia Corporation NV36.2 [GeForce FX 5700]"
Driver "nvidia"
BusID "PCI:1:0:0"
Option "UseFBDev" "true"
EndSection

Section "Monitor"
Identifier "AOC9K+"
Option "DPMS"
HorizSync 30-85
VertRefresh 50-160
EndSection

Section "Screen"
Identifier "Default Screen"
Device "nVidia Corporation NV36.2 [GeForce FX 5700]"
Monitor "AOC9K+"
DefaultDepth 24
SubSection "Display"
Modes "1024x768"
EndSubSection
EndSection

Section "ServerLayout"
Identifier "Default Layout"
Screen "Default Screen"
InputDevice "Generic Keyboard"
InputDevice "Configured Mouse"

# Uncomment if you have a wacom tablet
# InputDevice     "stylus" "SendCoreEvents"
# InputDevice     "cursor" "SendCoreEvents"
# InputDevice     "eraser" "SendCoreEvents"
EndSection
ale 3D akcelerace nejde stejně
Kód: [Vybrat]
zmije@zmije:~$ glxinfo | grep direct
direct rendering: No (If you want to find out why, try setting LIBGL_DEBUG=verbose)