Prosíme přihlašte se nebo zaregistrujte.

Přihlašte se svým uživatelským jménem a heslem.

Autor Téma: Zprovoznění LIRC na 8.04 - Winfast 2000XP deluxe  (Přečteno 1483 krát)

rejza

  • Návštěvník
  • *
  • Příspěvků: 61
  • Karma: +0/-0
    • Zobrazit profil
Zprovoznění LIRC na 8.04 - Winfast 2000XP deluxe
« kdy: 16 Květen 2008, 19:47:21 »
Na debianu a ubuntu 6.06 a 7.04 jsem dalkové ovládání pro kartu Winfast 2000XP deluxe vždy rozchodil. Je pravda, že vždy v tom byl nějaký problém, ale po zagooglování a případné úpravě zdrojáků jsem to vždy nějak rozchodil. Dříve jsem používal jaderné ovladače lirc_dev a lirc_gpio. Dočetl jsem se ale, že modul lirc_gpio si nerozumí s novějším jádrem a že je nutno  použít /dev/input/eventX. Více o tom zde:
https://help.ubuntu.com/community/InstallLirc/Hardy
https://blueprints.launchpad.net/mythbuntu/+spec/lirc-gpio-alternative

Bohužel se mi to takto nepovedlo rozchodit. Po zadání
Kód: [Vybrat]
sudo irrecord -H dev/input -d /dev/input/event4 lircd.conf můžu mačkat cokoliv na ovladači ale irrecord se ukončí aniž by vygeneroval lircd.conf. Pokud použiju lircd.conf pro danou kartu a spustím irw, příkaz se sice ihned neukončí, ale opět nereaguje na mačkání tlačítek na ovladači.

Jako poslední možnost jsem zkoušel nainstalovat lirc pomocí návodu zde:
https://wiki.ubuntu.com/LircHowto?action=show&redirect=HowToLirc
pouze s verzí 0.8.3, ale při nahrávání modulu lirc_gpio to vypíše:
Kód: [Vybrat]
FATAL: Error inserting lirc_gpio (/lib/modules/2.6.24-16-generic/misc/lirc_gpio.ko): Invalid request code.

Podařilo se už někomu tohle DO rozchodit? Zatím to je jediná věc, která mě brání přejít na 8.04.

Předem díky za rady.