Prosíme přihlašte se nebo zaregistrujte.

Přihlašte se svým uživatelským jménem a heslem.

Autor Téma: Sekání videa - ATI  (Přečteno 17563 krát)

macu

  • Závislák
  • ****
  • Příspěvků: 1153
    • Zobrazit profil
Sekání videa - ATI
« kdy: 30 Květen 2008, 23:41:01 »
Mám ATI X1600 a při přehrávání filmů či puštěné TV se mi na Ubuntu 8.04 po chvíli nepatrně seká video ve Fullscreanu. Když okno zmenším na menší velikost běží vše v pohodě. Sekání není nějaké moc přehnané, ale rozhodně je nepříjemné při sledování filmů a TV. V 7.10 jel obraz naprosto v pohodě. Je jedno, zda mám zaplý CF či nikoliv, problém je při obou variantách.

Kód: [Vybrat]
vladimir@athlon-v:~$ fglrxinfo
display: :0.0  screen: 0
OpenGL vendor string: ATI Technologies Inc.
OpenGL renderer string: Radeon X1600 Series
OpenGL version string: 2.1.7415 Release

vladimir@athlon-v:~$ glxgears
300 frames in 5.0 seconds = 59.832 FPS
300 frames in 5.0 seconds = 59.718 FPS
297 frames in 5.0 seconds = 59.001 FPS
301 frames in 5.0 seconds = 60.030 FPS
299 frames in 5.0 seconds = 59.599 FPS
297 frames in 5.0 seconds = 59.223 FPS

PC: Intel i5-6600K, 16 GB DDR4 RAM, Intel 530HD, ASUS Z170 Pro Gaming, , 2TB Toshiba HDD Sata III DT01ACA200, Ubuntu 19.10 64bit, Gnome Shell 3.34
Ntb: Toshiba L850-U12 - Intel i3 , 8 GB DDR3 RAM, Ubuntu 19.10 64bit, Gnome Shell 3.34

macu

  • Závislák
  • ****
  • Příspěvků: 1153
    • Zobrazit profil
Re: Sekání videa - ATI
« Odpověď #1 kdy: 31 Květen 2008, 13:33:00 »
nikdo neví? ještě jsem trošku víc testoval a dle mého to vypadá, jako kdyby mi též nefungovala 3D akcelerace...už  jen díky FPS a nainstaloval-li jsem nějakou hru a nastavil ji na fullscrean tak se nechutně začase sekat tak,že sem danou 3D hru musel vypnout
PC: Intel i5-6600K, 16 GB DDR4 RAM, Intel 530HD, ASUS Z170 Pro Gaming, , 2TB Toshiba HDD Sata III DT01ACA200, Ubuntu 19.10 64bit, Gnome Shell 3.34
Ntb: Toshiba L850-U12 - Intel i3 , 8 GB DDR3 RAM, Ubuntu 19.10 64bit, Gnome Shell 3.34

Pocmag

  • Návštěvník
  • *
  • Příspěvků: 18
  • junior-idiot
    • Zobrazit profil
Re: Sekání videa - ATI
« Odpověď #2 kdy: 02 Červen 2008, 08:43:50 »
mám obdobný problém na stolním pc s R9600Pro, pokud zakážů ovladače a jedu přes VESA tak je vytížení procesoru cca 10% (atlon 2400+), pokud jedu přes nesvobodné ovl. procesor 100%, zkoušel jsem starší ovladače, bez výsledku :(
HP nx7300 :Intel GM/A 950 Cel-M430, 1G RAM(128M sdileny :( ), 80G toshiba

Občas mám pravdu (jednou za uherský rok)

lanugo

  • Návštěvník
  • *
  • Příspěvků: 36
    • Zobrazit profil
Re: Sekání videa - ATI
« Odpověď #3 kdy: 02 Červen 2008, 20:11:33 »
Přidávám se ke stěžovatelům  :), videa se lehce sekají, jako by byl snížený framerate a náročnější šetřiče obrazovky jak by smet. Mám sice slabou grafiku, ale v Gutsym to šlapalo hladce.

pawlik

  • Návštěvník
  • *
  • Příspěvků: 29
    • Zobrazit profil
Re: Sekání videa - ATI
« Odpověď #4 kdy: 03 Červen 2008, 03:24:13 »
Taktéž se přidávám do skupiny stěžovatelů. Mám NB Asus A6Rp s integrovanou grafickou kartou Ati x200. ???

lanugo

  • Návštěvník
  • *
  • Příspěvků: 36
    • Zobrazit profil
Re: Sekání videa - ATI
« Odpověď #5 kdy: 03 Červen 2008, 14:17:43 »
Tak alespoň u mě instalace ovladačů přes Envy nepřinesla kýžené ovoce, výsledek je stejný jako předtím a to okolo 150FPS. Přes 500FPS jsem se dostal pouze, když jsem ovladač ATI přes Envy odinstaloval; pak jsem ale měl nesnesitelné rozlišení 1024x768 (na notebooku) nejsa ho schopen změnit.

lanugo

  • Návštěvník
  • *
  • Příspěvků: 36
    • Zobrazit profil
Re: Sekání videa - ATI
« Odpověď #6 kdy: 03 Červen 2008, 17:18:42 »
Nakonec jsem se pustil do ruční instalace ovladačů verze 8.5 podle:

http://wiki.cchtml.com/index.php/Ubuntu_Hardy_Installation_Guide#Removing_Mesa_drivers (metoda 2),

nicméně v mém případě byl problém spíš v "Mese" a nepřímém "rendrování" (flgrxinfo ukazovalo Mesu nikoli ATI), takže kdybych na to přišel dřív, možná by to šlapalo i s verzí 8.3, která je v repozitářích. Tak či tak, nyní 3000 FPS a žádné sekání.

macu

  • Závislák
  • ****
  • Příspěvků: 1153
    • Zobrazit profil
Re: Sekání videa - ATI
« Odpověď #7 kdy: 03 Červen 2008, 20:43:01 »
tak jsem provedl podobné, filmy se nesekají, fps je ok ale nejde mi direct rendering...zůstává mi me
Kód: [Vybrat]
vladimir@athlon-v:~$ DISPLAY=:0 glxinfo | grep render
direct rendering: No (If you want to find out why, try setting LIBGL_DEBUG=verbose)
OpenGL renderer string: Mesa GLX Indirect
vladimir@athlon-v:~$ glxgears
XIO:  fatal IO error 104 (Connection reset by peer) on X server ":0.0"
      after 5672 requests (36 known processed) with 0 events remaining.

vladimir@athlon-v:~$ fglrxinfo
display: :0.0  screen: 0
OpenGL vendor string: Mesa project: www.mesa3d.org
OpenGL renderer string: Mesa GLX Indirect
OpenGL version string: 1.4 (2.1 Mesa 7.0.3-rc2)

ještě xorg.conf

Kód: [Vybrat]
# xorg.conf (X.Org X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the xorg.conf manual page.
# (Type "man xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
#   sudo dpkg-reconfigure -phigh xserver-xorg

Section "InputDevice"
Identifier "Generic Keyboard"
Driver "kbd"
Option "CoreKeyboard"
Option "XkbRules" "xorg"
Option "XkbModel" "pc105"
Option "XkbLayout" "cz, us"
Option "XkbOptions" "grp:alt_shift_toggle"
EndSection

Section "InputDevice"
Identifier "Configured Mouse"
Driver "mouse"
Option "CorePointer"
EndSection

Section "Device"
Identifier "Configured Video Device"
Driver "fglrx"
Option "VideoOverlay" "on"
Option "OpenGLOverlay" "off"

EndSection

Section "Monitor"
Identifier "Configured Monitor"
EndSection

Section "Screen"
Identifier "Default Screen"
Monitor "Configured Monitor"
Device "Configured Video Device"
Defaultdepth 24
EndSection

Section "ServerLayout"
Identifier "Default Layout"
  screen 0 "screen1" 0 0
EndSection
Section "Module"
Load "glx"
Load "GLcore"
Load "v4l"
EndSection

Section "ServerFlags"
Option "BlankTime" "0"
EndSection
Section "device" #
Identifier "device1"
Boardname "ATI Radeon (fglrx)"
Busid "PCI:2:0:0"
Driver "ati"
Screen 0
Vendorname "ATI"
Option "MergedFB" "off"
EndSection
Section "screen" #
Identifier "screen1"
Device "device1"
Defaultdepth 24[/code
Monitor "monitor1"
EndSection
Section "monitor" #
Identifier "monitor1"
Gamma 1.0
EndSection
Section "device" #
Identifier "device2"
Boardname "VESA driver (generic)"
Busid "PCI:2:0:1"
Driver "ati"
Screen 0
Option "MergedFB" "off"
EndSection
Section "screen" #
Identifier "screen2"
Device "device2"
Defaultdepth 24
Monitor "monitor2"
EndSection
Section "monitor" #
Identifier "monitor2"
Gamma 1.0
EndSection

Section "Extensions"
Option "Composite" "Enable"
EndSection

PC: Intel i5-6600K, 16 GB DDR4 RAM, Intel 530HD, ASUS Z170 Pro Gaming, , 2TB Toshiba HDD Sata III DT01ACA200, Ubuntu 19.10 64bit, Gnome Shell 3.34
Ntb: Toshiba L850-U12 - Intel i3 , 8 GB DDR3 RAM, Ubuntu 19.10 64bit, Gnome Shell 3.34

lanugo

  • Návštěvník
  • *
  • Příspěvků: 36
    • Zobrazit profil
Re: Sekání videa - ATI
« Odpověď #8 kdy: 04 Červen 2008, 15:54:18 »
Odinstaluj balíček xserver-xgl, po restartu by mělo fglrxinfo vyhodit ATI... namísto Mesa...

Evžen Šubrt

  • Závislák
  • ****
  • Příspěvků: 2218
    • Zobrazit profil
    • EuGenio's Lair
Re: Sekání videa - ATI
« Odpověď #9 kdy: 04 Červen 2008, 16:19:39 »
Jdde o to, jak je nastavený konkrétní přehrávač. Vysoké zatížení procesoru by nasvědčovalo použití výstupu x11 - v tomto případě se nepoužívají žádné prostředky gr. karty a vše obstarává procesor. Na starém kompu (AthlonXP 2500+) mi přes x11 fest cukalo ve fulscreenu téměř jakékoli video (procák jel na 100%).

Všem doporučuji vyzkoušet nastavení přehrávače, nejlépe zkusit mplayer + přehrávat přes gl, gl2 či xv. Zatížení by mělo být minimální, ovšem většina těchto módů zlobí se zapnutým compizem.

P.S: Pro funkční xv musíte mít v xorg.conf v sekci Device položku Option "TexturedVideo" "on"
Athlon X2 6000+, MB ASUS M2R32-MVP, 6GB RAM, ATI Radeon HD7850 1GB, 1GB SSHD + 250GB HDD, Ubuntu 13.10 Saucy Salamander 64bit

pawlik

  • Návštěvník
  • *
  • Příspěvků: 29
    • Zobrazit profil
Re: Sekání videa - ATI
« Odpověď #10 kdy: 04 Červen 2008, 17:02:11 »
Ahoj...vsechno (krom master volume, ale to jeste neresim) mi uz s grafikou jde. Ale proste nesmi byt zaply compiz. Pri zaplem mi nejdou videa (jdou pouze s x11 nastavenym pro prehravac) a u her blika obrazovka nebo skoro nesviti. Jinak je to vlastne super ale tohle me opravdu stve.... neni tedy chyba nekde v copiz..???

Evžen Šubrt

  • Závislák
  • ****
  • Příspěvků: 2218
    • Zobrazit profil
    • EuGenio's Lair
Re: Sekání videa - ATI
« Odpověď #11 kdy: 04 Červen 2008, 17:21:04 »
Ano, je to compizem. Jeho overlay se nesnese s jinými. A tak to bliká. Buďto se použije pro přehrávání videí x11 (náročné na procesor), nebo je možnost stáhnout a zkompilovat si patchovaný mplayer, který přes xv (nenáročné na procesor) nebliká.

A nebo na hry a přehrávání filmů vypínat compiz. Např. přes fusion-icon.
Athlon X2 6000+, MB ASUS M2R32-MVP, 6GB RAM, ATI Radeon HD7850 1GB, 1GB SSHD + 250GB HDD, Ubuntu 13.10 Saucy Salamander 64bit

pawlik

  • Návštěvník
  • *
  • Příspěvků: 29
    • Zobrazit profil
Re: Sekání videa - ATI
« Odpověď #12 kdy: 04 Červen 2008, 17:42:56 »
Tomu vsemu rozumim....ale...s prominutim, neni to trochu na *censored*? Je to jako fakt skoda. Vidle sli uz pryc a tohle me teda dost mrzi.... ::) ;D Fakt se s tim neda nic???

macu

  • Závislák
  • ****
  • Příspěvků: 1153
    • Zobrazit profil
Re: Sekání videa - ATI
« Odpověď #13 kdy: 04 Červen 2008, 18:39:46 »
takže vše vyřešeno...nová aktualizace kernelu a restricted-modules na 2.6.24-18 zabrala a po instalaci nových fglrx driverů jede vše...nesekané video, 3D akcelerace a compiz

díky moc všem co mi radili
PC: Intel i5-6600K, 16 GB DDR4 RAM, Intel 530HD, ASUS Z170 Pro Gaming, , 2TB Toshiba HDD Sata III DT01ACA200, Ubuntu 19.10 64bit, Gnome Shell 3.34
Ntb: Toshiba L850-U12 - Intel i3 , 8 GB DDR3 RAM, Ubuntu 19.10 64bit, Gnome Shell 3.34

pawlik

  • Návštěvník
  • *
  • Příspěvků: 29
    • Zobrazit profil
Re: Sekání videa - ATI
« Odpověď #14 kdy: 04 Červen 2008, 21:29:10 »
tak tomu nerozumim...mohl bys to nejak lip popsat?
« Poslední změna: 04 Červen 2008, 21:55:41 od pawlik »

Jiří Vyorálek

  • Návštěvník
  • *
  • Příspěvků: 45
    • Zobrazit profil
Re: Sekání videa - ATI
« Odpověď #15 kdy: 04 Červen 2008, 22:27:19 »
takže vše vyřešeno...nová aktualizace kernelu a restricted-modules na 2.6.24-18 zabrala a po instalaci nových fglrx driverů jede vše...nesekané video, 3D akcelerace a compiz

díky moc všem co mi radili

To video ti funguje i při zapnutém Compizu bez problikávání obrazu?

Já mám zdá se mi téměř stejnou konfiguraci a toto se mi nedaří odstranit.

uname -a
Kód: [Vybrat]
Linux vyoralek-ubu 2.6.24-18-generic #1 SMP Wed May 28 20:27:26 UTC 2008 i686 GN
fglrxinfo
Kód: [Vybrat]
display: :0.0  screen: 0
OpenGL vendor string: ATI Technologies Inc.
OpenGL renderer string: ATI MOBILITY RADEON X600
OpenGL version string: 2.1.7415 Release

pawlik

  • Návštěvník
  • *
  • Příspěvků: 29
    • Zobrazit profil
Re: Sekání videa - ATI
« Odpověď #16 kdy: 04 Červen 2008, 23:29:25 »
no to vidko mi jde kdyz prepisu v mplayeru soubor gui.conf vo_driver "xv" na "x11" (vse poustim v Mplayeru) ale ted sem zjistil ze se obcas predchazi zvuk od obrazu...nekdy???...nechapu....kdyz vypnu compiz je vse v pohode i s "xv"


Kód: [Vybrat]
pawlik@pawlik1:~$ uname -a
Linux pawlik1 2.6.24-16-generic #1 SMP Thu Apr 10 13:23:42 UTC 2008 i686 GNU/Linux

pawlik@pawlik1:~$ fglrxinfo
display: :0.0  screen: 0
OpenGL vendor string: ATI Technologies Inc.
OpenGL renderer string: ATI Radeon Xpress Series
OpenGL version string: 2.1.7412 Release

pawlik@pawlik1:~$ glxgears
5018 frames in 5.0 seconds = 1003.049 FPS
5195 frames in 5.0 seconds = 1038.950 FPS
5141 frames in 5.0 seconds = 1028.094 FPS
4037 frames in 5.0 seconds = 807.287 FPS


pri vypnutem compiz jsou hodnoty FPS stejne
« Poslední změna: 04 Červen 2008, 23:37:43 od pawlik »

Jiří Vyorálek

  • Návštěvník
  • *
  • Příspěvků: 45
    • Zobrazit profil
Re: Sekání videa - ATI
« Odpověď #17 kdy: 04 Červen 2008, 23:35:59 »
Pomocí "X11" mi to funguje při Compizu také, ale to jaksi není to pravé ořechové. Pokud jsem to dobře pochopil, tak "X11" je režim ve kterém většinu práce místo grafické karty udělá CPU, což je značně na zatížení procesoru vidět. Na fullscreen mi to pak "vyžere" téměř celé CPU a to není dobře.

pawlik

  • Návštěvník
  • *
  • Příspěvků: 29
    • Zobrazit profil
Re: Sekání videa - ATI
« Odpověď #18 kdy: 04 Červen 2008, 23:39:25 »
ale jak z toho ven??? uz jsem fakt nestastnej.
« Poslední změna: 04 Červen 2008, 23:42:17 od pawlik »

Evžen Šubrt

  • Závislák
  • ****
  • Příspěvků: 2218
    • Zobrazit profil
    • EuGenio's Lair
Re: Sekání videa - ATI
« Odpověď #19 kdy: 05 Červen 2008, 09:43:56 »
ale jak z toho ven??? uz jsem fakt nestastnej.
Možnosti jsou tři: (+ dvě bez záruky)
1) Přehrávat přes x11 - na to člověk musí mít ale silný procesor (ze zkušenosti vím, že AthlonXP 2500+ je na fullscreen přes x11m málo). Pokud procák dostatečně silný není, může to mít za následek sekání obrazu, desynchronizaci zvuku a podobně.
2) Na video vypínat compiz - když si nainstaluješ fusion-icon, tak vypnutí compizu je 1x pravý klik + 1x levý klik
3) Zkompilovat si patchovaný mplayer - potom přehrávání přes xv nebliká ani se zapnutým compizem

4) Mám zkušenosti s kartami ATI, nevím, jestli se blikání se projevuje i na nVidiích
5) Čekat, než se objeví v repozitáři upravená verze mplayeru, nebo dokud nějaká aktualizace (gr. driverů, compizu, ...) tento problém neodstraní.
Athlon X2 6000+, MB ASUS M2R32-MVP, 6GB RAM, ATI Radeon HD7850 1GB, 1GB SSHD + 250GB HDD, Ubuntu 13.10 Saucy Salamander 64bit

pawlik

  • Návštěvník
  • *
  • Příspěvků: 29
    • Zobrazit profil
Re: Sekání videa - ATI
« Odpověď #20 kdy: 05 Červen 2008, 10:23:35 »
Tak jestli to je opravdu takhle tak to skusim jeste jinou distribuci. Vypinat compiz kvuli videu, kdyz komp v podstate na nic jineho nemam je hloupost. procesor mam na x11 opravdu slabej a vete "Zkompilovat si patchovaný mplayer" zrovna dvakrat nerozumim:) Kazdopadne vsem dekuji za rady, myslim ze se budou hodit i v jinych distribucich.

Evžen Šubrt

  • Závislák
  • ****
  • Příspěvků: 2218
    • Zobrazit profil
    • EuGenio's Lair
Re: Sekání videa - ATI
« Odpověď #21 kdy: 05 Červen 2008, 10:32:00 »
Tak jestli to je opravdu takhle tak to skusim jeste jinou distribuci. Vypinat compiz kvuli videu, kdyz komp v podstate na nic jineho nemam je hloupost. procesor mam na x11 opravdu slabej a vete "Zkompilovat si patchovaný mplayer" zrovna dvakrat nerozumim:) Kazdopadne vsem dekuji za rady, myslim ze se budou hodit i v jinych distribucich.
Myslím, že v tomto ohledu na tom budou i jiná distra úplně stejně ...

A k tomu mplayeru - to znamená
1) stáhnout zdrojový kód (buď z ubuntích repozitářů, nebo přímo od autorů mplayeru)
2) stáhnout patch, který opravuje blikání s compizem (google ho lehce najde)
3) aplikovat patch
4) zkompilovat

Není to sice úplně triviální, ale dá se najít postup, který vás tím vším provede "krok za krokem" hezky za ručičku.
« Poslední změna: 05 Červen 2008, 10:35:15 od EuGenio »
Athlon X2 6000+, MB ASUS M2R32-MVP, 6GB RAM, ATI Radeon HD7850 1GB, 1GB SSHD + 250GB HDD, Ubuntu 13.10 Saucy Salamander 64bit

macu

  • Závislák
  • ****
  • Příspěvků: 1153
    • Zobrazit profil
Re: Sekání videa - ATI
« Odpověď #22 kdy: 05 Červen 2008, 10:56:56 »
osobně při testování ukázky filmu se mi zdálo, že je vše v pořádku (smplayer) i když možná mírně se to sekalo....ale rozhodně ne tak jako při starých driverech...už valí v pořádku, ale třeba torcs jsou nehratelné ve fullscreen (skoro netestováno,nebyl čas)  Jinak obraz je nastaven na XV...
Digitální TV - čt24...rozhodně plynulejší ve fullscreenu a skoro se neseká, NOVA se mi bohužel občas sekla, ale to je možná i signálem, takže nevím
jinak pokud by to dle vyjádření kolegů občas probliklo jen s compizem tak rád compiz kvůli fullscreenu na chvíli vypnu, fusion-icon stejně používám kvůli tomu, že mi kvůli compizu problikává google-earth
PC: Intel i5-6600K, 16 GB DDR4 RAM, Intel 530HD, ASUS Z170 Pro Gaming, , 2TB Toshiba HDD Sata III DT01ACA200, Ubuntu 19.10 64bit, Gnome Shell 3.34
Ntb: Toshiba L850-U12 - Intel i3 , 8 GB DDR3 RAM, Ubuntu 19.10 64bit, Gnome Shell 3.34

Jiří Vyorálek

  • Návštěvník
  • *
  • Příspěvků: 45
    • Zobrazit profil
Re: Sekání videa - ATI
« Odpověď #23 kdy: 05 Červen 2008, 12:36:59 »
Pokud by to někoho taky napadlo, tak jsem vyzkoušel instalaci poslední verze ovladačů ATI fglrx (8.5) přímo od ATI a problémy s Compizem se bohužel nevyřešily  :(

fglrxinfo
Kód: [Vybrat]
display: :0.0  screen: 0
OpenGL vendor string: ATI Technologies Inc.
OpenGL renderer string: ATI MOBILITY RADEON X600
OpenGL version string: 2.1.7537 Release

Vypínání a zapínání Compizu se mi nezdá jako šťastné řešení a tak si večer ještě vyzkouším kompilaci mplayeru s patchem opravujím tuto chybu. Je to škoda, že to stále není vyřešeno, jelikož to vypadá, že tento problém se už "táhne" nějaký ten den  :-\.

pawlik

  • Návštěvník
  • *
  • Příspěvků: 29
    • Zobrazit profil
Re: Sekání videa - ATI
« Odpověď #24 kdy: 05 Červen 2008, 17:23:45 »
Citace
Vypínání a zapínání Compizu se mi nezdá jako šťastné řešení a tak si večer ještě vyzkouším kompilaci mplayeru s patchem opravujím tuto chybu. Je to škoda, že to stále není vyřešeno, jelikož to vypadá, že tento problém se už "táhne" nějaký ten den  Nevím co si myslet/Nerozhodný.

Kdyby si nasel nejaky pekny navod na tu kompilaci a patch na mplayer tak prosim sup sem s nim:) Diky moc.

Jeste sem se chtel zeptat, jak spoustet fusion-icon hned po startu. Abych to nemusel vzdycky zapinat (kdyz uz to jinac nejde >:(). Diky diky diky.