Prosíme přihlašte se nebo zaregistrujte.

Přihlašte se svým uživatelským jménem a heslem.

Autor Téma: WIFI = opět problémy... :-\  (Přečteno 3919 krát)

Tagy

  • Člen
  • **
  • Příspěvků: 189
  • Karma: +6/-1
    • Zobrazit profil
WIFI = opět problémy... :-\
« kdy: 05 Říjen 2008, 18:34:47 »
Ahoj, včera jsem WIFInu rozběhal, vše fungovalo (řešil jsem zde: http://forum.ubuntu.cz/index.php/topic,27787.0.html)
Dnes zapnu notebook, a nic... ledka svítí, svoji síť vidím, načítá... a načítá.
Restartuji pc, kontrolka svítí, a načítá... odebírám nastavení své sítě a zkouším znovu zadat svoje heslo + nastavuji druh šifrování.
Nic, restartuji router, také nic, router vidí v okolí nějaké jiné sítě notebook zprvu také, pak již ne.
Zprvu jsem měl signál teď ani to ne (přesto síť vidí)
Ok, vypínám šifrování, zvyšuji vyzařovaný výkon (podotýkám laptop a router jsou ve stejné místnosti max 3m od sebe...
Nefunguje...
Ok zkouším najít novější firmware pro router, stránky výrobce nefungují (stávající verze: 1.5.5, již jednou úspěšně flashnuto)
Ještě než odešlu příspěvěk, odebírám ovladače, restartuji, znovu instaluji ten samý (předtím funkční) ovladač, jaké je ale překvapení, WIFI ale žádné sítě v okolí nevidí!
Co s tím, jak diagnostikovat kde je problém?
S WIFI mám stále nějaké problémy...>:(
Router: WRT-311
WIFI: Broadcom B4318

Petr Merlin Vaněček

  • Moderátor
  • Závislák
  • ***
  • Příspěvků: 4993
  • Karma: +353/-11
    • Zobrazit profil
    • Lomítkáři
Re: WIFI = opět problémy... :-\
« Odpověď #1 kdy: 06 Říjen 2008, 21:15:19 »
Ping na router jede? Myslím na IP?
Co vypisuje iwconfig ?
Registered Linux user #421281
Stiskni CTRL + W ...
80% mozku tvoří kapalina ... u některých brzdová

Tagy

  • Člen
  • **
  • Příspěvků: 189
  • Karma: +6/-1
    • Zobrazit profil
Re: WIFI = opět problémy... :-\
« Odpověď #2 kdy: 06 Říjen 2008, 22:40:45 »
Ano PING jde, přes kabel.
Na WIFI se již nepřipojím, prostě ji ani nevidím.
Výpis iwconfig:
tagy@tagy-laptop:~$ iwconfig
lo        no wireless extensions.

eth0      no wireless extensions.

wmaster0  no wireless extensions.

wlan0     IEEE 802.11g  ESSID:"" 
          Mode:Managed  Frequency:2.412 GHz  Access Point: Not-Associated   
          Tx-Power=27 dBm   
          Retry min limit:7   RTS thr:off   Fragment thr=2346 B   
          Link Quality:0  Signal level:0  Noise level:0
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0

Petr Merlin Vaněček

  • Moderátor
  • Závislák
  • ***
  • Příspěvků: 4993
  • Karma: +353/-11
    • Zobrazit profil
    • Lomítkáři
Re: WIFI = opět problémy... :-\
« Odpověď #3 kdy: 07 Říjen 2008, 07:08:19 »
Kód: [Vybrat]
sudo iwlist scan

dá jaký výsledek?
Registered Linux user #421281
Stiskni CTRL + W ...
80% mozku tvoří kapalina ... u některých brzdová

Tagy

  • Člen
  • **
  • Příspěvků: 189
  • Karma: +6/-1
    • Zobrazit profil
Re: WIFI = opět problémy... :-\
« Odpověď #4 kdy: 07 Říjen 2008, 11:00:07 »
Nyní jsem na VŠ přes kabel:
[sudo] password for tagy:
lo        Interface doesn't support scanning.

eth0      Interface doesn't support scanning.

wmaster0  Interface doesn't support scanning.

wlan0     Scan completed :
          Cell 01 - Address: 00:19:E7:26:44:70
                    ESSID:"eduroam"
                    Mode:Master
                    Channel:11
                    Frequency:2.462 GHz (Channel 11)
                    Quality=70/100  Signal level=0 dBm  Noise level=-36 dBm
                    Encryption key:on
                    IE: WPA Version 1
                        Group Cipher : TKIP
                        Pairwise Ciphers (1) : TKIP
                        Authentication Suites (1) : 802.1x
                    Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 6 Mb/s; 9 Mb/s
                              11 Mb/s; 12 Mb/s; 18 Mb/s; 24 Mb/s; 36 Mb/s
                              48 Mb/s; 54 Mb/s
                    Extra:tsf=00000dd55ef088c9
-------------------------------------------------------------
Až přijdu domů, pošlu také výpis

Petr Merlin Vaněček

  • Moderátor
  • Závislák
  • ***
  • Příspěvků: 4993
  • Karma: +353/-11
    • Zobrazit profil
    • Lomítkáři
Re: WIFI = opět problémy... :-\
« Odpověď #5 kdy: 07 Říjen 2008, 17:59:14 »
Důležitý je hlavně ten výpis doma :)
Registered Linux user #421281
Stiskni CTRL + W ...
80% mozku tvoří kapalina ... u některých brzdová

Tagy

  • Člen
  • **
  • Příspěvků: 189
  • Karma: +6/-1
    • Zobrazit profil
Re: WIFI = opět problémy... :-\
« Odpověď #6 kdy: 07 Říjen 2008, 20:53:25 »
lo        Interface doesn't support scanning.

eth0      Interface doesn't support scanning.

wmaster0  Interface doesn't support scanning.

wlan0     Scan completed :
          Cell 01 - Address: 00:12:0E:34:30:AA
                    ESSID:"WRT-311"
                    Mode:Master
                    Channel:7
                    Frequency:2.442 GHz (Channel 7)
                    Quality=71/100  Signal level=-40 dBm  Noise level=-67 dBm
                    Encryption key:off
                    Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 6 Mb/s
                              9 Mb/s; 12 Mb/s; 18 Mb/s; 24 Mb/s; 36 Mb/s
                              48 Mb/s; 54 Mb/s
                    Extra:tsf=0000002a5e6fca66
          Cell 02 - Address: 00:0B:6B:57:D4:2B
                    ESSID:"LTNET1"
                    Mode:Master
                    Channel:4
                    Frequency:2.427 GHz (Channel 4)
                    Quality=43/100  Signal level=-72 dBm  Noise level=-67 dBm
                    Encryption key:off
                    Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s
                    Extra:tsf=0000007dbcb88181
          Cell 03 - Address: 00:0B:6B:83:11:8E
                    ESSID:"LTNETG"
                    Mode:Master
                    Channel:1
                    Frequency:2.412 GHz (Channel 1)
                    Quality=35/100  Signal level=-81 dBm  Noise level=-67 dBm
                    Encryption key:off
                    Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s
                    Extra:tsf=0000006954a47c75

Dnes změny, vidím jak ostatní sítě tak svoji, zkusil jsem se připojit, připojím se, signál mám.
Na net se ale nedostanu, zkusil jsem ping, výpis:
PING 192.168.1.1 (192.168.1.1) 56(84) bytes of data.
From 192.168.1.51 icmp_seq=1 Destination Host Unreachable
From 192.168.1.51 icmp_seq=4 Destination Host Unreachable
From 192.168.1.51 icmp_seq=5 Destination Host Unreachable
From 192.168.1.51 icmp_seq=8 Destination Host Unreachable
From 192.168.1.51 icmp_seq=9 Destination Host Unreachable

--- 192.168.1.1 ping statistics ---
10 packets transmitted, 0 received, +5 errors, 100% packet loss, time 8999ms
, pipe 2

Petr Merlin Vaněček

  • Moderátor
  • Závislák
  • ***
  • Příspěvků: 4993
  • Karma: +353/-11
    • Zobrazit profil
    • Lomítkáři
Re: WIFI = opět problémy... :-\
« Odpověď #7 kdy: 07 Říjen 2008, 21:36:46 »
A iwconfig?
Registered Linux user #421281
Stiskni CTRL + W ...
80% mozku tvoří kapalina ... u některých brzdová

Tagy

  • Člen
  • **
  • Příspěvků: 189
  • Karma: +6/-1
    • Zobrazit profil
Re: WIFI = opět problémy... :-\
« Odpověď #8 kdy: 07 Říjen 2008, 21:42:37 »
tagy@tagy-laptop:~$ iwconfig
lo        no wireless extensions.

eth0      no wireless extensions.

wmaster0  no wireless extensions.

wlan0     IEEE 802.11g  ESSID:"WRT-311" 
          Mode:Managed  Frequency:2.442 GHz  Access Point: 00:12:0E:34:30:AA   
          Bit Rate=36 Mb/s   Tx-Power=27 dBm   
          Retry min limit:7   RTS thr:off   Fragment thr=2346 B   
          Link Quality=71/100  Signal level=-40 dBm  Noise level=-71 dBm
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0

Petr Merlin Vaněček

  • Moderátor
  • Závislák
  • ***
  • Příspěvků: 4993
  • Karma: +353/-11
    • Zobrazit profil
    • Lomítkáři
Re: WIFI = opět problémy... :-\
« Odpověď #9 kdy: 07 Říjen 2008, 23:48:43 »
To vypadá, že jste opravdu připojen :)

Kód: [Vybrat]
ip a
resp.
ifconfig
Registered Linux user #421281
Stiskni CTRL + W ...
80% mozku tvoří kapalina ... u některých brzdová

kocar

  • Návštěvník
  • *
  • Příspěvků: 64
  • Karma: +5/-0
    • Zobrazit profil
Re: WIFI = opět problémy... :-\
« Odpověď #10 kdy: 08 Říjen 2008, 10:13:36 »
Mám podobný, ne-li stejný problém s wifi kartou do PCI s čipem RaLink RT2561/RT61. Výpisy zmíněných příkazů jsou následující:
Kód: [Vybrat]
[root@kocar ~]# iwlist wlan0 scan
wlan0     Scan completed :
          Cell 01 - Address: F6:8D:9A:E6:E1:8B
                    ESSID:"SGF_AP"
                    Mode:Ad-Hoc
                    Channel:1
                    Frequency:2.412 GHz (Channel 1)
                    Quality=0/100  Signal level:0 dBm 
                    Encryption key:off
                    Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 6 Mb/s
                              9 Mb/s; 12 Mb/s; 18 Mb/s; 24 Mb/s; 36 Mb/s
                              48 Mb/s; 54 Mb/s
                    Extra:tsf=0000000000000000
                    Extra: Last beacon: 27ms ago

[root@kocar ~]# iwconfig wlan0
wlan0     IEEE 802.11bg  ESSID:"SGF_AP" 
          Mode:Ad-Hoc  Frequency:2.412 GHz  Cell: F6:8D:9A:E6:E1:8B   
          Tx-Power=10 dBm   
          Retry min limit:7   RTS thr:off   Fragment thr=2352 B   
          Encryption key:off
          Link Quality:0  Signal level:0  Noise level:0
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0

[root@kocar ~]# ifconfig wlan0
wlan0     Link encap:Ethernet  HWadr 00:1F:1F:0B:18:1F 
          inet adr:10.109.204.59  Všesměr:10.109.204.63 Maska:255.255.255.192
          inet6-adr: fe80::21f:1fff:fe0b:181f/64 Rozsah:Linka
          AKTIVOVÁNO VŠESMĚROVÉ_VYSÍLÁNÍ BĚŽÍ MULTICAST  MTU:1500  Metrika:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:132 errors:0 dropped:0 overruns:0 carrier:0
          kolizí:0 délka odchozí fronty:1000
          RX bytes:0 (0.0 b)  TX bytes:14044 (13.7 KiB)

Nastavení AP (Ovislink 5460) je následující:

Kód: [Vybrat]
Wireless
Mode: AP
Physical Address: 00:4f:62:0c:41:76
Band: 2.4 GHz (B+G)
SSID: SGF_AP
Channel Number: 1
Encryption: Disabled
Associated Clients: 0
BSSID: 00:4f:62:0c:41:76
 
LAN Configuration
Connection Method: Fixed IP
Physical Address: 00:4f:62:0c:41:75
IP Address: 10.109.204.58
Network Mask: 255.255.255.192
Default Gateway: 10.109.204.1
DHCP Server: OFF
DHCP Start IP Address: 192.168.100.100
DHCP Finish IP Address: 192.168.100.200

Ale nepingnu ani na něj (10.109.204.58), ani nikam dál... Nevíte někdo, co dělám špatně?
Intel Pentium Dual-Core E5200, 4 GB RAM, GeForce 8600GT, Fedora 9 x64
Intel Core 2 Quad Q9300, 8GB RAM, GeForce 7300GT, Fedora 9 x64

mbiba

  • Návštěvník
  • *
  • Příspěvků: 67
  • Karma: +1/-0
    • Zobrazit profil
... manuální instalace
« Odpověď #11 kdy: 08 Říjen 2008, 10:34:32 »
a co to zkusit jako zastara? Myslím takto: http://ubuntuforums.org/showthread.php?t=132980

Já to dost používal na gg a v pohodě, prostě přechcat ten ovladač co je v ubuntu tím co je v návodu.

Miloš. B.

tom.i (Duriel)

  • Člen
  • **
  • Příspěvků: 165
  • Karma: +2/-1
    • Zobrazit profil
    • Tomíkův BLOG
Re: WIFI = opět problémy... :-\
« Odpověď #12 kdy: 08 Říjen 2008, 10:38:29 »
Ja ju rozjel vcera, ale zas mam problem, ze se mi nechce prihlasit do ESSID.. cili ani iwconfigem nedonutim wifi (BCM4312 rev02) aby si nastavila SSID routeru :(
HP 6715b, 2 GB RAM, TL-60 Turion64 X2, 2 GHz, ATI X1250, 15,4" 1680x1050, Archlinux x64

Fracty

  • Stálý člen
  • ***
  • Příspěvků: 809
  • Karma: +36/-7
    • Zobrazit profil
Re: WIFI = opět problémy... :-\
« Odpověď #13 kdy: 08 Říjen 2008, 11:46:46 »
podívejte se co se děje se systéme tedy logy deamon.log, kern.log popř dmesg....

Petr Merlin Vaněček

  • Moderátor
  • Závislák
  • ***
  • Příspěvků: 4993
  • Karma: +353/-11
    • Zobrazit profil
    • Lomítkáři
Re: WIFI = opět problémy... :-\
« Odpověď #14 kdy: 08 Říjen 2008, 12:26:53 »
kocar:
Kód: [Vybrat]
          Encryption key:off
          Link Quality:0  Signal level:0  Noise level:0
šifrování nepoužíváte? Vzhledem k naprosté 0 na link quality bych to na "připojeno" moc neviděl. RX je také 0 tj. karta nic nepřijala. Může se jednat i o chybu en/decryption - špatně zadaný klíč.
Registered Linux user #421281
Stiskni CTRL + W ...
80% mozku tvoří kapalina ... u některých brzdová

kocar

  • Návštěvník
  • *
  • Příspěvků: 64
  • Karma: +5/-0
    • Zobrazit profil
Re: WIFI = opět problémy... :-\
« Odpověď #15 kdy: 08 Říjen 2008, 12:46:46 »
kocar:
Kód: [Vybrat]
          Encryption key:off
          Link Quality:0  Signal level:0  Noise level:0
šifrování nepoužíváte? Vzhledem k naprosté 0 na link quality bych to na "připojeno" moc neviděl. RX je také 0 tj. karta nic nepřijala. Může se jednat i o chybu en/decryption - špatně zadaný klíč.

Právě, že to chci nejdřív rozchodit bez šifrování a pak to případně rozšířit o šifrování... AP je nastaveno také, aby nešifroval, viz
Kód: [Vybrat]
Encryption: Disabled
Taky myslím, že připojen není, ale nevím, kde hledat... Jdu zkusit prozkoumat ty logy.
Intel Pentium Dual-Core E5200, 4 GB RAM, GeForce 8600GT, Fedora 9 x64
Intel Core 2 Quad Q9300, 8GB RAM, GeForce 7300GT, Fedora 9 x64

76house

  • Návštěvník
  • *
  • Příspěvků: 42
  • Karma: +3/-0
    • Zobrazit profil
Re: WIFI = opět problémy... :-\
« Odpověď #16 kdy: 09 Říjen 2008, 08:47:43 »
Tak to vypadá, že tyhle síťovky s BCM43xx jsou fakt peklo >:( Po nějakém nedávném updatu mně taky opět přestala fungovat wifi (BCM4318). Páč nepomáhal ani iwconfig, zkusil jsem backport NetworkManagera 0.7 pro Hardyho podle tohohle návodu: http://sudan.ubuntuforums.com/showthread.php?t=797059. Všechno začalo pěkně fungovat, teda kromě pamatování WPA hesla (už na to ale mají bugreport). O to víc mě překvapilo, když po několika restartech najednou přestalo jet jak wifi, tak i pevné připojení. Takže jsem teď komplet bez sítě. Pokud byste měli nějaký nápad, co s tím, budu vděčný.

Tagy

  • Člen
  • **
  • Příspěvků: 189
  • Karma: +6/-1
    • Zobrazit profil
Re: WIFI = opět problémy... :-\
« Odpověď #17 kdy: 09 Říjen 2008, 14:07:45 »
Tak u mě se našlo řešení, NE elegantní, ale z časového důvodu nejrychlejší (potřebuji booka do školy)
Prostě jsem Ubuntu kompletně přeinstaloval (měl jsem oddělený /home) takže nastavení zůstalo, jen si musím doinstalovat aplikace, které jsem tam doinstalovával)
více tady: http://forum.ubuntu.cz/index.php/topic,27995.0.html

Zrazu wifi funguje a to bez jakéhokoli dalšího ovladače, je tam jen ten default!!!
Normálně jsem se včera doma připojil na router, ted jsem na VŠ a v pohodě vidím síť...
Čím to je, je mi záhadou!!!
Začínám tak trochu pochybovat.
Zprvu to bylo nejde my TrueCrypt (šifrování dat)
Odpověď byla Ubuntu je samý BUG (verze 7.10) během pár dní měla vyjít 8.04, počkal jsem pak už program fungoval.
Na pc mi nejde Flash/ na notebooku také nešel, po přeinstalaci někdy v září mi najednou flash na booku šel, na PC mi do této doby nefunguje (věřím že pokud OS přeinstaluji tak chodit bude...)
A teď wifi... z důvodu zkoušení jiného distra jsem si Ubuntu smazal, pak jsem se k němu vrátil, a wifi nešla, při povolování ovladače to dělalo psí kusy.... a ešlo až do úplné přeinstalce kdy najednou vše jde tak jak má.
Nevím co si o tom mám myslet... :-X

Dancer

  • Člen
  • **
  • Příspěvků: 106
  • Karma: +4/-0
  • .
    • Zobrazit profil
Re: WIFI = opět problémy... :-\
« Odpověď #18 kdy: 09 Říjen 2008, 15:17:46 »
Nevím co si o tom mám myslet... :-X

Prostě zázrak!   ;D

Ale ne... vážně: Co aktualizace systému? Pokud probíhaly, mohly se těmito updaty projevovat různé chybky v distribuci, které byly předtím zkryty - opatchovalo se tohle a něco jiného tím pádem nejelo, jak má.
Jinak routery a WiFi zvlášť je občas mrcha. Mám router OvisLink WL-1000UR a po cca. třech letech bezproblémového provozu mi postupně, aniž bych cokoliv měnil, přestávalo fungovat připojení na internet. Síťovka měla IP adresu (dynamicky přidělovanou routerem), dalo se na ni pingnout z jiného počítače (na kterém připojení fungovalo), ale z ní (resp. z počítače, v němž byla) se pingnout nedalo, cokoliv jiného také ne. Stejné chování jak pod Win, tak pod linuxem. Naštěstí stačil reset routeru a jeho opětovné nastavení a zase vše funguje.
Cesty dat jsou někdy nevyzpytatelné...  :-\
これはなんですか。 Ubuntu です。