Prosíme přihlašte se nebo zaregistrujte.

Přihlašte se svým uživatelským jménem a heslem.

Autor Téma: Ubuntu II + ATI  (Přečteno 3201 krát)

macu

  • Závislák
  • ****
  • Příspěvků: 1153
    • Zobrazit profil
Ubuntu II + ATI
« kdy: 24 Říjen 2008, 12:01:20 »
Dobrý den,
jelikož příští týden má vyjít nové Ubuntu II a dnes vyšla první RC verze, zajímalo by mě, zda již existují ovladače od ATI s podporou Xorg 7.4. Pokud tyto ovladače existují, jaká je jejich funkčnost (Compiz, blikání či sekání videí při fullscreenu atd.)
PC: Intel i5-6600K, 16 GB DDR4 RAM, Intel 530HD, ASUS Z170 Pro Gaming, , 2TB Toshiba HDD Sata III DT01ACA200, Ubuntu 19.10 64bit, Gnome Shell 3.34
Ntb: Toshiba L850-U12 - Intel i3 , 8 GB DDR3 RAM, Ubuntu 19.10 64bit, Gnome Shell 3.34

Evžen Šubrt

  • Závislák
  • ****
  • Příspěvků: 2218
    • Zobrazit profil
    • EuGenio's Lair
Re: Ubuntu II + ATI
« Odpověď #1 kdy: 24 Říjen 2008, 12:25:40 »
Ovladače fglrx v repozitářích Xorg 7.4 podporují (pozor! ty na stránkách ati ale ne!). Co se týče blikání, nezaznamenal jsem žádnou změnu - tj. stále bliká video při použití vrstvy xv, gl či gl2 (značení podle mplayeru) a hry využívající opengl. Stále je jedinou variantou vypínat compiz či přehrávat videa přes x11.

EDIT: Doporučuji instalovat přes Správce hardware!
Athlon X2 6000+, MB ASUS M2R32-MVP, 6GB RAM, ATI Radeon HD7850 1GB, 1GB SSHD + 250GB HDD, Ubuntu 13.10 Saucy Salamander 64bit

Tomáš Jančík

  • Závislák
  • ****
  • Příspěvků: 1179
    • Zobrazit profil
    • TomášJančík.net
Re: Ubuntu II + ATI
« Odpověď #2 kdy: 24 Říjen 2008, 12:48:26 »
jinak se mi zdá, že ovladače v II mají o něco nižší výkon než v HH

Evžen Šubrt

  • Závislák
  • ****
  • Příspěvků: 2218
    • Zobrazit profil
    • EuGenio's Lair
Re: Ubuntu II + ATI
« Odpověď #3 kdy: 24 Říjen 2008, 13:14:22 »
jinak se mi zdá, že ovladače v II mají o něco nižší výkon než v HH
Na mé gr. kartě to dělá cca 10% (v lightsmark benchmarku). Bude to způsobeno nejspíš tím, že ovladač v repozitářích je něco jako "betaverze". Díky tomu, že Canonical spolupracuje s AMD na testování ovladačů, získal do repozitářů II tuhle předverzi - její hlavní devizou není výkon, ale kompatibilita s Xorg 7.4

P.S: Stále je to ale nesrovnatelné s výkonem nesvobodných ovladačů - ty zatím, co se týče novějších karet (řady HDxxxx), 2D ani 3D akceleraci neimplementují, či ji mají v krajně nestabilní a nevýkonné vývojové fázi.
Athlon X2 6000+, MB ASUS M2R32-MVP, 6GB RAM, ATI Radeon HD7850 1GB, 1GB SSHD + 250GB HDD, Ubuntu 13.10 Saucy Salamander 64bit

olbrait

  • Stálý člen
  • ***
  • Příspěvků: 814
  • Registered User #452059
    • Zobrazit profil
Re: Ubuntu II + ATI
« Odpověď #4 kdy: 26 Říjen 2008, 11:00:48 »
Na odstránenie blikania stačí vypnúť compiz, to môžem potvrdiť. Vrstva "xv" v mplayeri mi vo fullscreene pri zapnutom compize nebliká, čo je super, ale radšej by som použil vrstvu "gl", lenže s tou sa pri fullscreene dostanem k takémuto obrazu a je jedno či je compiz pustený alebo nie. Ste na tom rovnako?
laptop: HP COMPAQ 6735s, AMD QL-60, ATI HD3200, Ram 1754 MB, HDD 250 GB, Ubuntu 9.04 64bit, Debain Squeeze 64bit. ...Ubunt 9.10 64bit šlo do /dev/null/
desktop: MB SV KT 400, AMD Athlon 2000XP, MSI GeForce MX 440 64 MB, Ram 512 MB, HDD Maxtor 80 GB, Ubuntu 8.04.3
 Linuxák v mojom okolí

luisah

  • Závislák
  • ****
  • Příspěvků: 3704
    • Zobrazit profil
Re: Ubuntu II + ATI
« Odpověď #5 kdy: 26 Říjen 2008, 11:22:14 »
Na odstránenie blikania stačí vypnúť compiz, to môžem potvrdiť. Vrstva "xv" v mplayeri mi vo fullscreene pri zapnutom compize nebliká, čo je super, ale radšej by som použil vrstvu "gl", lenže s tou sa pri fullscreene dostanem k takémuto obrazu a je jedno či je compiz pustený alebo nie. Ste na tom rovnako?
Mě funguje jak xv, tak i gl či gl2 OK.

olbrait

  • Stálý člen
  • ***
  • Příspěvků: 814
  • Registered User #452059
    • Zobrazit profil
Re: Ubuntu II + ATI
« Odpověď #6 kdy: 26 Říjen 2008, 11:45:44 »
Mě funguje jak xv, tak i gl či gl2 OK.
máš v xorg.conf nastavené nejaké "options" pre grafiku? Dal som preč tie čo som pridaval ja a xv pri fullscreene bliká a pri gl je len čierna obrazovka
laptop: HP COMPAQ 6735s, AMD QL-60, ATI HD3200, Ram 1754 MB, HDD 250 GB, Ubuntu 9.04 64bit, Debain Squeeze 64bit. ...Ubunt 9.10 64bit šlo do /dev/null/
desktop: MB SV KT 400, AMD Athlon 2000XP, MSI GeForce MX 440 64 MB, Ram 512 MB, HDD Maxtor 80 GB, Ubuntu 8.04.3
 Linuxák v mojom okolí

luisah

  • Závislák
  • ****
  • Příspěvků: 3704
    • Zobrazit profil
Re: Ubuntu II + ATI
« Odpověď #7 kdy: 26 Říjen 2008, 11:55:45 »
Mě funguje jak xv, tak i gl či gl2 OK.
máš v xorg.conf nastavené nejaké "options" pre grafiku? Dal som preč tie čo som pridaval ja a xv pri fullscreene bliká a pri gl je len čierna obrazovka
Ne nemám nic - něco upravovat, na to sem moc línej :D

Kód: [Vybrat]
Section "Device"
Identifier "Configured Video Device"
Driver "fglrx"
EndSection

Section "Monitor"
Identifier "Configured Monitor"
EndSection

Section "Screen"
Identifier "Default Screen"
Monitor "Configured Monitor"
Device "Configured Video Device"
Defaultdepth 24
EndSection

Section "ServerLayout"
Identifier "Default Layout"
  screen "Default Screen"
EndSection
Section "Module"
Load "glx"
EndSection
To je můj celej xorg.conf

olbrait

  • Stálý člen
  • ***
  • Příspěvků: 814
  • Registered User #452059
    • Zobrazit profil
Re: Ubuntu II + ATI
« Odpověď #8 kdy: 26 Říjen 2008, 12:23:45 »
prehnaná aktivita sa fakt niekedy nevypláca, dal som xorg.conf do pôvodného stavu, tak isto aj nastavenia videa v mplayeri a už to ide aj s gl. So zapnutým compizom video predpokladám stále bliká.
Dík za pomoc
laptop: HP COMPAQ 6735s, AMD QL-60, ATI HD3200, Ram 1754 MB, HDD 250 GB, Ubuntu 9.04 64bit, Debain Squeeze 64bit. ...Ubunt 9.10 64bit šlo do /dev/null/
desktop: MB SV KT 400, AMD Athlon 2000XP, MSI GeForce MX 440 64 MB, Ram 512 MB, HDD Maxtor 80 GB, Ubuntu 8.04.3
 Linuxák v mojom okolí

luisah

  • Závislák
  • ****
  • Příspěvků: 3704
    • Zobrazit profil
Re: Ubuntu II + ATI
« Odpověď #9 kdy: 26 Říjen 2008, 13:50:44 »
prehnaná aktivita sa fakt niekedy nevypláca, dal som xorg.conf do pôvodného stavu, tak isto aj nastavenia videa v mplayeri a už to ide aj s gl. So zapnutým compizom video predpokladám stále bliká.
Dík za pomoc
Jo, s compizem video bliká - to je furt stejný.