Prosíme přihlašte se nebo zaregistrujte.

Přihlašte se svým uživatelským jménem a heslem.

Autor Téma: aktivace NumLock v Ubuntu 8.10 - GNOME [vyřešeno]  (Přečteno 3479 krát)

regine

  • Stálý člen
  • ***
  • Příspěvků: 621
  • Karma: +22/-3
    • Zobrazit profil
aktivace NumLock v Ubuntu 8.10 - GNOME [vyřešeno]
« kdy: 07 Březen 2009, 10:57:53 »
Aktivace NumLock v Ubuntu 8.10 - GNOME
v diskusi
http://forum.ubuntu.cz/index.php/topic,17950.0.html
je návod, ale asi pro Ubuntu 7.04 (to jsem kdysi užil).
sudo apt-get install numlockx
sudo cp /etc/X11/gdm/Init/Default /etc/X11/gdm/Init/Default_backup
gksudo gedit /etc/X11/gdm/Init/Default

...
exit 0

* Add the following lines above it
if [ -x /usr/bin/numlockx ]; then
 /usr/bin/numlockx on
fi
* Save the edited file
* Read #How to restart GNOME without rebooting computer


Ale v Ubuntu 8.10 není adresář "gdm" /etc/X11/gdm/Init/
Jak to řešit? Kde je init?
« Poslední změna: 23 Březen 2009, 16:39:33 od kiklhorn »
Ubuntu 16.04 LTS 32bit

Numirah

  • Člen
  • **
  • Příspěvků: 191
  • Karma: +18/-6
    • Zobrazit profil
Re: aktivace NumLock v Ubuntu 8.10 - GNOME
« Odpověď #1 kdy: 07 Březen 2009, 11:14:05 »
Spusti (Alt+F2) gconf-editor /desktop/gnome/peripherials/keyboard/host-tvoje_meno-desktop/numlock_on
Ubuntu12.04, Asus M2N-X PLUS, AMD Athlon 64X2 4200+ (2.2GHz), 2GB RAM Kingston 800MHz, 1TB HDD SATA, n-Vidia GeForce 8500GT 512MB, zvuk onboard

regine

  • Stálý člen
  • ***
  • Příspěvků: 621
  • Karma: +22/-3
    • Zobrazit profil
Re: aktivace NumLock v Ubuntu 8.10 - GNOME
« Odpověď #2 kdy: 07 Březen 2009, 13:58:13 »
Dík, ale nějak nevím jak dál.  :(
Otevřelo se mi okno "Configuration editor" (apps, desktop, schemas, system) a jaksi nevím, kde nastavit zapnutí NumLock.
« Poslední změna: 24 Březen 2011, 15:33:49 od Anna Taliánová »
Ubuntu 16.04 LTS 32bit

MikiTwic

  • Člen
  • **
  • Příspěvků: 239
  • Karma: +23/-0
  • Vždycky to nějak jde...
    • Zobrazit profil
Re: aktivace NumLock v Ubuntu 8.10 - GNOME
« Odpověď #3 kdy: 07 Březen 2009, 15:15:21 »
no když se proklikáš tím stromem
Spusti (Alt+F2) gconf-editor /desktop/gnome/peripherials/keyboard/host-tvoje_meno-desktop/numlock_on
tak pak stačí zatrhnout u položky numlock políčko hodnota
Ubuntu 11.10 "Oneiric Ocelot" 64-bit, Asus F3Tc AP087 - AMD Turion64 2.2GHz, 2GB RAM, Geforce Go 7300 (NVIDIA Driver Version: 173.14.30)

regine

  • Stálý člen
  • ***
  • Příspěvků: 621
  • Karma: +22/-3
    • Zobrazit profil
Re: aktivace NumLock v Ubuntu 8.10 - GNOME
« Odpověď #4 kdy: 11 Březen 2009, 06:42:42 »
(Alt+F2) gconf-editor /desktop/gnome/peripherials/keyboard/host-tvoje_meno-desktop/numlock_on
jsem zkusil teprve včera (nebyl čas), ale řeší zapnutí zapnutí čí vypnutí klávesy NumLock až po přihlášení do GNOME.

Já bych potřeboval mít aktivní NumLock už při přihlašování k účtu.
Řeší to možná na:
http://ubuntuguide.org/wiki/Ubuntu:Intrepid
téma: Enabling NUM LOCK On Startup
System -> Administration -> Keyboard & Mouse -> Keyboard ->"turn on Numlock on Startup"
ale v mé verzi GNOME (české) to není dostupné.
V menu mám jen "klávesnice" a odděleně "myš".
V okénku "klávesnice" jsem nenašel něco jako "turn on Numlock on Startup".
Ubuntu 16.04 LTS 32bit

regine

  • Stálý člen
  • ***
  • Příspěvků: 621
  • Karma: +22/-3
    • Zobrazit profil
aktivace NumLock v Ubuntu 8.10 - GNOME - vyřešeno
« Odpověď #5 kdy: 22 Březen 2009, 10:29:44 »
* spustit terminal
* vlozit a spustit 3 prikazy:
sudo apt-get install numlockx
sudo cp /etc/gdm/Init/Default /etc/gdm/Init/Default_backup
gksudo gedit /etc/gdm/Init/Default


* najit radek
...
exit 0

* pred tento radek "exit 0"  vlozit prikazy:
if [ -x /usr/bin/numlockx ]; then
/usr/bin/numlockx on
fi

**************************************************
Celý problém byl ve změně umístění souboru "Default"
ve verzi Ubuntu 7.04 Feis Fawn
/etc/X11/gdm/Init/
ve verzi Ubuntu 8.10 - Intrepid Ibex, GNOME Panel 2.24.1
/etc/gdm/Init/
Ubuntu 16.04 LTS 32bit

regine

  • Stálý člen
  • ***
  • Příspěvků: 621
  • Karma: +22/-3
    • Zobrazit profil
Re: aktivace NumLock v Ubuntu 8.10 - GNOME [vyřešeno]
« Odpověď #6 kdy: 28 Květen 2010, 23:44:28 »
Po update Ubuntu 9.10 Karmic Koala ze dne 28.5.2010 nutno použít:
Kód: [Vybrat]
sudo cp /etc/gdm/Init/Default /etc/gdm/Init/Default_backup
gksudo gedit /etc/gdm/Init/Default
Řešení je z:
https://help.ubuntu.com/community/NumLock
Adresář již neobsahoval soubor /etc/gdm/Init/Default (původní řešení).
Ubuntu 16.04 LTS 32bit

bambulko

  • Člen
  • **
  • Příspěvků: 113
  • Karma: +3/-3
    • Zobrazit profil
Re: aktivace NumLock v Ubuntu 8.10 - GNOME
« Odpověď #7 kdy: 07 Listopad 2010, 17:53:10 »
ahojte
neviem preco, ale z nicoho-nic sa mi stalo, ze sa mi vypina numlock. zapnem, kliknem na nejake otvorene okno a numlock sa vypne. zapnem, kliknem na ine okno a znovu ... numlock sa vypne. skusil som aj toto:

Spusti (Alt+F2) gconf-editor /desktop/gnome/peripherials/keyboard/host-tvoje_meno-desktop/numlock_on

akonahle zaskrtnem numlock_on, numlock sa zapne, ale ked zavriem editor znovu zhasne. po opatovnom otvoreni editoru je numlock_on zase nezaskrtnute ;( zjavne sa to nejak nezapise. mozno sa pokaslali prava. v ktorom subore to mam hladat?

diky
FUJITSU; Ubuntu 12.04