Prosíme přihlašte se nebo zaregistrujte.

Přihlašte se svým uživatelským jménem a heslem.

Autor Téma: Problém s aktualizací Wine z repozitáře  (Přečteno 1343 krát)

Rover623

Problém s aktualizací Wine z repozitáře
« kdy: 16 Červen 2013, 19:51:15 »
V repozitáři pro aktuální verzi Wine
Kód: [Vybrat]
ppa:ubuntu-wine/ppa se momentálně vyskytuje poškozený balík pro verzi 1.6 a 1.5, který znemožňuje aktuální verzi nainstalovat.

Doporučuji vyčkat a neaktualizovat stávající verzi (pokud máte Wine 1.5 a vyšší z repozitáře). Těm kterým už se podařilo aktualizovat a nyní mají v systému částečně povýšené Wine (rozbité závislosti), nezbývá než se dočasně vrátit na verzi 1.4.1
Kód: [Vybrat]
sudo apt-get install wine1.4
EDIT: Pro ty co mají v systému poškozenou verzi Wine 1.6 nebo pro ty co se nechtějí dočasně vrátit na verzi 1.4, existuje způsob za použití "síly".

Pokud tedy máte v systému nedokončenou instalaci nebo upgrade Wine 1.6, spusťte tenhle příkaz
Kód: [Vybrat]
sudo apt-get -o Dpkg::Options::="--force-overwrite" -f install Ostatní co chtějí nainstalovat Wine 1.6 nechť postupují takto
Kód: [Vybrat]
sudo apt-get update
sudo apt-get install wine
sudo apt-get -o Dpkg::Options::="--force-overwrite" -f install

Postup jsem zkoušel, ale výše uvedené je na vlastní nebezpečí!

EDIT2: Dnes (tj. 18.6. 2013) došlo k opravě poškozeného balíku a lze provést normální instalaci Wine 1.6.

Kdo použil výše popsaný postup s použitím "síly", tomu pravděpodobně aktualizace selže, je nutné poté spustit příkaz
Kód: [Vybrat]
sudo apt-get install -f
« Poslední změna: 18 Červen 2013, 14:16:26 od Rover623 »