Prosíme přihlašte se nebo zaregistrujte.

Přihlašte se svým uživatelským jménem a heslem.

Novinky: Školení nejen k OS Ubuntu pro širokou veřejnost, více informací zde.

Autor Téma: Nastavení zvukovky jako default  (Přečteno 705 krát)

Le_Ze

  • Návštěvník
  • *
  • Příspěvků: 90
  • Karma: +1/-0
    • Zobrazit profil
Nastavení zvukovky jako default
« kdy: 24 Srpen 2015, 08:53:14 »
Zdravím.
I když řeším problém na mém raspberry s raspbianem, možná poradíte.
Přidal jsem si USB zvukovku.

Kód: [Vybrat]
pi@raspberrypi ~ $ aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: Set [C-Media USB Headphone Set], device 0: USB Audio [USB Audio]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: ALSA [bcm2835 ALSA], device 0: bcm2835 ALSA [bcm2835 ALSA]
  Subdevices: 8/8
  Subdevice #0: subdevice #0
  Subdevice #1: subdevice #1
  Subdevice #2: subdevice #2
  Subdevice #3: subdevice #3
  Subdevice #4: subdevice #4
  Subdevice #5: subdevice #5
  Subdevice #6: subdevice #6
  Subdevice #7: subdevice #7
card 1: ALSA [bcm2835 ALSA], device 1: bcm2835 ALSA [bcm2835 IEC958/HDMI]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

Takto přes ní nahrávám    arecord -D plughw:0,0 -f cd test.wav
Takto přes ní přehrávám   aplay -D plughw:0,0 test.wav

Jak vysvětlit systému, že chci tuto zvukovku jako default.
Abych nemusel zadávat ty parametry a moh přes ní přehravat pomoci aplay test.wav

Toto jsem už zkoušel a nefunguje.
http://plugable.com/2014/11/06/how-to-switch-to-usb-audio-on-raspberry-pi

Nebo úplně zakalazat tu na desce?
Děkují za jakoukoliv radu, která mi pomůže vyřešit můj problém
« Poslední změna: 24 Srpen 2015, 08:55:14 od Le_Ze »

GdH

  • Moderátor
  • Závislák
  • *****
  • Příspěvků: 3045
  • Karma: +484/-17
    • Zobrazit profil
    • GdH-Notes
Re:Nastavení zvukovky jako default
« Odpověď #1 kdy: 24 Srpen 2015, 12:03:31 »
Pořádně zkontroluj, žes někde neudělal chybu, podívej se ještě třeba sem, kde je alsa popsán podrobně.
Každopádně, než na to přijdeš, můžeš si udělat aliasy, abys to nemusel psát celé.

Le_Ze

  • Návštěvník
  • *
  • Příspěvků: 90
  • Karma: +1/-0
    • Zobrazit profil
Re:Nastavení zvukovky jako default
« Odpověď #2 kdy: 24 Srpen 2015, 17:55:44 »
Už jsem to několikrát kontroloval.
Kód: [Vybrat]
# autoloader aliases
install sound-slot-0 /sbin/modprobe snd-card-0
install sound-slot-1 /sbin/modprobe snd-card-1
install sound-slot-2 /sbin/modprobe snd-card-2
install sound-slot-3 /sbin/modprobe snd-card-3
install sound-slot-4 /sbin/modprobe snd-card-4
install sound-slot-5 /sbin/modprobe snd-card-5
install sound-slot-6 /sbin/modprobe snd-card-6
install sound-slot-7 /sbin/modprobe snd-card-7
# Cause optional modules to be loaded above generic modules
install snd /sbin/modprobe --ignore-install snd && { /sbin/modprobe --quiet snd-ioctl32 ; /sbin/modprobe --quiet snd-seq ; }
install snd-rawmidi /sbin/modprobe --ignore-install snd-rawmidi && { /sbin/modprobe --quiet snd-seq-midi ; : ; }
install snd-emu10k1 /sbin/modprobe --ignore-install snd-emu10k1 && { /sbin/modprobe --quiet snd-emu10k1-synth ; : ; }
# Assign USB Audio as default sound card
options snd_usb_audio index=0
options snd_bcm2835 index=1
# Prevent abnormal drivers from grabbing index 0
options bt87x index=-2
options cx88_alsa index=-2
options snd-atiixp-modem index=-2
options snd-intel8x0m index=-2
options snd-via82xx-modem index=-2
# Keep snd-pcsp from beeing loaded as first soundcard
options snd-pcsp index=-2
aliasy nepomůže.
Zkouším voicecommand.
Mikrofon jde u něj v setupu nastavit.
Výstup však furt použivá defalt na desce.