Prosíme přihlašte se nebo zaregistrujte.

Přihlašte se svým uživatelským jménem a heslem.

Autor Téma: Jak aktualizovat Ubuntu 14.04  (Přečteno 1004 krát)

Iwo

  • Člen
  • **
  • Příspěvků: 378
  • Karma: +16/-4
    • Zobrazit profil
Jak aktualizovat Ubuntu 14.04
« kdy: 02 Říjen 2015, 19:06:15 »
Ahoj, mam puvodni Ubuntu 14.04 a chtel jsem ho zaktualizovat na novejsi 14.04.3 vcetne jadra a X-ek.

https://wiki.ubuntu.com/Kernel/LTSEnablementStack

Nasel jsem si na netu prikazy:

Kód: [Vybrat]
sudo apt-get install --install-recommends linux-generic-lts-vivid xserver-xorg-core-lts-vivid xserver-xorg-lts-vivid xserver-xorg-video-all-lts-vivid xserver-xorg-input-all-lts-vivid libwayland-egl1-mesa-lts-vivid

ale vypsalo to:

Kód: [Vybrat]
Některé balíky nemohly být instalovány. To může znamenat, že požadujete
nemožnou situaci, nebo, pokud používáte nestabilní distribuci, že
vyžadované balíky ještě nebyly vytvořeny nebo přesunuty z Příchozí fronty.
Následující informace vám mohou pomoci vyřešit tuto situaci:

Následující balíky mají nesplněné závislosti:
 libqt5gui5 : Závisí na: libgbm1 (>= 8.1~0) ale nebude se instalovat
              Závisí na: libgles2-mesa (>= 7.8.1) nebo
                           libgles2
 libubuntu-application-api-mirserver1 : Závisí na: libmirserver18 (>= 0.1.8+14.04.20140408.1) ale nebude se instalovat
 libunity-mir1 : Závisí na: libmirserver18 (>= 0.1.8+14.04.20140411) ale nebude se instalovat
 qtdeclarative5-qtmultimedia-plugin : Závisí na: libqt5multimedia5-plugins ale nebude se instalovat
E: Chyba, pkgProblemResolver::Resolve vytváří poruchy, to může být způsobeno podrženými balíky.

Pak jsem zjistil, ze bych asi potreboval toto:

Kód: [Vybrat]
sudo apt-get install --install-recommends linux-generic-lts-vivid xserver-xorg-core-lts-vivid xserver-xorg-lts-vivid xserver-xorg-video-all-lts-vivid xserver-xorg-input-all-lts-vivid libwayland-egl1-mesa-lts-vivid libgl1-mesa-glx-lts-vivid libgl1-mesa-glx-lts-vivid:i386 libglapi-mesa-lts-vivid:i386

Ale nepomohl jsem si:

Kód: [Vybrat]
Některé balíky nemohly být instalovány. To může znamenat, že požadujete
nemožnou situaci, nebo, pokud používáte nestabilní distribuci, že
vyžadované balíky ještě nebyly vytvořeny nebo přesunuty z Příchozí fronty.
Následující informace vám mohou pomoci vyřešit tuto situaci:

Následující balíky mají nesplněné závislosti:
 account-plugin-facebook : Závisí na: libaccount-plugin-generic-oauth ale nebude se instalovat nebo
                                        ubuntu-system-settings-online-accounts ale nebude se instalovat
 account-plugin-google : Závisí na: libaccount-plugin-google ale nebude se instalovat nebo
                                      ubuntu-system-settings-online-accounts ale nebude se instalovat
 libqt5gui5 : Závisí na: libgbm1 (>= 8.1~0) ale nebude se instalovat
              Závisí na: libgles2-mesa (>= 7.8.1) nebo
                           libgles2
E: Chyba, pkgProblemResolver::Resolve vytváří poruchy, to může být způsobeno podrženými balíky.

Jak to vyresit, abych zaktualizoval? (dekuji)

Edit: Jsem se koukal:

Mam pritom nainstalovanou libgbm1 i libgles2-mesa verzi 11.0.1
a libaccount-plugin-google a libaccount-plugin-generic-oauth mam taky nainstalovane, tak proc to hlasi, ze nebude instalovat a ze to na tom zavisi?
Jo a problemove baliky v synapticu nemam.
« Poslední změna: 02 Říjen 2015, 19:37:25 od Iwo »

marun

  • Stálý člen
  • ***
  • Příspěvků: 601
  • Karma: +43/-2
    • Zobrazit profil
Re:Jak aktualizovat Ubuntu 14.04
« Odpověď #1 kdy: 02 Říjen 2015, 20:09:06 »
nemáš tam nějaké ppa? podle těch verzí ano
to ppa má stejně novjejší verze než to čím to chceš nahradit, aktualizuj jen jádro
 

Iwo

  • Člen
  • **
  • Příspěvků: 378
  • Karma: +16/-4
    • Zobrazit profil
Re:Jak aktualizovat Ubuntu 14.04
« Odpověď #2 kdy: 02 Říjen 2015, 23:05:43 »
Tak ti teda dekuju, ted jsem zase za blbce.  :-[

Ale fakt dik.  Jsem nejak vypnul, hlavne ze jsem chtel aktualizovat. :)

Takze jasne, mam tam repozitar na nove Xorg, takze stacilo dat aktualizaci jen jadra.