Prosíme přihlašte se nebo zaregistrujte.

Přihlašte se svým uživatelským jménem a heslem.

Autor Téma: Gimp 2.10 - chyba otvírání souborů  (Přečteno 2919 krát)

Rellik

  • Člen
  • **
  • Příspěvků: 118
  • Karma: +3/-0
    • Zobrazit profil
    • dv-foto
Gimp 2.10 - chyba otvírání souborů
« kdy: 15 Únor 2019, 17:17:21 »
Zdravím vespolek. Nainstaloval jsem si nový gimp (pomocí Flatpak), a má problém s otvíráním souborů. které mám na jiném disku než je systém. Pokud klepnu na obrázek pravým myšítkem mám na výběr dvě ikonky gimpu (starou verzi jsem před instalací nové odinstaloval). Ta první je ten nový gimp co už je jen jedno okno. Po kliknutí se gimp otevře s hláškou že soubor neexistuje. Pokud vyberu tu druhou ikonku, tak se spustí 3 panelový gimp a fotku normálně otevře. Přitom u obou v informacích o gimpu je že je to stejná verze...  Poradí někdo jak to rozchodit?
Ještě dodám, že pokud chci v tom  jednopanelovém gimpu otevřít obrázek a začnu od rootu /, tak ten disk (data) není viditelný...

Systém Kubuntu 18.04
Není nic co by nebylo možné, stačí jen najít tu správnou cestu.
http://dv-foto.cz
PC: i3-6100, 12Gb DDR4, Mainboard Asus H110IPLUS, GK Asus GT1030-SL-2G-BRK, HDD SSD Crucial 128Gb (systém) + HDD Seagate Barracuda 1Tb (data).

juwa2

  • Závislák
  • ****
  • Příspěvků: 3028
  • Karma: +219/-39
    • Zobrazit profil
Re:Gimp 2.10 - chyba otvírání souborů
« Odpověď #1 kdy: 15 Únor 2019, 18:19:19 »
1. Podívej se do obsahu těch dvou spouštěčů - ať je jasné co vlastně spouštíš..
2. Původní Gimp jsi neodinstaloval kompletně - měl jsi použít
Kód: [Vybrat]
sudo apt-get --purge remove gimp
3. Aplikace instalované jako snap/flatpack mají v základu omezen přístup pouze k souborům v domovské složce
(confinment).
U snapu se to řeší parametrem --classic, u flatpaku to bude určitě podobné, to už si zjisti sám..
--------------------------------------------------------------------------------------------------------------------------------------
Nicméně raději se tomuto způsobu instalace vyhni a použij klasický PPA
http://ubuntuhandbook.org/index.php/2018/04/how-to-install-gimp-2-10-in-ubuntu-18-04-17-10-via-ppa/
Napřed ale flatpak verzi odinstaluj. Ušetříš si spoustu starostí....
« Poslední změna: 15 Únor 2019, 18:36:46 od juwa2 »

Rellik

  • Člen
  • **
  • Příspěvků: 118
  • Karma: +3/-0
    • Zobrazit profil
    • dv-foto
Re:Gimp 2.10 - chyba otvírání souborů
« Odpověď #2 kdy: 15 Únor 2019, 19:12:32 »
To že to má omezení jen na domovskou složku jsem bohužel nevěděl. Dá se to nějak rozumně odinstalovat?

Kód: [Vybrat]
flatpak uninstall org.gimp.GIMP Sice napsalo, že je gimp odinstalovaný, ale stále jde pustit.
Pokud dám
Kód: [Vybrat]
apt-get remove gimpTak to zase napíše, že gimp není nainstalovaný.
:(
Není nic co by nebylo možné, stačí jen najít tu správnou cestu.
http://dv-foto.cz
PC: i3-6100, 12Gb DDR4, Mainboard Asus H110IPLUS, GK Asus GT1030-SL-2G-BRK, HDD SSD Crucial 128Gb (systém) + HDD Seagate Barracuda 1Tb (data).

juwa2

  • Závislák
  • ****
  • Příspěvků: 3028
  • Karma: +219/-39
    • Zobrazit profil
Re:Gimp 2.10 - chyba otvírání souborů
« Odpověď #3 kdy: 15 Únor 2019, 22:30:59 »
1. Dej sem výpis spouštěče kterým jde Gimp spustit. Ať víme, co vlastně spouštíš....
2. Asi to budeš muset "odinstalovat" ručně (= smazat přísl. soubory).
3. Můžeš odstranit celý ten "nesmysl" = balík flatpak
4. Odstraň všechny flatpak spouštěče.
5. Nainstaluj Gimp z PPA viz výše....
--------------------------------------------------------------------------------------------------------------------
P.S.  Pokud si do google zadáš pojem "ubuntu flatpak", najdeš většinou "problémy, problémy, potíže". Skoro jako u W10, ty samozř. vedou, ale flatpak je hned druhý.... :-\

Rellik

  • Člen
  • **
  • Příspěvků: 118
  • Karma: +3/-0
    • Zobrazit profil
    • dv-foto
Re:Gimp 2.10 - chyba otvírání souborů
« Odpověď #4 kdy: 15 Únor 2019, 22:48:11 »
Nevím jestli je to zrovna ono:
Kód: [Vybrat]
rellik@rellik-System-Product-Name:~$ flatpak list
Ref                                                  Možnosti     
org.freedesktop.Platform.GL.nvidia-390-77/x86_64/1.4 system,runtime
org.freedesktop.Platform.ffmpeg/x86_64/1.6           system,runtime
org.gnome.Platform/x86_64/3.28                       system,runtime
A ten gimp z toho flatpaku, jsem si našel cestu odkud to spouští i po odinstalaci a soubory smazal ručně. Pak už jsem neměl žádný gimp a nainstaloval ho tedy pomocí toho PPA. Můžu teď odinstalovat ten flatpak? Nebo nějak odebrat i ty další tři balíky?

Jinak moc díky za pomoc :)
Není nic co by nebylo možné, stačí jen najít tu správnou cestu.
http://dv-foto.cz
PC: i3-6100, 12Gb DDR4, Mainboard Asus H110IPLUS, GK Asus GT1030-SL-2G-BRK, HDD SSD Crucial 128Gb (systém) + HDD Seagate Barracuda 1Tb (data).

juwa2

  • Závislák
  • ****
  • Příspěvků: 3028
  • Karma: +219/-39
    • Zobrazit profil
Re:Gimp 2.10 - chyba otvírání souborů
« Odpověď #5 kdy: 15 Únor 2019, 23:10:08 »
Přkaz
Kód: [Vybrat]
flatpak list
vypisuje, které (flatpak) balíky máš ještě nainstalované.  Takže moje rada zní:
Těch tří balíků se zbav - odinstaluj je klasicky:
Kód: [Vybrat]
sudo flatpak uninstall org.freedesktop.Platform.GL.nvidia-390-77/x86_64/1.4 system org.freedesktop.Platform.ffmpeg/x86_64/1.6 org.gnome.Platform/x86_64/3.28
a pak se zbav celého slavného flatpaku:
Kód: [Vybrat]
sudo apt-get --purge remove flatpak
A až uvidíš někde instalaci něčeho pomocí flatpak/snap, rychle uteč....

Gimp (a ostatní aplikace) nainstalované z Ubuntu repo nebo přidaných PPA si můžeš užívat dle libosti, s přístupem kamkoli...  ;)
« Poslední změna: 15 Únor 2019, 23:58:11 od juwa2 »

Rellik

  • Člen
  • **
  • Příspěvků: 118
  • Karma: +3/-0
    • Zobrazit profil
    • dv-foto
Re:Gimp 2.10 - chyba otvírání souborů
« Odpověď #6 kdy: 16 Únor 2019, 07:38:49 »
Hotovo... Flatpak = fuj! :D
Moc díky... :)
Není nic co by nebylo možné, stačí jen najít tu správnou cestu.
http://dv-foto.cz
PC: i3-6100, 12Gb DDR4, Mainboard Asus H110IPLUS, GK Asus GT1030-SL-2G-BRK, HDD SSD Crucial 128Gb (systém) + HDD Seagate Barracuda 1Tb (data).

JirkaZ

  • Člen
  • **
  • Příspěvků: 371
  • Karma: +32/-5
    • Zobrazit profil
Re:Gimp 2.10 - chyba otvírání souborů
« Odpověď #7 kdy: 16 Únor 2019, 10:49:49 »
Citace: juwa2
...
A až uvidíš někde instalaci něčeho pomocí flatpak/snap, rychle uteč....

Já bych to neviděl tak černobíle...

Pochopitelně instalace pomocí balíčkovacího systému má v Linuxu vždy nejvyšší prioritu. Prostě proto, že ten systém je propracovaný a dle verze (myslím teď různé distribuce s různými systémy) umí správu software až téměř dokonale... K tomu navíc jako bonus bývá dobrá integrace do operačního systému (i když ne vždy, někdy autor zapomene třeba i na takovou samozřejmost, jakou je přidání daného programu do nabídky spouštění...).

Ale: v určitých situacích se nevyhneme použití něčeho jiného. Zpravidla proto, že potřebujeme nějaký software, který prostě není ani v základním, ani v dalších repozitářích. No a tam je jednoduše potřeba zvládat práci i s jinými způsoby instalace (nebo používání) dané aplikace...

Nejde jen o flatpak/snap/appimage, ale např. i o java aplikace, spouštění rovnou bez instalace a (nikoliv nakonec) i o Wine a odvozené věci (PlayOnLinux, CrossOver, Cedega...). V krajním případě (pro mě - jiní to naopak mají za základ) i o kompilaci ze zdrojového kódu.

Když se budu striktně držet toho, co je v repozitářích, tak si úmyslně omezuju výběr. Občas i značně...
« Poslední změna: 16 Únor 2019, 11:23:42 od JirkaZ »

juwa2

  • Závislák
  • ****
  • Příspěvků: 3028
  • Karma: +219/-39
    • Zobrazit profil
Re:Gimp 2.10 - chyba otvírání souborů
« Odpověď #8 kdy: 16 Únor 2019, 11:13:09 »
I když odhlédnu od ostatních "potíží", tak je to obrovský žrout místa na disku jelikož každá aplikace si všechno "táhne s sebou". Jeden malý příklad. Instalace VLC 3.0 do U14.04 (v repo je pouze verze 2.6) pomocí snap zabere 2GB na disku. Přitom klasická instalace VLC má 30MB.... :-\  Takže tudy opravdu ne...