Prosíme přihlašte se nebo zaregistrujte.

Přihlašte se svým uživatelským jménem a heslem.

Autor Téma: Potřebuji poradit - Vyřešeno  (Přečteno 308 krát)

zdelen

  • Člen
  • **
  • Příspěvků: 139
  • Karma: +8/-3
    • Zobrazit profil
Potřebuji poradit - Vyřešeno
« kdy: 19 Květen 2019, 23:42:27 »
Přeinstaloval jsem počítač a nemohu si vzpomenout jak na Kompozer. Mám Ubuntu 18.04. Stáhl jsem si balíček kompozer-08b3.lt.lt.gcc4.2-i686.tar.gz. Vyzkoušel jsem podle rad kde co a nejde mi stejně nainstalovat. Můžete mi někdo napsat postup instalace?
Děkuji.
« Poslední změna: 21 Květen 2019, 10:35:23 od zdelen »

juwa2

  • Závislák
  • ****
  • Příspěvků: 2867
  • Karma: +205/-38
    • Zobrazit profil
Re:Potřebuji poradit
« Odpověď #1 kdy: 20 Květen 2019, 00:14:36 »
Přeinstaloval jsem počítač a nemohu si vzpomenout jak na Kompozer. Mám Ubuntu 18.04. Stáhl jsem si balíček kompozer-08b3.lt.lt.gcc4.2-i686.tar.gz. Vyzkoušel jsem podle rad kde co a nejde mi stejně nainstalovat. Můžete mi někdo napsat postup instalace?
Děkuji.

No to máš stažený zdroják - napřed ho musíš zkompilovat....

Nebo raději použij tento postup https://help.ubuntu.com/community/InstallKompozer
https://askubuntu.com/questions/767028/install-kompozer-on-ubuntu-16-04
« Poslední změna: 20 Květen 2019, 00:19:03 od juwa2 »

zdelen

  • Člen
  • **
  • Příspěvků: 139
  • Karma: +8/-3
    • Zobrazit profil
Re:Potřebuji poradit
« Odpověď #2 kdy: 20 Květen 2019, 12:25:07 »
Tak jsem použil tu možnas instalace z odkazu a hlásili mi to:
Balík libidl0 není dostupný, ale jiný balík se na něj odkazuje.
To může znamenat že balík chybí, byl zastarán, nebo je dostupný
pouze z jiného zdroje
Nicméně následující balíky jej nahrazují:
  libidl-2-0:i386 libidl-2-0

Balík libpng12-0 není dostupný, ale jiný balík se na něj odkazuje.
To může znamenat že balík chybí, byl zastarán, nebo je dostupný
pouze z jiného zdroje

E: Balík „libidl0“ nemá kandidáta pro instalaci
E: Balík „libpng12-0“ nemá kandidáta pro instalaci
Když jsem celé dokončil, je vytvořena ikona Kompozer, ale nespustí se.
V těch odkazech bylo vždy zmíněna starší verze Ubuntu.

juwa2

  • Závislák
  • ****
  • Příspěvků: 2867
  • Karma: +205/-38
    • Zobrazit profil
Re:Potřebuji poradit
« Odpověď #3 kdy: 20 Květen 2019, 13:24:33 »
Tak jsem použil tu možnas instalace z odkazu a hlásili mi to:
Balík libidl0 není dostupný, ale jiný balík se na něj odkazuje.
To může znamenat že balík chybí, byl zastarán, nebo je dostupný
pouze z jiného zdroje
Nicméně následující balíky jej nahrazují:
  libidl-2-0:i386 libidl-2-0

Balík libpng12-0 není dostupný, ale jiný balík se na něj odkazuje.
To může znamenat že balík chybí, byl zastarán, nebo je dostupný
pouze z jiného zdroje

E: Balík „libidl0“ nemá kandidáta pro instalaci
E: Balík „libpng12-0“ nemá kandidáta pro instalaci
Když jsem celé dokončil, je vytvořena ikona Kompozer, ale nespustí se.
V těch odkazech bylo vždy zmíněna starší verze Ubuntu.

Ano zmíněna starší verze, protože Kompozer pro novější verze neexistuje - musel by sis ho sám zkompilovat ze zdrojáku (= poměrně obtížné...).

Pokud se nějaká aplikace nechce spustit, spusť ji příkazem z Terminálu - vypíše se případná chyba (většinou něco v systému chybí, obvykle nějaká knihovna) a to je i tvůj případ.
Ten cos nainstaloval se nespustí, jelikož v systému chybí potřebné knihovny. Které dvě to jsou už víš. A jelikož nejsou dostupné v repozitáři (U18.04), musíš je sehnat jinde: http://archive.ubuntu.com/ubuntu/pool/main/libi/libidl/libidl0_0.8.14-0.2ubuntu4_amd64.deb
http://archive.ubuntu.com/ubuntu/pool/main/libp/libpng/libpng12-0_1.2.54-1ubuntu1.1_amd64.deb
možná budeš potřebovat 32b verze:
http://archive.ubuntu.com/ubuntu/pool/main/libi/libidl/libidl0_0.8.14-0.2ubuntu4_i386.deb
http://archive.ubuntu.com/ubuntu/pool/main/libp/libpng/libpng12-0_1.2.54-1ubuntu1.1_i386.deb
a doinstalovat. Pokud by to z nějakého důvodu nainstalovat nešlo, balíky zkrátka rozbal a knihovny (vždy i s příslušným odkazem) nakopíruj do přísl. umístění (/usr/lib/x86_64-linux-gnu příp. 32b verze do /usr/lib/i386-linux-gnu)
Pak už by se ti to mohlo podařit spustit.
« Poslední změna: 20 Květen 2019, 14:19:22 od juwa2 »