Prosíme přihlašte se nebo zaregistrujte.

Přihlašte se svým uživatelským jménem a heslem.

Autor Téma: nVidia-smi pro Conky nevrací GPU Utilization  (Přečteno 345 krát)

panRajce

  • Návštěvník
  • *
  • Příspěvků: 53
  • Karma: +0/-0
    • Zobrazit profil
nVidia-smi pro Conky nevrací GPU Utilization
« kdy: 06 Červen 2019, 10:08:14 »
Ahoj,
zkouším hledat, ale marně, tak se zeptám jestli s tím už někdo měl zkušenosti.
V Conky chci vložit zobrazení zatížení (Utilization). Nejprve jsem myslel, že má chybu ve skriptu konfigurace Conky. Pak jsem zjistil, že ani samotné nVidia-smi neukazuje hodnotu pro GPU Utilization. Ostatní proměnné ale je schopna detekovat.
A například utilita nvidia-settings je schopná tuto hodnotu generovat. Takže můj předpoklad je, že to není problém HW (deska ASUS B250 Mining Expert, 2x nVidia GTX 780 TI v PCIe x1).

Někde jsem četl, že nVidia v nvidia-smi zakázala podporu pro karty mimo Quadra, ale to byl příspěvek z 2016.

EDIT: po chvíli hraní s Conky a nvidia-smi a nvidia-settings se zdá lepší používat informace právě z nvidia-setting ..... důvod = v parametrech lze odlišit z které GPU má informace být využita, v případě stroje s vícero GPU je pak snadnější v Conky graficky upravit pro každý kus GPU

Zvládl by někdo poradit co s tím? .... Ano, nouzovka je použít výstup z nvidia-settings.

EDIT 2 (26.8.2019) POTVRZENO, po výměně karet z nVidia 780 Ti na 980 Ti začalo nvidia-smi správně generovat všechny položky, tudíž je to o typu karty. Zastaralé holt SMI nepodporují nebo jen z malé části.
« Poslední změna: 26 Srpen 2019, 13:16:26 od panRajce »