Prosíme přihlašte se nebo zaregistrujte.

Přihlašte se svým uživatelským jménem a heslem.

Novinky: Školení nejen k OS Ubuntu pro širokou veřejnost, více informací zde.

Autor Téma: zobrazování integrované GPU + nVidia CUDA - edit xorg.conf  (Přečteno 155 krát)

panRajce

  • Návštěvník
  • *
  • Příspěvků: 10
  • Karma: +0/-0
    • Zobrazit profil
Ahoj,
mám nyní hotový stroj na desce ASUS B250 Mining Expert s Intel HD GPU a 2x nVidia GeForce GTX 780Ti pro GPu Rendering pod Octane. Momentálně to funguje, i když v nastavení se mi ukazuje, že obraz jde přes GeForce GTX 780Ti, monitor je však pře HDMI zapojen do Intel GPU  :D
Uvažuji o lepším řešení. Tedy aby obraz šel čistě přes Intel iGPU a výpočet CUDA přes všechny 780Ti.
Vygůůglil jsem toto řešení:
https://gist.github.com/alexlee-gk/76a409f62a53883971a18a11af93241b
Než se v tom ale začnu vrtat, tak se chci zeptat, zda je to opravdu správný směr, kterým se vydat?
Samozřejmě s přihlédnutím zadání správných hodnot pro BusID.
Podle jednoho z vláken zde jsem si nechal vygenerovat xorg.conf.new, který mi, mimo jiné, vyhodil tento současný stav:
Kód: [Vybrat]
Section "Device"
Identifier  "Card0"
Driver      "intel"
BusID       "PCI:0:2:0"
EndSection

Section "Device"
Identifier  "Card1"
Driver      "nouveau"
BusID       "PCI:11:0:0"
EndSection

Section "Device"
Identifier  "Card2"
Driver      "nouveau"
BusID       "PCI:13:0:0"
EndSection

Section "Screen"
Identifier "Screen0"
Device     "Card0"
Monitor    "Monitor0"
SubSection "Display"
Viewport   0 0
Depth     1
EndSubSection
SubSection "Display"
Viewport   0 0
Depth     4
EndSubSection
SubSection "Display"
Viewport   0 0
Depth     8
EndSubSection
SubSection "Display"
Viewport   0 0
Depth     15
EndSubSection
SubSection "Display"
Viewport   0 0
Depth     16
EndSubSection
SubSection "Display"
Viewport   0 0
Depth     24
EndSubSection
EndSection

Section "Screen"
Identifier "Screen1"
Device     "Card1"
Monitor    "Monitor1"
SubSection "Display"
Viewport   0 0
Depth     1
EndSubSection
SubSection "Display"
Viewport   0 0
Depth     4
EndSubSection
SubSection "Display"
Viewport   0 0
Depth     8
EndSubSection
SubSection "Display"
Viewport   0 0
Depth     15
EndSubSection
SubSection "Display"
Viewport   0 0
Depth     16
EndSubSection
SubSection "Display"
Viewport   0 0
Depth     24
EndSubSection
EndSection

Section "Screen"
Identifier "Screen2"
Device     "Card2"
Monitor    "Monitor2"
SubSection "Display"
Viewport   0 0
Depth     1
EndSubSection
SubSection "Display"
Viewport   0 0
Depth     4
EndSubSection
SubSection "Display"
Viewport   0 0
Depth     8
EndSubSection
SubSection "Display"
Viewport   0 0
Depth     15
EndSubSection
SubSection "Display"
Viewport   0 0
Depth     16
EndSubSection
SubSection "Display"
Viewport   0 0
Depth     24
EndSubSection
EndSection
« Poslední změna: 11 Červen 2019, 20:44:52 od panRajce »

Gmisiycs

  • Člen
  • **
  • Příspěvků: 237
  • Karma: +11/-0
    • Zobrazit profil
    • Helltracker
Re:zobrazování integrované GPU + nVidia CUDA - edit xorg.conf
« Odpověď #1 kdy: 14 Červen 2019, 18:43:09 »
Kdybych se jednou v tomto vyznal alespoň z 10%, mohl bych Vás kontaktovat pro dořešení zbytků? Myslím to naprosto vážně.
R.I.P. Trusty Tahr - nezapomenu...

panRajce

  • Návštěvník
  • *
  • Příspěvků: 10
  • Karma: +0/-0
    • Zobrazit profil
Re:zobrazování integrované GPU + nVidia CUDA - edit xorg.conf
« Odpověď #2 kdy: Včera v 13:54:20 »
Kdybych se jednou v tomto vyznal alespoň z 10%, mohl bych Vás kontaktovat pro dořešení zbytků? Myslím to naprosto vážně.

Jaké zbytky máte namysli?  :) Chybí vám nějaké další informace? Rád dodám budu-li vědět co je potřeba.

Nebo se alespoň pokusím. Jelikož jsem vlastní blbostí dal na radu uživatele z jiného fóra a zkusil jedoduše v Nvidia-Settings přepnout z NVIDIA (Performance Mode) na Intel (PowerSawing Mode). Tím došlo k destabilizaci, v nvidia-settings zmizely všechny karty nVidia a do Ubuntu se je schopné přihlásit jenom pod Waylandem (doteď jsem fungoval pod x11). Tam ale nefungují určité síťové služby, především pak právě Octane-slave-daemon, aplikace pro GPU rendring v síti.
Při zpětném přepnutí na Performance Mode ale bohužel nVidia-setting karty stále nevidí. Bude nutná nějaká čistá reinstalace ovladačů nvidia včetně nvidia-settings.