Prosíme přihlašte se nebo zaregistrujte.

Přihlašte se svým uživatelským jménem a heslem.

Autor Téma: nescanuje  (Přečteno 1999 krát)

Petr Bartoš

  • Návštěvník
  • *
  • Příspěvků: 6
  • Karma: +0/-0
    • Zobrazit profil
nescanuje
« kdy: 16 Červenec 2019, 07:58:48 »
Dobrý den, mám ubuntu 18.04 a multifunkční epson aculaser cx17 no a ten mi nescanuje, nenalezen. Už jsem zkusil tolik, že si už ani nepamatuji co, a pořád nic. Nejsem IT, jen trochu lama, ani nevím jaké údaje sem mám poskytnout pro vyřešení mého problému. Díky

JirkaZ

  • Člen
  • **
  • Příspěvků: 362
  • Karma: +31/-5
    • Zobrazit profil
Re:nescanuje
« Odpověď #1 kdy: 16 Červenec 2019, 12:56:57 »

Petr Bartoš

  • Návštěvník
  • *
  • Příspěvků: 6
  • Karma: +0/-0
    • Zobrazit profil
Re:nescanuje
« Odpověď #2 kdy: 23 Červenec 2019, 12:57:53 »
Díky, ale nic. Dle odkazu jsem šel, ovladače na tento typ nejsou pro Linux. Mám je v programech ve Winu. Tiskárna slouží, scaner ne. ~$ lsusb
Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 007 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 006 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 002 Device 003: ID 058f:6366 Alcor Micro Corp. Multi Flash Reader
Bus 002 Device 002: ID 152d:0567 JMicron Technology Corp. / JMicron USA Technology Corp. JMS567 SATA 6Gb/s bridge
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 005 Device 003: ID 0b38:0003 Gear Head Keyboard
Bus 005 Device 005: ID 1c4f:0003 SiGma Micro HID controller
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 002: ID 04b8:0882 Seiko Epson Corp.
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub

víte co dál,prosím.

JirkaZ

  • Člen
  • **
  • Příspěvků: 362
  • Karma: +31/-5
    • Zobrazit profil
Re:nescanuje
« Odpověď #3 kdy: 23 Červenec 2019, 19:01:24 »
Neposkytují ovladač pro Linux, hmmm...

No tak pak smůla. Možná by šlo (zcela bez záruky!) zkusit ovladač pro nějaký příbuzný typ, nebo zkusit Vuescan (i když ten má uvedenou pouze podporu CX-16, 17 nikoliv a je tam snad taky že scanování v Linuxu ne). Navíc je to placený proprietární software.

S Linuxem je to prostě tak, že pokud se pro něj rozhodnu, tak si musím vybírat takový hardware, který má linuxovou podporu (ať už od výrobce, nebo od třetí strany).

Jestli se to vyplatí či ne, to musí každý zvážit sám. Mně už léta ano a jako pozitivní "vedlejší efekt" bývá i to, že po takové filtraci odpadnou různá obskurní (obvykle podezřele levná) zařízení, se kterými by pravděpodobně mohl být problém i jinde...

Petr Bartoš

  • Návštěvník
  • *
  • Příspěvků: 6
  • Karma: +0/-0
    • Zobrazit profil
Re:nescanuje
« Odpověď #4 kdy: 23 Červenec 2019, 20:36:04 »
Jenže v 12.04 to šlo. A běželo to na všem co jsem potkal, Ubuntu mám od roku 2008, na všechny problémy  se vždy našlo řešení. Linux  jsem nacpal do všeho co jsem potkal. Ten problém musí být logicky definovatelný, jsou to jedničky a dvojky. Jenže škol nemám.......kdybych někde našel učebnici abych pochopil ty principy, jenže já ani nevím kde se zeptat. Budu to zkoušet nějak dál. Díky

juwa2

  • Závislák
  • ****
  • Příspěvků: 3003
  • Karma: +219/-39
    • Zobrazit profil
Re:nescanuje
« Odpověď #5 kdy: 23 Červenec 2019, 22:07:00 »
Jenže v 12.04 to šlo. A běželo to na všem co jsem potkal, Ubuntu mám od roku 2008, na všechny problémy  se vždy našlo řešení. Linux  jsem nacpal do všeho co jsem potkal. Ten problém musí být logicky definovatelný, jsou to jedničky a dvojky. Jenže škol nemám.......kdybych někde našel učebnici abych pochopil ty principy, jenže já ani nevím kde se zeptat. Budu to zkoušet nějak dál. Díky

Je to záležitost driveru. Drivery jsou obsaženy v kernelu. Různé kernely obsahují různé drivery >> zkus jiný (novější/starší) kernel https://kernel.ubuntu.com/~kernel-ppa/mainline/?C=N;O=D

Petr Bartoš

  • Návštěvník
  • *
  • Příspěvků: 6
  • Karma: +0/-0
    • Zobrazit profil
Re:nescanuje
« Odpověď #6 kdy: 23 Červenec 2019, 22:44:18 »
Jadro mám aktualizované, starší mažu, nechávám jedno pro případ problému, už se mi to hodilo. Ale co závislosti?

juwa2

  • Závislák
  • ****
  • Příspěvků: 3003
  • Karma: +219/-39
    • Zobrazit profil
Re:nescanuje
« Odpověď #7 kdy: 24 Červenec 2019, 00:25:19 »
Jadro mám aktualizované, starší mažu, nechávám jedno pro případ problému, už se mi to hodilo. Ale co závislosti?

Závislosti (balíků) nemají s verzí kernelu co dělat.
Zkus se vrátit na tu verzi (kernelu), ve které ti to fungovalo (odhadneš podle verze U).

JirkaZ

  • Člen
  • **
  • Příspěvků: 362
  • Karma: +31/-5
    • Zobrazit profil
Re:nescanuje
« Odpověď #8 kdy: 24 Červenec 2019, 10:08:08 »
Jenže v 12.04 to šlo. ...

No to je zvláštní... Co znamená že to šlo? Bez dodatečného ovladače? A v jakém programu (xsane nebo jiném)?

Zkusil bych někam (na samostatnou partition, na jiný disk...) nainstalovat 12.04 (http://releases.ubuntu.com/12.04/), zprovoznil bych scanner  a podíval se tam (do systému přes závislosti atd.), jak je to řešené...

Hanz55

  • Návštěvník
  • *
  • Příspěvků: 38
  • Karma: +0/-0
    • Zobrazit profil
Re:nescanuje
« Odpověď #9 kdy: 28 Červenec 2019, 17:25:39 »
V programu UKUU se dají lehce měnit kernely.

juwa2

  • Závislák
  • ****
  • Příspěvků: 3003
  • Karma: +219/-39
    • Zobrazit profil
Re:nescanuje
« Odpověď #10 kdy: 28 Červenec 2019, 22:59:17 »
V programu UKUU se dají lehce měnit kernely.

To ano, pouze dodám, že nové verze ukuu přešly na placený model.  :-[
Nicméně starší (free) verze ukuu (18.9) stále funguje.  Krom toho lze kernely instalovat klasicky ručně (jako balíky .deb) odtud https://kernel.ubuntu.com/~kernel-ppa/mainline/?C=N;O=D

Je třeba stáhnout/nainstalovat příslušné čtyři balíky viz obrázek.
Odinstalaci starých/nepotřebných kernelů lze provést buď pomocí Synaptic nebo Ubuntu-Tweak/Ubuntu-Cleaner.

Nicméně uznávám, že pomocí ukuu je to celé pohodlnější/snažší. Ale zase licence přijde na pětikilo.....
« Poslední změna: 28 Červenec 2019, 23:05:04 od juwa2 »