Fórum Ubuntu.cz

Ubuntu pro osobní počítače => Pracovní prostředí => Téma založeno: Janslav 25 Srpen 2018, 16:03:36

Název: Blokování klávesy Caps Lock (Vyřešeno)
Přispěvatel: Janslav 25 Srpen 2018, 16:03:36
Při přechodu na Lubuntu 18.04.1 LTS (64) mi přestalo fungovat blokování klávesy Caps Lock.
Dříve v 16.04 jsem používal příkaz "xkbset nullify lock" zapsaný v Výchozích programech pro LxSession-Automatické spouštění-Ručně, to v 18přestalo fungovat.
Jak bych mohl trvale zablokovat klávesu Caps Lock v Lubuntu 18 ?
Název: Re:Blokování klávesy Caps Lock
Přispěvatel: juwa2 26 Srpen 2018, 00:22:12
Použij tento příkaz:
Kód: [Vybrat]
setxkbmap -option ctrl:nocaps
Jen pro úplnost - zapnutí Caps Locku (obnovení vých. stavu) je příkazem:
Kód: [Vybrat]
setxkbmap -option
 ;)
Název: Re:Blokování klávesy Caps Lock
Přispěvatel: Janslav 26 Srpen 2018, 08:50:11
OK, ale kam ten příkaz mám dát ? Pokud jej spustím z terminalu (i jako root), tak to nefunguje - příkaz se zdánlivě bez chyby provede, ale Caps Lock funguje vesele dál...
Název: Re:Blokování klávesy Caps Lock
Přispěvatel: juwa2 26 Srpen 2018, 10:33:00
Příkaz se dává (potom) do Aplikací po spuštění, jinak by po restartu toto nastavení "zmizelo".
--------------------------------
Ale základ je, aby příkaz neprve fungoval z Terminálu. A není ho rozhodně nutné spouštět jako root...
Zadáváš ho správně?
Je divné, že ti nefunguje, mě to na stejném OS funguje, schválně jsem to zkoušel. Zdá se, že máš v systému nějakou chybu (spíše nekompatibilitu OS s HW), protože i ten tvůj první příkaz by měl fungovat. Jiné věci týkající se klávesnice ti fungují? Např. přepínání rozložení (jazyků)?
--------------------------------------------------------------------
Zkus nabootovat live a vyzkoušej příkaz v něm.
Název: Re:Blokování klávesy Caps Lock
Přispěvatel: Janslav 26 Srpen 2018, 11:05:26
Přepínání jazyků CZ-US mi funguje normálně a i klávesnice CZ nebo US. Nějaký jiný nápad co vyzkoušet (mimo Live instalaci) ?
Název: Re:Blokování klávesy Caps Lock
Přispěvatel: Janslav 26 Srpen 2018, 11:55:05
Ještě dále:

příkaz:  xmodmap -e "keycode 66 = Shift_L NoSymbol Shift_L"   zadaný z terminalu funguje (vypíná Caps Lock), zatímco tentýž zadaný do Automatické spouštění nefunguje.

Ale příkaz: setxkbmap -option ctrl:nocaps nefunguje ani z terminalu ani v Automatickém spouštění.

Není to trochu divné ?
Název: Re:Blokování klávesy Caps Lock
Přispěvatel: juwa2 26 Srpen 2018, 11:56:38
Live není instalace. Nechápu, proč už jsi to nezkusil.....
Nic jiného nevymyslíš. Pokud to tam půjde, znamená to že máš chybu v systému a čeká tě reinstalace. Pokud to nepůjde ani tam, nejedná se o chybu ve tvé instalaci ale buď o chybu HW nebo spíše o již zmíněnou nekompatibilitu OS/HW. Pak jedině zkusit jiné distro (různá distra obsahují jiné drivery) či kernel. A vždy napřed vyzkoušet v live režimu, pokud to nebude fungovat, nemá smysl instalovat. Záleží na tobě kolik úsilí/času tomu hodláš věnovat...
Název: Re:Blokování klávesy Caps Lock
Přispěvatel: juwa2 26 Srpen 2018, 12:03:47
Ještě dále:

příkaz:  xmodmap -e "keycode 66 = Shift_L NoSymbol Shift_L"   zadaný z terminalu funguje (vypíná Caps Lock), zatímco tentýž zadaný do Automatické spouštění nefunguje.

Ale příkaz: setxkbmap -option ctrl:nocaps nefunguje ani z terminalu ani v Automatickém spouštění.

Není to trochu divné ?

No pokud ti funguje aspoň nějaký příkaz (v Terminálu), máš "vyhráno"....
Vytvoř si jednoduchý skript, příkaz napiš do něj, skript (pojmenuj ho třeba capslock_off.sh, nezapomeň mu nastavit spustitelnost) a někam si ho ulož.
Potom do Autom. spouštění místo příkazu napiš cestu k tomu skriptu. Hotovo.  ;)
Název: Re:Blokování klávesy Caps Lock
Přispěvatel: Janslav 26 Srpen 2018, 13:06:29
Skript jsem dle návodu vytvořil, když jej spustím samostatně, tak funguje (zablokuje Caps Lock). Pokud ale dám jeho celou adresu vč., jména filu do Automat. spuštění, pak to (po restartu) nefunguje.
Nemohl bych to dát někam jinam ?

Asi se na to už ale vykašlu, blokování Caps Locku není zas tak podstatné.
Ale je zajímavé, že v Lubuntu 16 tohle fungovalo. Můj přechod na 18.04.1 byl asi poněkud ukvapený.
Název: Re:Blokování klávesy Caps Lock
Přispěvatel: juwa2 26 Srpen 2018, 13:30:16
1. A kam jinam bys ho chtěl dávat? Spíš jestli tu cestu nezadáváš blbě, např. to nefunguje s tildou (~)....
2. Snad neshoříš na takové banální věci jako je spouštění skriptu po přihlášení... :-\
Název: Re:Blokování klávesy Caps Lock
Přispěvatel: Janslav 26 Srpen 2018, 16:01:08
Tak to máme asi každý jiné grafické prostředí. Já mám Lubuntu 18.04.1 s Lxde, v něm jsem žádné menu "Předvolby aplikací spouštěných při přihlášení" dle Vašeho obrázku  nenalezl, mám tam jenom "Nastavení Lx Session" a v něm "Automatické spuštění", a v něm "Ručně spuštěné aplikace". Do toho jsem ten příkaz dal a v tom nechodí.

Jinak ten spustitelný soubor mi chodí OK když ho zadám z terminalu, tak je asi dobře.
Název: Re:Blokování klávesy Caps Lock
Přispěvatel: juwa2 26 Srpen 2018, 17:06:37
Prostředí máme sice jiné, ale na principu to nic nemění - je to podobné ve všech "buntu".
A abys nebyl schopen dát příkaz/skript do "Spouštění po přihlášení" ať už se to u tebe nazývá jakkoli je tedy unikát.... :-\
---------------------------------------
Otevři si v textovém editoru soubor
Kód: [Vybrat]
~/.config/lxsession/LXDE/autostart
a na nový řádek napiš ten příkaz nebo tu cestu k tomu skriptu a soubor ulož.
Název: Re:Blokování klávesy Caps Lock
Přispěvatel: Janslav 26 Srpen 2018, 17:41:45
Při otevření Autostartu jsem zjistil, že cesta k tomu skriptu a jeho spuštění tam už je zapsaná, zřejmě přenesená z Automatického spouštění/Nastavení LX Session.

Problém je ale v tom, že se to po startu počítače z nějakých důvodů neprovede.
Název: Re:Blokování klávesy Caps Lock
Přispěvatel: juwa2 26 Srpen 2018, 17:57:28
Při otevření Autostartu jsem zjistil, že cesta k tomu skriptu a jeho spuštění tam už je zapsaná, zřejmě přenesená z Automatického spouštění/Nastavení LX Session.

Problém je ale v tom, že se to po startu počítače z nějakých důvodů neprovede.

Napiš sem tu cestu.
A má ten skript nastavenou spustitelnost?
Název: Re:Blokování klávesy Caps Lock
Přispěvatel: Janslav 27 Srpen 2018, 08:43:05
Soubor Autostart je ve větvi /home/jan/.config/lxsession/Lubuntu a není spustitelný. Má v sobě pouze 3 řádky:

numlockx
setxkbmap -layout cz,us
/home/jan/Veřejné/capslock-off.sh

což jsou zřejmě příkazy automaticky přenesené z Automatického nastavení.
Upozorňuji ale, že soubor se vytvořil sám při instalaci systému resp při jeho spuštění.
Název: Re:Blokování klávesy Caps Lock
Přispěvatel: TIBOR 27 Srpen 2018, 12:56:03
juwa2 sa pytal ci mas nastaveny spustitelny priznak pre ten tvoj skript. Pravy klik na skript(subor na disku, nie ten zapisany riadok), vlastnosti, prava, povolit spustit subor ako program.
Název: Re:Blokování klávesy Caps Lock
Přispěvatel: Janslav 27 Srpen 2018, 14:53:07
Ale ovšem že mám nastavený znak spustitelnosti pro tento můj skript. Taky ten skript funguje když jej spustím z terminalu.
Název: Re:Blokování klávesy Caps Lock
Přispěvatel: juwa2 27 Srpen 2018, 17:06:16
Nevidím důvod proč by ten skript (a jiné) neměl fungovat....
A automatické spuštění nějakého příkazu/skriptu po přihlášení je triviální záležitost, nic světoborného co by se muselo několik dní řešit zde či jinde...
Jo, a v cestě k tomu skriptu se mi nezdá ta diakritika/velká písmena, to nemá systém rád a taky není od věci dávat cestu do uvozovek. Možná je tohle ten kámen úrazu...
Název: Re:Blokování klávesy Caps Lock
Přispěvatel: Janslav 27 Srpen 2018, 17:45:15
Tak jsem skript nazvaný capslock-off.sh přesunul pod /home/jan abych se vyhnul velkým písmenům a diakritice, a žádná změna - cesta ke skriptu je v autostartu správně a stejně při restartu nefunguje, přitom tentýž skript spuštěný z terminalu funguje OK (blokuje Caps Lock resp. mění jej na Shift). Už mne to nebaví, zavřeme tuto diskuzi, zřejmě to nemá jednoduché řešení a navíc je to pouze marginální problém..

Mám z minulosti obdobný problém na notebooku s Lubuntu 16 a klávesou numlock, neměl jsem čas to tehdy nějak důkladněji řešit a tak musím zapínat numlock tlačítkem.

Také je zajímavé, že souborů a také složek se jménem autostart je v systému více (5-6) a bůh ví, který z nich se vlastně provádí při startu systému...

Jinak dík za pomoc.
Název: Re:Blokování klávesy Caps Lock
Přispěvatel: Ventero 27 Srpen 2018, 18:07:56
A co na to jít od jinud - co takhle předefinovat klávesu capslock třeba na další shift?
Název: Re:Blokování klávesy Caps Lock
Přispěvatel: TIBOR 27 Srpen 2018, 18:27:39
Ja by som este skusil do toho skriptu dat pred prikaz dalsi prikaz a to
Kód: [Vybrat]
sleep 10Ide o to ze ten skript sa moze spustat ale az po nom moze system spustit nastavenie/nacitanie toho caps lock.
Název: Re:Blokování klávesy Caps Lock
Přispěvatel: juwa2 27 Srpen 2018, 18:42:41
Ja by som este skusil do toho skriptu dat pred prikaz dalsi prikaz a to
Kód: [Vybrat]
sleep 10Ide o to ze ten skript sa moze spustat ale az po nom moze system spustit nastavenie/nacitanie toho caps lock.

Ano, tohle je docela možné, klidně bych tam dal i 30s...
Název: Re:Blokování klávesy Caps Lock
Přispěvatel: Janslav 27 Srpen 2018, 19:11:24
Dal jsem tam 10 a žádná změna.
Co tam dát něco, co by ukázalo, že se ten autostart skutečně provádí ? A co ?
Název: Re:Blokování klávesy Caps Lock
Přispěvatel: juwa2 27 Srpen 2018, 19:58:36
Dal jsem tam 10 a žádná změna.
Co tam dát něco, co by ukázalo, že se ten autostart skutečně provádí ? A co ?

No tak tam napiš nějaký jiný příkaz, třeba na spuštění txt editoru
Kód: [Vybrat]
leafpad
nebo
Kód: [Vybrat]
notify-send "Ahoj. Jsem příkaz který se spustil."
A pak uvidíš, jestli se skutečně spustí.
Nicméně opravdu nevidím sebemenší důvod proč by se jakýkoli příkaz/skript neměl spustit - sám jich takto spouštím desítky...
Název: Re:Blokování klávesy Caps Lock
Přispěvatel: TIBOR 27 Srpen 2018, 20:25:05
Dal jsem tam 10 a žádná změna.
Co tam dát něco, co by ukázalo, že se ten autostart skutečně provádí ? A co ?
Alebo zapis na disk
Kód: [Vybrat]
echo "ahoj spustil som sa" > ~/kontrola.txtv /home/tvoje_meno by sa mal vytvorit subor kontrola.txt s tym textom.
Název: Re:Blokování klávesy Caps Lock
Přispěvatel: Janslav 28 Srpen 2018, 07:47:02
Udělal jsem jak jste mi poradil, a při startu se žádný soubor kontrola.txt nevytvoří.

To jen potvrzuje moje podezření, že při startu se tímto souborem /home/.config/lxsessionLubuntu/autostart  neprochází, ač by asi mělo.
Název: Re:Blokování klávesy Caps Lock
Přispěvatel: juwa2 28 Srpen 2018, 09:01:28
Máš jako první řádek v tom skriptu shebang?
#!/bin/bash
Název: Re:Blokování klávesy Caps Lock
Přispěvatel: Janslav 28 Srpen 2018, 09:10:26
Ten skript vypadal takto::

#!/bin/sh
# tento skript deaktivuje klávesu Caps Lock
xmodmap -e "keycode 66 = Shift_L NoSymbol Shift_L"
exit 0

Dal jsem tam tedy dle Vás na první řádek :  #!/bin/bash

nevím jaký je v tom rozdíl, ale funguje to stejně...
Název: Re:Blokování klávesy Caps Lock
Přispěvatel: juwa2 28 Srpen 2018, 09:24:47
No, ten skript je OK, horší je to s tím tvým slavným autostartem...
---------------------
Autostartem se přece spouští ve vých. stavu spousta věcí, tak nemůže být problém k nim přidat další - když se spustí ostatní, musí se spustit ta přidaná taky...
---------------------------
Teď jsem kdesi vyčetl že před cestou k tomu skriptu se musí napsat "bash":
Kód: [Vybrat]
bash /home/uživatel/cesta/ke/skript.sh
Název: Re:Blokování klávesy Caps Lock
Přispěvatel: TIBOR 28 Srpen 2018, 12:20:44
Tak mi to nedalo a nainstaloval som lubuntu 18.04 do VB. Autostart naozaj nejde ani cez gui ani priamo zapisom do ~/.config/lxsession/Lubuntu/autostart .
Cize pre Janslav mam len radu googlit a skusat.
Název: Re:Blokování klávesy Caps Lock
Přispěvatel: Janslav 28 Srpen 2018, 16:07:25
Přidal jsem do souboru /home/.config/lxsession/Lubuntu/autostart příkaz na spuštění editoru leafpad, ten se skutečně při startu systému  spustí. Takže tento soubor se při spuštění nějak používá (není ale spustitelný).

Nevím tedy proč se nevykoná příkaz /home/jan/capslock-off.sh zapsaný v témže autostartu.

Přitom capslock-off.sh je spustitelný a obsahuje jen:

#!/bin/bash
# tento skript deaktivuje klávesu Caps Lock
xmodmap -e "keycode 66 = Shift_L NoSymbol Shift_L"
exit 0

a také spuštěný soubor capslock-off.sh samostatně jak z terminalu, tak z PcmanFm funguje OK.
Název: Re:Blokování klávesy Caps Lock
Přispěvatel: juwa2 28 Srpen 2018, 18:17:23
Dej tam sleep 20
Napiš před ten přkaz bash
Kód: [Vybrat]
#!/bin/bash
# tento skript deaktivuje klávesu Caps Lock
sleep 20; bash xmodmap -e "keycode 66 = Shift_L NoSymbol Shift_L"
exit 0

případně ještě takto
Kód: [Vybrat]
#!/bin/bash
# tento skript deaktivuje klávesu Caps Lock
sleep 20; bash "xmodmap -e "keycode 66 = Shift_L NoSymbol Shift_L""
exit 0
Název: Re:Blokování klávesy Caps Lock
Přispěvatel: Janslav 28 Srpen 2018, 23:17:31
Použil jsem obojí - před příkaz xmodmap -e "keycode 66 = Shift_L NoSymbol Shift_L"  jsem dal bash  a potom také jsem dal celý příkaz do uvozovek, bez výsledku, stále se při startu systému se ten příkaz neprovede.

Přitom pokud tam dám např. příkaz leafpad, ten se provádí OK.
Název: Re:Blokování klávesy Caps Lock
Přispěvatel: juwa2 29 Srpen 2018, 00:03:58
Použil jsem obojí - před příkaz xmodmap -e "keycode 66 = Shift_L NoSymbol Shift_L"  jsem dal bash  a potom také jsem dal celý příkaz do uvozovek, bez výsledku, stále se při startu systému se ten příkaz neprovede.

Přitom pokud tam dám např. příkaz leafpad, ten se provádí OK.

A nastavils tam to zpoždění 20s ?
-----------------------------------------------------------------------------------
Pokud to stále nepůjde, spouštěj ten skript přes cron. Do Terminálu zadej:
Kód: [Vybrat]
sudo crontab -e
Otevře se nano s crontabem. Na konec dopiš řádek:
Kód: [Vybrat]
@reboot (sleep 10; sh /home/jan/cesta/capslock-off.sh)

uložit (ctrl+o)
enter
zavřít crontab (ctrl+x)
A můžeš vyzkoušet restart.
Název: Re:Blokování klávesy Caps Lock
Přispěvatel: Ventero 29 Srpen 2018, 07:51:20
A není problém na úrovni oprávnění - není třeba to spouštět se sudo? Něco podobného jsme si tady přece prošli ohledně spouštění servisů ...

http://forum.ubuntu.cz/index.php?topic=83010.msg559151
Název: Re:Blokování klávesy Caps Lock
Přispěvatel: Janslav 29 Srpen 2018, 08:05:00
Sleep jsem ta měl - a nic. Pak jsem vyzkoušel to s tím cronem, také bez výsledku.
Ani když přidám před příkaz sudo, nic.
Název: Re:Blokování klávesy Caps Lock
Přispěvatel: juwa2 29 Srpen 2018, 08:14:06
A není problém na úrovni oprávnění - není třeba to spouštět se sudo? Něco podobného jsme si tady přece prošli ohledně spouštění servisů ...

http://forum.ubuntu.cz/index.php?topic=83010.msg559151

Ne, to není nic na systémové úrovni. Navíc ten příkaz/skript samotný mu funguje. Jedná se o to autospouštění které všem ostatním taky funguje bez problému (tedy kromě Lubuntu). Tam je to nějaké "zakleté"...
Název: Re:Blokování klávesy Caps Lock
Přispěvatel: Janslav 29 Srpen 2018, 09:00:48
Kdo vůbec stvořil Lubuntu ?

Nešlo by se ho nějak přímo zeptat ?
Název: Re:Blokování klávesy Caps Lock
Přispěvatel: ok1dtm 29 Srpen 2018, 22:53:38
Ještě bych vyzkoušel nastavení v dconf : dconf write /org/gnome/desktop/input-sources/xkb-options "['caps:none']" Nemohu to zkusit používám KDE
Název: Re:Blokování klávesy Caps Lock
Přispěvatel: juwa2 29 Srpen 2018, 23:11:51
Kdo vůbec stvořil Lubuntu ?

Nešlo by se ho nějak přímo zeptat ?

No můžeš googlit, navštěvovat různá fóra a pokládat tam dotazy. Musíš se holt snažit sám... 
https://lubuntu.net/support/
https://ubuntuforums.org/tags.php?tag=lubuntu
Název: Re:Blokování klávesy Caps Lock
Přispěvatel: Janslav 31 Srpen 2018, 09:11:45
Na Ubuntu forech jsem našel jen velmi málo odpovědí na tento problém, pokud tam jsou, tak jen potvrzují jeho existenci. Zdá se že to má nějakou spojitost s funkcí Openbox, ale vysvětlení je mlhavé a nepodařilo se mi do něj proniknout.

Pozoruhodné řešení nabídl diskutující "porphyry52" dne 12.6.2018, který prohlásil, že po množství neúspěšných  pokusů o řešení sice označil problém za vyřešený, ale raději se vrátil od Ubuntu k distribuci Arch.
Název: Re:Blokování klávesy Caps Lock
Přispěvatel: juwa2 31 Srpen 2018, 09:32:35
Na Ubuntu forech jsem našel jen velmi málo odpovědí na tento problém, pokud tam jsou, tak jen potvrzují jeho existenci. Zdá se že to má nějakou spojitost s funkcí Openbox, ale vysvětlení je mlhavé a nepodařilo se mi do něj proniknout.

Pozoruhodné řešení nabídl diskutující "porphyry52" dne 12.6.2018, který prohlásil, že po množství neúspěšných  pokusů o řešení sice označil problém za vyřešený, ale raději se vrátil od Ubuntu k distribuci Arch.

Já jsem se kdysi domníval, že se dá vyřešit 100% možných problémů, ale v průběhu času jsem zjistil (a smířil se), že určité problémy se vyřešit nedají. A v každém distru se něco takového najde.
Například včera jsem řešil hibernaci v U 18.04 a byl to "porod".  Strávil jsem tím celé odpoledne  >:(  Přitom ve 14.04 to funguje úplně normálně....
Oproti tomu se spouštěním jakýchkoli příkazů/skriptů po přihlášení nikdy problém nebyl. Dokonce šlo vyřešit spouštění příkazů/skriptů po probuzení ze spánku/hibernace
----------------------------------------------------
Ještě k tvému problému. Zkus napsat do toho skriptu před příkaz sh

Název: Re:Blokování klávesy Caps Lock
Přispěvatel: Janslav 31 Srpen 2018, 10:31:02
Připsání sh do skriptu nepomohlo. Ještě nějaké nápady ?
Název: Re:Blokování klávesy Caps Lock
Přispěvatel: juwa2 31 Srpen 2018, 10:43:06
Připsání sh do skriptu nepomohlo. Ještě nějaké nápady ?

Ještě jsem někde četl že se tam má napsat @ (před příkaz)...
Zkus vytvořit soubot .desktop s tím příkazem jako Exec a dát ho do autostartu jako běžnou aplikaci
Název: Re:Blokování klávesy Caps Lock
Přispěvatel: Janslav 01 Září 2018, 09:48:07
Nic z toho nepomáhá.
Nakonec jsem to vyřešil primitivně tak, že z příkazu jsem udělal spustitelný soubor Caps-off:

#!/bin/sh
# tento skript blokuje Caps
# spouštět ručně na začátku práce
xmodmap -e "keycode 66 = Shift_L NoSymbol Shift_L" 
exit 0

tento soubor jsem umístil na plochu a spouštím jej ručně po startu systému.
To funguje.

Zdá se, že více se s tím nedá v Lubuntu udělat.
Název: Re:Blokování klávesy Caps Lock
Přispěvatel: juwa2 01 Září 2018, 13:01:11
Ještě bys mohl zkusit spouštět to na systémové úrovni. Spouštěč (soubor .desktop) dej do složky
Kód: [Vybrat]
/etc/xdg/autostart
Název: Re:Blokování klávesy Caps Lock
Přispěvatel: Janslav 01 Září 2018, 15:45:17
Ani tento nápad nefunguje...
Název: Re:Blokování klávesy Caps Lock
Přispěvatel: roj 03 Září 2018, 12:52:29
Řešení, který funguje na všech distribucích a dokonce na všech OS je ...
vydloubnout Capslock! Mám to u všech klávesnic a funguje naprosto spolehlivě. Trvá to asi 1 sekundu, bez pomoci komunity, bez helplajny :)
Název: Re:Blokování klávesy Caps Lock
Přispěvatel: Ventero 03 Září 2018, 20:28:33
Zkus ho prece jen premapovat na shift, kdyz vsechno selhalo ...
Název: Re:Blokování klávesy Caps Lock
Přispěvatel: Janslav 04 Září 2018, 18:49:21
Ale o tom se tady celou dobu bavíme, že nejsem schopen nalézt způsob, jak to přemapování zařadit někam, aby se provedlo automaticky při startu systému. Ruční spuštění skriptu, který přemapovává Caps funguje dobře.
Název: Re:Blokování klávesy Caps Lock
Přispěvatel: Ventero 05 Září 2018, 08:13:01
Promin - mel jsem za to, ze se porad zkousi jen vypnout ... Necetl jsem pozorne vse ve vlaknu ...
Název: Re:Blokování klávesy Caps Lock
Přispěvatel: TIBOR 05 Září 2018, 11:26:04
Inak nad tym som uz tiez rozmyslal. Podla toho co som cital tak sa da vytvorit vlastne rozlozenie klavesnice, ovsem nikdy som to neskusal tak som to ani neradil ked neviem podrobnosti. Ale mozno za pogoolenie by to stalo.
Název: Re:Blokování klávesy Caps Lock
Přispěvatel: Ventero 06 Září 2018, 13:41:13
To sem mel na mysli prave taky - ze se proste prepise konfiguracni soubor klavesnice a tim se obejde synteticke premapovani pomoci prikazu ...
Název: Re:Blokování klávesy Caps Lock
Přispěvatel: Janslav 07 Září 2018, 10:09:47
A jak se prosím přepíše ten konfigurační soubor ?   Vyzkoušel bych to,,,
Název: Re:Blokování klávesy Caps Lock
Přispěvatel: juwa2 07 Září 2018, 15:57:24
Edituj soubor
Kód: [Vybrat]
/etc/default/keyboard
XKBOPTIONS="ctrl:nocaps"
Kód: [Vybrat]
sudo dpkg-reconfigure keyboard-configuration
Název: Re:Blokování klávesy Caps Lock
Přispěvatel: Janslav 07 Září 2018, 16:48:00
Další pokus - a opět bez úspěchu...
Název: Re:Blokování klávesy Caps Lock
Přispěvatel: Marp 07 Září 2018, 17:28:28
Nečetl jsem celé, jen tak vstoupím do diskuze dotazem: "Proč vypínat DŮLEŽITOU klávesu Caps Lock?" Stačí mít zvukové a vizuální upozornění, ne?
Název: Re:Blokování klávesy Caps Lock
Přispěvatel: Janslav 08 Září 2018, 10:08:55
Podle mne klávesa Caps Lock není nijak zvlášť důležitá, naopak se mi často stává, že místo Shift omylem zmáčknu Caps Lock (který je hned vedle) a od toho okamžiku se mi všechno píše velkými písmeny, což většinou nechci.

Dle diskuzí na zahraničních fórech  tato klávesa štve více lidí, proto bych jí chtěl zrušit (nebo jí přemapovat na Shift). Nejjednodušší by asi bylo jí vyloupnout z klávesnice, ale to mně připadá dost brutální zásah, tak jsem myslel, že to půjde softwarově, nejlépe automaticky při startu systému, ale zdá se, že je to pěkný oříšek, viz diskuze výše (alespoň v Lubuntu).
Název: Re:Blokování klávesy Caps Lock
Přispěvatel: TIBOR 08 Září 2018, 12:50:42
Neviem cim to je ale teraz som skusil vo VB tento postup
https://www.jveweb.net/en/archives/2010/11/making-better-use-of-the-caps-lock-key-in-linux.html
Vytvorit subor ~/.Xmodmap . Donho som vlozil
Kód: [Vybrat]
remove Lock = Caps_Lock
keysym Caps_Lock = Escape
a spustil som ho cez
Kód: [Vybrat]
xmodmap ~/.XmodmapOdvtedy mam caps lock ako escape. Len mi nejde do hlavy ze to tak mam aj po restarte aj ked tam tusim riesia pridavanie do autostartu.
Název: Re:Blokování klávesy Caps Lock
Přispěvatel: Janslav 08 Září 2018, 16:07:49
Hezky popsáno, ale v Lubuntu to nechodí - dá tento výsledek:

jan@jan-desktop:~$ xmodmap ~/.Xmodmap
xmodmap:  /home/jan/.Xmodmap:1:  bad keysym in remove modifier list 'Caps_Lock', no corresponding keycodes
xmodmap:  /home/jan/.Xmodmap:2:  bad keysym target keysym 'Caps_Lock', no corresponding keycodes
xmodmap:  2 errors encountered, aborting.
Název: Re:Blokování klávesy Caps Lock
Přispěvatel: TIBOR 08 Září 2018, 16:26:17
Toto mi pisalo ked som zle opisal velkost pismen, otazka je preco to pise tebe. Nemoze byt ze po tych pokusoch ho uz mas niekolko krat pomeneny? Cize system ho uz neregistruje ako Caps_Lock. Na konci toho navodu je ako to vratit naspat, a ako zistit keykody pre klavesy.
Inak v tom VB to skusam na lubuntu 18.04.
Název: Re:Blokování klávesy Caps Lock
Přispěvatel: Janslav 09 Září 2018, 09:19:37
Děkuji Tibore, už jsem to vrátil a spustil znovu, funguje to.
Ale s jedním problémem - po restartu systému se to samo nespustí, a o to mi především šlo, aby to bylo automatické.
Nějaký nápad, jak to udělat, aby se to spouštělo při bootu ?
Název: Re:Blokování klávesy Caps Lock
Přispěvatel: TIBOR 09 Září 2018, 10:02:15
To je divne u mna to funguje aj po restarte/vypnuti.
Název: Re:Blokování klávesy Caps Lock
Přispěvatel: Janslav 09 Září 2018, 10:42:13
Ještě jednou jsem to ověřil, určitě mi to nefunguje automaticky po restartu systému. Ani když to ještě navíc přidám do Autostartu.

Mám Lubuntu 18.04.1 LTS 64 bit
A toto HW:
Intel Pentium j2900
2x4GiB DDIM DDR3 133 MHz
systémový SCSI disk 120GB SSD Kingston
přídavný 80GB HDD IDE přes IDE controller
DVDRAM GSA-4167B
Název: Re:Blokování klávesy Caps Lock
Přispěvatel: juwa2 09 Září 2018, 11:15:09
Je třeba rozlišit spouštění (něčeho) po bootu a po přihlášení, jsou to dvě různé věci. Samozřejmě po bootu následuje přihlášení - ať už automatické nebo manuální.  K ověření funkčností příkazů v autostartu se stačí odhlásit/přihlásit.
-----------------
Pokud to v Lubuntu opravdu nefunguje, zajímalo by mne jak se to chová v klasickém Ubuntu do kterého se doinstaluje prostředí LXDE.
Název: Re:Blokování klávesy Caps Lock
Přispěvatel: TIBOR 09 Září 2018, 12:48:10
Děkuji Tibore, už jsem to vrátil a spustil znovu, funguje to.
Ale to potom znamena ze klavesa sa premapuje a ostane to aj po restarte. Otazka potom je ci to uz nemas tymi pokusmi tolko krat premapovane ze uz sa to medzi sebou bije.
Inak povedane ci by sa chyba uz nemala hladat v inej casti systemu.
Název: Re:Blokování klávesy Caps Lock
Přispěvatel: Janslav 10 Září 2018, 08:09:57
Určitě v jiné části systému ale kde ?
Název: Re:Blokování klávesy Caps Lock
Přispěvatel: juwa2 10 Září 2018, 10:58:37
Určitě v jiné části systému ale kde ?

Pokud nabootuješ live a už tam se to chová stejně, těžko s tím něco uděláš....
Název: Blokování klávesy Caps Lock s 16.04
Přispěvatel: regine 22 Září 2018, 11:29:05
JEN POPIS MÉHO STAVU. Mám Ubuntu 16.04 LTS na třech kompech. Na dvou CapsLock lze nastavit jakkoliv. U jednoho mi příkaz:
Kód: [Vybrat]
setxkbmap -option ctrl:nocapsjen nahodile vypínal CapsLock. Asi jeden z deseti startů mi vypnul CapsLock.  U něj mám namapováno:
Kód: [Vybrat]
xmodmap -e "keycode 66 = Shift_L NoSymbol Shift_L"
exit 0
které je zcela bezproblémové. A při řešení problému jsem kdysi na netu zjistil, že nejsem sám. Mám tím klid na duši.  ;)
Název: Re:Blokování klávesy Caps Lock (Vyřešeno)
Přispěvatel: Janslav 24 Září 2018, 16:25:11
Tak já jsem to konečně vyřešil, a to pro Lubuntu 18.04.1 LTS, aby to chodilo automaticky při startu:

- zadání blokovacího (přemapovacího) příkazu xmodmap -e "keycode 66 = Shift_L NoSymbol Shift_L"   do Automatického spouštění v "Nastavení Lx session" nefunguje, neboť tento příkaz se sice asi skutečně provede, ale je v rámci bootu systému posléze přepsán standartním nastavením klávesnice...
Tohle je srozumitelně popsáno v https://askubuntu.com/a/934797/282454
a také v https://askubuntu.com/questions/574208/deactivate-caps-lock-in-14-04

- aby se tomu zabránilo, je třeba jako superuživatel (sudo) vytvořit spustitelný  soubor s názvem
"99-disable-caps.conf"  s např. tímto obsahem:

#!/bin/sh
# tento skript přemapuje  klávesu Caps Lock
xmodmap -e "keycode 66 = Shift_L NoSymbol Shift_L"
exit 0

a tento soubor uložit do  složky   /etc/lightdm/lightdm.conf.d

(The 99 prefix means that it will be run after the standard setup scripts provided in /usr/share/lightdm/lightdm.conf.d)
 
Takto uložený soubor se opravdu provádí až poslední a funguje jak má - při bootu systému.

Dík všem za pomoc