Fórum Ubuntu.cz

Ubuntu pro osobní počítače => Hry a zábava => Téma založeno: baculatej 09 Srpen 2019, 16:05:06

Název: Hearthstone - Arena Tracker
Přispěvatel: baculatej 09 Srpen 2019, 16:05:06
Mám dual boot s Kubuntu 19.4 a Windows.
Hru Hearthstone spouštím z disku Windows a funguje bez problémů.

Problém: Chtěl bych k ní přidat Arena Tracker (pro linux) https://github.com/supertriodo/Arena-Tracker/releases/tag/v7.02 (https://github.com/supertriodo/Arena-Tracker/releases/tag/v7.02) ale ten nejde spustit.
Dvojklik nic nedělá, když ho spustím v konzoli, tak tak výsledek je:
Kód: [Vybrat]
/home/petr/Stažené/Arena.Tracker.v7.02.Linux/ArenaTracker: error while loading shared libraries: libssl.so.1.0.0: cannot open shared object file: No such file or directory

Kód: [Vybrat]
sudo apt install libssl1.0.0 píše
Kód: [Vybrat]
Načítají se seznamy balíků… Hotovo
Vytváří se strom závislostí       
Načítají se stavové informace… Hotovo
Balík libssl1.0.0 není dostupný, ale jiný balík se na něj odkazuje.
To může znamenat že balík chybí, byl zastarán, nebo je dostupný
pouze z jiného zdroje

E: Balík „libssl1.0.0“ nemá kandidáta pro instalaci

Dokáže mi někdo prosím poradit, jak Arcane Tracker rozchodit?
Název: Re:Hearthstone - Arena Tracker
Přispěvatel: Gmisiycs 22 Srpen 2019, 13:53:23
Někdo se ještě určitě ozve.

Já si podle čísla verze myslím, že se jedná o deprecated software.
Přeci jen SSL ve verzi 1 je dědeček.
Kód: [Vybrat]
libssl1.0.0
Název: Re:Hearthstone - Arena Tracker
Přispěvatel: JirkaZ 22 Srpen 2019, 14:37:46
Zkusil bych se inspirovat tím, co jsem před časem napsal:

https://forum.ubuntu.cz/index.php/topic,84425.msg566161.html#msg566161
Název: Re:Hearthstone - Arena Tracker
Přispěvatel: baculatej 25 Srpen 2019, 18:04:23
Zkusil jsem dle uvedeného naisntalovat jak 32, tak 64, ale stále se dostávám pouze k:
Kód: [Vybrat]
/home/petr/Stažené/Arena.Tracker.v7.02.Linux/ArenaTracker: /lib/x86_64-linux-gnu/libssl.so.1.0.0: version `OPENSSL_1.0.2' not found (required by /home/petr/Stažené/Arena.Tracker.v7.02.Linux/ArenaTracker)
/home/petr/Stažené/Arena.Tracker.v7.02.Linux/ArenaTracker: /lib/x86_64-linux-gnu/libcrypto.so.1.0.0: version `OPENSSL_1.0.2' not found (required by /home/petr/Stažené/Arena.Tracker.v7.02.Linux/ArenaTracker)

Když obdobně zkouším stáhnout a nainstalovat OPENSSL_1.0.2, tak dostanu "Error: Breaks the existing package 'ca-certificates'".
Následující taky nejde:
Kód: [Vybrat]
sudo apt-get install openssl
Načítají se seznamy balíků… Hotovo
Vytváří se strom závislostí       
Načítají se stavové informace… Hotovo
openssl je již nejnovější verze (1.1.1b-1ubuntu2.1)
Název: Re:Hearthstone - Arena Tracker
Přispěvatel: juwa2 25 Srpen 2019, 19:01:12
Musíš použít knihovnu z 18.04 protože v 19.04 už není:
Potřebnou verzi knihovny (respektive balík ve kterém je obsažena) si stáhni http://archive.ubuntu.com/ubuntu/pool/main/o/openssl1.0/libssl1.0.0_1.0.2n-1ubuntu5.3_amd64.deb. Pak ho rozbal (běžným archivátorem) a ty knihovny (soubory libssl.so.1.0.0  libcrypto.so.1.0.0  a složku openssl-1.0.0) ručně nakopíruj (musíš kopírovat jako root, to je snad jasné) do složky
Kód: [Vybrat]
/lib/x86_64-linux-gnu
Pak zkus program opět spustit z Terminálu. Buď to pojede, nebo vypíše jinou chybu kterou budeš opět řešit.

Druhou možností je poslechnout rady zkušenějších a nepoužívat non LTS verze = dát si tam U18.04.5
Pak nebudeš mít tyto starosti...
Název: Re:Hearthstone - Arena Tracker
Přispěvatel: baculatej 06 Září 2019, 19:13:46
Díky juwa2, to nakopírování pomohlo!