Prosíme přihlašte se nebo zaregistrujte.

Přihlašte se svým uživatelským jménem a heslem.
Vaše pomoc je stále potřeba!

Zobrazit příspěvky

Tato sekce Vám umožňuje zobrazit všechny příspěvky tohoto uživatele. Prosím uvědomte si, že můžete vidět příspěvky pouze z oblastí Vám přístupných.


Příspěvky - ATomas

Stran: [1]
1
Zdravím,
nainstaloval jsem si tensorflow (tensorflow.org), který jede na pythonu. Vse funguje ok kdyz do konzole zadam prikaz tak to funguje jak ma. Ovsem jakmile se stejny prikaz pokusim spustit pres exec v php tak to prosto nevyhodi nic.

Kód: [Vybrat]
<?php

error_reporting
(E_ALL);
ini_set('display_errors',1);

$msg exec("python /var/www/tensorflow/tensorflow/examples/label_image/label_image.py --graph=/tmp/output_graph.pb --labels=/tmp/output_labels.txt --input_layer=Mul --output_layer=final_result --image=/var/www/ruze.jpg",$msg2,$retval);

var_dump($msg);
var_dump($msg2);
var_dump($retval);

echo 
"Hotovo";

?>

Vysledek

Kód: [Vybrat]
string(0) "" array(0) { } int(1) Hotovo
Pokud ten script pustim v konzoli, funguje to OK

Kód: [Vybrat]
www-data@sp:/var/www# python /var/www/tensorflow/tensorflow/examples/label_image/label_image.py --graph=/tmp/output_graph.pb --labels=/tmp/output_labels.txt --input_layer=Mul --output_layer=final_result --image=/var/www/ruze.jpg
2018-04-14 09:36:05.672657: I tensorflow/core/platform/cpu_feature_guard.cc:140] Your CPU supports instructions that this TensorFlow binary was not compiled to use: AVX2 FMA
2018-04-14 09:36:05.896400: W tensorflow/core/framework/op_def_util.cc:343] Op BatchNormWithGlobalNormalization is deprecated. It will cease to work in GraphDef version 9. Use tf.nn.batch_normalization().
roses 0.99905473
tulips 0.00085386337
sunflowers 8.967988e-05
dandelion 1.0716676e-06
daisy 5.9500644e-07

Zkousel jsem si vytvorit jednoduchy bash script kde jsem mel "echo funguje". Ktery jsem spustil pomoci "echo exec("test");" a to normalne vypsalo ten text "funguje" do html stranky.

Takze ted vubec nevim kde delam chybu.

Dokonce jsem v zachvatu zoufalosti dal chmod 777 na vsechno.

Diky za pomoc.

2
Zdravím,
doufam že nepíši do špatné kategorie, pokud ano tak se omlouvám, jsem tu poprvé.

Mám linux debian 6. Mám problém že se mi v poslední době v iptables vždy ukáže nějaká IP adresa, která odesíla na můj server 300MB. Coz je celkem dost a server to spomaluje. Sice jsem ji zabanoval pomoci
iptables -A INPUT -s 81.89.48.8 -j DROP
Tim jsem zablokoval pouze download ale kdyz jsem se pokusil zablokovat i upload takto:
iptables -A OUTPUT -s 81.89.48.8 -j DROP
Tak se zadna zmena neprojevila.

A jeste bych se chtel zeptat, jestli lze nejak nastavit, že každé připojení bude mít limit např 10MB/s a pokud to překročí, bude ip zabanována.

Děkuji.

Stran: [1]

Provoz zaštiťuje spolek OpenAlt.