Prosíme přihlašte se nebo zaregistrujte.

Přihlašte se svým uživatelským jménem a heslem.

Zobrazit příspěvky

Tato sekce Vám umožňuje zobrazit všechny příspěvky tohoto uživatele. Prosím uvědomte si, že můžete vidět příspěvky pouze z oblastí Vám přístupných.


Příspěvky - Fisir

Stran: [1] 2
1
Obecná podpora / Řešení
« kdy: 27 Srpen 2015, 15:57:54 »
Zdrojové soubory pro kompilaci jsem nakonec nezískal, ale Debian balíček pro verzi libssl-dev 1.0.2d a libssl 1.0.2d ano.

2
Obecná podpora / Kde získat libssl-dev 1.0.2d?
« kdy: 26 Srpen 2015, 19:45:51 »
Ahoj,
pokouším se ručně zkompilovat Apache 2.4, abych do něj mohl zabudovat OpenSSL 1.0.2d (potřebuji jej kvůli konfigurační direktivě SSLOpenSSLConfCmd). Všechno běží krásně, ze zdrojáků jsem zkompiloval OpenSSL, příkaz openssl version vypíše správnou verzi a zkompilované Apache také běží bez problémů.

Bohužel, navzdory instalované verzi OpenSSL Apache používá verzi 1.0.1f (podle phpinfo()). Podle mého výzkumu za to může fakt, že je v systému nainstalován balíček libssl-dev pro starší verzi OpenSSL.

Nikde ale nemohu najít zdrojový kód tohoto balíčku, abych zkompiloval jeho nejnovější verzi a bez něj se Apache nezkompiluje vůbec. V repozitáři je pouze verze 1.0.1.

Existuje tedy nějaká možnost, jak tento balíček upgradovat nebo ručně zkompilovat a nainstalovat? Předem díky.

3
Hardware / Re:ALSA nedetekuje zvukovku
« kdy: 20 Prosinec 2014, 21:07:02 »
Citace
modprobe: ERROR: could not insert 'snd_hda_intel': Operation not permitted

mal si práva roota?

Ne, pokud jsem to spustil s rootem, vypsalo to jiný error.

Nějak se mi to ale podařilo magicky zprovoznit. ALSA i PulseAudio jsem přeinstaloval, nainstaloval jsem i ovladače ze stránek Realteku, všechno včetně jádra aktualizoval a zkusil jsem znovu povolit snd_hda_intel. Jaké překvapení, že to fungovalo. Potom už jenom stačilo spustit alsa force-reload a zvuk šel. Netuším, čím to bylo, jen jsem prostě vyzkoušel různé rady, co jsem našel na fórech.

4
Hardware / Re:ALSA nedetekuje zvukovku
« kdy: 20 Prosinec 2014, 16:27:08 »
Už vážně netuším, kdyžtak tady je diagnostika alsa-info.sh: http://www.alsa-project.org/db/?f=dca3c5dcd0dbba3d9f9de72051facb35bcc5d3b3

5
Hardware / Re:ALSA nedetekuje zvukovku
« kdy: 20 Prosinec 2014, 15:32:50 »
Kompletně jsem přeinstaloval PulseAudio i ALSA, dokonce i balíčky, které by ty drivery měly obsahovat. Nic. Pak jsem instaloval ovladače přímo od Realteku, taky nic. Při pokusech jsem ale zjistil, že vůbec neexistuje /proc/asound/.

Vážně nikdo nic neví?

6
Hardware / Re:ALSA nedetekuje zvukovku
« kdy: 19 Prosinec 2014, 21:40:12 »
Pořád hledám a pravděpodobně nemám nainstalované drivery.
Kód: [Vybrat]
modprobe: ERROR: could not insert 'snd_hda_intel': Operation not permitted
modprobe: ERROR: could not insert 'snd_hda_intel': Unknown symbol in module, or unknown parameter (see dmesg)

Bohužel netuším jak je mám nainstalovat, protože sudo m-a a-i alsa vždycky selže.

7
Hardware / ALSA nedetekuje zvukovku
« kdy: 19 Prosinec 2014, 18:25:44 »
Ahoj. Používám Ubuntu 14.10 na starém stolním počítači. Nefunguje zvuk, aplay -l vypisuje:
Kód: [Vybrat]
aplay: device_list:268: no soundcards found...lspci -v | grep -A7 -i "audio" vypisuje:
Kód: [Vybrat]
00:1b.0 Audio device: Intel Corporation NM10/ICH7 Family High Definition Audio Controller (rev 01)
        Subsystem: Micro-Star International Co., Ltd. [MSI] Device 7267
        Flags: bus master, fast devsel, latency 0, IRQ 10
        Memory at cfe3c000 (64-bit, non-prefetchable) [size=16K]
        Capabilities: <access denied>

00:1c.0 PCI bridge: Intel Corporation NM10/ICH7 Family PCI Express Port 1 (rev 01) (prog-if 00 [Normal decode])
        Flags: bus master, fast devsel, latency 0
alsamixer hlásí:
Kód: [Vybrat]
cannot open mixer: No such file or directoryPulseAudio list-sinks vypisuje:
Kód: [Vybrat]
1 sink(s) available.
  * index: 0
        name: <auto_null>
        driver: <module-null-sink.c>
        flags: DECIBEL_VOLUME LATENCY DYNAMIC_LATENCY
        state: SUSPENDED
        suspend cause: IDLE
        priority: 1000
        volume: 0: 100% 1: 100%
                0: 0.00 dB 1: 0.00 dB
                balance 0.00
        base volume: 100%
                     0.00 dB
        volume steps: 65537
        muted: no
        current latency: 0.00 ms
        max request: 344 KiB
        max rewind: 344 KiB
        monitor source: 0
        sample spec: s16le 2ch 44100Hz
        channel map: front-left,front-right
                     Stereo
        used by: 0
        linked by: 0
        configured latency: 0.00 ms; range is 0.50 .. 2000.00 ms
        module: 9
        properties:
                device.description = "Dummy Output"
                device.class = "abstract"
                device.icon_name = "audio-card"
Když spustím alsa force-reload, v pořádku se provede, ale vypíše, že nejsou načteny žádné moduly.

Už vážně nevím, co s tím. Poradíte?

8
Obecná podpora / Re:Instalace Airtime v Ubuntu 14.10 Utopic Unicorn
« kdy: 23 Červenec 2014, 13:02:49 »
Omlouvám se, trochu jsem to přehnal. Instalace s nastavením zdroje na trusty to vyřešila! Díky :-)!

9
Obecná podpora / Re:Instalace Airtime v Ubuntu 14.10 Utopic Unicorn
« kdy: 23 Červenec 2014, 11:14:03 »
Linux (CentOS 6) provozuji na svých webových (mailových, DNS, …) serverech a taky je dost těžké se v tom vyznat. Vývojovou verzi Ubuntu jsem si vybral pro provozování na domácím serveru, kde zas tak nevadí, když jsou v systému nějaké nedodělky. Ale že je zrušená zpětná kompatibilita, to jsem nečekal.

10
Obecná podpora / Re:Instalace Airtime v Ubuntu 14.10 Utopic Unicorn
« kdy: 21 Červenec 2014, 19:20:13 »
Nenapsal výsledek...
Protože se na to asi vykašlu, Linux už mě vážně vytáčí. Pro změnu nejdou nainstalovat závislosti Liquidsoap (ocaml-dtools, ocaml-duppy, ocaml-mm a ocaml-pcre).

11
Obecná podpora / Re:Instalace Airtime v Ubuntu 14.10 Utopic Unicorn
« kdy: 17 Červenec 2014, 16:45:52 »
Tak jsem zjistil, že stačí přepsat v /etc/apt/sources.list utopic na saucy. Pak repozitář Sourcefabric funguje. Ale asi Airtime není s 14.10 kompatibilní, protože po řádné instalaci přes apt-get vypíše:
Kód: [Vybrat]
Preparing to unpack .../airtime_2.5.1-2_all.deb ...
Unpacking airtime (2.5.1-2) ...
Processing triggers for man-db (2.6.7.1-1) ...
Processing triggers for desktop-file-utils (0.22-1ubuntu2) ...
Processing triggers for mime-support (3.55ubuntu1) ...
Processing triggers for gnome-menus (3.10.1-0ubuntu2) ...
Processing triggers for bamfdaemon (0.5.1+14.04.20140409-0ubuntu1) ...
Rebuilding /usr/share/applications/bamf-2.index...
Setting up airtime-audio-samples (1.9.3-2) ...
/var/lib/dpkg/info/airtime-audio-samples.postinst: line 13: airtime-import: command not found
dpkg: error processing package airtime-audio-samples (--configure):
 subprocess installed post-installation script returned error exit status 127
Setting up airtime (2.5.1-2) ...
Setting up apache2...
Site airtime-vhost already disabled
Apache 2.4 detected, using newer access configuration...
sed: can't read /etc/airtime/apache24.vhost.tpl: No such file or directory
dpkg: error processing package airtime (--configure):
 subprocess installed post-installation script returned error exit status 2
Errors were encountered while processing:
 airtime-audio-samples
 airtime
E: Sub-process /usr/bin/dpkg returned an error code (1)

12
Obecná podpora / Re:Instalace Airtime v Ubuntu 14.10 Utopic Unicorn
« kdy: 17 Červenec 2014, 15:13:28 »
A v čem je problém? (přidáš zdroj (viz. zdejší Wiki) a "apt-get update")
A apt.sourcefabric.org vyhodí chybu 404. To je důvod, proč jsem nemohl nainstalovat Airtime normálně.

13
Obecná podpora / Re:Instalace Airtime v Ubuntu 14.10 Utopic Unicorn
« kdy: 17 Červenec 2014, 15:04:13 »
Nainstaloval jsem závislosti podle full-install a pak jsem spustil minimal-install. Ta proběhla v pořádku, až na chybějící balíčky
  • sourcefabric-keyring,
  • liquidsoap,
  • silan,
  • libopus0
a ty jsou podle všeho dostupné jen z repozitáře Sourcefabric.

14
Obecná podpora / Re:Instalace Airtime v Ubuntu 14.10 Utopic Unicorn
« kdy: 17 Červenec 2014, 14:43:07 »
Zvládneš instalaci ze zdrojáků?
Pokud mě alespoň trochu nasměruješ, jak na to, tak asi ano.

15
Obecná podpora / Instalace Airtime v Ubuntu 14.10 Utopic Unicorn
« kdy: 17 Červenec 2014, 14:22:36 »
Pokouším se nainstalovat Airtime na Ubuntu 14.10. Mám nainstalovaný airtime-easy-setup. Když však chci nainstalovat balíček airtime, apt.sourcefabric.org hlásí chybu 404 a balíček se nepodaří nainstalovat. To samé se děje při pokusu o instalaci pomocí Ubuntu Software Center. Jde to nějak vyřešit?

16
Multimédia / Re:Streamování do Xboxu
« kdy: 15 Červen 2014, 18:19:28 »
Já ale nechci využít playlist, já chci, aby se dvě videa spojila dohromady pod jednu položku. Jde to?

17
Multimédia / Re:AviDemux MP3 Surround
« kdy: 15 Červen 2014, 15:06:58 »
Evidentně nejde. Na Windowsu jsem si AC3 zvuk do MP3 Surround překódoval a v AviDemuxu jen zvolil metodu Copy. Ubuntu totiž vůbec netuší, že ta empétrojka má šest kanálů (Windows ano).

18
Multimédia / Re:Streamování do Xboxu
« kdy: 11 Červen 2014, 20:12:02 »
Vypadá to, že přesunout položky ze složky RSS streamu do rootu nejde. Mám ale další otázku – dá se nějak nastavit, aby se po přehrátí videa ihned spustilo jiné? Možná nějak přes playlisty, ale nevím, jak. Navíc používám to RSS. Začínám si myslet, že zvolit Serviio byla špatná volba, protože má funkce, které nepotřebuji, zatímco ty stěžejní mu chybí.

19
Multimédia / AviDemux MP3 Surround
« kdy: 11 Červen 2014, 18:25:03 »
Ahoj,
jde do AviDemuxu nějak dostat podpora pro 5.1 zvuk ve formátu MP3 (MP3 Surround)? A ne, nechci jiný formát.

20
Multimédia / Re:Streamování do Xboxu
« kdy: 03 Červen 2014, 19:05:31 »
Už zbývá jen jediná otázka – jak přesunout videa ze složky RSS streamu rovnou do rootu?

FFmpeg jsem vyřešil přesunutím samotných spustitelných souborů do /bin.

21
Multimédia / Re:Streamování do Xboxu
« kdy: 03 Červen 2014, 14:45:26 »
Tak RSS mám nějak zpracované, ale zdá se, že narážím na ten ffmpeg, protože Serviio nenačte média a log hlásí:
Kód: [Vybrat]
Fatal error in process starting: cannot run program "ffmpeg": java.io.IOException: error=2, No such file or directoryPak se chci taky zeptat, jestli se dá obsah RSS přesunout rovnou do rootu, tedy bez toho, aby pro něj byla zvláštní složka.

22
Multimédia / Re:Streamování do Xboxu
« kdy: 02 Červen 2014, 20:42:17 »
Rád bych si pořádně zanadával. Cvičně jsem si složku Serviia přesunul z externího disku do domovského adresáře a magie nastala, Serviio se rozběhlo  ::).

Teď už jenom, nevíte, jak má být strukturované RSS? Když už jsem u toho, můžu se v něm odkazovat na lokální disk?

23
Multimédia / Re:Streamování do Xboxu
« kdy: 29 Květen 2014, 16:03:02 »
Serviio jsem stahoval znovu, ubuntu-restricted-extras mám nainstalované, ale pořád nic.

Prosím, ví někdo o nějaké alternativě MediaTombu, která podporuje Xbox 360, je možné její knihovnu spravovat přes MySQL databázi a umožňuje změnit svůj název a ikonu? Případně mi poraďte, jak zprovoznit podporu Xboxu 360 na MediaTombu, to by bylo nejlepší.

24
Multimédia / Re:Streamování do Xboxu
« kdy: 28 Květen 2014, 19:04:00 »
Kód: [Vybrat]
update-java-alternatives -l
Vyhodí:
Kód: [Vybrat]
java-1.6.0-openjdk-i386 1061 /usr/lib/jvm/java-1.6.0-openjdk-i386
java-1.7.0-openjdk-i386 1071 /usr/lib/jvm/java-1.7.0-openjdk-i386

Pak tady může být problém s ffmpegem, protože ten mi nejde nainstalovat. Mám jeho soubory jenom nakopírované v adresáři Serviia.

Děkuji, že se mým problémem zabýváš. Mimochodem, nejsem takový blb, jak vypadám, počítače jsou moje hobby, ale tady si už opravdu nevím rady…

25
Multimédia / Re:Streamování do Xboxu
« kdy: 28 Květen 2014, 16:24:15 »
Nainstaloval jsem OpenJDK 6 (a vypadá to, že je nastaveno jako výchozí) a tohle se zobrazilo při pokusu spustit serviio.sh:
Kód: [Vybrat]
Exception in thread "main" java.lang.NoClassDefFoundError: data/serviio/library
Caused by: java.lang.ClassNotFoundException: data.serviio.library
at java.net.URLClassLoader$1.run(URLClassLoader.java:217)
at java.security.AccessController.doPrivileged(Native Method)
at java.net.URLClassLoader.findClass(URLClassLoader.java:205)
at java.lang.ClassLoader.loadClass(ClassLoader.java:323)
at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:294)
at java.lang.ClassLoader.loadClass(ClassLoader.java:268)
Could not find the main class: data/serviio/library. Program will exit.
Právě jsem taky zjistil, že nemám nainstalovaný ffmpeg. V repozitářích už ale není, a jediné, co jsem našel je tohle, ale vypadá to, že se to neinstaluje, takže to asi nebude fungovat, co? Kde mám tedy ffmpeg pro Ubuntu Utopic Unicorn získat?

Případně, nemůže být nějaký problém s právy? Nejdřív jsem Serviio na server nakopíroval přes FTP a potom ve správci souborů přesunul na jiné umístění.

Stran: [1] 2