Prosíme přihlašte se nebo zaregistrujte.

Přihlašte se svým uživatelským jménem a heslem.

Zobrazit příspěvky

Tato sekce Vám umožňuje zobrazit všechny příspěvky tohoto uživatele. Prosím uvědomte si, že můžete vidět příspěvky pouze z oblastí Vám přístupných.


Témata - DarkMeni

Stran: [1]
1
Ahoj, chtěl bych na noťas nainstalovat UbuntuDDE, ale po dokončení instalace a restartu nenaběhne žádný zavaděč, akorát to chvíli zkouší najít PXE boot na síti a pak to oznámí že to nenašlo žádný systém.

Zkoušel jsem i BootRepairDisk, ten navrhnul odebrání a novou instalaci grub2, ale ani to nepomohlo. Ve výsledném logu bylo, že to na sda1 našlo Ubuntu 20.04, ale po restartu opět žádný systém.

Noťas plně nepodporuje UEFI, proto to chci nainstalovat jako Legacy boot s MBR tabulkou:
/dev/sda:
/dev/sda1: ext4, mount point: / (40 GiB) [boot]
/dev/sda2: ext4, mount point: /home (160 GiB)

Nevidím tam žádný problém, proč by to nemělo fungovat.

Zkoušel jsem také instalaci na GPT tabulku s tím 512MB oddílem ve FAT formátu pro EFI a zapnutým UEFI Bootem v BIOSu, ale systém stejně nenabíhal.

Předtím tam byl Deepin OS, také přes Legacy boot, a ten normálně fungoval, ale už si nepamatuju, jestli jsem při instalaci musel dělat něco speciálního, nebo to fungovalo hned po instalaci.

Děkuji za rady

2
Ahoj, nevíte o nějakém článku nebo návodu jak udělat částečně komprimovaný systém?
Na tenkém klientu mám k dispozici jen 2 GB SSD flash paměti, a základní instalace Debianu 10 zabere kolem 1 GB. Po doinstalování Xfce4 je to na 1,9 GB a zůstane volných jen 100 MB. Zároveň je ale potřeba, aby jádro a moduly byly nekomprimované.

Zkoušel jsem Linux Live Kit (https://www.linux-live.org), což zabralo celkem i s Xfce4 jen 300 MB, ale načítání systému po připojení dvou monitorů bylo dost nestabilní. Občas se načetl, občas zůstal viset u zprávy "Reached target Sound Card", před "Created slice system-systemd\x2dblacklight.slice", která se zobrazila, když měl zrovna náladu se úspěšně načíst až do konce.

U normální instalace se zatím nestalo, že by se systém při načítání takle zasekl.
Šlo by teda nechat úplný minimum (asi /boot a /lib/modules) pro načtení základního systému nekomprimovaný a všechno ostatní pak načítat z nějakého squashfs, nebo overlayfs, nebo něčeho takového?

3
Hardware / DRM pro VIA VX900 grafiku
« kdy: 28 Červen 2021, 14:05:40 »
Ahoj, máte někdo ještě někde grafiku od VIA a řešil jste zprovoznění na novějších linuxech?
V práci máme stovky starších terminálů s touto grafikou, které se budou nahrazovat novějšími, a je celkem škoda je jen tak vyhodit. Šli by použít třeba místo noťasů na homeoffice atd.

Momentálně mají nainstalovaný systém Igel OS 10, kde je podpora grafiky v pohodě a funguje i zobrazení na dvou monitorech. Ale tento systém mi příjde hodně omezený, prostě nedává možnost nainstalovat nic vlastního, kromě jejich aplikací. Je tam kernel verze 4.19.65 a ovladač grafiky via_chrome9, což nechápu jak se jim tam podařilo dostat, když poslední properiterní ovladač pro VIA jsem našel pro verzi kernelu 3.4.0-3.x.x.

Zkoušel jsem tento ovladač (via_chrome9) zkompilovat na Debianu 10 s kernelem 4.19.0-17-amd64, ale bylo tam už moc problémů, a když to řeklo, že struktura drm_driver neobsahuje položku suspend, resume atd., tak jsem to vzdal, protože by to znamenalo projít dokumentaci starého i nového kernelu, abych zjistil jak to patchnout...

Zkusil jsem tedy neproperitární ovladač openchrome, ale obraz funguje jen když je monitor připojený do DVI-I (s analogovým výstupem) a je použitá redukce na VGA, takže si ovladač myslí, že je monitor připojený do VGA konektoru (který tam fyzicky není, ale takle to tvrdí xrandr). Po připojení druhého monitoru se objeví na obou monitorech "Input not supported".
Po zkompilování xf86-video-openchrome z freedekstop.org se částečně zprovozní dual monitor funkce, ale na jednom monitoru je celou dobu černá obrazovka a ten monitor nejde nijak aktivovat, a na druhém jsou rozlité barvy, a xrandr tvrdí že je nastavené maximální rozlišení cca 1440 x něco, přitom ten monitor má 1680 x 1050. Po odpojení druhého monitoru, a nechání jen toho v DVI-I (VGA) to zase funguje normálně, ale cílem je zprovoznit zobrazení na obou monitorech.
Každopádně, ve /var/log/Xorg.0.log je řádek:

CHROME(0): [drm] Failed to open DRM device for pci:0000:01:00.0: No such file or directory

a po vypsání "dmesg | grep -e agp -e drm" to nic takového, jako je v příkladě na https://www.freedesktop.org/wiki/Openchrome/Troubleshooting/ tedy že [drm] Initialized via 2.11.1 20070202 on minor 0 nevypíše.
Takže si myslím, že hlavní problém je ten, že žádná současně dostupná distribuce linuxu s kernelem > 4.5 už nemá DRM pro tyto grafiky. Dalo by se to tam nějak zpětně doinstalovat? Nebo rozjet třeba Xubuntu 20.04 na kernelu 3.5?

Našel jsem ještě toto: https://cgit.freedesktop.org/openchrome/drm-openchrome/tree/drivers/gpu/drm/openchrome?h=drm-next-4.19
Ale nevím co s tím. Podle všeho to vypadá jako upravený kernel linuxu, který má DRM pro VIA grafiky. Ale jak bych potom z toho udělal nějaký debian/ubuntu/xubuntu, prostě cokoliv s možností instalovat balíky přes apt?
Případně šlo by z toho zkompilovat jen obsah z "drivers/gpu/drm/openchrome", nebo je potřeba ještě něco?

I když teď koukám, že standardní kernel 4.19 má pořád DRM pro via (https://git.kernel.org/pub/scm/linux/kernel/git/stable/linux.git/tree/drivers/gpu/drm/via?h=linux-4.19.y), tak nevím, proč se nepoužije.

4
Obecná podpora / [Kubuntu] Přestává fungovat pulseaudio
« kdy: 26 Březen 2021, 15:39:38 »
Zdravím, po několika minutách od zapnutí PC vždy přestane fungovat pulseaudio. Nejde změnit nastavení hlasitosti a později zmizí i zařízení a píše to "No output or input devices found". Zároveň nejdou přehrávat videa na youtube, myslím že to má souvislost, protože než zamrzne ten ovladač zvuku, tak youtube funguje.

Nevíte někdo jak to opravit, případně které informace o PC a kterými příkazy v terminálu mám vyjet?

5
Obecná podpora / Lepší sériová konzole
« kdy: 04 Květen 2020, 17:59:30 »
Ahoj, neznáte někdo lepší sériovou konzoli než screen?

Hledám něco jako Serial monitor v Arduino IDE, ale abych kvůli tomu nemusel pokaždé pouštět celé Arduino IDE, které se mi načítá tak minutu.

Tedy aby tam šlo nejdřív napsat příkaz, případně text při překliku opravit, a až pak poslat entrem - aby to neposílalo znak hned jak ho napíšu.
A také by bylo fajn, kdyby to umělo např. při stisknutí šipky nahoru předvyplnit předchozí příkazy.

Děkuju za rady.

6
Obecná podpora / wine32 pod 64 bit kubuntu
« kdy: 12 Prosinec 2019, 13:30:45 »
Zdravím, jde vám spustit 32 bitová exe aplikace pod 64 bitovým linuxem?

Mně šel nainstalovat jen balík wine64, a po spuštění winecfg to psalo že chybí wine32 a ať to nainstaluju, ale ten už nainstalovat nešel. A po přidání i386 architektury příkazem
Kód: [Vybrat]
dpkg --add-architecture i386 to ten wine32 už našlo, ale napsalo to tohle:
Kód: [Vybrat]
Načítají se seznamy balíků… Hotovo
Vytváří se strom závislostí       
Načítají se stavové informace… Hotovo
Některé balíky nemohly být instalovány. To může znamenat, že požadujete
nemožnou situaci, nebo, pokud používáte nestabilní distribuci, že
vyžadované balíky ještě nebyly vytvořeny nebo přesunuty z Příchozí fronty.
Následující informace vám mohou pomoci vyřešit tuto situaci:

Následující balíky mají nesplněné závislosti:
 wine32:i386 : Závisí na: libwine:i386 (= 3.0-1ubuntu1) ale nebude se instalovat
E: Nelze opravit problémy, některé balíky držíte v porouchaném stavu.

Při pokusu o manuální instalaci toho libwine:i386 balíku to zase napsalo chybějící závislost
Kód: [Vybrat]
Načítají se seznamy balíků… Hotovo
Vytváří se strom závislostí       
Načítají se stavové informace… Hotovo
Některé balíky nemohly být instalovány. To může znamenat, že požadujete
nemožnou situaci, nebo, pokud používáte nestabilní distribuci, že
vyžadované balíky ještě nebyly vytvořeny nebo přesunuty z Příchozí fronty.
Následující informace vám mohou pomoci vyřešit tuto situaci:

Následující balíky mají nesplněné závislosti:
 libwine:i386 : Závisí na: libpulse0:i386 (>= 0.99.1) ale nebude se instalovat
                Doporučuje: libasound2-plugins:i386 ale nebude se instalovat
E: Nelze opravit problémy, některé balíky držíte v porouchaném stavu.

Tak mi příjde že bych takle musel nainstalovat manuálně pomalu všechny balíky systému s architekturou i386


Tak jsem zkusil WINEPREFIX=prefix32 a WINEARCH=win32, ale ta 32 bitová aplikace pořád nejde spustit. Předtím to psalo že EXE soubor je ve špatném formátu (asi protože to zkoušel spustit jako 64 bit) a teď po vytvoření .wine s tím 32 prefixem to píše
Kód: [Vybrat]
$ wine motherboard_utility_gbttools_gbt_et5.exe
it looks like wine32 is missing, you should install it.
multiarch needs to be enabled first.  as root, please
execute "dpkg --add-architecture i386 && apt-get update &&
apt-get install wine32"
wine: '/home/parrot/.wine' is a 32-bit installation, it cannot support 64-bit applications.

Tak nevím co s tím je ???

7
Obecná podpora / Nesprávné teploty od lm-sensors
« kdy: 11 Listopad 2019, 19:36:14 »
Zdravím, rád bych si zobrazil teploty (cpu, severního můstku atd.) ale mám pocit že mi příkaz "sensors" vypisuje nesprávné.

Kód: [Vybrat]
it8718-isa-0290
Adapter: ISA adapter
in0:          +1.22 V  (min =  +0.00 V, max =  +4.08 V)
in1:          +1.81 V  (min =  +0.00 V, max =  +4.08 V)
in2:          +3.44 V  (min =  +0.00 V, max =  +4.08 V)
+5V:          +2.98 V  (min =  +0.00 V, max =  +4.08 V)
in4:          +0.00 V  (min =  +0.00 V, max =  +4.08 V)  ALARM
in5:          +0.00 V  (min =  +0.00 V, max =  +4.08 V)  ALARM
in6:          +1.26 V  (min =  +0.00 V, max =  +4.08 V)
in7:          +3.04 V  (min =  +0.00 V, max =  +4.08 V)
Vbat:         +4.08 V 
fan1:         975 RPM  (min =    0 RPM)
fan2:           0 RPM  (min =    0 RPM)
fan3:           0 RPM  (min =    0 RPM)
temp1:        -55.0°C  (low  = +127.0°C, high = +127.0°C)  sensor = thermistor
temp2:        +37.0°C  (low  = +127.0°C, high = +127.0°C)  sensor = thermal diode
temp3:         -1.0°C  (low  = +127.0°C, high = +127.0°C)  sensor = thermistor
cpu0_vid:    +1.313 V
intrusion0:  ALARM

nouveau-pci-0100
Adapter: PCI adapter
temp1:        +58.0°C  (high = +95.0°C, hyst =  +3.0°C)
                       (crit = +130.0°C, hyst =  +2.0°C)
                       (emerg = +135.0°C, hyst =  +5.0°C)

Hlavně když si zobrazím teplotu CPU v biosu, tak ten říká 46°C, což tady není ani jedna z teplot, a těch -55°C bych možná věřil (až na to mínus) že má severní most, je celkem dost horký. Ale stejně bych radši kdyby to ukazovalo ty teploty víc důvěryhodně a já si nemusel nic domýšlet. Nesetkal se s tím někdo? Nestačí jen nainstalovat nějaký další balíček?

Díky za rady

8
Zdravím, nejde mi nainstalovat 64 bit Ubuntu na Dell Vostro 1000 s procesorem Mobile AMD Sempron 3600+

Při spouštění to vypisuje chyby jako ACPI Error atd, ale stejné chyby to vypisuje i u 32 bit verze Xubuntu a ta se normálně spustí.

Ve výsledku bych chtěl nainstalovat Xubuntu kvůli Xfce prostředí (je míň náročné), a 64 bitovou verzi OS kvůli skypu.

Nevíte nědko kde by mohl být problém? Jestli by to šlo rozchodit nějakou kombinací příkazů při bootování jako acpi=off apod.?
Zkoušel jsem nomodeset s noapic a acpi=off, ale to způsobovalo Kernel panic.

Zkoušel jsem instalátory Xubuntu i Ubuntu vytvořené přes rufus i unebootin:
  • 64 bit Xubuntu přes unebootin se spustil do Try Xubuntu, ale nešel spustit instalátor, ani žádný příkaz začínající sudo, vždy se zasekla konzole. U Install Xubuntu se to zaseklo někde u "Xubuntu splash screen"

  • 64 bit Xubuntu přes rufus se zasekl někde při "Xubuntu splash screen", nevím jak zjistit u čeho přesně.

  • 64 bit Ubuntu přes rufus vypíše ty ACPI chyby, potom je chvíli vidět "Ubuntu splash screen", a potom se zobrazí zase konzole s těma chybama a pod tím BusyBox a (initramfs) kam můžu psát příkazy, ale grafické prostředí se už nenačte.

9
Zdravim, na starším ntb mám xubuntu a chtěl sem si nainstalovat minitube, ale video vždy jen problikne a pak zůstane jen černé pozadí se zvukem. Po spuštění z terminálu to vypíše:
Error disabling idle sleep "The name org.freedesktop.ScreenSaver was not provided by any .service files"
A co jsem hledal tak xfce prostředí nemá nic, co by takovou službu vyvolalo (btw ani pořádně nevím co si pod pojmem služba v PC představit) ale řekl bych že stačí vytvořit službu která by se tak jmenovala, i když by vlastně nic nedělala ne?

Ten program se chce asi jen ujistit že neztmavla obrazovka, takže asi potřebuju službu, která by ho uklidnila, že ne. Nevíte někdo jak na to? Díky.

Edit: Tak už nic, zjistil jsem že to probliknutí videa dělá i vlc (kde se to po nastavení výstupu do X11 vyřešilo), takže to s tou službou nemá nic společného.

10
Multimédia / Neplynulé animace
« kdy: 11 Červenec 2012, 19:41:10 »
Zdravím, měl někdo podobnej problém a vyřešil ho?
Některé animace u Kubuntu u mě nejsou plynulé (někdy se sekná přesouvání okna, nebo při změně okna [ctrl+tab] a nebo při hovoru přes skype po zapnutí kamery není vidět obraz, ale to, co je jako za tím oknem - takže 100% průhlednost). Grafárnu si myslim mám takovou, která by ty animace měla zvládat (Sapphire Radeon HD 4650), s ovladačem fglrx.
Ví někdo, čím to je?
Hlavně by sem rád vyřešil ten problém s videem u skype.

11
Pracovní prostředí / Kubuntu - změna ikonek složek
« kdy: 26 Červen 2012, 15:53:43 »
Zdravím, změnil jsem si ikonky na "Crystal project" (přes Menu -> Nastavení systému -> Vzhled aplikací :: Ikony > Instalovat soubor s motivem), sice se mi některý změnily, ale ty, co jsem chtěl aby se změnily (ikonky složek), zůstaly stejné (oxygen). Zkusil jsem pár dalších ikonkových motivů, ale pokaždý u složek zůstal motiv oxygenu. Jak se to teda dá změnit i u složek?

12
Zdravím, je pro Ubuntu 12.04 (nějak od P...) nějakej způsob jak instalovat programy a aktualizovat systém bez připojení k internetu?
Třeba nějakej balíček aktualizace a pak možnost si někde stáhnout software v "Centru software..." a uložit si ho, aby pak šel nainstalovat na PC bez připojení k netu?

Jo a má cenu instalovat 64 bitovou verzi na PC kde je sice AMD s 64, ale jen 750MB RAM?

Stran: [1]