Prosíme přihlašte se nebo zaregistrujte.

Přihlašte se svým uživatelským jménem a heslem.

Zobrazit příspěvky

Tato sekce Vám umožňuje zobrazit všechny příspěvky tohoto uživatele. Prosím uvědomte si, že můžete vidět příspěvky pouze z oblastí Vám přístupných.


Témata - panRajce

Stran: [1]
1
Obecná podpora / Ubuntu 20.04 - HELP ! - odmítá heslo správce
« kdy: 28 Červenec 2020, 11:24:09 »
Ahoj
potřebuji urgentní radu
Včera proběhla na mém Ubuntu 20.04 nějaká aktualizace. Vše bylo snad v pohodě. Ale od dnešního rána se potýkám se zásadním problémem. Celý systém odmítá heslo správce.
Mám jediného uživatele s automatickým přihlášením. A když se pokusím o cokoliv - instalace aplikace, odinstalace aplikace, spuštění aplikace vyžadující root (GPard, GrubEdit,....), tak po zadání hesla zahlásí "Ověření bohužel nebylo úspěšné". Jako bych zadal blbě heslo.
Zkusil jsem tedy Recorvery Mode a reset hesla. To proběhlo v pořádku a stejně nadále moje heslo je tvrdošijně odmítáno.

Postup resetu root hesla jsem volil dle tohoto
https://linuxconfig.org/ubuntu-20-04-reset-root-password

2
Hry a zábava / Hledám Audio přehrávač + Web remote control + skiny
« kdy: 23 Červenec 2020, 09:04:08 »
Ahoj
jdu si pro radu. Pro liluxovou "multimediální" mašinu hledám přehrávač audio (MP3, ACC, FLAC, online rádia), ale požaduji aby podporoval vzdálené webové ovládání (co nejkomplexnější !) a jakous alespoň úpravu vzhledů.

Rhytmbox - splňuje, ale jeho web remote control je naprosto strohá = předchozí, stop/play, další

Zatím nejlépe co jsem zkoušel mě vyšel VLC Player ..... splňuje naprosto vše, ale mám s ním nějaké potíže = občas se přehrávání zasekává, někdy úplně zastaví .... VLC pak nejde ani zavřít běžným způsobem, musím do Sledování systému a ukončit proces

Clementine - příjemný, ale nemá web control, pouze ovládání přes Androidí aplikaci

Děkuji za další návrhy

3
Hardware / Průša i3 MK2S - připojení USB
« kdy: 20 Červenec 2020, 15:14:23 »
Ahoj,
hledám jak zběsilý už půl dne a nemám žádný výsledek, tak snad někdo poradí tady.
Mám tu 3D tiskárnu (Rap/Rap) Prusa i3 MK2S a chci jí připojit na PC s Ubuntu 20.04 přes USB.

V Tiskárnách pro přidání mě jí to nenajde. Mám nainstalovaný jejich originál software Prusa Slicer. Na jejich stránkách jsem nalezl akorát zmínku "Linux users connect the printer using the virtual serial port."

EDIT:
doplním snad pár údajů
systém USB tiskárni "vidí"
Kód: [Vybrat]
lsusb
Bus 001 Device 002: ID 2c99:0001 Prusa Research (prusa3d.com) Original Prusa i3 MK2
PrusaSlicer v nastavení a Nahrávání firmware nabízí Sériový port /dev/ttyACM0
Ale při pokusu o upgrade firmware skončí s chybou
Kód: [Vybrat]
avrdude-slic3r: ser_open(): can't open device "/dev/ttyACM0": Operation not permitted
avrdude-slic3r: Could not open port: /dev/ttyACM0

Zkoušel jsem hledat tuto chybu a nalezl jsem nějaké možnosti o povolení zápisu na port /dev/ttyACM0
Kód: [Vybrat]
sudo chmod a+rw /dev/ttyACM0 nebo
Kód: [Vybrat]
sudo chmod 777 /dev/ttyACM0ale ani potom nelze provést upgrade firmware



4
Ahoj,
vím že se to netýká přímo Ubuntu Linux jako takové. Ale přesto se zde zkusím zeptat, jelikož asi zde budou hlavy, které umí poradit.

Mám v tuto chvíli PC, deska Asusu P8P67 r.3.1 UEFI BIOS, s Windows 10 na SSD v Sata 6G AHCI.
Chtěl jsem si zkusit Android OS, přesněji Bliss OS v12 (Android 10). Rufusem jsem si udělal instalační USB. Pořídil (resp. půjčil) si druhý SSD, protože na prvním není místo na další oddíl (má jen 64GB).
Nabootoval jsem z USB. Nainstaloval BlisOS s povolením GRUB. Po restartu ale není žádná nabídka, startují opět jen Wokna.
V EasyBCD jsem koukal na boot menu a tam je také zapsáno jenom Windows.
Zkusil jsem i nainstalovat Bliss OS s povolením UEFI GRUB 2. Ale prostě druhý systém nenabootuje.
Když si F8 vyvolám Boot menu a zvolím pro boot disk na kterém je Android nic se nestane,PC se samo restartujte a opět naběhnou jen Wokna.

Co mohou podniknouti, abychom mohli mít oba systémy?
Nebo co mám špatně nastavené?

PS: Našel jsem i návod na Bliss OS , jak ve Windows pomocí EasyBCD přidat další boot položku, přes NeoGrub, ale měla by se přidat konfigurace a mě to nic neudělá, není kam zadat kód.

5
Ahoj,
prosím poraďte. Mám nastavený v Aplikace po spuštění jeden SH skript. Ale jeho spuštěním dochází k ověření síťové licence.
Bohužel proti 18.04 se mi u 20.04 síť připojuje poměrně dlouho (PS, zkusil jsem i kdysi poraděný fígl pro 18.04 s ohlášením a opětovným přihlášením). Tím pádem u funkce nedojde k potřebnému ověření a zůstane "viset". Když já zavřu a spustím následně manuálně, když už je připojená síť, tak vše proběhne v pořádku.

Našel jsem sice možné řešení - https://linuxconfig.org/how-to-run-script-on-startup-on-ubuntu-20-04-focal-fossa-server-desktop, ale jakožto neLINUXák tápu v tom, vytvořil jsem si soubor /etc/systemd/system/run_octane_daemon.services , ale po startu zdá se se skript stejně nespustí

6
Pracovní prostředí / Ubuntu 18.04 xorg login ve smyčce
« kdy: 13 Červen 2020, 14:44:07 »
Ahoj,
jdu si pro radu.
"hrál" jsem si s nastavením Ubuntu 18.04 s výstupní metodou (xorg.conf, nVidia/Intel prime-select) a jak už to bývá, pokazil jsem "něco". Teď když se snažím do Ubuntu nalogovat pod standardním Ubuntu (myšleno "zubaté kolečko - Ubuntu"), tak heslo je přijato, na chvíli obrazovka blikne a pak je zpátky na přihlášení. Když zkusím Ubuntu pod Wayland, tak se přihlásím a většina věcí i běží tak jak má. Co mi ale vadí, nefunguje absolutně žádná vzdálená plocha, ať už přes TigerVNC (v mém případě přesněji přes x0vncserver), tak ani AnyDesk (obdoba TeamViewer).
Zkusil jsem dám vše do původního stavu. Pomáhal jsem si i sledováním jak mám nastavenou Ubuntu 20.04, kde běží vše OK.

Takže otázka je, co se mohlo ještě pokazit a jak to dát dokupy?

7
Ahoj,
jsem tu opět s žádostí o pomoc s nefunkční fukcionalitou.

Mám SSD, rozdělené na 3 oddíly
sda1 fat32 - boot efi
sda2 ext4 - Ubuntu 18.04
sda3 ext4 - Ubuntu 20.04
(poznámka. kromě přidání sda3 se mi takto disk sám rozdělil při prvotní instalaci Ubuntu 18.04)

A teď bych rád, vzhledem k tomu, že systém ovládám vzdálenou plochou, chtěl do obou (18 i 20) vytvořit funkci pro přepínání/bootování jiného OS. Konkrétně tedy, když jsem v 18.04 tak aby se po spuštění funkce při dalším bootu spustila automaticky 20.04. A naopak.

Našel jsem návod pro Dual Boot s Window, jak s vytvořit spouštět a úpravu GRUB.
https://unix.stackexchange.com/questions/43196/how-can-i-tell-grub-i-want-to-reboot-into-windows-before-i-reboot/112284#112284
Aktuální grub je na sda3/etc/default

Kód: [Vybrat]
GRUB_DEFAULT="saved"
GRUB_SAVEDEFAULT="true"
GRUB_TIMEOUT_STYLE="hidden"
GRUB_TIMEOUT="5"
GRUB_DISTRIBUTOR="`lsb_release -i -s 2> /dev/null || echo Debian`"
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
GRUB_CMDLINE_LINUX=""

Použiju-li
Kód: [Vybrat]
sudo grub-reboot X kde místo X dám 0 nebo 1... podle toho do kterého UBUNTU chci po restartu nabootovat, tak se tak nestane. Nabootuji vždy do posledního manuálně zvoleného OS (Předchozí zavedená položka).

8
Obecná podpora / 20.04 LST - grafické chyby desktopu
« kdy: 30 Duben 2020, 10:46:34 »
Ahoj,
běžně provozuji na PC plně funkční 18.04.
Nutno podotknout, mám stroj s multi-GPU = integrovaná Intel HD Graphics 630, dedikované 4x NVIDIA GeForce GTX 980 Ti.
Jelikož nVidie užívám jen pro výpočty CUDA, je zobrazení posíláno na Intel HD - úpravou /etc/X11/xorg.conf

Kód: [Vybrat]
Section "ServerLayout"
    Identifier "layout"
    Screen 0 "intel"
    Screen 1 "nvidia1"
EndSection

Section "Device"
    Identifier "intel"
    Driver "intel"
    BusID "PCI:00:02:0"
EndSection

Section "Screen"
    Identifier "intel"
    Device "intel"
EndSection

Section "Device"
    Identifier "nvidia1"
    Driver "nvidia"
    BusID "PCI:01:00:0"
EndSection

Section "Screen"
    Identifier "nvidia1"
    Device "nvidia1"
EndSection

PS: Screen 1 by možná šel i vypustit

Po vydání 20.04 jsme si rozdělil disk a na druhou partition jsme nainstaloval čistou Ubuntu 20.04 LST. Postupně si přenáším všechny funkcionality z 18.04 - Conky, Octane Slave Daemon (nástroj pro síťový rendering přes CUDA). Vše zatím běží O.K. Jen po upravě výše zmíněného xorg.conf v nastavení 20.04 se na obrazovce objevují na desktopu vady v grafice.


PS2: Malý uživatelský postřeh ... v defaultním nastavení při Tmavém vzhledu Editor zvýrazňuje aktuální řádek v bílé bárvě s bílým textem, takže NIC není vidět. Zatím řeším vypnutím zvýrazňováním aktuálního řádku.

9
Internet a sítě / Ubuntu 18.04 - dlouhé ověření drátové síte
« kdy: 17 Březen 2020, 13:11:16 »
Ahoj,
jdu si pro radu. Poslední dobou mám na PC s Ubuntu problém s délkou ověření (prvotního připojení) při startu.
Zkusím to trochu rozvést. Při sledování monitoringu Conky - čas spuštěného systému, tak při nějakých 30s se teprve objeví ikonka sítě v liště, a to ještě s otazníkem. A skoro 2min trvá, než se ikona změní na "bez otazníku".
Bohužel mám při startu spouštěn daemon, který si po síti ověřuje licenci. Takže když nedojde ke včasnému správnému připojení, zůstane viset a nepřihlásí se.
Zkusil jsem do SH scriptu pro spuštění toho daemona přidat čekací dobu, nejprve 10s, pak i 20s a nyní 30s. Ale i tak se to né vždy podaří.
Zajímavé je, že když jsem cca tak před tím rokem UBUNTU instaloval a rozchodil, tak se nic takového nestávalo. Daemon se byl schopen přihlásit téměř okamžitě po startu.
Byl bych tedy rád za doporučení, co mohu udělat pro rychlejší "nastartování" síťového připojení?
Ještě dodám, že používám router Cisco RV130W a v mám pro konkrétní PC rezervovanou IP adresu (DHCP Leased Client).

10
Ahoj,
jdu si pro radu. Zkusil jsem si podle návodu https://vitux.com/how-to-install-the-kde-plasma-desktop-on-ubuntu-18-04-lts/ přidat k Ubuntu 18.04 prostředí KDE Plasma.
Po restartu však mě vyplivne takhle chybová hláška viz příloha. Když odkliknu "Budiž" naběhne klasicky Ubuntu Gnome.
Poradil by mi někdo prosím, co udělat, abych zprovoznil Plasmu?
Možná bych měl dodat ještě, že mám v nainstalovaném Gnome přidám x11VNC server a také PC je nakonfigurováno pro provoz "bez monitoru" - zobrazení právě přec VNC klienta.
Citace
nastavením ../etc/X11/xorg.conf
V současnosti ale mám připojen "servisní" monitor.

11
Ahoj,
snažím se najít, jestli pro Conky (nebo samostatně) existuje skript, který umožní při určité události vypnout PC?

Přesněji potřebuji
- při sledování hodnoty nvidia-settings - GPU Utilization bude nižší jak 10% po dobu např. 60sec, pak vypnout počítač

12
Ahoj,
mám nyní hotový stroj na desce ASUS B250 Mining Expert s Intel HD GPU a 2x nVidia GeForce GTX 780Ti pro GPu Rendering pod Octane. Momentálně to funguje, i když v nastavení se mi ukazuje, že obraz jde přes GeForce GTX 780Ti, monitor je však pře HDMI zapojen do Intel GPU  :D
Uvažuji o lepším řešení. Tedy aby obraz šel čistě přes Intel iGPU a výpočet CUDA přes všechny 780Ti.
Vygůůglil jsem toto řešení:
https://gist.github.com/alexlee-gk/76a409f62a53883971a18a11af93241b
Než se v tom ale začnu vrtat, tak se chci zeptat, zda je to opravdu správný směr, kterým se vydat?
Samozřejmě s přihlédnutím zadání správných hodnot pro BusID.
Podle jednoho z vláken zde jsem si nechal vygenerovat xorg.conf.new, který mi, mimo jiné, vyhodil tento současný stav:
Kód: [Vybrat]
Section "Device"
Identifier  "Card0"
Driver      "intel"
BusID       "PCI:0:2:0"
EndSection

Section "Device"
Identifier  "Card1"
Driver      "nouveau"
BusID       "PCI:11:0:0"
EndSection

Section "Device"
Identifier  "Card2"
Driver      "nouveau"
BusID       "PCI:13:0:0"
EndSection

Section "Screen"
Identifier "Screen0"
Device     "Card0"
Monitor    "Monitor0"
SubSection "Display"
Viewport   0 0
Depth     1
EndSubSection
SubSection "Display"
Viewport   0 0
Depth     4
EndSubSection
SubSection "Display"
Viewport   0 0
Depth     8
EndSubSection
SubSection "Display"
Viewport   0 0
Depth     15
EndSubSection
SubSection "Display"
Viewport   0 0
Depth     16
EndSubSection
SubSection "Display"
Viewport   0 0
Depth     24
EndSubSection
EndSection

Section "Screen"
Identifier "Screen1"
Device     "Card1"
Monitor    "Monitor1"
SubSection "Display"
Viewport   0 0
Depth     1
EndSubSection
SubSection "Display"
Viewport   0 0
Depth     4
EndSubSection
SubSection "Display"
Viewport   0 0
Depth     8
EndSubSection
SubSection "Display"
Viewport   0 0
Depth     15
EndSubSection
SubSection "Display"
Viewport   0 0
Depth     16
EndSubSection
SubSection "Display"
Viewport   0 0
Depth     24
EndSubSection
EndSection

Section "Screen"
Identifier "Screen2"
Device     "Card2"
Monitor    "Monitor2"
SubSection "Display"
Viewport   0 0
Depth     1
EndSubSection
SubSection "Display"
Viewport   0 0
Depth     4
EndSubSection
SubSection "Display"
Viewport   0 0
Depth     8
EndSubSection
SubSection "Display"
Viewport   0 0
Depth     15
EndSubSection
SubSection "Display"
Viewport   0 0
Depth     16
EndSubSection
SubSection "Display"
Viewport   0 0
Depth     24
EndSubSection
EndSection

13
Ahoj,
zkouším hledat, ale marně, tak se zeptám jestli s tím už někdo měl zkušenosti.
V Conky chci vložit zobrazení zatížení (Utilization). Nejprve jsem myslel, že má chybu ve skriptu konfigurace Conky. Pak jsem zjistil, že ani samotné nVidia-smi neukazuje hodnotu pro GPU Utilization. Ostatní proměnné ale je schopna detekovat.
A například utilita nvidia-settings je schopná tuto hodnotu generovat. Takže můj předpoklad je, že to není problém HW (deska ASUS B250 Mining Expert, 2x nVidia GTX 780 TI v PCIe x1).

Někde jsem četl, že nVidia v nvidia-smi zakázala podporu pro karty mimo Quadra, ale to byl příspěvek z 2016.

EDIT: po chvíli hraní s Conky a nvidia-smi a nvidia-settings se zdá lepší používat informace právě z nvidia-setting ..... důvod = v parametrech lze odlišit z které GPU má informace být využita, v případě stroje s vícero GPU je pak snadnější v Conky graficky upravit pro každý kus GPU

Zvládl by někdo poradit co s tím? .... Ano, nouzovka je použít výstup z nvidia-settings.

EDIT 2 (26.8.2019) POTVRZENO, po výměně karet z nVidia 780 Ti na 980 Ti začalo nvidia-smi správně generovat všechny položky, tudíž je to o typu karty. Zastaralé holt SMI nepodporují nebo jen z malé části.

14
Pracovní prostředí / Ubuntu 18.04: zobrazení procesu v okně
« kdy: 30 Květen 2019, 10:59:06 »
Ahoj,
řešil jsem nedávno rozběhnutí renderfarmy s Octane Render a jeho Slave Daemon pro síťový rendering pod Ubuntu 18.04. To se mi s pomocí podpory podařilo.
Nyní bych potřeboval pomoci s trochu odlišnou záležitostí.
Mám-li nějaký bežící proces - v mém případě právě octane_slave_daemon - lze nějak nastavit, aby tento proces byl vidět v "okně" na desktopu GNOME?

Na Widlích když spustíme Octane Slave Daemon, tak nám zůstane "viset" okno a máme přehled o jeho případně aktivitě/zhroucení (viz Screenshot_1). To samé by mi pomohlo v Ubuntu, abych věděl, že Daemon je v procesu aktivní nebo při jeho zhroucení věděl že jej musím znovu nastartovat. Ale o jeho aktivitě bohužel vím jedině ze Sledování systému (viz Snímek z 2019-05-24 14-25-25.png).
A nebo je to záležitost daného software (Octane Render pro LINUX) a parametrů při spuštění?

Stran: [1]