Prosíme přihlašte se nebo zaregistrujte.

Přihlašte se svým uživatelským jménem a heslem.

Zobrazit příspěvky

Tato sekce Vám umožňuje zobrazit všechny příspěvky tohoto uživatele. Prosím uvědomte si, že můžete vidět příspěvky pouze z oblastí Vám přístupných.


Příspěvky - qvoshi

Stran: [1]
1
AMD vydalo novou verzi AMDGPU-PRO 16.40-348864.

viz http://support.amd.com/en-us/kb-articles/Pages/AMD-Radeon-GPU-PRO-Linux-Beta-Driver%e2%80%93Release-Notes.aspx

Nezjistil jsem žádné problémy s touto verzí, takže doporučuju.

Bohužel stále jsou podporovány pouze GCN 1.1 a novější. Pro GCN 1.0 je možné sáhnout k experimentální podpoře v jádře.

Došlo k přejmenování některých balíčků, takže je nutné starší verzi nejdřív odinstalovat (instalátor to tentokrát neudělá).

2
AMD vydalo novou verzi AMDGPU-PRO  16.30.3-306809.

viz http://support.amd.com/en-us/kb-articles/Pages/AMD-Radeon-GPU-PRO-Linux-Beta-Driver%e2%80%93Release-Notes.aspx

Osobně tuto verzi nedoporučuju - doporučuju zůstat na verzi 16.20.3.
Ač nová verze přináší mírně vyšší výkon, ale začal mi zamrzat PC.

3
Ahoj myslíš že to bude fungovat na R9 270X?

No tady asi neuspěješ.

R9 270X je PITCAIRN z rodiny Southern Islands (někdy označované jako SI) tedy GCN 1.0 viz. https://www.x.org/wiki/RadeonFeature/
Podle toho co vím, tak podpora těchto čipů je v plánu. Zkus se podívat do souboru amdgpu-pro_16.20.3-294842.tar.xz/amdgpu-pro-dkms_16.20.3-294842_all.deb/usr/src/amdgpu-pro-16.20.3-294842/amd/amdgpu/amdgpu_drv.c zda je tam hw id tvé karty...ale jestli dobře koukám, tak tam jsou GCN 1.1 a novější

4
AMD vydalo novou verzi ovladače. Stále se jedná o BETA. https://www2.ati.com/drivers/beta/amdgpu-pro_16.20.3-294842.tar.xz

Novinky na HD7790:
  • podpora jádra 4.4 (opět pouze tohoto jádra)
  • není potřeba podvrhování EDID
  • HDMI audio je nyní funkční
  • výrazně vylepšený výkon - myslím, že odpovídá fglrx

Výkon:
  • Skóre v Unigine Haven 4.0 - preset Basic se zvýšilo z 236 na 1576 bodů (cca 6,5krát)
  • V Half-live 2 Episode two se fps zvýšilo z 20 na 240 (cca 12x)

Návod na instalaci:
  • Odstranit všechny případné modifikace z prvního příspěvku
Kód: [Vybrat]
# odinstalace starých driverů
amdgpu-pro-uninstall

# odstranit "drm_kms_helper.edid_firmware=edid/monitor.bin" z grubu
sudo gedit /etc/default/grub

sudo update-grub
  • Odstranit všechny jádra novější 4.4
  • Nainstalovat / aktualizovat jádro 4.4
  • Stáhnout a nainstalovat amdgpu-pro driver

Pokud máte zájem, pak můžu za týden napsat zda jsem našel nějaké problémy.

5
Testuji tento ovladač od 5.4.2016 a nezaznamenal jsem jiné problémy než zmíněné.
  • stále se mi nepodařilo zprovoznit HDMI zvuk
  • výkon je nízký
  • jinak plně funkční OpenGL 4.5, OpenCL, Vulkan, VDPAU

Pro instalaci na Ubuntu 16.04 LTS Xenial je potřeba downgradovat na jádro na 4.2 a všechna jádra novější než 4.2 odstranit. Pak lze použít potup uvedený 1. příspěvku.

6
Podařilo se mi zprovoznit ovladač AMDGPU-PRO na AMD Radeon™ HD 7790 (BONAIRE).
   Přináším tento návod pro všechny, kdo chtějí experimentovat  :)
   Ovladač by "prý" měl fungovat pro všechny GCN 1.1 a novější.
   Výkon je zatím dost nízký - nejspíš není aktivní powerplay (pokud najdete řešení dejte vědět). <- řeší nový ovladač
   Nepodařilo se mi zprovoznit HDMI audio <- řeší nový ovladač

Aktualizováno - viz 3. příspěvek.

Upozornění:
   AMDGPU-PRO je aktuálně v beta verzi. Já, AMD, Linux a ani váš soused neneseme žádnou zodpovědnost pokud přijdete o data nebo si poškodíte svůj počítač.
   Pokud Vám tento návod nepomůže, pak je mi líto. Zkuste googlit jako já a možná se vám povede problém vyřešit.


AMD uvádí podporu pro:
AMD Radeon™ R9 Fury X GraphicsAMD Radeon™ R9 380X Graphics
AMD Radeon™ R9 Fury GraphicsAMD Radeon™ R9 380 Graphics
AMD Radeon™ R9 Nano GraphicsAMD Radeon™ R9 285 Graphics
AMD Radeon™ R9 M395X Graphics

   Tento postup je určen pro konfiguraci s jedním monitorem (pro více monitorů upravte postup viz. zdroje).

1. Přečtěte si celý postup než budete pokračovat
   Pokud postupu nerozumíte, pak sežeňte někoho kdo mu bude rozumět :)
   Postup je učen pro Ubuntu 14.04.4 LTS (Trusty Tahr) ... tedy s jádrem 4.2.
   Nesmí být aktivní "nomodeset", "vga=" a další parametry kernelu (v grubu), které blokují KMS.

2. Zálohujte si EDID informaci z monitoru (bude potřeba pokud dojde k problémům)
Kód: [Vybrat]
$ sudo apt-get install read-edid
$ sudo get-edid > monitor.bin
$ sudo chmod 777 monitor.bin

3. Stáhnout a rozbalit ovladač AMDGPU-PRO
Kód: [Vybrat]
$ mkdir AMDGPU; cd AMDGPU
$ wget https://www2.ati.com/drivers/beta/amdgpu-pro_16.15.2-277429.tar.xz
$ tar -Jxvf amdgpu-pro_16.15.2-277429​.tar.xz

4. Nainstalovat ovladač (dle návodu od AMD)
Kód: [Vybrat]
$ amdgpu-pro-driver/amdgpu-pro-install
$ sudo usermod -a -G video $ LOGNAME
   - restart

5. Podvržení EDID informace (jen pokud budete mít problém)
Symptomy:
   - po restartu se zobrazí desktop ve špatném rozlišení a nejde rozlišení zvětšit (u mě 1024x768 na FHD monitoru).
Kód: [Vybrat]
$ dmesg | grep amd   zobrazuje
Citace
amdgpu 0000:01:00.0: HDMI-A-1: EDID invalid.
   - ovladač pravděpodobně neumí správně přečíst EDID u monitoru - podle mých pokusů je odlišný od EDID získaného v kroku 2.
   - v tuto chvíli již nemá cenu EDID stahovat. Je třeba nejdříve ovladač odstranit a restartovat.

Řešení:
Kód: [Vybrat]
$ sudo mkdir -p /lib/firmware/edid
$ sudo cp monitor.bin /lib/firmware/edid/monitor.bin
$ sudo gedit /etc/default/grub
   - do řádku
Kód: [Vybrat]
GRUB_CMDLINE_LINUX_DEFAULT   přidat
Kód: [Vybrat]
drm_kms_helper.edid_firmware=edid/monitor.bin
Kód: [Vybrat]
$ sudo update-grub   - restart

6. HDMI audio (jen pokud budete mít problém)
Symptomy:
   - nefunguje audio
   - při otevření nastavení hlasitosti není nic na záložce Výstup, nebo tam chybí HDMI audio
Řešení:
   - zatím nenalezeno, pokud máte tip, napište

7. Ověření konfigurace:
Kód: [Vybrat]
$ lshw -c video 2> /dev/null | grep driver= ; glxinfo | grep OpenGL   - příkaz vypíše něco ve stylu
Citace
configuration: driver=amdgpu latency=0
OpenGL vendor string: Advanced Micro Devices, Inc.
OpenGL renderer string: AMD Radeon HD 7700 Series
OpenGL core profile version string: 4.3.13830 Core Profile Context 16.15.2
OpenGL core profile shading language version string: 4.50
OpenGL core profile context flags: (none)
OpenGL core profile profile mask: core profile
OpenGL core profile extensions:
OpenGL version string: 4.5.13830 Compatibility Profile Context 16.15.2
OpenGL shading language version string: 4.50
OpenGL context flags: (none)
OpenGL profile mask: compatibility profile
-------------
zdroj:
   http://support.amd.com/en-us/kb-articles/Pages/AMDGPU-PRO-Beta-Driver-for-Vulkan-Release-Notes.aspx
   https://wiki.archlinux.org/index.php/AMDGPU
   https://wiki.archlinux.org/index.php/Kernel_mode_setting#Forcing_modes_and_EDID

7
Obecná podpora / Re: Ubuntu 9.10 a ATi 9550
« kdy: 14 Prosinec 2009, 22:27:26 »
mám ten samý problém ??? mám grafiku ati x1650 a funguje mi pouze v ubuntu přes vesa driver ani svobodný ovladač na ní nejde 9.3 ovladače na novém ubuntu taky nejdou prostě stěmahle šmejdama ati jsem už zkončil na dobro při příštím nákupu grafiky si budu kupovat nvidia má super ovladače pro linux je za stejnou cenu a kvalitnější než ty náhražky ati  :-\ uplně mi znehodnotily mojí grafiku hlavně že na windows 7---aneb vista s novou reklamou a plno slibu na takovou shitku co  má jenom jiný jméno a jinej panel na tu vývoj ovladaču pro starší karty pokračuje :'(Ati nepřišla jenom o jednoho zákaznáka kterým jsem já ale o spoustu dalších mích přátel kterým skládám pc sestavy :-*
no podle téhle stránky nejsou oficiální ovladače pro karty X1 a starší ani pro Win 7 - mají se instalovat ovladače pro vistu (jen by mě zajímalo proč tam je nabídnuta ke stažení verze 9.11)
Tyhle grafiky jsou 4 a více let staré a navíc řada HD má dost změněnou architekturu...takže se dalo čekat že je ATI přestane podporovat
Nvidia podporuje grafiky řady 7 a novější ... protože část jejich sortimenu je přejmenovaná starší generace (např. GeForce 8800GT -> GeForce 9800GT -> GeForce GTS 240 viz. odkaz ) a nvidia musí prodávané grafiky podporovat...takže to je taky vcelku logické...nechci vyvolávat flame a nebudu na takové příspěvky reagovat, pouze ukazuji co jsem jinde našel
...já už mám jen ATi grafiky, jsou to novější kusy - HD2400, HD2600, HD3300 a neměl jsem s nimi žádné problémy...takže si strčte nářky o dokanalé nvidii a nahovno ATI někam...to už dávno neplatí

a teď k problému s ATI ovladači....
Tak originální ovladače nefungují. V Ovladače hardwaru se mi nic neukazuje, ale před chvílí se mi to tam jednou ukázalo, tak jsem je zapnul, restartoval, a byl jsem v Low Graphics Mode. Zkusil jsem třetí možnost, mám "direct rendering: Yes", ale efekty mi stejně nejdou zapnout.
Zkoušel jste jestli funguje 3D akcelerace? ...např. glxgears (počet snímků musí být vyšší...tohle zvládne renderovat i CPU...nevím to jistě ale tisíce fps. Já mám s aktivnímy efekty cca 1000fps na IGP HD3300)
Problém může být že se nepodařilo úplně odstranit fglrx...zkusil bych to ještě jednou....pokud možno s čistou instalací, nebo podle tohodle návodu ... Problem: Need to fully remove -fglrx and reinstall -ati from scratch
nic dalšího jsem buhužel nenašel....je potřeba googlit a já už jdu spát

8
Obecná podpora / Re: Ubuntu 9.10 a ATi 9550
« kdy: 12 Prosinec 2009, 09:06:04 »
Podporu pro tyto grafiky odstřihlo AMD(ATI) - poslední verze je 9.3 a ty zase nefungujou v ubunu 9.X viz.    http://support.amd.com/us/gpudownload/linux/Legacy/Pages/radeon_linux.aspx?type=2.4.1&product=2.4.1.3.35&lang=English

AMD teď podporuje HD 2xxx a novější. Na origál ovladače můžeš zapomenout  :-\

Vím o dvou možnostech:
  1) ovladač v ubuntu Systém → Správa → Ovladače hardwaru ... a povolit nevobodný ovladač viz. http://wiki.ubuntu.cz/Ovlada%C4%8De%20grafick%C3%BDch%20karet
  2) open source ovladač ... měl by 3D zvládnout viz. https://help.ubuntu.com/community/RadeonDriver
A nebo zůstaň u 9.04...pokud ti všechno fugnovalo dobře (novější ne vždy je lepší)

9
Problém s vyžadováním hesla pro změnu frekvence procesoru
- našel jsem návod jak to vyřešit: http://www.aldeby.org/blog/do-not-require-the-password-for-cpu-frequency-scaling-in-ubuntu-karmic-9-10.html

10
Hardware / Re: NotebookMicroStar EX610 a wireless ( ATH 5007EG )
« kdy: 04 Leden 2009, 19:04:12 »
Taky jsem to dlouho hledal....
Tenhle notebook pouziva Atheros 5007EG takze potrebujes madwifi-hal-0.10.5.6 (v repo je zatim 0.9.4 takze manualne )

zkracene (uz nevim kde jsem to nasel):

sudo aptitude update && sudo aptitude -y install build-essential linux-headers-$(uname -r)
cd ~
wget -O driver.tar.gz http://snapshots.madwifi-project.org/madwifi-hal-0.10.5.6-current.tar.gz
tar xf driver.tar.gz
cd madwifi-*
make
sudo make install
echo ath_pci | sudo tee -a /etc/modules
sudo modprobe ath_pci

-------------------------------------
Snad je to alespon trochu srozumitelne.....dyztak pouzijte slovnik svahylstiny :-)

Stran: [1]