Prosíme přihlašte se nebo zaregistrujte.

Přihlašte se svým uživatelským jménem a heslem.

Zobrazit příspěvky

Tato sekce Vám umožňuje zobrazit všechny příspěvky tohoto uživatele. Prosím uvědomte si, že můžete vidět příspěvky pouze z oblastí Vám přístupných.


Témata - Rover623

Stran: 1 [2] 3
26
Tipy a triky pro Linux / Vytvoření vlastního spouštěče na ploše
« kdy: 06 Červenec 2012, 22:03:53 »
Už vás nebaví vytvářet si v GNOME 3 vlastní spouštěč příkazem
Kód: [Vybrat]
gnome-desktop-item-edit ~/Plocha/ --create-new tahle funkce v Nautilu prostě chybí, ale stačí doinstalovat tenhle doplněk http://www.florian-diesch.de/software/arronax/ a můžete opět vytvářet spouštěče jako v GNOME 2

27
Tak jsem si všiml, že Ubuntu 12.04 vytváří v domovském adresáři poměrně velký počet skrytých prázdných textových souborů, které mají stejný název, pouze se odlišují řadou asi 6 velkých písmen na konci (myslím, že to vypadá nějak takhle .gauthorityXVCVDF).

V žádném jiném prostředí se mi to neděje, pouze v GNOME. Jestli nad ním běží Unity nebo Shell je celkem lhostejné. Absolutně nechápu k čemu GNOME ty soubory potřebuje (po jejich vymazání se nic nestane).

Děje se mi to na několika počítačích, počet těch souborů naroste asi na 50 a pak se zastaví. Zajímaly by mě tedy 2 věci, k čemu ty soubory jsou a děje se vám to taky?

28
Přenosné počítače / Acer Aspire One D-257 s Ubuntu 12.04
« kdy: 17 Červen 2012, 16:16:47 »
Tenhle netbook prodává Acer se systémem MeeGo, náhrada za nějaké distro Linuxu je asi žádoucí, ať už proto že MeeGo nepodporuje češtinu nebo nelze použít repozitáře. Tedy lze, je k dispozici repozitář Aceru, ale stejně jako u konkurenčního Asusu, není v něm skoro nic.

Výběr prostředí

Prvně je nutné vybrat si prostředí, v případě Xubuntu a Lubuntu je to celkem jedno co si zvolíte. Na Kubuntu rovnou zapomeňte odezvy na Atomu jsou žalostné. Pokud se rozhodnete pro standardní Ubuntu, velmi doporučuji 32bit verzi, její odezvy jsou na Atomu daleko lepší a i zatížení procesoru je menší.

Instalace

Instalace je bezproblémová. Klasický postup, ověřit stažené ISO, převést na nějaký Flash disk (v Ubuntu máte "Tvůrce spouštěcího disku", ve Windows doporučuji "Unetbootin).

Jak jsem psal výše vlastní instalace je bez potíží, já sám jsem použil jako obvykle instalaci s ručním dělením disku a odděleným "/home".

Po instalaci

V poslední verzi systému by již mělo ovládání jasu i wifi fungovat správně, není tedy nutné zadávat parametr do GRUBu a blacklistovat acer_wmi. Bohužel Wifi zlobí ještě víc, viz. sekce Wifi

Prvotní radost z toho, že vše funguje vystřídá velmi rychle vystřízlivění.
Nefunguje restart a ovládání jasu se chová divně
Obojí napravíme velmi rychle v konfiguraci GRUBu
Kód: [Vybrat]
sudo gedit /etc/default/grub nejdeme řádek
Kód: [Vybrat]
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash" a upravíme ho takhle
Kód: [Vybrat]
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_backlight=vendor" pak nejdeme řádek
Kód: [Vybrat]
GRUB_CMDLINE_LINUX="" a upravíme takhle
Kód: [Vybrat]
GRUB_CMDLINE_LINUX="reboot=efi" uložit a provést
Kód: [Vybrat]
sudo update-grub
Disk

Já měl opět štěstí na WD (díky bohu bez AF), bohužel stejně disk cvaká jako šílenec. Prvně je to krajně otravné, za druhé to při kopírování na USB disky zvyšuje nechutně latenci systému (při provozu na baterii). Je tedy vhodné to příšerné parkování zastavit, zadáme
Kód: [Vybrat]
sudo gedit /etc/hdparm.conf a na jeho konec přidáme tohle
Kód: [Vybrat]
/dev/sda {
apm_battery = 254
}
pokud nechcete parkování úplně zastavit a jen o málo prodloužit interval, pak tohle
Kód: [Vybrat]
/dev/sda {
apm_battery = 180
}
Povšimněte si struktury souboru, před přidávaným blokem musíte mít jeden řádek mezeru, zároveň musíte mít i jeden řádek prázdný na konci souboru, jinak zápis nefunguje.

Plymouth

Jako obvykle nejde Plymouth, je to zcela normální jev od Ubuntu 10.04, oprava je naštěstí lehká
Kód: [Vybrat]
sudo gedit /etc/initramfs-tools/conf.d/splash to by mělo vytvořit prázdný soubor s názvem "splash", do něj vložte
Kód: [Vybrat]
FRAMEBUFFER=y uložit a zadat
Kód: [Vybrat]
sudo update-initramfs -u
Wifi

Věc která mě pěkně potrápila je Wifi, netbook podporuje pouze draft-n, pokud tedy máte router s podporou normy "N", ověřte že má podporu i pro draft-n, jinak se dočkáte otravného odpojování (ne moc často, ale stejně) nebo mu rovnou přepněte "radio" jen na b/g. Pokud to stále blbne změňte nastavení routeru v sekci zabezpečení na WPA (ne WPA2) a šifrování na AES.

Ta horší věc je, že velmi často po probuzení Wifi prostě nejde, zkusil jsem různé postupy jak ji rozjet, ale vše je na houby, prostě musíte resetovat počítač, pak to naskočí. Nakonec mě napadlo delegovat řízení pouze na systém. HW řízení Wifi zastává modul acer_wmi, ten v kostce dělá asi tolik, že imituje signály, které u Acerů vysílá originální ovladač (pro Windows) a tím po stlačení klávesové zkratky adaptér povoluje a zakazuje (řízení je pouze SW). Bohužel, právě tenhle modul má v Ubuntu na svědomí, že karta po probuzení prostě nejde a resetnout ji do funkčního stavu je nemožné. Systém si totiž myslí, že karta funguje, ale netbook ji drží vypnutou. Zakázáním modulu acer_wmi si sice znefunkčníme klávesovou zkratku pro zapnutí a vypnutí Wifi (Fn+F3), ale převedeme kompletně řízení rádia na systém, což by mělo vyřešit problém s nefunkční Wifi po probuzení. Postup je následující
Kód: [Vybrat]
sudo gedit /etc/modprobe.d/blacklist.conf a na konec souboru přidáme
Kód: [Vybrat]
blacklist acer_wmi
V poslední verzi jádra zlobí Atheros 9485 naprosto neskutečným způsobem, skoro každých 30 minut spadne spojení a karta má mizerný výkon, síla signálu 2 metry od routeru je asi 60%, naštěstí to se vzrůstající vzdáleností už exponenciálně neklesá.

Bohužel nemám řešení jak na nestabilně se chovající kartu, zkombinoval jsem několik postupů, ale díky naprosté nahodilosti problému, pořád ještě testuji co vlastně funguje. Nicméně, zatím jsem se dobral ke 4 postopům, které lze zkusit dohromady.

Nastavení BIOSu

Někomu pomohlo zapnout v BIOSu boot z LAN a přesunout ho na první místo bootovací sekvence.

Vypnutí HW cryptování

Tenhle postup zabírá pro více karet Atherosu, které používají ovladač ath9k (při změně konfiguračního souboru na ath5k, to zabírá i na karty s ovladačem ath5k). Postup je následující
Kód: [Vybrat]
sudo gedit /etc/modprobe.d/ath9k.conf to by mělo vytvořit prázdný textový soubor jehož obsahem bude toto
Kód: [Vybrat]
options ath9k nohwcrypt=1 majitelé karet s ovladačem ath5k asi již pochopili, že jediné co musí udělat je vyměnit "9" za "5".

Blacklistování atl

Někomu pomohlo toto
Kód: [Vybrat]
sudo gedit /etc/modprobe.d/blacklist.conf a na konec souboru přidat
Kód: [Vybrat]
blacklist atl1c uložit a provést
Kód: [Vybrat]
sudo update-initramfs -u
Vypnutí správy napájení

Na tomhle Aceru se to na výdrži baterie u mě podepsalo snížením doby běhu na baterku asi o 10 minut. Postup je následující
Kód: [Vybrat]
sudo gedit /etc/pm/power.d/wireless to by mělo vytvořit prázdný soubor, do kterého se vloží tohle
Kód: [Vybrat]
#!/bin/sh

/sbin/iwconfig wlan0 power off
uložit a přidělit spustitelný příznak
Kód: [Vybrat]
sudo chmod +x /etc/pm/power.d/wireless
Update jádra

Někomu prý pomohlo updatovat jádro na verzi 3.4 (verze 3.3 je prý postižena stejně jako 3.2.0-26). U mě update na verzi 3.4 rc4 nic nevyřešil a ještě to rozhodilo několik dalších věcí v systému které fungovaly.

U mě žádná ze 4 metod použitých samostatně nefunguje, v kombinaci všech to snad i vypadá, že vše funguje. Pokud máte nějakou z problémových karet Atheros, napište mi sem co vám pomohlo, případně kombinace jakých postupů vám pomohla.

Hibernace

V Ubuntu 12.04 na většině HW nefunguje hibernace (uspání na disk), stejně tomu je i na tomto Aceru, provedl jsem tedy několik testů a zjistil, že hibernace zde funguje naprosto spolehlivě a je možné ji tedy povolit. Zadáme
Kód: [Vybrat]
sudo gedit /etc/polkit-1/localauthority/50-local.d/hibernate.pkla
to nám vytvoří prázdný soubor, do kterého vložíme
Kód: [Vybrat]
[Re-enable hibernate by default]
Identity=unix-user:*
Action=org.freedesktop.upower.hibernate
ResultActive=yes
uložit a restartovat
Kód: [Vybrat]
sudo shutdown -r now Po restartu by měla být hibernace povolena.

29
Hardware / Problém s řadiči (asi)
« kdy: 13 Červen 2012, 13:26:12 »
Tak se mi začal objevovat zvláštní problém, když na IDE řadič připojím druhé zařízení (slave), trvá naběhnutí systému enormně dlouho. Linux vůbec nenabootuje, skončí s hláškou o chybě disku, Windows kupodivu skoro celou minutu čeká a nakonec najede, start systému i jeho chod je potom plynulý i disk má normální rychlost.

Pokud nemám na IDE řadiči nic nebo jen jedno zařízení (master) je všechno v pořádku.

Na SATA se objevuje jiný problém, pokud připojím 2 DVD mechaniky, chovají se pod systémem velmi zvláštně, jedna obvykle okamžitě přestane číst média. S jednou mechanikou se mi poslední dobou často stává, že systém hlásí chybu při mountování média.

Desku mám tuhle http://www.asrock.com/MB/overview.asp?Model=ConRoe1333-D667%20R3.0

Kontrolou jsem žádné nafouklé kondenzátory nenašel i deska celkově vypadá v pořádku, nicméně se mi zdá, že selhávají řadiče, protože výše popsané chování rozhodně není normální. Co si o tom myslíte vy?

30
S hrdostí mohu prohlásit, že jsem dokončil přechod další západočeské kapely na Ubuntu.

Medium Rock je kapela, která za mojí malé pomoci téměř kompletně přešla na distribuci Ubuntu Studio. Kvůli zesilovači Fender, se zatím ještě udržuje jeden postarší stroj s Windows, ale zbytek byl kompletně přemigrován.

Kdyby někdo věděl jak rozchodit ovládací soft Fenderu pod Wine, docela by mi to pomohlo.

Nakonec aby z toho komunita něco měla, první CD bylo uvolněno pod svobodnou licencí, tahat můžete tady http://www.ulozto.cz/xCuQLBs/medium-rock-cd-medium-1-7z

31
Chtěl bych se zeptat místních odborníků na síť, protože moje znalosti v této problematice nejsou až tak obsáhlé.

V současné době používám na chatě internet přes klasický repeater, anténa poskytovatele je na dohled, ale pokrytí v domě už je mizerné, proto je nutné signál "opakovat" aby se zesílil.

Poskytovatel má stanici která distribuuje signál na 3 pásmech (2.4, 5.4, 5.8 ), ale v poslední době mu na střídačku odpadávají různě frekvence. Moc se mi nechce dávat anténu na dům, přijde mi to zbytečné, protože v předsíni kde je umístěn repeater je síla ještě nějakých 75%. Potřeboval bych tedy router nebo nějaké řešení jak přijímat signál ve všech 3 pásmech, ale dál v domě už ho distribuovat jen v pásmu 2.4 pro síťovou kartu v notebooku.

Předem děkuji za návrhy jak to provést.

32
Předem říkám, že repozitář Mozilla mám přidaný, nicméně nedávno se provedla aktualizace Firefoxu na verzi 10 a jazykový balíček pro češtinu už se zase hlásí jako nepodporovaný (problémy s kompatibilitou). Nemám ho v FF jako doplněk, ale normálně mám přes Synaptic přidaný balík firefox-locale-cs.

Předpokládám, že podobný problém bude v Ubuntu 10.04, na verzi 11.10 je vše v pořádku. Zajímalo by mě jestli to funguje vám

33
Multimédia / Jak dostat titulky z DVD?
« kdy: 07 Prosinec 2011, 19:52:10 »
Zkusil jsem už kde co, ale udělat z titulků uložených na DVD normální textový soubor se jeví jako dost neřešitelný problém.

Vyzkoušel jsem OGMrip, ten ovšem spadne s chybou, program Acidrip se sice tváří, že něco dělá, ale nedělá. DVD::rip mě při pokusu o uložení titulků neustále otravuje s tím, že musím znovu načíst obsah DVD a tím se z toho stává začarovaná smyčka. Avidemux mi sice vytvoří SUB soubor, ale to je pouze soubor s obrázky titulků+IDX soubor, což je časový index.

Při pokusu z toho udělat SRT se mě potom Avidemux pořád dokola dotazuje, co je tohle a tohle za písmenko. Zkusil jsem i pár programů pro Windows které se dušují jak to jde snadno, ovšem dělají to samé co Avidemux, neustále se mě doptávají co je tohle a tohle za znak.

Převod souboru SUB na text za pomoci terminálu a nějakého OCR nástroje (nejlepší výsledek podává zatím cuneiform) je sice možný, ale chybí mi tam ten časový index, který to neumí zohlednit.

Nezná tedy někdo, nějaký časově méně náročný způsob jak z DVD dostat titulky?

34
Pracovní prostředí / GNOME 3 a výchozí aplikace
« kdy: 29 Listopad 2011, 18:06:57 »
Otázka je jednoduchá v GNOME 2 byla možnost si nastavit výchozí aplikace pro systém. Ještě v 11.04 toto nastavení ovlivňovalo i aplikace v Dash, od 11.10 to ale nikde nejde nastavit. Bohužel pokud odeberu ten nedodělek Banshee, který dodnes neumí spustit internetové rádio, stejně se po něm systém naprosto nelogicky shání, protože je někde nastaveno jako výchozí aplikace.

Zkoušel jsem hledat po internetu jak se vlastně v GNOME 3 nastavují výchozí aplikace, ale prostě jsem to nenašel

35
Přenosné počítače / Wifi AR242x/542x extrémně pomalý internet
« kdy: 26 Listopad 2011, 10:24:21 »
Dostala se mi do rukou Toshiba A200 s Wifi kartou Atheros 242x/542x. Karta v 11.10 normálně funguje už po instalaci, dokonce i signál na větší vzdálenosti má dobrý, všechno tedy vypadalo, že to funguje správně. U mě doma dokonce vidí i sítě o kterých jiné karty ani neví.

Problém nastal když jsem se pokusil připojit, spojení je pomalé a nestabilní, hlášky Firefoxu o tom, že server není dostupný jsou celkem běžné. Zkusil jsem tedy problém řešit, ale zatím bez úspěchu. Co jsem tedy udělal:

-zakázal IPv6 natvrdo parametrem GRUBu (ipv6.disable=1)
-přidal jsem do blacklistu řádek "blacklist acer_wmi"
-upravil soubor NetworkManager.conf a změnil hodnotu managed=false na true
-nakonec jsem vyměnil Network Manager za Wicd

Nicméně problém stále přetrvává a nějak mi docházejí nápady co dál. Pokud někoho napadá co zkusit dalšího, budu rád

36
Instalace, aktualizace a spouštění / Repozitář pro 64bit Flash
« kdy: 08 Listopad 2011, 16:14:35 »
Narazil jsem na zajímavý problém, od verze 10.04 používám repozitář pro 64bit Flash player, konkrétně tento
Kód: [Vybrat]
http://ppa.launchpad.net/sevenmachines/flash/ubuntu ovšem dnes jsem zjistil, že složka flash ze serveru zmizela.

Bohužel se mi nějak nedaří dohledat co se vlastně stalo, takže nevíte někdo co se s repozitářem "sevenmachines" děje, že Flash z něj zmizel

37
Hardware / nVidia 7300GS v Ubuntu 11.10
« kdy: 15 Říjen 2011, 11:13:28 »
Takže situace se v Ubuntu 11.10 ještě zhoršila, nesvobodný ovladač 280 pro tuhle kartu už mi nefungoval v 11.04, což jsem řešil použitím ovladače 173.

Po upgradu na 11.10 jsem opět vyměnil ovladač za verzi 280 (v repozitářích je ten samý jako na stránce nVidia, takže ruční instalací za stránek nVidia cesta nevede). Po nahození ovladače 280 se opakuje stav z 11.04, systém naběhne až do prostředí a následně celé prostředí kompletně zatuhne, jde jen pomocí CTRL+ALT+F1 přepnout se do terminálu. Vliv pracovního prostředí jsem vyloučil, protože se to děje všude (KDE, LXDE, Xfce), jakmile zapnu akcelerovaný desktop, prostě to zamrzne a je úplně jedno jestli používám Compiz, Mutter, Beryl nebo něco jiného.

Takže opět návrat na ovladač 173 kde vše funguje jak má, ovšem v 11.10 mě po spuštění
Kód: [Vybrat]
nvidia-settings nástroj na stránce konfigurace X serveru oblaží hláškou "Unable to load X Server Display Configuration page" a končím. Bug už je hlášený z předchozích verzí a je znovu otevřený. Bohužel všechno co jsem nalezl ve vztahu k nVidia 7300GS se týká starších verzí Ubuntu, kde se radí provést upgrade na novější ovladač, což by jistě pomohlo protože při použití ovladače 280 kdy nahodím Unity 2D nebo cokoli bez akcelerace se do konfigurace normálně dostanu a vše funguje jak má, jenže jakmile zapnu akcelerovaný desktop skončím (jak jsem psal výše) zatuhnutím.

Zkusil jsem tedy za pomoci ovladače 280 vygenerovat soubor xorg.conf a ten následně podstrčit ovladači 173, ale výsledek byl stejný, opět hlášení "Unable to load X Server Display Configuration page". Zkusil jsem provést i downgrade ovladače 280 ne verzi 260, která mi v Ubuntu 10.10 normálně fungovala, ovšem se stejným výsledkem, po naběhnutí akcelerovaného prostředí, zátuh.

Měl bych tedy otázku, jak spustit fungující akcelerovaný desktop na kartě nVidia 7300GS s ovladačem 280 nebo případně jak se zbavit toho hlášení s ovladačem 173.

38
Přenosné počítače / Touchpad, vypnu ale už nezapnu
« kdy: 05 Říjen 2011, 11:39:34 »
Setkal jsem se na některých notebookách s poměrně zvláštním problémem který neumím řešit.

Na notebooku je umístěno tlačítko pro vypnutí touchpadu, případně to provádí klávesová zkratka. Problém je následující, systém ví co s takovým tlačítkem dělat, na jeho stisk reaguje, kontrolka (pokud je přítomna) se také rozsvěcuje a zhasíná, ale touchpad jde pouze vypnout. Pokud ho zapnu, kontrolka sice zhasne ale myš je i nadále mrtvá, kurzor se nehýbe a nezbývá než restartovat systém, pak je vše opět OK do dalšího stisku vypínacího tlačítka.

Moje teorie je taková, že systém po vypnutí touchpadu odstraní příslušný modul, ale po jeho zapnutí už touchpad nedetekuje a nenahraje ho zpátky. Problém se omezuje pouze na touchpady od Synapticu a pouze na systémy kde je touchpad správně detekován jako touchpad.

Pokud někdo alespoň trochu tuší co s tím, uvítám každý návrh

39
Přenosné počítače / Lenovo S205 a Ubuntu
« kdy: 30 Září 2011, 14:50:41 »
V návodu jsem nalezl několik chyb, které znemožňovali instalaci úspěšně dokončit. Tyto chyby jdou na vrub mé nepozornosti. Za způsobené komplikace se omlouvám. A zároveň děkuji uživateli sw3d.

Tenhle netbook se prodává bez OS, bohužel k instalaci prakticky jakéhokoli systému není zrovna přívětivý.

V základní konfiguraci obsahuje totiž procesor AMD E-350 což je vlastně výkonnostní obdoba Atomu D525 a disk s technologií Advanced format od WD (tuto informaci překontrolujte v BIOSu, narazil jsem teď na Hitachi které advanced formát samozřejmě nemá). Kdo si myslí, že se jedná o disk s 4kB sektory, který se však v reálu tváří tak, že má velikost sektoru pouze 512B, tak ten si myslí správně. Díky tomu se třeba systémy Windows nedají použít (ačkoli k nim výrobce dodává ovladače), WXP totiž trpí extrémní ztrátou rychlosti kvůli disku a W7 se nedají na AMD E-350 skoro používat, tedy kromě verze "Starter", ale tu asi nikde nekoupíte. Takže instalace Linuxu je logickou volbou, ovšem pokud má vaše oblíbené distro GRUB2, není to jen tak. Jinak třeba Fedora 15 funguje hned od začátku bez nutnosti jakéhokoli zásahu.

Takže nejdříve formát
Rozdělení disku věnujte velkou pozornost, špatně rozdělený disk obvykle znemožní správně následně nainstalovat GRUB 1.

Právě kvůli tomu pitomému disku nelze "partišny" pořádně zarovnat (pokud máte jiný disk než WD s advanced format, problém se zarovnáním u vás odpadá). Zkusil jsem kde co (dokonce i nástroj přímo od WD), ale výsledek je vždy stejný, v momentě kdy vytvoříte rozšířený oddíl, jste v háji. Nakonec jsem tedy disk rozdělil takto:

"/boot" jako EXT2 o velikosti 512MB, primární oddíl umístěný na začátek
"/" jako EXT4 pro samotný systém, primární oddíl umístěný na začátek (velikost je na vás, já dal 40GB)
"/home" jako EXT4, primární oddíl umístěný na začátek
"swap", (odkládací prostor) umístěný na konec disku jako primární oddíl o velikosti minimálně 1,25-násobku velikosti RAM (pokud chcete používat hibernaci)

Během dělení disku si zapamatujte kam je umístěn "/boot" a "/". Následně vám to ušetří práci.

Instalace
Pokud budete chtít instalovat 64bit systém, musíte instalovat z flash disku a nikdy nevytvářejte takový disk za pomoci nástroje přímo v Ubuntu. Výsledný systém totiž nepůjde spustit, použijte raději třeba Unetbootin.
Při instalaci za pomoci externí mechaniky, nelze 64bit systém vůbec nainstalovat (spuštění selže hned na začátku) je to způsobeno špatným zacházením ze strany EFI (BIOSu) s bootloaderem.

Následná instalace je potom už lehká, bohužel díky EFI po instalaci systém nenaběhne, problém je GRUB2. Instalaci jsem proto provedl následovně

-nejdřív zvolím, že chci systém vyzkoušet, poté provedu instalaci a při dotazu jestli chci restartovat počítač, zvolím "Pokračovat ve zkoušení"
-zapnu terminál a zadám
Kód: [Vybrat]
sudo fdiks -l jeho výstup by měl být posloupný, tedy něco takového
Kód: [Vybrat]
/dev/sda1 /boot
/dev/sda2 /
/dev/sda3 /home
/dev/sda4 swap
Nyní je potřeba se do systému dostat, takže provedeme chroot, takto
Kód: [Vybrat]
sudo mount /dev/sda2 /mnt
sudo mount /dev/sda1 /mnt/boot
sudo mount --bind /sys /mnt/sys
sudo mount --bind /proc /mnt/proc
sudo mount --bind /dev /mnt/dev
sudo chroot /mnt
Nyní by jste měli být v systému instalovaném na disku jako root, takže nyní provedeme odstranění GRUBu2 a jeho náhradu za GRUB1
Kód: [Vybrat]
apt-get purge grub-pc potvrdit odstranění zavaděče
Kód: [Vybrat]
apt-get update
apt-get install grub
instalace nového zavaděče
Kód: [Vybrat]
grub-install /dev/sda a nakonec
Kód: [Vybrat]
update-grub poté se vás terminál optá, že chybí soubor "menu.lst" jestli ho má pro vás vytvořit, zadejte "y" a můžete restartovat
Kód: [Vybrat]
shutdown -r now Během restartu vás může systém oblažit hláškou o tom, že běží v "low grafic", nic nepotvrzujte a vyčkejte než se dokončí restart.

Po instalaci

Pokud jste majiteli Ubuntu do verze 10.10 nemusí vás tento odstavec zajímat, pro ostatní platí toto (verze 11.04 a 11.10):

-nefunguje Wi-fi, problém je jak v systému, tak v samotném network-manageru, provedeme proto náhradu za network-manager, takto
Kód: [Vybrat]
sudo apt-get purge network-manager
sudo apt-get install wicd
jistě si po restartu všimnete, že vám z panelu jaksi zmizela ikona "Připojení", je nutné nainstalovat "dconf-editor", spustit a vyhledat cestu desktop-unity-panel a zde přidat Wicd do whitelistu.

-po uspání bohužel Wi-fi opět nefunguje, je nutné ji resetovat příkazem
Kód: [Vybrat]
rfkill unblock all aby jste to nemuseli dělat pokaždé ručně, vytvořte si do cesty /etc/pm/sleep.d soubor "0000wifi.sh", takže nejsnadněji asi takto
Kód: [Vybrat]
gksudo nautilus a potom graficky vytvořte prázdný dokument a do něj vložte tohle
Kód: [Vybrat]
#!/bin/bash
case "$1" in
    thaw|resume)
        rfkill unblock all
        ;;
    *)
        ;;
esac
exit $?
uložte, pojmenujte soubor jak jsem psal výše a nezapomeňte souboru přidělit spustitelný příznak.

Parkování
Pokud máte jiný disk než WD, použijte tento postup jen pokud se vám zdá, že disk až příliš "cvaká".

Disky WD jsou známé tím, že velmi rády parkují hlavičky, při provozu na adaptér je to OK, ovšem při provozu na baterii je to katastrofa, otevřete si tedy terminál a do něj zadejte
Kód: [Vybrat]
gksudo gedit /etc/hdparm.conf a na konec souboru přidejte
Kód: [Vybrat]
/dev/sda {
apm_battery = 250
}
pro úplné vypnutí můžete použít hodnotu "255", pro standardní nastavení jako na adaptér potom hodnotu "254", pokud ovšem počítač budete přenášet, osvědčila se mi hodnota někde mezi "230-250".

To je asi tak všechno, poslední věcí kterou musíte udělat je doinstalovat ovladač grafické karty, přes "Dodatečné ovladače".

40
Hardware / Parkování hlaviček disku
« kdy: 13 Září 2011, 09:02:36 »
Je to sice už poměrně staré, ale pořád je to dle mě aktuální.

Stále se mi na některých noteboocích a vlastně i desktopech objevuje problém s tím, že disk parkuje hlavičku jako o život. Problém není asi ani tak v Ubuntu, ale spíš v discích nebo BIOSu počítačů, protože na Windows i jiných distribucích, včetně něčeho jako je FreeBSD se to děje taky.

Nicméně po zadání příkazu
Kód: [Vybrat]
sudo hdparm -B xxx /dev/sdx kdy obvykle dám parametr 254 nebo úplně vypnu APM zadáním 255 je vše v pořádku. Nicméně tohle se udrží jen do restartu systému.

Takže k problému, hledal jsem kde se dalo a zkoušel jak dát při spuštění systému vědět, že chci aby provedl
Kód: [Vybrat]
hdparm -B 254 /dev/sdx ale nějak to nefunguje.

Co jsem tedy zkusil
-nejdříve obvyklý postup vložit příkaz do startovacích skriptů jako jsou soubory sysctl.conf, rc.local což nefunguje, po restartu je vše při starém

-následně jsem tedy zkusil umístit spustitelný soubor do /etc/init.d s požadovaným parametrem a vytvořit na něj symbolický odkaz do /etc/rcs.d (teď nevím jestli to náhodou není rCs.d) v následujícím tvaru (soubor hdd-fix), odkaz ve tvaru S99hdd-fix+přidělení spustitelného příznaku jsem tedy vložil do /etc/rcs.d, číslo 99 by mělo být dostatečně vysoké aby se příkaz provedl až jako poslední. Nicméně to také nefunguje, po restartu je vše zase při starém.

Moje otázka tedy zní, kam vložit
Kód: [Vybrat]
hdparm -B 255 /dev/sdx tak aby na to systém bral ohled a nastavil to při každém spuštění systému.

Jen doplním, že zadáním
Kód: [Vybrat]
sudo hdparm -B /dev/sdx vám systém vypíše aktuální hodnotu.

41
Přenosné počítače / HP 630-LH380EA a Ubuntu
« kdy: 07 Září 2011, 11:18:19 »
Tak po dlouhé době potřebuji radu, chtěl bych pořídit výše zmíněný notebook (tady http://www.alza.cz/hp-630-d236827.htm ), ale nějak se mi nedaří nic o něm najít. Tedy hlavně jak spolupracuje s Ubuntu, většina prodejců ho prodává s předinstalovaným SUSE, ale já ho budu kupovat úplně bez OS.

Našel jsem tedy nějaké problémy s připojením k Wi-fi na Ubuntu 11.04, ale ty se týkají trochu jiné verze. Chtěl bych tedy požádat o nějaké recenze od těch co tento notebook mají, případně pokud se vám jen podaří najít nějaké odkazy na internetu jak tohle HP spolupracuje s Ubuntu (já jsem toho moc nenašel).

Za všechny odpovědi děkuji.

42
Pracovní prostředí / Unity, compiz a nesvobodné ovladače
« kdy: 05 Květen 2011, 19:43:10 »
Tak už hezkou chvilku laboruji s Ubuntu 11.04, mám grafiku nVidia GeForce 7600GS, doporučený ovladač z repozitářů mi nejede, ovladač ze stránek nVidia (270) také ne, funguje mi to jen s ovladačem 173 z repozitářů.

Horší je to s compizem, při pokusu cokoli změnit přes Compiz config, se skoro pokaždé totálně rozpadne Unity, launcher zmizí a horní panel se udělá duhový a je konec. Jediné s čím můžu do jisté míry manipulovat jsou již aktivované volby, ale i tak to někdy při manipulaci s jejich nastavením nedopadne dobře. Prostředí začne blikat, přestane fungovat horní panel a tak podobně.

Když Canonical oznámil, že Unity pojede na compizu, myslel jsem, že s tím půjde něco udělat (třeba zapnout hoření oken), ale bohužel, téměř každý zásah do nastavení compizu způsobí, že něco přestane fungovat správně.

43
Jak asi víte když vyšlo Ubuntu 10.10 nebylo prostředí Gnome na rozdíl od verze 10.04 celé přeložené,nedávno vyšla aktualizace která toto řeší,bohužel na mém systému došlo k fatální chybě.

1)Nástroj pro hledání souborů obsažený v Gnome po každém hledání kdy necháte prohledat celý souborový systém,vydá hlášku o tom,že výsledky nejsou aktuální,při rozkliknutí protokolu dostanete docela dlouhý seznam souborů a adresářů ke kterým nelze přistoupit

2)Jako závažnější problém ovšem vidím fakt,že se totálně rozpadne systém práv k souborům,pokud pominu fakt,že v ten moment nedokáže Nautilus správně nastavit práva k několika souborům naráz a je nutné to dělat soubor po souboru ručně.Je mnohem větší chybou,že ve vašem domovském adresáři kde se ukládají skrytá nastavení programů dojde k tomu,že každý nově nainstalovaný program který si vytvoří složku s nastavením si takovou složku vytvoří s právy pro uživatele "root" a ačkoli do ní nějakým záhadným způsobem dokáže zapisovat,tak pokud se jako uživatel pokusíte s takovou složkou manipulovat (byť je ve vašem domovském adresáři,tedy s politiky systému by jste měli mít práva dělat si co chcete v rámci tohoto adresáře),setkáte se pouze s hlášením systému,že nemáte oprávnění manipulovat se souborem a to dokonce takovým stylem,že nelze vůbec nic (soubor nelze ani číst)

Jediné funkční řešení,které jsem zatím nalezl je vynutit si starou verzi balíku "language-pack-cs" a uzamknout ji,aby ji systém nemohl aktualizovat,to vás ovšem pošle opět do prostředí přeloženého jen z části.Bohužel mě tato chyba stála den hledání toho co je špatně a taky novou instalaci systému (včetně nastavení ve složce /home),kdy se mi při běžné práci se soubory totálně rozhodil systém práv k nim do takového stavu,že již nemělo cenu cokoli zachraňovat

44
Tak jsem našel další chybu v U10.10,kromě již zmíněného ztraceného překladu,kdy se prostě již přeložené položky (v předchozích vydáních) opět zobrazují anglicky (víc jsem psal tady http://forum.ubuntu.cz/index.php/topic,51023.0.html ),tak jsem zjistil další chybu,po vypnutí počítače zůstane svítit klávesnice (PS2),na klasické klávesnici mi zůstanou svítit jen před vypnutím zapnuté kontrolní ledky,na klávesnici s podsvícením,bohužel zůstane svítit celá klávesnice.Abych chybu vyloučil,zkusil jsem LiveCD,čistou instalaci a nakonec i upgrade z 10.04 na 10.10,výsledek je ovšem pořád stejný,zajímavé,ale je,že na verzi 9.04,9.10,10.04 je vše v nejlepším pořádku,tam prostě klávesnice při vypínání klasicky problikne a všechno zhasne.

Takže moje otázka,děje se to také někomu z vás,případně,zná někdo řešení tohoto problému?

45
Obecná podpora / Upgrade na 10.10,ztratila se lokalizace do CZ
« kdy: 14 Říjen 2010, 21:47:05 »
Dnes bych měl pouze obecný dotaz,po updatu na U10.10 se mi u některých dříve přeložených položek ztratila jazyková lokalizace.Nejviditelnější je to asi v kontextové nabídce Nautilu,kde po kliknutí na nějaký soubor se objeví nahoře možnosti "otevřít s",momentálně tam mám "open with",ne že by mi to nějak vadilo,ale je docela zvláštní,že v 10.04 to přeložené bylo (v 9.04 a 9.10 také) a v 10.10 se ten překlad ztratil.Tak se chci zeptat jestli se taky někomu stalo,že již dříve přeložené části systému,najednou přeložené nejsou

46
Obecná podpora / Jak rozbalit archiv ACE 2.0 [Vyřešeno]
« kdy: 25 Září 2010, 20:36:12 »
Tak už jsem zkusil snad vše co mě napadlo,ale bohužel se mi nedaří v Ubuntu rozbalit archiv ACE 2.0 (druhá generace).Ve Windows to dokáže třeba WinRAR,ale až od verze 3.3x..V ubuntu jsem klasicky zkusil doinstalovat balík unace (jsou dva,jeden free a ten druhý je asi uzavřený),každopádně vždy dopadnu stejně,když použiju ten non-free balík,tak mi fileroller zamrzne už při vstupu do toho archivu,tedy přesněji se tváří,že něco dělá,ale nic se neděje (nechal jsem to i pár hodin,jestli se to náhodou nehne).Pokud použiju ten free balík,tak mi fileroller po chvilce zobrazí obsah toho archivu (asi tak 2 minuty),ale při pokusu to z něj vybalit skončím tam co předtím,program se tváří,že něco dělá,ale nic se neděje.Chráněné heslem ty archivy nejsou a problémy s tím se objevily po upgradu na 9.04,nicméně,teď mám čistou instalaci 10.04 (asi 14 dní starou)

47
Obecná podpora / Synaptic při pokusu o uložení nastavení zamrzne
« kdy: 11 Červenec 2010, 19:09:51 »

Dobrý den,tak jsem dospěl k problému se kterým si bohužel ani já ani google nevíme rady.

Jedná se o to,že pokud v Synapticu zvolím "Nastavení",změním nějakou volbu (ani to dokonce nemusím,jak jsem zjistil) a potom okno s nastavením normálně potvrdím nebo kliknu na "Použít",tak celý program zamrzne a musím ho sestřelit.čímž se mi samozřejmě změny neuloží.

Zkoušel jsem podle určitých návodů spustit Synaptic přes gksudo synaptic nebo jen přes sudo synaptic (i když se to nemá),ale problém přetrvává.
Odinstalace (kompletní) a zpětná instalace také nepomohla.

Celé to vypadá jako když program nemůže provést změny ve svém konfiguračním souboru,bohužel nevím kam si konfiguraci Synaptic ukládá

Chtěl bych se tedy zeptat jestli někdo neví jak tento problém vyřešit nebo alespoň mě navést k souboru kde si Synaotic ukládá nastavení.Předem děkuji za jakoukoli radu

48
Multimédia / Jak nastavit systémovou hlasitost na 500 procent
« kdy: 02 Červenec 2010, 10:51:57 »
Takže jsem hledal,pak různě zkoušel a výsledek veskrze žádný.Možná na to stačí příkaz do terminálu,ale nemůžu přijít na to jaký.

Problém je vlastně v nadpisu,občas by se mi hodilo nastavit hlasitost (softwarově) ne vyšší úroveň než 100 procent.Přes ikonu reproduktoru to sice lze,ale hlasitost se při nejlepším dá zvýšit tak na dvojnásobek normálu.Občas by se mi prostě hodilo to co umí VLC,vytáhnout hlasitost až na 400 procent,ale prostě tak aby to bylo nastaveno globálně

49
Hardware / Touchpad (Dell Vostro)
« kdy: 23 Květen 2010, 17:51:52 »
Mám takový zajímavý problém,na notebooku mám tlačítko pro vypnutí touchpadu,když ho stisknu,podsvítí se a touchpad se vypne.Když ho stisknu znova,podsvícení zhasne a touchpad by se měl znovu zapnout (alespoň tak to funguje ve windows),ale v Ubuntu 10.04,kurzor prostě zmrzne.Systém o touchpadu ví i po vypnutí,ale kurzor mám pořád zamrzlý (až do restartu).

Zkoušel jsem i jiná distra (SUSE,Fedora,Mandriva,Debian) a bohužel se stejným výsledkem,po vypnutí a znovu zapnutí touchpadu,mám kurzor zamrzlý a myší nemůžu pohnout (externí myš v USB funguje).
Kdyby někdo věděl jak to odstranit,budu rád za každou radu

50
Internet a sítě / Nejde Ubuntu.cz [Vyřešeno]
« kdy: 27 Leden 2010, 16:05:41 »
Mám takový celkem záhadný problém,po nainstalování Ubuntu 9.10 se nedokážu vůbec dostat na stránky www.ubuntu.cz,zkoušel jsem už celkem dost věcí,od kontroly instalace,použití jiného prohlížeče,změny nastavení sítě (včetně jiného připojení),výsledek je stále stejný,po zadání adresy se prohlížeč tváří jako,že hledá server a tím to prostě skončí.NTB s Windows připojený k tomu samému kabelu ovšem žádný problém nemá a stránku zobrazí

Stran: 1 [2] 3