Prosíme přihlašte se nebo zaregistrujte.

Přihlašte se svým uživatelským jménem a heslem.
Blog Ubuntu -- Správa "projektů" české komunity Ubuntu

Novinky: Školení nejen k OS Ubuntu pro širokou veřejnost, více informací zde.

Autor Téma: Wine  (Přečteno 12248 krát)

ubuntu-upgrade

  • Návštěvník
  • *
  • Příspěvků: 21
  • Karma: +3/-10
    • Zobrazit profil
Wine
« kdy: 09 Srpen 2008, 09:34:53 »
Dobrý den, rád bych se zeptal něco ohledně instalace Wine v již nepodporované verzi Ubuntu 6.10. Zkoušel jsem instalovat wine přes synaptic, terminál... a myslím, že zdroj balíčku již není dostupný v archivu.. :

W: Chyba při přenosu http://cz.archive.ubuntu.com/ubuntu/pool/universe/w/wine/wine_0.9.22-0ubuntu3_i386.deb
  404 Not Found [IP: 91.189.88.31 80]

Je to tedy díky tomu že ubuntu 6.10 ztratilo podporu?

Zkoušel jsem to tedy "obejít" přes přímý balíček z web. stránek wine hq:
např. http://wine.budgetdedicated.com/archive/ubuntu/edgy/wine_1.0.0~winehq0~ubuntu~6.10-1_i386.deb

Spustil jsem instalaci a nic se nestalo, několikrát jsem proces opakoval, ale vždy když jsem zakliknul instalovat balík, za 10 s instalace zmizela a nic nebylo nainstalováno....
Proto bych se rád zeptal:
1) Je možné instalovat v nepodporované distribuci ubuntu?
2) Jestli ano, tak proč se instalace vždy "zhroutí"? (je to dost obecné.. ale nemám k tomu parametry, vždy instalace se nějak vypaří...?

Předem děkuji za odpověď.
 

qUAKER

  • Host
Re: Wine
« Odpověď #1 kdy: 09 Srpen 2008, 11:43:37 »
k Edgy Eft už neexistují repozitáře.

ubuntu-upgrade

  • Návštěvník
  • *
  • Příspěvků: 21
  • Karma: +3/-10
    • Zobrazit profil
Re: Wine
« Odpověď #2 kdy: 09 Srpen 2008, 12:14:17 »
k Edgy Eft už neexistují repozitáře.

díky moc, přesně to jsem si myslel, přesto wine nelze již teď nainstalovat žádným způsobem? lze to nějak obejít? lze instalovat z balíčku přímo?

qUAKER

  • Host
Re: Wine
« Odpověď #3 kdy: 09 Srpen 2008, 13:46:43 »
můžeš zkusit stáhnout nejnovější balíček z wine archivů

wget http://wine.budgetdedicated.com/archive/ubuntu/edgy/wine_1.0.0~winehq0~ubuntu~6.10-1_i386.deb

a pak

sudo dpkg -i wine_1.0.0*.deb

ubuntu-upgrade

  • Návštěvník
  • *
  • Příspěvků: 21
  • Karma: +3/-10
    • Zobrazit profil
Re: Wine
« Odpověď #4 kdy: 10 Srpen 2008, 20:38:07 »
můžeš zkusit stáhnout nejnovější balíček z wine archivů

wget http://wine.budgetdedicated.com/archive/ubuntu/edgy/wine_1.0.0~winehq0~ubuntu~6.10-1_i386.deb

a pak

sudo dpkg -i wine_1.0.0*.deb


Instaluji balík wine.
(Čtu databázi ... nyní je nainstalováno 171954 souborů a adresářů.)
Rozbaluji wine (z wine_1.0.0~winehq0~ubuntu~6.10-1_i386.deb) ...
dpkg: nesplněné závislosti zamezily konfiguraci balíku wine:
 wine závisí na winbind; avšak:
  Balík winbind není nainstalován.
dpkg: chyba při zpracovávání wine (--install):
 problém se závislostmi - nechávám nezkonfigurované
Při zpracování nastaly chyby:
 wine
ubuntu@linux:~$

dík moc, šlo to skvěle... ale nakonec jsem zjistil, že mi teda chybí ta závislost...na winbind...:) .. repozitáře bohužel vyschly a na netu se nedá najít zdroj.... nebo znáte zdroj primární k winbind? Jinka díky moc! Kdyby nebyl ten zdroj, tak se to časem vyřeší... budu totiž měnit OS..:) Díky!

qUAKER

  • Host
Re: Wine
« Odpověď #5 kdy: 11 Srpen 2008, 15:51:51 »
EDIT: nebo lepší alternativa. Odstraň si edgy zdroje a dej si tam dapper zdroje a potřebné balíčky tahej z Dappera.


http://packages.debian.org/sarge-backports/winbind zkus si stáhnout z Debianu Sarge a ten nainstalovat pomocí dpkg. Kdyby chyběly další balíky, tak z Debianu Sarge repozitáře dotahej další balíčky. Z Etche to asi nebude fungovat, ten má o něco novější balíčky než Ubuntu Edgy.

MaSo1

  • Návštěvník
  • *
  • Příspěvků: 2
  • Karma: +0/-0
    • Zobrazit profil
Re: Wine
« Odpověď #6 kdy: 13 Duben 2009, 07:45:56 »
Omlouvám se, že oživuji toto staré téma, mohlo by to ještě někomu pomoct. Také používám na starším booku Ubuntu 6.10 Edgy a mám nastaveno tyto zdroje v /etc/apt/sources.list (důležité jsou ty řádky s eld-releases.ubuntu.com..., tak si z toho profiltruj co chceš):

Kód: [Vybrat]
#deb http://cz.archive.ubuntu.com/ubuntu/ edgy main restricted
deb http://old-releases.ubuntu.com/ubuntu/ edgy main restricted universe multiverse
#deb-src http://cz.archive.ubuntu.com/ubuntu/ edgy main restricted
deb-src http://old-releases.ubuntu.com/ubuntu/ edgy main restricted universe multiverse

## Major bug fix updates produced after the final release of the
## distribution.
#deb http://cz.archive.ubuntu.com/ubuntu/ edgy-updates main restricted
#deb-src http://cz.archive.ubuntu.com/ubuntu/ edgy-updates main restricted
deb http://old-releases.ubuntu.com/ubuntu/ edgy-updates main restricted universe multiverse
deb-src http://old-releases.ubuntu.com/ubuntu/ edgy-updates main restricted universe multiverse

## Uncomment the following two lines to add software from the 'universe'
## repository.
## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu
## team, and may not be under a free licence. Please satisfy yourself as to
## your rights to use the software. Also, please note that software in
## universe WILL NOT receive any review or updates from the Ubuntu security
## team.
# deb http://cz.archive.ubuntu.com/ubuntu/ edgy universe
# deb-src http://cz.archive.ubuntu.com/ubuntu/ edgy universe

## Uncomment the following two lines to add software from the 'backports'
## repository.
## N.B. software from this repository may not have been tested as
## extensively as that contained in the main release, although it includes
## newer versions of some applications which may provide useful features.
## Also, please note that software in backports WILL NOT receive any review
## or updates from the Ubuntu security team.
# deb http://cz.archive.ubuntu.com/ubuntu/ edgy-backports main restricted universe multiverse
# deb-src http://cz.archive.ubuntu.com/ubuntu/ edgy-backports main restricted universe multiverse
deb http://old-releases.ubuntu.com/ubuntu/ edgy-backports main restricted universe multiverse
deb-src http://old-releases.ubuntu.com/ubuntu/ edgy-backports main restricted universe multiverse

#deb http://security.ubuntu.com/ubuntu edgy-security main restricted
#deb-src http://security.ubuntu.com/ubuntu edgy-security main restricted
deb http://old-releases.ubuntu.com/ubuntu edgy-security main restricted universe
deb-src http://old-releases.ubuntu.com/ubuntu edgy-security main restricted universe

# deb http://security.ubuntu.com/ubuntu edgy-security universe
# deb-src http://security.ubuntu.com/ubuntu edgy-security universe

S pozdravem,
      MaSo