Prosíme přihlašte se nebo zaregistrujte.

Přihlašte se svým uživatelským jménem a heslem.
Vaše pomoc je stále potřeba!

Autor Téma: Kodeky  (Přečteno 10003 krát)

moner

  • Člen
  • **
  • Příspěvků: 134
    • Zobrazit profil
    • Můj Blog
Kodeky
« kdy: 26 Listopadu 2007, 18:19:01 »
Zdravim,

Neco jsem udelal s kodeky pro prehravani filmu.
Chtel jsem se zeptat, kde nastavim, ci predelam zakladni nastaveni video prehravani?

dekuji

3D, Ubuntu, linux, macos,windows, python, QT, Pyside.

Pavel Půlpán

Re: Kodeky
« Odpověď #1 kdy: 26 Listopadu 2007, 18:26:08 »
Jak to myslis? Preference vetsinou najdes v prehravaci, kterej pouzivas...

moner

  • Člen
  • **
  • Příspěvků: 134
    • Zobrazit profil
    • Můj Blog
Re: Kodeky
« Odpověď #2 kdy: 26 Listopadu 2007, 18:50:23 »
Jak to myslis? Preference vetsinou najdes v prehravaci, kterej pouzivas...

No to jo no, ale u kazdeho prehravace mam nejaky problem... jeden je modry, druhy se seka... a pod...
3D, Ubuntu, linux, macos,windows, python, QT, Pyside.

Pavel Půlpán

Re: Kodeky
« Odpověď #3 kdy: 26 Listopadu 2007, 19:34:22 »
Je mozny ze kazdy pouziva jine kodeky? Ktere si instaloval?

Ke vsi spokojenosti (takrka) jsem na Ubuntu pouzival prehravac VLC. Nikdy s nim nebyli zadne problemy.

moner

  • Člen
  • **
  • Příspěvků: 134
    • Zobrazit profil
    • Můj Blog
Re: Kodeky
« Odpověď #4 kdy: 26 Listopadu 2007, 19:40:44 »
Je mozny ze kazdy pouziva jine kodeky? Ktere si instaloval?

Ke vsi spokojenosti (takrka) jsem na Ubuntu pouzival prehravac VLC. Nikdy s nim nebyli zadne problemy.

No, ale video ve VLC se mi nyni seka. Cim to muze byt? Spatny kodek? Jaky petrebuje?
3D, Ubuntu, linux, macos,windows, python, QT, Pyside.

Pavel Půlpán

Re: Kodeky
« Odpověď #5 kdy: 26 Listopadu 2007, 19:42:31 »
VLC ma kodeky vlastni... spis bych to videl na Compiz jestli ho pouzivas. ;)

moner

  • Člen
  • **
  • Příspěvků: 134
    • Zobrazit profil
    • Můj Blog
Re: Kodeky
« Odpověď #6 kdy: 26 Listopadu 2007, 19:58:55 »
VLC ma kodeky vlastni... spis bych to videl na Compiz jestli ho pouzivas. ;)

compiz nepouzivam.

Dal jsem i v terminalu vlc a cestu k filmu a nevypsalo to zadnou chybu.
« Poslední změna: 26 Listopadu 2007, 20:08:52 od moner »
3D, Ubuntu, linux, macos,windows, python, QT, Pyside.

Marcel 'Maky' Šuška

  • Závislák
  • ****
  • Příspěvků: 1425
  • Kdo si hraje s Ubuntu, nezlobí.
    • Zobrazit profil
Re: Kodeky
« Odpověď #7 kdy: 26 Listopadu 2007, 20:12:13 »
Mrkněte se sem, třeba se něco hodí: http://wiki.ubuntu.cz/Vyhrazené_formáty , pak pisněte co jste asi udělal, a co a v čem vám nejde přehrát film.

moner

  • Člen
  • **
  • Příspěvků: 134
    • Zobrazit profil
    • Můj Blog
Re: Kodeky
« Odpověď #8 kdy: 27 Listopadu 2007, 16:35:24 »
Mrkněte se sem, třeba se něco hodí: http://wiki.ubuntu.cz/Vyhrazené_formáty , pak pisněte co jste asi udělal, a co a v čem vám nejde přehrát film.

Zkoušel jsem a žádná změna... nějak mi to rozhazelo defaultni nastaveni... ale nejsem si jist.

Co mam naspsat do terminalu, aby mi vypsal v čem je problem? :)
3D, Ubuntu, linux, macos,windows, python, QT, Pyside.

Marcel 'Maky' Šuška

  • Závislák
  • ****
  • Příspěvků: 1425
  • Kdo si hraje s Ubuntu, nezlobí.
    • Zobrazit profil
Re: Kodeky
« Odpověď #9 kdy: 27 Listopadu 2007, 19:58:35 »
Co jste konkrétně zkoušel.

Tohle?

Citace
Ubuntu 7.10 Gutsy Gibbon

Klikněte na Aplikace → Přidat/Odstranit. V pravém horním rohu zvolte Všechny dostupné aplikace. Poté pomocí vyhledávací lišty vyhledejte a zaškrtněte balík Ubuntu restricted extras. Klikněte na Uplatnit změny.

Pro přehrávání většiny DVD potřebujete balík libdvdcss2. Tento balík je dostupný ve zdroji Medibuntu.
Poznámka: Pokud přehrávání DVD i přesto nefunguje, a nikdy předtím jste na svém systému DVD nepřehrávali, můžete potřebovat nainstalovat balík regionset pro počáteční nastavení regionu mechaniky.

Některé externí kodeky mohou být potřeba pro přehrávání určitých nesvobodných formátů jako jsou WMA/WMV (zejména nejnovější verze) nebo RealMedia. Tyto externí kodeky jsou dostupné v neoficiálním zdroji Medibuntu.

Pokud byste stále měli problém s přehráním některých videí (pravděpodobně s microsoftími WMA/WMV soubory), můžete si nainstalovat balík gstreamer0.10-pitfdll. Tento balík vám umožní plně využívat binární microsoftí kodeky získané z Medibuntu zdroje. Může vám to pomoci tyto formáty přehrát a také snížit zatížení procesoru, na druhou stranu je možné snížení kvality obrazu u mnoha typů videí.



V synaptiku jste našel a instaloval?
libdvdcss2
non-free-codecs



Skeletonix

  • Host
Re: Kodeky
« Odpověď #10 kdy: 27 Listopadu 2007, 20:51:08 »
zkus mplayer ;)

moner

  • Člen
  • **
  • Příspěvků: 134
    • Zobrazit profil
    • Můj Blog
Re: Kodeky
« Odpověď #11 kdy: 28 Listopadu 2007, 03:29:05 »
zkus mplayer ;)

Jo mplayer jede, kdyz mu nastavim gl codek, ale u ostatnich prehravacich to nejde... nevim cim to muze byt. :/

Medibuntu jsem zkusil i pridat Ubuntu restricted extras.

Jinak sypantic nemuze najit tento soubor: gstreamer0.10-pitfdll
Pritom mam nainstalovany medibuntu.
« Poslední změna: 28 Listopadu 2007, 03:39:29 od moner »
3D, Ubuntu, linux, macos,windows, python, QT, Pyside.

moner

  • Člen
  • **
  • Příspěvků: 134
    • Zobrazit profil
    • Můj Blog
Re: Kodeky
« Odpověď #12 kdy: 11 Prosince 2007, 00:09:25 »
Tak jem to zkusil znovu... ted jsem preinstaloval VLC a spoustel jsem video pres terminal:

Kód: [Vybrat]
moner@moner:~$ vlc /home/moner/blender/robot/animation/aniace10001_0060.avi
VLC media player 0.8.6c Janus
Segmentation fault (core dumped)
moner@moner:~$ vlc /home/moner/blender/robot/animation/aniace10001_0060.avi
VLC media player 0.8.6c Janus

** (.:28711): CRITICAL **: clearlooks_style_draw_box: assertion `width >= -1' failed
[00000291] main playlist: nothing to play

** (.:28711): CRITICAL **: clearlooks_style_draw_box: assertion `width >= -1' failed

** (.:28711): CRITICAL **: clearlooks_style_draw_box: assertion `width >= -1' failed
Segmentation fault (core dumped)
moner@moner:~$ vlc /home/moner/blender/robot/animation/aniace10001_0060.avi
VLC media player 0.8.6c Janus
Segmentation fault (core dumped)
moner@moner:~$ vlc /home/moner/blender/robot/animation/aniace10001_0060.avi
VLC media player 0.8.6c Janus
Segmentation fault (core dumped)
moner@moner:~$ vlc /home/moner/blender/robot/animation/aniace10001_0060.avi
VLC media player 0.8.6c Janus
Segmentation fault (core dumped)
3D, Ubuntu, linux, macos,windows, python, QT, Pyside.

tatra

  • Člen
  • **
  • Příspěvků: 187
    • Zobrazit profil
Re: Kodeky
« Odpověď #13 kdy: 26 Prosince 2007, 13:44:33 »
resim ten samy problem, vznikl pri prechodu na vyssi verzi ubuntu. :-/
CPU 1,6 GHz, HDD 160 GB, 1  GB RAM, Kubuntu 11.10, Slax

charon

  • Člen
  • **
  • Příspěvků: 244
    • Zobrazit profil
Re: Kodeky
« Odpověď #14 kdy: 26 Prosince 2007, 13:50:37 »
skús prepnúť videovýstup na X11
Laptop:  HP510   Ubuntu 10.04 Lucid Lynx LTS
Laptop:  Asus EeePC  Ubuntu 10.04 Lucid Lynx LTS
Desktop: Ubuntu 10.04 Lucid Lynx  LTS

charon

  • Člen
  • **
  • Příspěvků: 244
    • Zobrazit profil
Re: Kodeky
« Odpověď #15 kdy: 26 Prosince 2007, 13:52:24 »
Skús  si ešte nastaviť vo VLC Nastavenia ...Nastavenia...Video...Výstupné moduly,zaškrtni políčko Pokročilé nastavenie,vyber Video výstup-X11 daj uložiť a malo by to fungovať.
Laptop:  HP510   Ubuntu 10.04 Lucid Lynx LTS
Laptop:  Asus EeePC  Ubuntu 10.04 Lucid Lynx LTS
Desktop: Ubuntu 10.04 Lucid Lynx  LTS

tatra

  • Člen
  • **
  • Příspěvků: 187
    • Zobrazit profil
Re: Kodeky
« Odpověď #16 kdy: 26 Prosince 2007, 14:05:46 »
ano, jde to pouze u mplayeru. u vlc jsem tu to moznost nenasel.
CPU 1,6 GHz, HDD 160 GB, 1  GB RAM, Kubuntu 11.10, Slax

charon

  • Člen
  • **
  • Příspěvků: 244
    • Zobrazit profil
Re: Kodeky
« Odpověď #17 kdy: 26 Prosince 2007, 18:02:39 »
Čítaj poriadne!!! Zaškrtni políčko Pokročilé nastavenie!
Laptop:  HP510   Ubuntu 10.04 Lucid Lynx LTS
Laptop:  Asus EeePC  Ubuntu 10.04 Lucid Lynx LTS
Desktop: Ubuntu 10.04 Lucid Lynx  LTS

tatra

  • Člen
  • **
  • Příspěvků: 187
    • Zobrazit profil
Re: Kodeky
« Odpověď #18 kdy: 03 Ledna 2008, 16:58:28 »
pri vystupe x11 v mplayeru jde aj obraz, len nejde na fullscreen. Je tam asi nekde nastavena maximalna velikost, se kterou nic neudelam. V podstate je cerna obrazovka a film bezi uprostred. V standardni velikosti. Zvetsit to nejde.
CPU 1,6 GHz, HDD 160 GB, 1  GB RAM, Kubuntu 11.10, Slax

vhejda

  • Člen
  • **
  • Příspěvků: 161
  • Když něco nevíš tak se zeptej, pěstí toneopravíš!
    • Zobrazit profil
    • VHComputer
Re: Kodeky
« Odpověď #19 kdy: 03 Ledna 2008, 17:31:26 »
já jsem stejné problémy vyřešil takto:
http://forum.ubuntu.cz/index.php?topic=17876.0

co na to ríkáte?

charon

  • Člen
  • **
  • Příspěvků: 244
    • Zobrazit profil
Re: Kodeky
« Odpověď #20 kdy: 03 Ledna 2008, 17:38:43 »
A ja takto:Otvor si Centrum ovládania,Screen and Graphics Preferences a v kolonke Model zadaj namiesto Plug n Play svoj monitor a jeho rozlíšenie.Toto som skúsil a ono to funguje.Možno to pomôže aj tebe.
Laptop:  HP510   Ubuntu 10.04 Lucid Lynx LTS
Laptop:  Asus EeePC  Ubuntu 10.04 Lucid Lynx LTS
Desktop: Ubuntu 10.04 Lucid Lynx  LTS

 


Provoz zaštiťuje spolek OpenAlt.