Prosíme přihlašte se nebo zaregistrujte.

Přihlašte se svým uživatelským jménem a heslem.
Vaše pomoc je stále potřeba!

Autor Téma: metabalík KDE4 je sebevrah  (Přečteno 1647 krát)

honorguard

  • Host
metabalík KDE4 je sebevrah
« kdy: 11 Dubna 2008, 13:50:19 »
Zdravím všechny,
chtěl bych vás varovat před metabalíkem kde4. Užívám KDE4 již docela dlouho a jsem s ním spokojený. Jenže včera se mi stala pod rootem malá nehoda. Předvedu:
místo apt-get install superkaramba-kde4 jsem dal apt-get install superkaramba – kde4.
Sice se mě to zeptalo jestli chci balíky nainstalovat a já se divil nad jejich množstvím, ale myslel jsem že to jsou holt závislosti superkaramby pro KDE4.
Když jsem si všimnul že instaluji metabalík kde4, tak jsem si řekl že alespoň vyzkouším programy které nemám nainstalované...
Pokud jsem správně pochopil vlastnosti metabalíku tak je to balík který má hromadu závislostí na různých jiných balících (jako například kubuntu-desktop). Takže když potom odinstaluju jednu ze závislotí metabalíku, tak se sice odebere samotný metabalík, ale jeho závislosti mi v systému zůstanou... Jenže tady jsem zjistil jak těžce jsem se mýlil. Nevím jestli je to jen u tohoto metabalíku, ale ostatní závislosti metabalíku kde4 se přesunuly do NEPOTŘEBNÝCH, takže ve chvíli kdy udělám apt-get autoremove tak se mi odebere polovina systému...
Budu to řešit tak že odeberu jeden program (kmix-kde4, který ještě neumí ovládat hw čudlíky mého ntb), skouknu seznam co jde do autoremove, udělám autoremove a aplikace si nainstaluju jednotlivě. Mohl bych možná rovnou odebrat ten metabalík, ale děsí mě představa že se mi odeberou závislosti třeba na kde4-core. Rozhodně mi to přijde strašně nedomyšlené...

Kód: [Vybrat]
root@jakub-laptop:~# apt-get remove kmix-kde4
Čtu seznamy balíků... Hotovo
Vytvářím strom závislostí
Reading state information... Hotovo
Následující balíky byly nainstalovány automaticky a nejsou již zapotřebí:
  kwordquiz-kde4 kstars-kde4 kiriki-kde4 libopenbabel2 kolf-kde4 kwikdisk-kde4 kppp-kde4 kdf-kde4 libkcddb4-kde4 kscd-kde4 kgeography-kde4 kreversi-kde4
  amor-kde4 libneon25 kcolorchooser-kde4 kdeartwork-theme-window-kde4 kalzium-data-kde4 libmarble4-kde4 kpercentage-kde4 libcfitsio3 kruler-kde4
  python-pycurl kgpg-kde4 parley-kde4 krfb-kde4 okular-kde4 kpat-kde4 libboost-python1.34.1 kdewallpapers-kde4 kgamma-kde4 kdegames-kde4 ttf-dustin
  kturtle-kde4 ksquares-kde4 ktouch-kde4 libkdeedu4-kde4 knetworkconf-kde4 marble-kde4 klettres-kde4 kdetoys-kde4 librpm4 kmahjongg-kde4 ktuberling-kde4
  libpoppler-qt4-2 kbruch-kde4 libokularcore1-kde4 kjumpingcube-kde4 kdeartwork-style-kde4 kde4-amusements kalgebra-kde4 kworldclock-kde4
  kdeartwork-emoticons-kde4 ksame-kde4 kalzium-kde4 blinken-kde4 kdegames-mahjongg-data-kde4 kdenetwork-kde4 libnova-0.12-1 kdeaccessibility-kde4
  kdegames-card-data-kde4 kdeartwork-theme-icon-kde4 kdeartwork-kde4 marble-data-kde4 kbounce-kde4 kcron-kde4 ttf-sjfonts python-rpm kgeography-data-kde4
  knewsticker-kde4 kget-kde4 kgoldrunner-kde4 libkdegames4-kde4 konquest-kde4 kdemultimedia-kio-plugins-kde4 kblackbox-kde4 kdeartwork-misc-kde4
  kmines-kde4 libvncserver0 kteatime-kde4 edict sweeper-kde4 parley-data-kde4 kcharselect-kde4 kdeadmin-kde4 libkiten4-kde4 kmplot-kde4 kamera-kde4
  smartpm-core ktimer-kde4 bovo-kde4 kiten-kde4 kdeedu-kde4 kwalletmanager-kde4 knetwalk-kde4 kanjidic khangman-kde4 krdc-kde4 kfloppy-kde4
  kdegraphics-kde4 kolourpaint4-kde4 katomic-kde4 klines-kde4 kbattleship-kde4 kuser-kde4 libbeecrypt6 kig-kde4 python-pexpect kmilo-kde4 indi-kde4
  lskat-kde4 kshisen-kde4 kscan-kde4 kspaceduel-kde4 kscreensaver-kde4 klettres-data-kde4 kfourinline-kde4 kpackage-kde4 kdeutils-kde4 ksudoku-kde4
  juk-kde4 kdessh-kde4 kanagram-kde4 kjots-kde4 kstars-data-kde4
Použijte 'apt-get autoremove' pro jejich smazání.
Následující balíky budou ODSTRANĚNY:
  kde4 kdemultimedia-kde4 kmix-kde4
0 aktualizováno, 0 nově instalováno, 3 k odstranění a 0 neaktualizováno.
Potřebuji stáhnout 0B archivů.
Po rozbalení bude na disku uvolněno 1065kB.
Chcete pokračovat [Y/n]?

Michal Breškovec

  • Stálý člen
  • **
  • Příspěvků: 1185
  • skill :: aggressive-llama
    • MojeID
Re: metabalík KDE4 je sebevrah
« Odpověď #1 kdy: 11 Dubna 2008, 20:40:15 »
Snad to bude jen problém této testovací verze KDE4, protože s metabalíky by to opravdu mělo být tak jak píšeš.
Kubuntu forever :-)

honorguard

  • Host
Re: metabalík KDE4 je sebevrah
« Odpověď #2 kdy: 11 Dubna 2008, 20:44:11 »
No tak jsem rád že mé informace nebyly chybné - poděkujme mistru Donátovi :). Každopádně jsem to vyřešil tak že jsem si nainstaloval všechny balíčky zvlášť... to by mě zajímalo jak se může takováhle chyba stát...

Poborskiii

  • Aktivní člen
  • *
  • Příspěvků: 422
Re: metabalík KDE4 je sebevrah
« Odpověď #3 kdy: 11 Dubna 2008, 21:42:49 »
U K/Ubuntu je tradičně bordel v závislostech metabalíků. Já osobně proto metabalíky ignoruji, vždy se podívám jaké má závislosti a ty jednotlivě nainstaluji bez metabalíku.
OS: Kubuntu 15.10 64bit, KDE 5, Qt 4.8.6/5.4.2, Nvidia 352.30
PC: ASUS M5A99X EVO, AMD FX-4300, RAM Kingston 2x4 GB DDR3 1600 MHz,
SSD Kingston V300 120 GB, HDD Seagate NAS 3TB (ST3000VN000), VGA ASUS Nvidia GeForce GT 440 Silent, Monitor Dell U2412M, skříň Coolermaster Sileo 500

 

Provoz zaštiťuje spolek OpenAlt.