Prosíme přihlašte se nebo zaregistrujte.

Přihlašte se svým uživatelským jménem a heslem.
Vaše pomoc je stále potřeba!

Autor Téma: Klavesnica Microsoft pre Media center Edition v1.0  (Přečteno 2766 krát)

DyL

  • Návštěvník
  • Příspěvků: 29
Klavesnica Microsoft pre Media center Edition v1.0
« kdy: 01 Ledna 2008, 21:34:38 »
Kupil som si tuto klavesnicu  s dialkovym ovladacom. Dialkac pomocou Lirc
funguje, ale klavesnica nie. Nemate niekto navod ako na to?

Link na produkt http://www.microsoft.com/hardware/mouseandkeyboard/productdetails.aspx?pid=038
« Poslední změna: 02 Ledna 2008, 10:49:58 od DyL »

DyL

  • Návštěvník
  • Příspěvků: 29
Re: Klavesnica Microsoft pre Media center Edition v1.0
« Odpověď #1 kdy: 07 Ledna 2008, 08:11:54 »
Nainstaloval som lirc. Ked pouzijem driver mce-usb2 funguje mi dialkac ale klavesnica nie.
Ked pouzijem lirc_mod_mce tak mi ide klavesnica ale dialkac nie.

Poradi niekto?

DyL

  • Návštěvník
  • Příspěvků: 29
Re: Klavesnica Microsoft pre Media center Edition v1.0
« Odpověď #2 kdy: 10 Ledna 2008, 11:03:29 »
To som trocha sklamany ze nikto nevie pomoct. Nevadi.

Problem je v lirc. Lirc by mal namiesto modulu lirc_mceusb2 natiahnut modul lirc_mod_mce.
Bohuzial Lirc 0.8.2 pre ubuntu /s repozitarov/ nespozna tento modul. Pri kompilacii modulu to papuluje
ze tento modul nie je registrovany.

:~/mod_mce/lirc_mod_mce# make
make -C /lib/modules/2.6.22.969/build SUBDIRS=/root/mod_mce/lirc_mod_mce modules
make[1]: Entering directory `/usr/src/linux-source-2.6.22'
  Building modules, stage 2.
  MODPOST 1 modules
WARNING: "lirc_register_plugin" [/root/mod_mce/lirc_mod_mce/lirc_mod_mce.ko] undefined!
WARNING: "lirc_get_pdata" [/root/mod_mce/lirc_mod_mce/lirc_mod_mce.ko] undefined!
WARNING: "lirc_unregister_plugin" [/root/mod_mce/lirc_mod_mce/lirc_mod_mce.ko] undefined!
make[1]: Leaving directory `/usr/src/linux-source-2.6.22'

Dalsi problem je ze ked zmenim nastavenie modulu v /etc/lirc/hardware.conf s MODULES = lirc_mceusb2 na MODULES = lirc_mod_mce
tak aj tak lirc natiahne modul lirc_mceusb2.

Takze:
1.da sa nejak registrovat novy modul pre LIRC
2.Ako sa da natiahnut iny modul do lirc
3.Existuje balicek starsieho LIRC-0.8.1 pre gutsy? Mozno tam to bude fungovat.   

 

Provoz zaštiťuje spolek OpenAlt.