Prosíme přihlašte se nebo zaregistrujte.

Přihlašte se svým uživatelským jménem a heslem.
Vaše pomoc je stále potřeba!

Autor Téma: fstab [vyřešeno]  (Přečteno 2725 krát)

Beleval

  • Návštěvník
  • Příspěvků: 20
fstab [vyřešeno]
« kdy: 15 Ledna 2008, 20:59:48 »
No asi se nakonec budu ptat castej. Neco ani s pomoci googlu nenajdu, nebo nepochopim  ??? Tak muj druhy dotaz je podobneho razeni. Naformatoval jsem si druhy disk na ext3 a snazimse ho pridat at se mountuje pri startu. Kdyz edituju fstab tak pouziju "/dev/sdb1  /media/filmy  ext3". A at pak dalsi parametry menim jak chci tak dosahnu maximalne toho ze bud se nenamountuje vubec, nebo jo ale prava zapisu ma root. A potreboval bych na nej zapisovat i jako uzivatel. Nenapsali by jste  mi kdyz tak jak ma vypadat cely radek? Snazil jsem se podle tohoto navodu http://ubuntuforums.org/showthread.php?t=283131, ale nejak porad nic. Dik predem
« Poslední změna: 16 Ledna 2008, 12:22:58 od Anna Taliánová »

tomato

  • Aktivní člen
  • *
  • Příspěvků: 155
Re: fstab
« Odpověď #1 kdy: 15 Ledna 2008, 22:02:22 »
zdar, za spravnost nerucim, ale myslim ze nejak takto:
UUID="zjisti si uuid, treba prikazem: ls /dev/disk/by-uuid -l"   /media/filmy   ext3   defaults   0   0
jinak adresar /media/filmy musis mit predem vytvoreny.. pripadne jeste jako parametr (misto defaults) - users,rw,exec.. ale me funguje defaults v pohode (na ntfs)..
nemam nejak detailne ozkouseno, spis jen tak zkousim poradit.. :)
kdyztak zkus jeste kouknout sem: http://www.tuxfiles.org/linuxhelp/fstab.html

LS

  • Závislák
  • ***
  • Příspěvků: 3849
    • http://linux.euweb.cz
Re: fstab
« Odpověď #2 kdy: 15 Ledna 2008, 22:05:46 »
Je potreba nastavit spravne prava. Bud pro cely svazek nebo pro jednotlive adresare. Pokud chcete cely disk odemknout pro cteni i zapis vsem uzivatelum, pak jako parametr v fstabu dejte umask=0.

tomato

  • Aktivní člen
  • *
  • Příspěvků: 155
Re: fstab
« Odpověď #3 kdy: 16 Ledna 2008, 09:27:03 »
sice se v tom vazne nijak moc nevyznam, nastavil jsem si toto jen jednou (a to uz je davno :)) a od te doby mi to funguje, ale na tom odkazu od Belevala je napsano toto:
Citace
Note: ext2 and ext3 do not take uid=xxx, gid=xxx, or umask=xxx

To set group rw permissions:
fstab options: users,noauto

   1. mount the partition: mount /mnt/ext3
   2. Set permisions of the mount point: chmod 777 /mnt/ext3

The set ownership and permissions will remain in effect with un-mount and re-boot.
takze nevim jestli umask zabere..
« Poslední změna: 16 Ledna 2008, 12:27:09 od Anna Taliánová »

LS

  • Závislák
  • ***
  • Příspěvků: 3849
    • http://linux.euweb.cz
Re: fstab
« Odpověď #4 kdy: 16 Ledna 2008, 09:46:57 »
na tom neco bude :)

Beleval

  • Návštěvník
  • Příspěvků: 20
Re: fstab
« Odpověď #5 kdy: 16 Ledna 2008, 09:50:09 »
Tak diky pomohlo nastaveni prav u adresare do ktereho to mountuju. Tadle varianta me nenapadla a nejak jsem ji prehlidl na te strance. Takze u ext3 nenastavovat v pripojeni, ale pomoci chmod u adresare. No snad uz dalsi vetsi zasek nebude   ;)
« Poslední změna: 16 Ledna 2008, 12:43:26 od Anna Taliánová »

 

Provoz zaštiťuje spolek OpenAlt.