Prosíme přihlašte se nebo zaregistrujte.

Přihlašte se svým uživatelským jménem a heslem.

Autor Téma: Klávesové zkratky  (Přečteno 2513 krát)

pepper

  • Návštěvník
  • *
  • Příspěvků: 4
    • Zobrazit profil
Klávesové zkratky
« kdy: 28 Duben 2008, 15:20:30 »
Přechod proběhl zdá se v pořádku, ale nefungují mi klávesové zkratky.
Například pro přepínání klávesnice mezi českou a anglickou jsem používal dva Alt současně.
Nebo mi nefunguje zamykání obrazovky pomocí Alt + Ctrl + L.

Nevíte někdo čím to?

Jaké výpisy by vám mohly napovědět?

nezik

  • Stálý člen
  • ***
  • Příspěvků: 722
    • Zobrazit profil
    • Chalupa Himmelreich
Re: Klávesové zkratky
« Odpověď #1 kdy: 28 Duben 2008, 16:21:45 »
Taky mi to nechodí, ale už sem se naučil žít bez US nastavení, páč sem narazil na fígl, že pravej alt plus příslušná klávesa napíše znak z US klávesnice. snad sem to napsal pochopitelně. nevím jak jinak to popsat :D
Ubuntu 16.04
Kdesu není první slovo Hanáckeho opilce po probuzení, ale příkaz systému.
Ubuntu - nejlepší pařba od Diabla II. ;D

pepper

  • Návštěvník
  • *
  • Příspěvků: 4
    • Zobrazit profil
Re: Klávesové zkratky
« Odpověď #2 kdy: 28 Duben 2008, 16:37:22 »
to je pro mě naprosto neuspokojivé.

Potřebuji mít anglické rozvržení kláves a občas přepínat do českého. Pro přepínání rozvržení si můžu nastavit jinou zkratku, ikdyž nerad, ale chci zamykat obrazovku, přepínat plochy, přesouvat aplikace mezi plochami a podobně pomocí klávesnice.

Hledám systémové řešení.

Osobně se domnívám, že za to může compiz a nevím. Veškeré efekty mám vypnuté. Zapnutí nepomáhá. :-)

Pavel Půlpán

Re: Klávesové zkratky
« Odpověď #3 kdy: 28 Duben 2008, 16:43:22 »
Když jsem včera koukal do xorg.conf Ubu, co jsem hodil do virtuálu, naskočila mi husí kůže. Prostě nemám rád automatiku, zvlášť když nefunguje. :D

Ale zkus štěstí s tímto postupem:
1) Zazálohuj si /etc/X11/xorg.conf
2) Sekci konfigurace keyboardu uprav zhruba do této podoby:
Kód: [Vybrat]
Section "InputDevice"
   Identifier   "Keyboard0"
   Driver      "kbd"
   Option      "CoreKeyboard"
   Option      "XkbRules"   "xorg"
   Option      "XkbModel"   "pc105"
   Option      "XkbLayout"   "cz,us"
   Option      "XkbOptions"   "grp:alt_shift_toggle"
EndSection

Pozn. V podstatě tě zajímají poslední dva opšny. Zbytek rači nech plavat.

pepper

  • Návštěvník
  • *
  • Příspěvků: 4
    • Zobrazit profil
Re: Klávesové zkratky
« Odpověď #4 kdy: 28 Duben 2008, 17:05:23 »
Díky za radu.
Bohužel v mém případě to vypadá nějak takto:
Kód: [Vybrat]
Section "InputDevice"
Identifier "Generic Keyboard"
Driver "kbd"
Option "CoreKeyboard"
Option "XkbRules" "xorg"
Option "XkbModel" "pc105"
Option "XkbLayout" "cz"
EndSection

Ale v Gnome mám dvě rozložení. Přepínání Alt + Shift nechci(dočasně ho tak mám), protože standardně Alt + Shift + Ctrl + šipka přesouvá okno mezi plochami a pří Alt + Shif přepínání klávesnice se okna nepřesouvají ale přepne se klávesnice a přesunu se na plochu já, nikoliv okno. :-(

Pokud by někdo tedy byl od té dobroty se mnou řešit tenhle problém, zaměřil bych se spíše na standardní zkratku Ctrl + Alt + L na uzamknutí obrazovky.

nezik

  • Stálý člen
  • ***
  • Příspěvků: 722
    • Zobrazit profil
    • Chalupa Himmelreich
Re: Klávesové zkratky
« Odpověď #5 kdy: 28 Duben 2008, 18:36:23 »
zkus tam jen přidat ten polsední řádek, ale v tomhle tvaru
Kód: [Vybrat]
   Option      "XkbOptions"   "grp:alt_altgr_toggle"
EDIT:
mě teda uzamykání chodí, nastavit by se to mělo dát v gconf-editoru
dej hledat screensaver a měla by u něj být hodnota
Kód: [Vybrat]
<Control><Alt>l
« Poslední změna: 28 Duben 2008, 18:41:05 od nezik »
Ubuntu 16.04
Kdesu není první slovo Hanáckeho opilce po probuzení, ale příkaz systému.
Ubuntu - nejlepší pařba od Diabla II. ;D

pepper

  • Návštěvník
  • *
  • Příspěvků: 4
    • Zobrazit profil
Re: Klávesové zkratky
« Odpověď #6 kdy: 07 Květen 2008, 17:25:11 »
Nějak jsem se stále nedobral k uspokojivému řešení.

V konfiguraci X mam jen jednu klávesnici. V Gnome ale mám dvě a lze mezi nimi přepínat.

Klávesová zkratka pro uzamknutí Ctrl-ALt-L a přepínání rozložení klávesnice dvěma Alt nefunguje.
Zkoušel jsem vše co mi bylo raděno ale nic nezabírá.