Prosíme přihlašte se nebo zaregistrujte.

Přihlašte se svým uživatelským jménem a heslem.
Vaše pomoc je stále potřeba!

Autor Téma: Sekání videa - ATI  (Přečteno 21388 krát)

lanugo

  • Návštěvník
  • Příspěvků: 36
Re: Sekání videa - ATI
« Odpověď #25 kdy: 05 Června 2008, 18:42:25 »
Jeste sem se chtel zeptat, jak spoustet fusion-icon hned po startu.

Koukám, že dáváš Ubuntu ještě šanci  ;)

Spouštění fusion-icon po startu: Systém -> Volby -> Sezení -> Přidat a příkaz
Kód: [Vybrat]
fusion-icon --no-start případně bez toho no-startu viz http://forum.ubuntu.cz/index.php?topic=22867.30

pawlik

  • Návštěvník
  • Příspěvků: 29
Re: Sekání videa - ATI
« Odpověď #26 kdy: 05 Června 2008, 20:19:03 »
Citace
Koukám, že dáváš Ubuntu ještě šanci

No neboj....celou noc sem u toho sedel a brzo po ranu z toho zase vyslo Ubuntu na jednicku:))

Jiří Vyorálek

  • Návštěvník
  • Příspěvků: 45
Re: Sekání videa - ATI
« Odpověď #27 kdy: 05 Června 2008, 20:50:24 »
Kdyby si nasel nejaky pekny navod na tu kompilaci a patch na mplayer tak prosim sup sem s nim:) Diky moc.

Tak jsem to vyzkoušel dle návodu zde: http://ubuntuforums.org/showthread.php?t=571556 .. bohužel je to již starší kousek a balíčky, které jsou v požadovaných závilostech už jsou v HH v jiných verzích. Pokusil jsem se to upravit dle aktuálního stavu, ale i přesto mi kompilace spadla na chybě.

Kód: [Vybrat]
../libavutil/mem.h:100: warning: ‘alloc_size’ attribute directive ignored
libx264.c: In function ‘X264_init’:
libx264.c:224: error: ‘X264_ME_TESA’ undeclared (first use in this function)
libx264.c:224: error: (Each undeclared identifier is reported only once
libx264.c:224: error: for each function it appears in.)
libx264.c:256: warning: assignment discards qualifiers from pointer target type
make[1]: *** [libx264.o] Error 1
make[1]: Leaving directory `/usr/src/mplayer/libavcodec'
make: *** [libavcodec/libavcodec.a] Error 2

.. momentálně nemám čas do toho více zabředávat, čili zatím tuto možnost opustím. Pokud by se někomu kompilace podařila, rád uvítám výsledný deb soubor :)

Jiří Vyorálek

  • Návštěvník
  • Příspěvků: 45
Re: Sekání videa - ATI
« Odpověď #28 kdy: 06 Června 2008, 09:51:52 »
Tak kompilace MPlayeru (z svn) se nakonec podařila, bylo potřeba nainstalovat ještě dvě knihovny, ale bez kýženého výsledku. Mplayer stále jak v okně tak na fullscreen při zapnutém Compizu přeblikává. Jelikož mě už nic dalšího nenapadá dám zde k dispozici jak zkompilovaný balíček, tak i přidané knihovny a i mou konfiguraci na které jsem to vyráběl a testoval.

Nejprve výsledný balíček mplayer_1.0svn_i386.deb, který obsahuje i patch z adresy, kterou jsem uváděl v minulém příspěvku. A dále potřebné knihovny, které nebyly v repository HH 8.04 - libx264-59_0.svn20080408-0.0ubuntu1_i386.deb, libx264-dev_0.svn20080408-0.0ubuntu1_i386.deb.

A zde slibovaná konfigurace:
výsledný mplayer
Kód: [Vybrat]
MPlayer dev-SVN-r26993-4.2.3 (C) 2000-2008 MPlayer Team
CPU: Intel(R) Pentium(R) M processor 1.73GHz (Family: 6, Model: 13, Stepping: 8)
CPUflags:  MMX: 1 MMX2: 1 3DNow: 0 3DNow2: 0 SSE: 1 SSE2: 1
Compiled for x86 CPU with extensions: MMX MMX2 SSE SSE2

ovladač grafické karty
Kód: [Vybrat]
display: :0.0  screen: 0
OpenGL vendor string: ATI Technologies Inc.
OpenGL renderer string: ATI MOBILITY RADEON X600
OpenGL version string: 2.1.7537 Release

xorg.conf
Kód: [Vybrat]
Section "Screen"
Identifier "Default Screen"
Monitor "Configured Monitor"
Device "Configured Video Device"
Defaultdepth 24
EndSection

Section "Device"
Identifier "Configured Video Device"
Driver "fglrx"
Option "VideoOverlay" "on"
Option "OpenGLOverlay" "off"
Option "TexturedVideo" "on"
EndSection

Section "Module"
Load "glx"
EndSection

Section "Extensions"
Option "Composite" "Enable"
EndSection

Zkoušel jsem si hrát s Option na Device a vyzkoušel všechny kombinace on/off, leč bohužel nic nepomohlo. V Compizu mám vyplé "Undirect Fullscreen Windows". A snad poslední informace, že Compiz mám kompilovaný z GItu a aktualizavaný cca. před týdnem.

Buď to někdo prosím vyzkoušejte, zda vám tato verze Mplayeru také nepomáhá a nebo prosím o nakopnutí správným směrem :). Díky.

Evžen Šubrt

  • Závislák
  • ***
  • Příspěvků: 2218
    • EuGenio's Lair
Re: Sekání videa - ATI
« Odpověď #29 kdy: 06 Června 2008, 10:04:31 »
Já jsem to kompiloval cca před dvěma měsící a vše jede v pohodě. Ujistěte se, že máte nastavené přehrávání přes xv (přes gl a gl2 bliká dál). Případně to zkuste z příkazové řádky, v terminálu napište
Kód: [Vybrat]
mplayer -vo xv jménovidoisouboru.

Váš balíček bohužel vyzkoušet nemůžu, neb mám 64bit
Athlon X2 6000+, MB ASUS M2R32-MVP, 6GB RAM, ATI Radeon HD7850 1GB, 1GB SSHD + 250GB HDD, Ubuntu 13.10 Saucy Salamander 64bit

Jiří Vyorálek

  • Návštěvník
  • Příspěvků: 45
Re: Sekání videa - ATI
« Odpověď #30 kdy: 06 Června 2008, 10:18:59 »
Jj, zkoušel jsem to se všemi možnými parametry, tj:
- x11 - funguje spolehlivě, ale vyžírá CPU
- xv - obraz problikává mezi černou a videem
- gl - obraz problikává mezi okny Ubuntu a videem

Jiří Vyorálek

  • Návštěvník
  • Příspěvků: 45
Re: Sekání videa - ATI
« Odpověď #31 kdy: 06 Června 2008, 11:26:31 »
A to jsi ten mplayer nemusel ani patchovat? .. jakou máš konfiguraci? ... ovladač + xorg.conf?

Jiří Vyorálek

  • Návštěvník
  • Příspěvků: 45
Re: Sekání videa - ATI
« Odpověď #32 kdy: 10 Června 2008, 13:07:52 »
Tak jsem konečně vyřešil problikávání videa v patchovaném mplayeru :)

Kromě postupu uvedenému níže v mém příspěvku z 06.06.2008, 08:51:51:52 je potřeba v Compizu zapnout plugin "Utility->Přehrávání videa". Pak video v opatchované verzi v kombinaci s xorg.conf a ati ovladačemi neproblikává :) .. konečně, přišel jsem na to víceméně náhodně  :P

Roman Vacho

  • Moderátor
  • Závislák
  • ***
  • Příspěvků: 6021
Re: Sekání videa - ATI
« Odpověď #33 kdy: 10 Června 2008, 14:00:44 »
A 3D hry blikaj? Třeba Tremulous?
Vyřešená vlákna je vhodné uzavřít "Topic Solved" dole pod vláknem. Děkujeme.

Evžen Šubrt

  • Závislák
  • ***
  • Příspěvků: 2218
    • EuGenio's Lair
Re: Sekání videa - ATI
« Odpověď #34 kdy: 10 Června 2008, 14:02:43 »
A 3D hry blikaj? Třeba Tremulous?
3D hry budou blikat, protože zobrazují přes gl. Mplayer nebliká pouze patchovaný a přes zobrazovací vrstrvu xv.

Pokud chcete neblikající 3D hry, budete muset zatím vypínat compiz - což se při použití fusion-icon zrealizuje dvěma kliknutími myši.
Athlon X2 6000+, MB ASUS M2R32-MVP, 6GB RAM, ATI Radeon HD7850 1GB, 1GB SSHD + 250GB HDD, Ubuntu 13.10 Saucy Salamander 64bit

Jiří Vyorálek

  • Návštěvník
  • Příspěvků: 45
Re: Sekání videa - ATI
« Odpověď #35 kdy: 10 Června 2008, 14:26:40 »
Přesně tak.. uvedený postup zabírá pouze na opatchovaný mplayer... všechny ostatní přehrávače používající xv, gl nebo gl2 budou bohužel blikat nadále.

Roman Vacho

  • Moderátor
  • Závislák
  • ***
  • Příspěvků: 6021
Re: Sekání videa - ATI
« Odpověď #36 kdy: 24 Června 2008, 02:29:32 »
Oživuji tento thread, protože se tu moc hezky bavíme o naší milované Ati :p

Jak jste na tom s ovladačem 8.6?
Nativně mi už funguje vyhlazování videa, obraz neproblikává.

Ale občas se mi stane, patrně vyskočením nějakého okna na ploše, když hraju Tremulous, že se mi obraz rozkouskuje na 4kusy a každej má jinou grafiku. Mám pocit, že se mi to stalo i u Mplayeru. Někdy se z tohoto stavu to nějak nebo mačkáním nějakých kláves dokáže vrátit zpět do normálu :o) Jindy restartuju X.

Nainstaloval jsem zkusmo i beta updaty. Teď když dám
rovano@rovano:~$ fglrxinfo
display: :0.0  screen: 0
OpenGL vendor string: ATI Technologies Inc.
OpenGL renderer string: ATI Radeon X1200 Series
OpenGL version string: 2.1.7659 Release

Segmentation fault

...Co to přesně znamená? Že ovladač havaruje?
« Poslední změna: 24 Června 2008, 02:33:35 od Rovano »
Vyřešená vlákna je vhodné uzavřít "Topic Solved" dole pod vláknem. Děkujeme.

Roman Vacho

  • Moderátor
  • Závislák
  • ***
  • Příspěvků: 6021
Re: Sekání videa - ATI
« Odpověď #37 kdy: 24 Června 2008, 15:08:59 »
Oživuji tento thread, protože se tu moc hezky bavíme o naší milované Ati :p

Jak jste na tom s ovladačem 8.6?
Nativně mi už funguje vyhlazování videa, obraz neproblikává ani s Compizem při X11. A to ani v okně, ani při fullscreen.

Ale občas se mi stane, patrně vyskočením nějakého okna na ploše, když hraju Tremulous, že se mi obraz rozkouskuje na 4kusy a každej má jinou grafiku. Mám pocit, že se mi to stalo i u Mplayeru. Někdy se z tohoto stavu to nějak nebo mačkáním nějakých kláves dokáže vrátit zpět do normálu :o) Jindy restartuju X.

Nainstaloval jsem zkusmo i beta updaty. Teď když dám
rovano@rovano:~$ fglrxinfo
display: :0.0  screen: 0
OpenGL vendor string: ATI Technologies Inc.
OpenGL renderer string: ATI Radeon X1200 Series
OpenGL version string: 2.1.7659 Release

Segmentation fault

...Co to přesně znamená? Že ovladač havaruje?
Vyřešená vlákna je vhodné uzavřít "Topic Solved" dole pod vláknem. Děkujeme.

 

Provoz zaštiťuje spolek OpenAlt.